Test mit einfachem ADB Befehl schlägt fehl, was tun?

  • 27 Antworten
  • Neuester Beitrag
Diskutiere Test mit einfachem ADB Befehl schlägt fehl, was tun? im Xiaomi Allgemein im Bereich Xiaomi Forum.
A

amaryllis

Neues Mitglied
Ich möchte mit adb devices probieren, ob adb funktioniert. Dazu habe ich USB Debugging aktiviert (siehe Screenshot).
Muss ich noch etwas aktivieren? Der Befehl zeigt das Handy nicht an. Ich erinnere mich bei einem anderen Handy, dass da eine Abfrage kam, ob sich PC und Handy dauerhaft vertrauen oder so ähnlich. Fastboot devices gestartet mit Vol - und Power hat mir das Handy angezeigt.
 

Anhänge

Empfohlene Antwort(en)
rene3006

rene3006

Inventar
@amaryllis
Schalte Usb Debbugging an
Dann kommt Abfrage
RSA bestätigen.
Dann in Fastboot starten
fastboot devices eingeben
Schlüssrlnummer sollte angezeigt werden
 
Alle Antworten (27)
maik005

maik005

Urgestein
@amaryllis
wieso der riesige Screenshot?

USB Debugging ist aus. Das musst du einschalten.
1612967546195.png
 
rene3006

rene3006

Inventar
@amaryllis
Schalte Usb Debbugging an
Dann kommt Abfrage
RSA bestätigen.
Dann in Fastboot starten
fastboot devices eingeben
Schlüssrlnummer sollte angezeigt werden
 
A

amaryllis

Neues Mitglied
Danke! Ich hatte das falsche USB Debugging aktiviert. Deshalb habe ich den Screenshot mit den Einstellungen geschickt.
 
Bruno1872

Bruno1872

Stammgast
Hallo
Bei mir funktioniert aktuell unter Windows 10 64 Bit vor ein paar Monaten neu installiert adb und Fastboot
nun nicht mehr mit meinem Redmi Note 5 Android 9.
Früher funktionierte es aber bei dem gleichen PC unter Windows 10.
Ich habe Minimal ADB and Fastboot neu installiert, danach noch die ADB Treiber, aus 2 verschiedenen Quellen.
Weder die von Google nach andere brachten bisher einen Erfolg.

C:\Program Files (x86)\Minimal ADB and Fastboot>adb devices
List of devices attached

Es werden keine devices gelistet.
USB-Debugging im RN5 ist aktivert.

Ist das ein ADB Treiber Problem?

Kann sein vor Jahren hatte ich das so auch schon mal, was geholfen hat, weiß ich nicht mehr.
Mit 3 verchiedenen USB Kabeln habe ich es nun versucht, jeweils an 2 unterschiedlichen USB Ports vorn am PC.

Im Gerätemanger:
Andere Geräte: Android (!)
Die Treiber für dieses Gerät wurden nicht installiert. (Code 28)
Es sind keine kompatiblen Treiber für dieses Gerät vorhanden.
Klicken Sie auf "Treiber aktualisieren", um einen Treiber für dieses Gerät zu finden.

Die ADB Treiber von Google habe ich wieder deinstalliert, es war damit genau das selbe.
Sind die denn nötig und richtig?
 
Zuletzt bearbeitet:
Bruno1872

Bruno1872

Stammgast
Ich habe erstmal die Schnauze voll, es funktioniert immer noch nicht unter Windows 10 aber auch nicht unter Linux Mint.
Unter Windows habe ich nun zuletzt, 2 optionale Treiber Updates nach installiert.
Jeweils für adb 1. von Google und 2. von LeMobile.

Das Ergebnis ist nur, das im Gerätemanager nun nicht mehr oben Gerät: Android mit ! gekennzeichnet ist.
Siehe Screen-Shot mit ausgeblendeten Geräten.

Im Bios des Asrock Board habe ich noch die USB Einstellungen geändert, dort war der Kompatiblitäts-Modus für ältere USB Geräte aktiviert, den habe ich auf UEFI Modus umgestellt.

Wie schon geschrieben am selben PC lief es unter einer vorherigen Windows 10 Installation schon mal tadellos.
Wenn ich das RN5 nicht im Fastboot Modus habe, wird das RN5 auch unter Windows als Device angezeigt.
C:\Program Files (x86)\Minimal ADB and Fastboot>adb devices
List of devices attached
4335906e device

Ich habe dann auch Zugriff auf den Speicher des RN5.
 

Anhänge

Zuletzt bearbeitet:
rene3006

rene3006

Inventar
@Bruno1872
Geh doch mal im Gerätemanager auf Legacyhardware zufügen.
 
maik005

maik005

Urgestein
@Bruno1872
Entferne mal alle anderen Smartphones vom PC.
 
rene3006

rene3006

Inventar
Hast du noch mehr am PC Verbunden?
Dongles usw?
 
Bruno1872

Bruno1872

Stammgast
Ich habe nun fast alles was mit Mobile Geräten zu tun hat entfernt, geht immer noch nicht.
@rene3006
Welche Legacyhardware soll ich hinzufügen? Muss ich auch erst schauen, wie das geht.

Kedacom ist das Android Boot Interface.
Bei den Geräten wird im Fastboot Modus nur dieses angezeigt, nicht als Redmi Note 5.

Kann das auch an den Windows Sicherheitseinstellungen liegen?
Dort ist bei mir ua. Kernel Isolation aktiviert.

Wo ich das von Kedacom her habe, möchte ich auch mal wissen.
Ist das denn richtig?
 

Anhänge

Zuletzt bearbeitet:
rene3006

rene3006

Inventar
@Bruno1872
Das wird dir unten in 2 Fenstern angezeigt.
Schau mal was du drinn hast.
 
Bruno1872

Bruno1872

Stammgast
Das Legacy Hardware hinzufügen oder anzeigen lassen finde ich nicht.
Muss hier erst nachlesen? How to Install Legacy Hardware devices on Windows OS - Get Cool Tricks

Ausserdem muss ich immer switchen, da ich hier im Forum nur mit eingeschränkten Rechten unter Windows eingeloogt bin.
Kann ich den Gerätemanager auch mit generellen Admin Recht als normaler user starten?
So werde ich bei fast jeder Aktion im Gerätemanger nach dem Admin PW gefragt.
Legacy Hardware könnte ich hinzufügen:
Kedacom USB (wird 2 mal gelistet)
und LeMobile.

Den noch vorhandenen Kedacom USB Treiber werde ich auch entfernen, vielleicht ist der Mist.
How to delete Kedacom USB Device Driver from PC - Xiaomi Firmware

Ich mache jetzt erstmal eine Pause.
 
Zuletzt bearbeitet:
Bruno1872

Bruno1872

Stammgast
Es funktioiert weiterhin nicht, weder unter Windows 10 noch unter Linux Mint.
Entweder ich habe ich unter Windows ständig die falschen ADB Treiber oder alle meine 3 USB Kabel sind dafür unbrauchbar.
Welches ich früher verwendete, ob es das originale Ladekabel war, womit es noch vor Monaten ging, weiß ich nicht mehr.
Neu ist eigentlich nur, das es MIUI Updates und Windows Updates gab.
Im Nicht Fastboot Modus, wird von Windows das RN5 korrekt erkannt, Dateitransfer geht auch.
Im Fastboot Modus listet adb devices mir aber mein RN5 einfach nicht.

Welche ADB Treiber verwendet ihr denn genau für Euer XIAOMI?
Ich könnte die MIUI Suite auch noch installieren.
Ich muss mal sehen was ich früher an ADB Software bzw. Treiber ich herunter geladen habe.

Im normal Modus wird z.Z. wieder der LeMobile Treiber geladen.
 
Zuletzt bearbeitet:
J

JohnBill

Erfahrenes Mitglied
im fastboot Modus hat adb noch nie funktioniert und wird auch nie funktionieren.
Das Kommando heißt fastboot.
 
Bruno1872

Bruno1872

Stammgast
Ja Fastboot boot recovery.img will ich machen, das ging doch früher.
Aber dann kommt waiting for devices und nichts passiert.
Muss ich das nicht im Fastboot Modus des RN5 machen oder im normal Modus?

Versuchen kann ich noch PTP Modus statt MTP.
 
Zuletzt bearbeitet:
J

JohnBill

Erfahrenes Mitglied
wenn du ein "fastboot boot ..." machen willst, dann bist du im fastboot Modus richtig. Dann ist aber adb egal.
Wenn du aber wie beschrieben adb Probleme hast, dann bist du im fastboot Modus falsch, denn da geht kein adb.
Du musst dich schon entscheiden, was du willst und was dein Problem ist.
 
Bruno1872

Bruno1872

Stammgast
Mein Problem ist im Fastboot Modus:
C:\Program Files (x86)\Minimal ADB and Fastboot>fastboot boot recovery.img
< waiting for any device >

Woran soll das denn liegen?
Die recovery.img ist aus OrangeFox entpackt. OrangeFox-R11.0-Stable-whyred
 
Zuletzt bearbeitet:
T

thunder43

Experte
Hast du einen AMD Ryzen?
 
Bruno1872

Bruno1872

Stammgast
@thunder43
Nein den habe ich:
  • Marke des Prozessors : Qualcomm
  • Prozessor-Typ : Octa-core, Snapdragon 636
Brauche ich die Treiber von Qualcomm?
 
Zuletzt bearbeitet:
T

thunder43

Experte
Ich meine deinen PC.
 
Ähnliche Themen - Test mit einfachem ADB Befehl schlägt fehl, was tun? Antworten Datum
8
0
0