Fastboot adb Devices Problem

  • 38 Antworten
  • Neuester Beitrag
Diskutiere Fastboot adb Devices Problem im Xiaomi Redmi Note 5 Forum im Bereich Xiaomi Forum.
Bruno1872

Bruno1872

Stammgast
Hallo,

wenn ich das RN5 im Fastboot starte, listet der Befehl "adb devices" in der Windows 10 Shell (cmd)
keine Devices also nicht mein RN5, welches am USB-Port angeschlossen ist auf.

Ohne Fastboot also wenn ich das RN5 normal starte wird das device mit "adb devices"
angezeigt als Nummer.

Installiert unter Windows 10 /64bit habe ich die ADB PlatForm-Tools.

USB Debugging ist im RN5 aktiviert.
Windows Android Driver habe ich schon einige installiert und deinstalliert.
Im Prinzip funzen die Treiber ja nur unter fastboot, scheinbar nicht.

Oder verstehe ich was falsch?
So kann ich auch keine adb shell in Windows cmd öffnen da ja kein adb Device erkannt wird.

Oder muss ich zuvor per Fastboot zb. das OrangFox Image laden, wenn das denn geht.
Ich wollte noch mal versuchen die Camera2 api aktivieren (ohne root).
 
Zuletzt bearbeitet von einem Moderator:
Andy

Andy

Ehrenmitglied
Im Fastboot funktionieren ja auch ADB Befehle nicht und vice versa.
 
Bruno1872

Bruno1872

Stammgast
Danke Andy,
also funktioieren de ADB Befehle erst, wenn ich das OrangeFox*.img gebootet habe.

So versuche ich es noch mal wie John Bill es hier im Forum beschrieben hat.

Zitat:
RN5 im fastboot-Modus booten, dann
$ fastboot boot OrangeFox*.img
im Recovery per Swipe Änderungen an /system erlauben und /system per Menü mounten
$ adb shell
sh-5.0# cd /system
sh-5.0# vi build.prop (wenn man vi kann...)
dort
persist.vendor.camera.HAL3.enabled=0 in =1 ändern und
persist.camera.HAL3.enabled=1 hinzufügen (evtl ist das auch optional, ich habs gemacht)
abspeichern
sh-5.0# exit
$ adb reboot

Da hatte ich vor Tagen was falsch gemacht.
Wohl hatte ich die System Partition nicht gemountet.
So hatte ich gar keine existierene build.prop öffnen können.
Und zerschossen oder gelöscht hatte ich versehentlich auch irgendwas.
-- Dieser Beitrag wurde automatisch mit dem folgenden Beitrag zusammengeführt --
Funktioniert nun auch nicht, da das RN5 nun wieder locked (Bootloader gesperrt) ist. ;)
Ich hatte es aber schon entsperrt, aber per Flashtool wieder neu geflasht, da erst nichts mehr ging.
 
Andy

Andy

Ehrenmitglied
Bruno1872 schrieb:
also funktioieren de ADB Befehle erst, wenn ich das OrangeFox*.img gebootet habe.
Ja zum Beispiel.
Bruno1872 schrieb:
Wohl hatte ich die System Partition nicht gemountet.
Ja standardmäßig wird /system nicht gemountet (aus Sicherheitsgründen)
Bruno1872 schrieb:
Funktioniert nun auch nicht, da das RN5 nun wieder locked (Bootloader gesperrt) ist. ;)
Ich hatte es aber schon entsperrt, aber per Flashtool wieder neu geflasht, da erst nichts mehr ging.
Ja das kommt davon wenn man im Flashtool unten rechts "clean all and lock" ausgewählt hat, anstatt nur "clean all".
 
Zuletzt bearbeitet:
Bruno1872

Bruno1872

Stammgast
Stimmt, auf den Punkt "clean all and lock" im Mi FlashTool hatte ich nicht geachtet. :(

Jetzt wieder was anderes beim Eingabe-Befehl:
Fastboot boot recovery.img
kommt folgende Fehler Meldung:
Sending 'boot.img' (43356 KB) FAILED (Write to device failed (Too many links))
fastboot: error: Command failed

ich habe die hier heruntergeladen: OrangeFox-R9.0-1-whyred
entpackt und das recovery.img nach Platform-Tools kopiert.

hiermit das gleiche Spiel. OrangeFox-R9.0-2-whyred-MIUI-Pie

Das funzte aber bei mir schon mal, so dass OrangeFox auf dem RN5 startete.

Mein RN5 hatte ich gestern wieder entsperrt.
Android Pi 9 PKQ1 ....
MIUI Global 10.3.10 Stable
 
Zuletzt bearbeitet von einem Moderator:
Andy

Andy

Ehrenmitglied
Ja, das funktioniert erst wieder wenn der Bootloader entsperrt ist.
 
Bruno1872

Bruno1872

Stammgast
Andy der ist ja entsperrt
Jetzt hat das booten des OrangeFox-R9.0-1-whyred (recovery.img) doch geklappt, nachdem ich das USB-Kabel austauschte.
Vielleicht lag es daran.

Nun weiter in der Anleitung (build.prop) editieren.
Ich muss aufpassen das ich nichts falsch mache.
-- Dieser Beitrag wurde automatisch mit dem folgenden Beitrag zusammengeführt --
In Windows (OrangeFox läuft auf dem RN5)
C:\Program Files\platform-tools>adb shell
error: no devices/emulators found
 
Fietze

Fietze

Dauergast
Wieso willst du jetzt schon die Build.prob Editieren.

Ich würde jetzt erstmal sehen, dass alles rund läuft.
Also die Recovery per Recovery flashen (im Moment ist sie doch nur temporär installiert, oder täusche ich mich da), in der OF die Miui OTA Einstellungen setzen, das Rom noch mal per OF flashen, Magisk drauf und rooten.

Hast du Root, kannst du die Build.prob leicht mit dem Buildprob Editor editieren.
Oder halt in der Recovery, aber wieso per ADB?
 
Bruno1872

Bruno1872

Stammgast
@Fietze
Mein Ziel ist nur die Build.prob zu editieren.
Um den folgenden Eintrag:
persist.vendor.camera.HAL3.enabled=0 in =1 ändern
persist.camera.HAL3.enabled=1 hinzufügen

Weiter will ich gar nichts. Ich denke das reicht, um eine GCam Port App zum laufen zu bekommen.
Das ohne Root.

Ich dachte das geht so einfach.

Aber zur Zeit laufen die adb Befehle im Windows Cmd nicht, wenn OrangeFOX gestartet ist.
Windows erkennt dann wieder kein adb device.

Muss ich das anders machen?

Der User John Bill hat das hier im Forum in der Kurzfassung beschrieben:
Xiaomi Redmi Note 5: Kamera
 
Zuletzt bearbeitet von einem Moderator:
Fietze

Fietze

Dauergast
Wenn du aber so vorgeht, kannst du das wohl bei jedem Rom Update machen?

Gehe mal in der OF oben auf die Kaffeetasse. ADB ist an?
Evtl. kannst du auch über den Terminal die Build.prob editieren. Findest du unter Erweitert.
Aber k. A. wie das geht.

Dann kannst du noch die Build.prob per OF Datei Manager kopieren, auf den internen Speicher schieben, so hast du vom PC Zugriff drauf, unter Windows mit dem Editor editieren und die alte Buildprob per OF Datei Manager durch die Editierte ersetzen.
Sollte auch funktionieren.
 
Zuletzt bearbeitet:
Bruno1872

Bruno1872

Stammgast
Gehe mal in der OF oben auf die Kaffeetasse. ADB ist an
ADB ist on, aber das ganze rechteckige Buttom ist grau.

Soll ich die Buildprob nach storage kopieren?

Wird aber nichts bringen, wenn ich unter OrangeFox keine Verbindung zu Windows bekomme.
Kann ich die Buildprob auch im OrangeFox editieren?
 
Fietze

Fietze

Dauergast
Bisher hat ja nur ADB nicht funktioniert.
Wenn in der OF MTP aktiviert ist, sollte in Windows das Telefon ganz normal als Wechsellaufwerk oder Medienspeicher angezeigt werden.
Einfach die Datei in bekannte Regionen kopieren.
D. H., wenn unter Storage deine dir bekannten Verzeichnisse und Dateien liegen? Ja, dann bist du dort richtig.
 
Bruno1872

Bruno1872

Stammgast
Ok.
Im OrangeFox Terminal geht ja der Editor Vi.
Bin mit dem kein Fuchs, aber damit könnte ich doch auch die build.prop editieren oder?

Zur Zeit ist die build.prop read only.

Nachtrag: ich mache erstmal Pause, das RN5 hat schon 52C und wird immer wärmer unter OrangeFox.
Erstmal runterkühlen sonst ist das Teil noch hinüber.
 
Zuletzt bearbeitet von einem Moderator:
J

JohnBill

Erfahrenes Mitglied
OrangeFox hat ein Terminal mit vi? Das macht es ja noch einfacher (jedenfalls für mich...)

Ich weiß ja noch immer nicht, woran es beim letzten Versuch geklemmt hat, im Zweifelsfall wirklich mehrfach überprüfen, ob /system als rw gemountet ist. Bei mir reicht dazu der Swipe beim Start von OF plus das Mounten im Mount-Menü. Habe das grade mal testweise verifiziert, im OF-Terminal dann mount eingegeben und /system ist als rw gemountet. Die build.prop hat dann 600 als Zugriffsrecht, im OF ist man aber sowieso als root unterwegs (sagt jedenfalls id in der shell), ist also egal. vi könnte hakelig in der Bedienung werden, sollte aber funktionieren.
 
Zuletzt bearbeitet:
Bruno1872

Bruno1872

Stammgast
OrangeFox hat ein Terminal mit vi? Das macht es ja noch einfacher (jedenfalls für mich...)
ja vi ist im Terminal von OrangeFox vorhanden.
Ich hatte die build.prop im vi (Terminal) schon geöffnet.

Den vi kenne ich zwar, aber bin mit vi kein Profi.
So, wie man im vi nach den entscheidenen Einträgen, wie
"persist.vendor.camera.HAL3.enabled=0"
suchen kann, um die Zeile zu editieren.
Muss ich mich mal einlesen:

Die Build.prop ist ja ziemlich lang.

:wq aktuelles File sichern und vi verlassen
:q! vi verlassen, ohne das aktuelle File zu sichern

Die build.prop hat dann 600 als Zugriffsrecht
Werde ich später noch mal testen.

Wie gesagt, mir war das RN5 zuletzt deutlich zu warm.
Ich weiß nicht ob, unter OrangeFox ein Überhitzungsschutz wirksam ist.
 
Zuletzt bearbeitet von einem Moderator:
Bruno1872

Bruno1872

Stammgast
Hallo,

ich habe in der build.prop mit vi Editor im Terminal des OrangeFox folgende Zeile geändert:
persist.vendor.camera.HAL3.enabled=0 auf =1

Nach Neustart des RN5 habe ich zum Test die App camera2 Probe verwendet https://play.google.com/store/apps/details?id=com.airbeat.device.inspector&hl

Da steht bei camera 1 aber nun auch nur legacy.
------------------------------------------------
Nachtrag
Das habe ich noch nicht eingefügt: ist nämlich nicht als Zeile vorhanden.
persist.camera.HAL3.enabled=1

Versuche ich jetzt.
Die Zeile lässt sich zwar einfügen, wird aber nicht gespeichert, da die build.prop read only ist.
Finde ich aber seltsam, da ich ja die Datei auch ändern konnte
und auf system per cp nach "build.prop.org" zur Sicherung kopieren konnte.

Wie mir scheint kann ich die System Partition nicht beschreibbar mounten mit OrangeFox.
Beim Start des OrangeFox wird mir angezeigt das data encrypted ist und
es wird nach einem Passwort verlangt. :(

-------------------------------------------------
Noch mal OrangeFox gestartet und mit vi die build.prop angesehen.
Der von mir geänderte Eintrag ist noch vorhanden.
Habe ich eine "falsche" build.prop" bearbeitet?

Mit OrangeFox hatte ich die system Partition gemountet
und dort mit vi die build.prop bearbeitet.
 
Zuletzt bearbeitet von einem Moderator:
Andy

Andy

Ehrenmitglied
Hier mal die bearbeitete build.prop im Anhang. Musst noch die Dateiendung .txt entfernen.
Vielleicht schaffst du es ja dann.

Nur noch zur Info: Du musst nach jedem Systemupdate die Prozedur wiederholen (also den Eintrag anpassen), da ja die build.prop überschrieben wird.
 

Anhänge

  • build.prop.txt
    11,2 KB Aufrufe: 75
Bruno1872

Bruno1872

Stammgast
Danke Andy,

seit gestern nicht noch mal probiert.
Also ich brauche beide dieser Zeilen in der build.prop
persist.vendor.camera.HAL3.enabled=1
persist.camera.HAL3.enabled=1

Wie kann es sein das ich die erste Zeile von =0 auf =1 per vi abspeichern konnte
aber die von mir eingefügte Zeile
persist.camera.HAL3.enabled=1
nicht abgespeichert wurde?

Mir wird im Vi Editor ja angezeigt, die build.prop sei "read only"
Das kann ich auch per chmod nicht ändern, schon probiert.

Soll das vielleicht am Fingerprint und PW Schutz liegen, das die Daten encrypted sind?
Irgendwo hier im Forum, war das wohl mal erwähnt.

Die System Partion kann ich zwar mounten und die Build.prop konnte ich auch kopieren,
nur meine eingefügte Zeile wurde, wie gesagt nicht übernommen.

Oder ich war zu blöd für den vi Editor.
suchen im vi nach String
/persist.vendor.camera.HAL3.enabled

darunter neue Zeile einfügen:
persist.camera.HAL3.enabled=1
Erst Esc Taste betätigen dann in Einfüge-Modus wechseln mit I
Text eingeben,
Abspeichern mit :w

Ich bilde mir ein so habe ich es richtig gemacht, aber ging nicht, wohl wegen read only.

Beim Start von OrangeFox wird mir gleich angezeigt das Data encrypted ist.
Der Swipe Schieber wir mir auch nicht gezeigt.
 
Zuletzt bearbeitet von einem Moderator:
TomGeBe

TomGeBe

Stammgast
Bruno1872 schrieb:
Wie mir scheint kann ich die System Partition nicht beschreibbar mounten mit OrangeFox.
Beim Start des OrangeFox wird mir angezeigt das data encrypted ist und
es wird nach einem Passwort verlangt. :(
Wenn ich das jetzt richtig verfolgt habe benutzt du Orangefox 9.01, nur ist die für Oreo. Für Pie mußt du 9.02 nehmen, da hast du dann auch keine Passwortabfage....

Um deinem Leiden ein Ende zu setzen kannst du die angefügte Zip in Orangefox 9.02 flashen, falls du dich traust ;)
Es handelt sich dabei um eine Zip aus dem Orngefox 8 Archiv. Ich habe das auf Pie angepasst und nutze es selbst um HAL3 frei zu schalten, wie weiter oben schon erwähnt nach jedem Update. Root ist meines Wissens nicht erforderlich.
 

Anhänge

  • Camera2Api_Pie.zip
    126,6 KB Aufrufe: 17
Zuletzt bearbeitet:
Bruno1872

Bruno1872

Stammgast
Stimmt, sehe ich jetzt es ist die Version OrangeFox-R9.0-1-whyred.
recovery.img laut Windows Explorer: 43.356 KB

Die Version Orangefox 9.02 hatte ich aber auch schon heruntergeladen.
Meiner Erinnerung nach kam dort beim Versuch zu booten eine Fehlermeldung.
... too many Links.

Ich versuche es noch mal.
Nachtrag gebootet hat die Version 9.02 nun doch :)
Jetzt wurde der von mir eingefügte Eintrag abgespeichert:
persist.camera.HAL3.enabled=1

Aber Camera2api Probe zeigt immer noch nur legacy

Danke, für das hochladen. Schauen wa mal. ;)
 
Zuletzt bearbeitet von einem Moderator:
Ähnliche Themen - Fastboot adb Devices Problem Antworten Datum
8