1. Nimm jetzt an unserem Uhans - 3. ADVENT - Gewinnspiel teil - Alle Informationen findest Du hier!

ADB mit Ubuntu Linux verwenden

Dieses Thema im Forum "Root / Hacking / Modding für HTC Desire HD" wurde erstellt von Alvar Hanso, 13.11.2010.

  1. Alvar Hanso, 13.11.2010 #1
    Alvar Hanso

    Alvar Hanso Threadstarter Fortgeschrittenes Mitglied

    Beiträge:
    381
    Erhaltene Danke:
    37
    Registriert seit:
    30.07.2009
    Hallo Zusammen,

    wäre schön wenn Ihr mir kurz helfen würdet. Komme nicht weiter und hab das Gefühl ich seh den Wald vor lauter Bäumen nicht.

    Wie der thread Titel schon sagt möchte ich mein DHD per ADB mit dem PC verbinden. Das SDK (2.2) ist installiert und funktioniert. Allerdings bekomme ich keine Verbindung zum Laufen.

    Code:
    alvarhanso@alvarhanso:~$ lsusb
    Bus 001 Device 003: ID 0bb4:0ca2 High Tech Computer Corp. 
    
    Als nächstes habe ich 51-android.rules in /etc/udev/rules.d erstellt

    Inhalt:

    SUBSYSTEM==”usb”, ATTRS{idVendor}==”0bb4“, ATTRS{idProduct}==”0ca2“, MODE=”0666″ OWNER=”alvarhanso”

    ...und

    sudo chown username 51.android.rules

    sudo chgrp username 51.android.rules


    ...ausgeführt

    Code:
    alvarhanso@alvarhanso:~$ adb devices
    List of devices attached 
    ????????????	no permissions
    
    alvarhanso@alvarhanso:~$ adb kill-server
    alvarhanso@alvarhanso:~$ adb start-server
    * daemon not running. starting it now on port 5037 *
    * daemon started successfully *
    alvarhanso@alvarhanso:~$ adb devices
    List of devices attached 
    ????????????	no permissions
    
    
    Wisst Ihr was ich falsch gemacht habe? Wäre nett.

    LG

    Alvar
     
  2. JustDroidIt, 13.11.2010 #2
    JustDroidIt

    JustDroidIt Android-Guru

    Beiträge:
    3,033
    Erhaltene Danke:
    882
    Registriert seit:
    14.03.2010
    Phone:
    HTC One M8
    Tablet:
    Nexus 7 (2013)
    Hast du die passenden Treiber installiert?

    Ist 'USB-Debugging' in den Einstellungen aktiviert?
     
  3. Alvar Hanso, 13.11.2010 #3
    Alvar Hanso

    Alvar Hanso Threadstarter Fortgeschrittenes Mitglied

    Beiträge:
    381
    Erhaltene Danke:
    37
    Registriert seit:
    30.07.2009
    USB Debugging ist natürlich aktiviert.

    Passende Treiber? :-O

    Wo bekomme ich die her? Kannst Du vielleicht etwas dazu sagen?

    Vielen Dank :-(
     
  4. ixi, 13.11.2010 #4
    ixi

    ixi Android-Lexikon

    Beiträge:
    1,093
    Erhaltene Danke:
    311
    Registriert seit:
    22.12.2009
  5. DoubleX667, 13.11.2010 #5
    DoubleX667

    DoubleX667 Android-Experte

    Beiträge:
    605
    Erhaltene Danke:
    100
    Registriert seit:
    23.01.2010
    Ich bin mir nicht sicher ob das mit den Rechte Änderungen an der 51-android.rules so eine gute Idee war...

    Zumindest musst du aber adb mindest einmal als root gestartet haben, mach mal ein

    sudo adb kill-server
    sudo adb start-server

    wenn es dann noch immer nicht geht, lösche die 51-android.rules und erstelle sie neu...

    ganz wichtig ist auch nach Änderungen an den udev Regeln udev neu zu starten

    sudo service udev restart
     
    hasbai und Alvar Hanso haben sich bedankt.
  6. Alvar Hanso, 14.11.2010 #6
    Alvar Hanso

    Alvar Hanso Threadstarter Fortgeschrittenes Mitglied

    Beiträge:
    381
    Erhaltene Danke:
    37
    Registriert seit:
    30.07.2009
    Problem gelöst. Lösung siehe Post 4. :)
     

Diese Seite empfehlen