1. Nimm jetzt an unserem 2. ADVENT-Gewinnspiel teil - Alle Informationen findest Du hier!

ADB zugriff unter Windows 7 funktioniert nicht!

Dieses Thema im Forum "Root / Hacking / Modding für HTC Desire" wurde erstellt von Toisan, 11.07.2010.

  1. Toisan, 11.07.2010 #1
    Toisan

    Toisan Threadstarter Android-Experte

    Beiträge:
    455
    Erhaltene Danke:
    26
    Registriert seit:
    18.02.2010
    Phone:
    HTC Desire
    hallo,

    habe seit kurzem (gestern) Windows 7 instaliert, nun habe ich das Android SDK, HTC Sync und Java JDK runtergeladen, Path unter Systemvariablen gesetzt, und wollte nun zum testen eine .apk die in dem Tools ordner vom Android SDK liegt instalieren!

    so bin ich vorgegangen:

    jemand ne idee wie das ganze unter Windows7 läuft, unter meinem alten Vista hatte ich keine Probleme...

    Habe Win7 Home Premium 32 bit.


    vielen dank und LG
     

    Anhänge:

    • adb.PNG
      adb.PNG
      Dateigröße:
      58.5 KB
      Aufrufe:
      1,970
    Zuletzt bearbeitet: 11.07.2010
  2. norbert, 11.07.2010 #2
    norbert

    norbert Ehrenmitglied

    Beiträge:
    9,394
    Erhaltene Danke:
    1,631
    Registriert seit:
    10.02.2009
    Phone:
    LG G3
    Tablet:
    Medion Lifetab P9516
    Dem bild nach zu urteilen: vor dem cd hättest vielleicht erst auf lw d wechseln sollen? (D:)
    Und was meinst mit "des cmd fellt"?
     
  3. wanschi, 11.07.2010 #3
    wanschi

    wanschi Android-Lexikon

    Beiträge:
    1,122
    Erhaltene Danke:
    246
    Registriert seit:
    25.09.2009
    also ich habe auch wondows 7 64 bit und habe da keine probleme mit adb.
    hast du im desire das usb debugging in den optionen aktiviert?
    und der pfad scheint nicht zu stimmen bei dir.
    ansonsten probier mal "adb kill-server" und danach wieder "adb start-server".
    manchmal hilft das auch. wobei manchmal bei "adb devices" auch der server ist mal beendet wird und automatisch gestartet wird.
     
  4. Toisan, 11.07.2010 #4
    Toisan

    Toisan Threadstarter Android-Experte

    Beiträge:
    455
    Erhaltene Danke:
    26
    Registriert seit:
    18.02.2010
    Phone:
    HTC Desire
    also pfad ist 1000% richtig, habe ihn ja dort kopiert, USB debug. is au an, probiere nun mal des mit dem server...

    LG

    EDIT/ also server wurde gekillt, gestartet, sieht nun so aus:

    [​IMG]
     

    Anhänge:

    • adb.PNG
      adb.PNG
      Dateigröße:
      73.3 KB
      Aufrufe:
      1,864
    Zuletzt bearbeitet: 11.07.2010
  5. wanschi, 11.07.2010 #5
    wanschi

    wanschi Android-Lexikon

    Beiträge:
    1,122
    Erhaltene Danke:
    246
    Registriert seit:
    25.09.2009
    also wenn das bild oben stimmt, dann stimmt dein pfad nicht. denn du landest wieder in deinem user ordner "tim" und nicht im sdk und nicht im tools ordner.
     
  6. norbert, 11.07.2010 #6
    norbert

    norbert Ehrenmitglied

    Beiträge:
    9,394
    Erhaltene Danke:
    1,631
    Registriert seit:
    10.02.2009
    Phone:
    LG G3
    Tablet:
    Medion Lifetab P9516
    An win7 kanns nicht liegen, ich nutz es auf meinem netbook mit der starter-version.
    Pfad hab ich gar nicht gesetzt, ich wechsel immer händisch dorthin. Brauch es aber auch nur selten für push/pull
     
  7. norbert, 11.07.2010 #7
    norbert

    norbert Ehrenmitglied

    Beiträge:
    9,394
    Erhaltene Danke:
    1,631
    Registriert seit:
    10.02.2009
    Phone:
    LG G3
    Tablet:
    Medion Lifetab P9516
    Ich hab ja schon geschrieben er muss auf laufwerk d: wechseln ...
     
  8. Toisan, 11.07.2010 #8
    Toisan

    Toisan Threadstarter Android-Experte

    Beiträge:
    455
    Erhaltene Danke:
    26
    Registriert seit:
    18.02.2010
    Phone:
    HTC Desire

    aber was ich dann nicht verstehe, ich kopiere den link oben aus dem fenster raus, und füge es im cmd ein?

    wie kann dann der link nich stimmen, außerdem gibt es eine möglichkeit das die nötigen treiber nicht vorhanden sind?

    Bild:

    [​IMG]
     

    Anhänge:

    • adb.PNG
      adb.PNG
      Dateigröße:
      201.1 KB
      Aufrufe:
      1,971
  9. norbert, 11.07.2010 #9
    norbert

    norbert Ehrenmitglied

    Beiträge:
    9,394
    Erhaltene Danke:
    1,631
    Registriert seit:
    10.02.2009
    Phone:
    LG G3
    Tablet:
    Medion Lifetab P9516
    Hört mir keiner zu? Also noch mal

    Win+r, cmd+enter
    D:
    Cd /android.....
    Adb .......
     
  10. Toisan, 11.07.2010 #10
    Toisan

    Toisan Threadstarter Android-Experte

    Beiträge:
    455
    Erhaltene Danke:
    26
    Registriert seit:
    18.02.2010
    Phone:
    HTC Desire
    sry, dann kommt das:
    [​IMG]




    aber iwie kann es doch schon an den treibern liegen?

    siehe Bild:

    [​IMG]

    außerdem denke ich kann es nicht am ADb selbst liegen!

    [​IMG]


    denn wenn ich nur "adb" ins cmd schreib kommt des ganze...

    LG
     

    Anhänge:

    • adb2.PNG
      adb2.PNG
      Dateigröße:
      28.4 KB
      Aufrufe:
      1,913
    • adb3.PNG
      adb3.PNG
      Dateigröße:
      122.1 KB
      Aufrufe:
      1,922
    Zuletzt bearbeitet: 11.07.2010
  11. norbert, 11.07.2010 #11
    norbert

    norbert Ehrenmitglied

    Beiträge:
    9,394
    Erhaltene Danke:
    1,631
    Registriert seit:
    10.02.2009
    Phone:
    LG G3
    Tablet:
    Medion Lifetab P9516
    Ich kenn mich mit adb nicht sonderlich aus.

    Schon mal

    Adb remount
    Adb install xyz.apk

    Versucht?

    Find's übrigens putzig das du immer von links redest, aber eigentlich pfade und dateinamen meinst ggg
    Empfehle mal, sich vorerst mal mit dos-grundlagen zu beschäftigen :)
     
  12. lumich, 11.07.2010 #12
    lumich

    lumich Fortgeschrittenes Mitglied

    Beiträge:
    334
    Erhaltene Danke:
    42
    Registriert seit:
    20.05.2010
    Phone:
    HTC Desire
    Mit CD und so kann man sich sparen. Einfach in den Ordner wo die adb.exe ist über den Explorer wechseln, Shift-Taste gedrückt halten, rechte Maustaste und Eingabeaufforderung hier öffnen auswählen. :)
     
  13. Toisan, 11.07.2010 #13
    Toisan

    Toisan Threadstarter Android-Experte

    Beiträge:
    455
    Erhaltene Danke:
    26
    Registriert seit:
    18.02.2010
    Phone:
    HTC Desire
    bringt auch nichts:

    [​IMG]
     

    Anhänge:

    • adb.PNG
      adb.PNG
      Dateigröße:
      23.2 KB
      Aufrufe:
      1,370
  14. lumich, 11.07.2010 #14
    lumich

    lumich Fortgeschrittenes Mitglied

    Beiträge:
    334
    Erhaltene Danke:
    42
    Registriert seit:
    20.05.2010
    Phone:
    HTC Desire
    Die neuesten HTC Treiber hast du drauf? Welches ROM nutzt du denn? Wird es noch als Wechseldatenträger erkannt? Ich hatte auch mal Probleme mit einen 2.2 ROM, da es als Passion erkannt wird. Es kann sein das es dann durch das public:windows_hboot_driver_install [RootWiki] bei mir behoben wurde. Bin mir aber nicht sicher
     
  15. norbert, 11.07.2010 #15
    norbert

    norbert Ehrenmitglied

    Beiträge:
    9,394
    Erhaltene Danke:
    1,631
    Registriert seit:
    10.02.2009
    Phone:
    LG G3
    Tablet:
    Medion Lifetab P9516
    Das geht unter win7 auch so? Noch gar nicht probiert.
    Aber ehrlich gesagt, ich bin am dos-prompt viel schneller als mit dem explorer. Wahrscheinlich auch schneller als du :)
     
  16. Toisan, 11.07.2010 #16
    Toisan

    Toisan Threadstarter Android-Experte

    Beiträge:
    455
    Erhaltene Danke:
    26
    Registriert seit:
    18.02.2010
    Phone:
    HTC Desire
    also ich habe des HTC sync nochmal neu instaliert, android sdk neu runtergeladen und jetzt wird es wenigstens unter "adbe devices" gelistet.

    hoffe das bleibt auch so...

    lg und vielen dank für die gedult =)
     
  17. Bob@Nexus, 24.08.2010 #17
    Bob@Nexus

    Bob@Nexus Android-Experte

    Beiträge:
    755
    Erhaltene Danke:
    22
    Registriert seit:
    28.10.2009
    Ich schaffe es mittlerweile mein Desire mit dem PC zu verbinden. Ich schaffe es aber immer noch nicht System-Apps zu löschen, entweder kommt "Read-Only System" oder "rm" not listed.

    Kann mir irgend jemand weiterhelfen
     
  18. cargo, 24.08.2010 #18
    cargo

    cargo Gast

    @Bob@Desire

    1. starte dein Desire ins Recovery Menü (leiser Taste u.s.w.)
    2. öffne die Eingabeaufforderung und wechsel per cd in den "adb tools" Ordner
    3. tip dann folgendes ein:

    adb shell (enter)
    mount system (enter)
    cd system (enter)
    cd app (enter)
    ls (enter) mit ls wird dir der Inhalt aufgelistet

    Programme löschen funzt z.B. so:

    rm HTCFootprints.apk (enter - damit löschst du nur diesen App-Teil)

    wenn du alles was mit z.B. Footprints zu tun hat löschen möchtest tip das ein:

    rm *Footprints* (enter - mit den Sternchen werden alle Apps die zu Footprints gehören gelöscht)

    danach nochmal ls eintippen dann siehst du das die gelöschten Programme nicht mehr dabei sind.:D:D

    Viel Spaß beim löschen
     
    Pierro bedankt sich.
  19. M-Arc, 16.09.2011 #19
    M-Arc

    M-Arc Neuer Benutzer

    Beiträge:
    8
    Erhaltene Danke:
    0
    Registriert seit:
    11.09.2011
    hey leute ich hab mal ein Adb Tut gefunden
    Installiere Android SDK/ADB/Fastboot auf Ubuntu Linux « Inmediato.de
    nach dem ich es versucht habe aber irgentwie komm ich nicht weiter wenn ich den fastboot binary ausführbar machen möchte hab bei meinem win 7 keine Option die sich Zugriffsrechte nennt und wenn ich die Links jetzt im Cmd eingeben kommt immer die Fehlermeldung :der Befehl Abd wurde nicht gefunden oder falsch geschieben
     
  20. 2WildFire, 16.09.2011 #20
    2WildFire

    2WildFire Android-Guru

    Beiträge:
    3,000
    Erhaltene Danke:
    469
    Registriert seit:
    26.10.2010
    Hast die cmd mal als admin gestartet?
     

Diese Seite empfehlen