1. Nimm jetzt an unserem Uhans - 3. ADVENT - Gewinnspiel teil - Alle Informationen findest Du hier!

Boot / Startsound ICS Bei Galaxy WIE ?

Dieses Thema im Forum "Root / Hacking / Modding für Samsung Galaxy S" wurde erstellt von Andeas_hu, 29.01.2012.

Status des Themas:
Es sind keine weiteren Antworten möglich.
  1. Andeas_hu, 29.01.2012 #1
    Andeas_hu

    Andeas_hu Threadstarter Fortgeschrittenes Mitglied

    Beiträge:
    281
    Erhaltene Danke:
    139
    Registriert seit:
    29.01.2012
    Hallo erstmal,
    bin neu und muss sagen, tolles Forum........

    Habe mir nun auf mein Galaxy die akutelle ICS Version von
    onecosmic´s eingespielt, dann den aktuellsten Kernel von Teufel.

    Dank des Forums und viel lesen habe ich alle Probs lösen können, eines blieb aber
    über...

    Ich bekomme keinen Bootsound abgespielt.
    Habe eine feine Bootanimation eingefügt, läuft auch prima, aber der passende
    Sound dazu will einfach nicht abspielen. Ob mp3, ob wave, in allen möglichen Verzeichnissen hin und her kopiert, nix....

    Hat jemand da einen Tip für mich ???:crying:

    Grüße,
    Andreas
     
  2. ilovemysgs, 30.01.2012 #2
    ilovemysgs

    ilovemysgs Android-Lexikon

    Beiträge:
    1,094
    Erhaltene Danke:
    156
    Registriert seit:
    26.08.2011
    wie weiß ich nicht muss aber ne ogg sein

    Gesendet von meinem GT-I9000 mit Tapatalk
     
  3. Bavaria_Blues, 30.01.2012 #3
    Bavaria_Blues

    Bavaria_Blues Gast

  4. Andeas_hu, 31.01.2012 #4
    Andeas_hu

    Andeas_hu Threadstarter Fortgeschrittenes Mitglied

    Beiträge:
    281
    Erhaltene Danke:
    139
    Registriert seit:
    29.01.2012
    hmmm, also

    ich habe in der aktuellen RC4 eine Bootanimation.zip unter System/Media liegen.
    Die wird auch abgespielt ( die bunten Ecken ).

    Alternativ kann ich auch eine Bootanimation.zip in /data/local ablegen, auch die
    wird abgespielt.

    Da ich keinen Platz mehr in meinem System Rom habe, konnte ich meine große
    Bootanimation ( Android Männchen lasert Apple Symbol weg ) dort ablegen.

    Also hab ich nun dieser 6 MB Große Zip Datei unter /data/local abgelegt und die
    Bootanimation.zip in System/Media gelöscht.

    Nun wird mir nach dem Kernel Bootlogo die Animation abgespielt, prima.
    Und ich hab wieder etwas Luft in meinem System Rom.

    Soweit, so gut.....

    Nun hab ich einen passenden WAV Sound zur Animation.

    Nur wo stelle ich den unter RC 3.1oder 4.0 eben hin und in welchem Format und wie muss die Datei lauten ??? ( Poweron.wav etc. ??? )

    Finde da nix dazu unter rc 3.1 oder 4.0, hab was unter desire gefunden, passt aber nicht......
     
  5. Weissi46, 31.01.2012 #5
    Weissi46

    Weissi46 Android-Experte

    Beiträge:
    496
    Erhaltene Danke:
    106
    Registriert seit:
    07.11.2011
    Phone:
    Oneplus One
    die datei muss soweit ich weiß im ogg format sein (PowerOn.ogg)

    Gesendet von meinem GT-I9000 mit der Android-Hilfe.de-App
     
  6. Andeas_hu, 31.01.2012 #6
    Andeas_hu

    Andeas_hu Threadstarter Fortgeschrittenes Mitglied

    Beiträge:
    281
    Erhaltene Danke:
    139
    Registriert seit:
    29.01.2012
    Tja, immer noch kein Erfolg...........

    Ich fasse mal zusammen:

    Datei Bootanimation.zip in /system/media wird abgespielt.
    Datei Bootanimation.zip in /data/local wird auch abgespielt.

    Lösche ich die Bootanimation.zip sowohl in Media als auch in local , es befindet sich also keine bootanimation.zip mehr im System, wird dennoch nach Kernel logo
    eine Bootanimation abgespielt.

    Und zwar ein Schriftzug "android" in türkis, der von links nach rechts weißlich durchleuchtet wird.

    Wie und wo der sich befindet, hab ich noch nicht gefunden..

    Zum Thema Sound:

    Es gelingt mir nicht, einen Bootsound abzuspielen, hab schon alles versucht,
    PowerOn.ogg, PowerOn.wav, Poweron.snd in alle möglichen Verzeichnisse ohne jedglichen Erfolg.

    Kann das auch eine Kernel Frage sein, das sowas nicht von den Kernels unterstützt wird ??

    Letztlich muss ja vor fertigem Laden des Betriebssystemes dies alles irgendwie abgespielt werden ??

    Gibt es denn dazu keinerlei Dokumentation innerhalb der RC 3.1 oder 4.0 ?
     
  7. scheichuwe, 31.01.2012 #7
    scheichuwe

    scheichuwe Android-Ikone

    Beiträge:
    5,441
    Erhaltene Danke:
    2,541
    Registriert seit:
    09.09.2009
    Phone:
    LG G4
  8. Andeas_hu, 31.01.2012 #8
    Andeas_hu

    Andeas_hu Threadstarter Fortgeschrittenes Mitglied

    Beiträge:
    281
    Erhaltene Danke:
    139
    Registriert seit:
    29.01.2012
    Danke erstmal,

    Da ich aber ein wenig "blond" bin, hänge ich nun bei der Ausführung fest.

    Laut Anweisung soll ich:

    schnipp-----------


    0. It's recommended to do a nandroid backup first!

    1. Download the "bootsnd.sh" file and put it on the root of your sd card.

    2. Download the "android_audio.mp3" file and using root explorer copy it to /system/media

    3. Open Terminal Emulator and type the following commands using the stock keyboard. Press enter after each line:
    su
    cd /sdcard
    sh bootsnd.sh
    reboot

    4. As the device boots up you will be greeted by the "Dolby THX" test sound heard before movies. You are now free to replace the android_audio.mp3 file in /system/media with any .mp3 file you like as long as you rename it to "android_audio.mp3"

    5. DO NOT ATTEMPT TO OUTSMART THESE DIRECTIONS OR YOU WILL BE RESTORING YOUR NANDROID BACKUP!

    6. Enjoy

    _schnapp----------

    Habe mir alle Files gezogen und an die jeweiligen Stellen kopiert.
    Habe mir aus dem Market einen Terminal Emulator gezogen.
    Den starte ich und sehe als erstes:

    a/local/bin:$path
    app_97@android:/ $

    Ich tippe: su (return)

    app_97@android:/ #

    Ich tippe: cd /sdcard

    app_97@android:/sdcard #

    Ich tippe: sh bootsnd.sh (return)

    Es erscheint: NO such User ´root:shell´

    Was hab ich falsch gemacht ???

    Bitte um Nachhilfestunden, danke
     
  9. Andeas_hu, 01.02.2012 #9
    Andeas_hu

    Andeas_hu Threadstarter Fortgeschrittenes Mitglied

    Beiträge:
    281
    Erhaltene Danke:
    139
    Registriert seit:
    29.01.2012
    Ok, News......

    Es geht, sowohl Bootanimation als auch Bootsound.

    Allerdings nur unter dem Devil Kernel, aktuelle Version.

    Zum einen war ein Fehler im Script, zum anderen mußte einiges geändert werden. Dank eines guten Kumpels von mir, der sich in Script programmierung
    gut auskennt, haben wir es in 4 Stunden hinbekommen.

    Es wird nun das ursprüngliche Script bearbeiten, mir dann zuschicken, ich werde mein SGS wieder plattmachen um dann das script zu testen.

    Wenn alles klappt, werde ich es hier dann einstellen.

    bis später....

    UPDATE: Fertig, habs geschafft, und hab einen neuen Fred aufgemacht, dieser kann ja mit Verweis auf den neuen geschlossen werden.
     
    Zuletzt bearbeitet: 01.02.2012
  10. DrMole, 02.02.2012 #10
    DrMole

    DrMole Android-Ikone

    Beiträge:
    4,941
    Erhaltene Danke:
    1,463
    Registriert seit:
    06.08.2010
Status des Themas:
Es sind keine weiteren Antworten möglich.

Diese Seite empfehlen