1. Nimm jetzt an unserem Uhans - 3. ADVENT - Gewinnspiel teil - Alle Informationen findest Du hier!

Das Akkulog "der große Schwund"

Dieses Thema im Forum "LG Optimus Speed (P990) Forum" wurde erstellt von space79, 09.04.2011.

  1. space79, 09.04.2011 #1
    space79

    space79 Threadstarter Erfahrener Benutzer

    Beiträge:
    238
    Erhaltene Danke:
    103
    Registriert seit:
    09.05.2010
    Guten Morgen Gemeinde!

    So, nachdem ich nun schon einige male dachte der Lösung des Akkudrain-Problems auf die Schliche gekommen zu sein und sich das jedesmal als zu kurzweilige Beobachtung herausgestellt hat, habe ich beschlossen einen vollständigen Wipe meines OS durchzuführen. Und zwar mit NVFlash.

    Warum NVFlash? Ganz einfach, ich lief bisher an MoDaCo ROMs. Also mit Root, angepassten System Apps usw.

    Und immer wieder habe ich von NiCiN gelesen dass ihr Akku so (beinahe) unendliche Standby reserven zu haben scheint. Das hat mich letztlich so genervt dass ich es wissen wollte.

    In diesem Threat möchte ich nun versuchen herauszufinden was, welche App oder welches Zusammenspiel aus Apps oder Apps und Einstellungen für den "großen Schwund" verantwortlich ist.

    Von daher bitte ich ALLE sich in diesem Threat zusammenzureißen, nicht ins OT Abzuschweifen, sondern produktiv mit zu helfen. Auch mag ich die Mods bitten hier hart durchzugreifen und OT in die passenden Threats auzulagern oder wenn es nicht anders geht zu löschen. So dass dieser Threat ein reines produktives Ergebnis erbringen kann.

    Wie soll das nun erreicht werden? Ganz einfach. In aller erster Linie richtet sich das nicht an die Leute mit Custom ROMs, sondern an alle die bisher noch nicht gerootet haben, kein CWM installiert haben usw. Denn ich will versuchen eine Analyse von Anfang an aufzunehmen. Nach jeder Änderung im System solltet ihr zusehen das OS für mindestens 2h im Standby laufen zu lassen um zu sehen ob sich die Verbrauchswerte wieder einregeln, oder ob diese nun daneben liegen.

    Ist das der Fall muss wohl oder übel gerootet werden um die App zu freezen oder zu löschen um zu sehen ob es nun daran lag oder nicht..........

    Demnach mache ich auch gleich den ersten Schritt und berichte euch folgendes:


    Gestern:

    1. Ich habe gestern Abend ca. 2200 die Kiste mittels NVFlash auf den aktuellsten Stand (v10b) mit der neuesten Baseband gebracht.

    2. Ich habe nur den Google Account eingerichtet und das "Battery Monitor Widget" installiert (und das Widget auf dem Homescreen abgelegt), sowie die ganzen anderen Widgets vom Homescreen entfernt.

    3. Das Ergebnis: 2330-0830 -> 3% Akkuverlust. Sensationell! Es liegt also vielleicht nicht an LG-Apps oder generell dem Gerät!


    Heute:

    1. F-Secure aktiviert, kurzen Prüfvorgang gestartet und wieder abgebrochen.


    Nun werde ich ca. 2h-3h lang versuchen das Handy im Standby zu lassen um zu sehen auf welches Niveau sich der Akku in dieser Zeit einregelt.


    EDIT: Ich habe vergessen zu erwähnen dass ich hier in meiner Wohnung nur einen erbärmlich mießen 3G Empfang habe und daher das Handy auf 2G begrenzt ist. Auch, was aber hier irrelevant sein dürfte habe ich die Displayhelligkeit auf automatisches Management gestellt.

    EDIT2: WLAN war ständig an bzw. ich habe es nicht von Hand deaktiviert! Sprich Originalsetting in den Energieeinstelllungen! Und bei ausgeschaltetem Display geht es nach einer gewissen Zeit automatisch auf 2G zurück.
     
    Zuletzt bearbeitet: 09.04.2011
    McFlow, moony, aquarito und 4 andere haben sich bedankt.
  2. n3m3sis, 09.04.2011 #2
    n3m3sis

    n3m3sis Android-Hilfe.de Mitglied

    Beiträge:
    56
    Erhaltene Danke:
    1
    Registriert seit:
    09.04.2011
    ich hab gerootet und dann f-secure und carhome entfernt. hatte so am ende des tages bei gleicher (intensiver) nutzung anstatt 13 noch 29% vom akku über. displayhelligkeit manuell zu reduzieren bringt auch was. gps und wlan sollte man auch nur an machen wenn man es braucht.

    hab mir das battery monitor widget installiert und werd die sache mal beobachten
     
  3. moony, 09.04.2011 #3
    moony

    moony Neuer Benutzer

    Beiträge:
    10
    Erhaltene Danke:
    0
    Registriert seit:
    01.04.2011
    Hallo,

    ich habe mein Speed nun seit einer Woche, alles was "mitgeliefert" wurde ist immer noch drin (Originalzustand :biggrin:) und außer ein paar neuen Widges habe ich nichts installiert.

    Ich bin, auch mit der Akkuleistung voll zufrieden :thumbsup:

    Ich gebe es nimmer her :wubwub::wubwub:
     
  4. space79, 09.04.2011 #4
    space79

    space79 Threadstarter Erfahrener Benutzer

    Beiträge:
    238
    Erhaltene Danke:
    103
    Registriert seit:
    09.05.2010
    So, ein weiterer Stand ohne Änderungen am System. Ich war etwas unterwegs, hatte davor ein kurzes Telefonat und das OS dann die letzten zwei Stunden nicht mehr genutzt...

    So, nun aber zu den neuen Ergebnissen:

    von 0855 bis 1000 1%
    von 1000 bis 1050 1%

    Der Log des Battery Widget beschreibt nunmehr immer "-5mA" anstelle wie in der Nacht "-2mA". Bei nächster Gelegenheit werde ich mir das mal genauer ansehen, denn wenn die Zeitabstände Nachts kleiner und Tagsüber größer sind, relativiert sich der Stromverbrauch ja wieder...

    Als nächsten Schritt werde ich nun mittels Super-One-Click rooten und den System App Remover installieren um F-Secure zu kicken. Danach werde ich es wiedermals liegen lassen um zu sehen ob und was sich tut.

    EDIT: Root in unter 20 Sekunden erledigt, dafür ja eine App runtergeladen. Ich gehe davon aus, dass bis auf erhöte Werte in den nächsten Minuten das Log schnell wieder auf "normal" fallen (seitens des Stromverbrauchs) sollte.

    EDIT2: Um den Gesamt Akkuverlauf mal darzustellen:

    Mein Test beginnt gestern um 2330 mit 82% Akkuladung!
    Jetzt (1150) im Augenblick (kurzes Telefonat + Display ab und an angeschalten [~4 Minuten] hat es noch 71% Akkuladung!

    Alleine dieser Wert ist doch schon echt toll :D Weil ~11% Akku in ca. 12h finde ich Klasse!!!
     
    Zuletzt bearbeitet: 09.04.2011
  5. Caracal, 09.04.2011 #5
    Caracal

    Caracal Android-Hilfe.de Mitglied

    Beiträge:
    130
    Erhaltene Danke:
    66
    Registriert seit:
    27.03.2011
    Mal eine Frage dazu...
    welches Batterie Monitor Widget nutzt du ?
    Könntest du da mal nen Link zum Market posten ?

    Und ich muss sagen das ich im moment Juice Defender nutze der ja
    allein viele Stromsparmaßnahmen macht. Also 2G statt 3G einschalten wenn nicht gebraucht etc.. das hat bei mir schon mal was gebracht aber 1,5 Tag Akkulaufzeit mit dem MoDaCo Fr10 ist trotzdem das Maximale was drin ist.
     
  6. fighterchris, 09.04.2011 #6
    fighterchris

    fighterchris Ehrenmitglied

    Beiträge:
    7,270
    Erhaltene Danke:
    1,487
    Registriert seit:
    16.08.2010
    Phone:
    LG G2
    @space79 kann es sein das das neue Baseband auch bissl besser ist als das alte ?? Möchte mal Erfahrungen drüber hören ob es sich lohnt zu flashen.
     
  7. space79, 09.04.2011 #7
    space79

    space79 Threadstarter Erfahrener Benutzer

    Beiträge:
    238
    Erhaltene Danke:
    103
    Registriert seit:
    09.05.2010
    Ich habe es im ersten Post von mir verlinkt. Beachtet bitte dass ein Widget aktiv sein muss damit das ganze funktioniert!
     
  8. space79, 09.04.2011 #8
    space79

    space79 Threadstarter Erfahrener Benutzer

    Beiträge:
    238
    Erhaltene Danke:
    103
    Registriert seit:
    09.05.2010
    Ja, das neue BaseBand bringt ein paar Vorteile gegenüber dem alten. Einige hatten Probleme mit der Sprachqualität und auch mit dem Empfang. Siehe einige Beiträge im XDA. Da half das neue BaseBand hervorragend.

    Ich selbst habe es einfach so, direkt nach dem auspacken des OS geflasht... ;)
     
  9. n3m3sis, 09.04.2011 #9
    n3m3sis

    n3m3sis Android-Hilfe.de Mitglied

    Beiträge:
    56
    Erhaltene Danke:
    1
    Registriert seit:
    09.04.2011
    das battery widget zeigt, wenn ich es antippe, ein menü wo grafisch der verbrauch dargestellt ist. bei akku steht li-ion und 120mAh. sollte das handy nicht einen 1500mAh akku haben????
     
  10. space79, 09.04.2011 #10
    space79

    space79 Threadstarter Erfahrener Benutzer

    Beiträge:
    238
    Erhaltene Danke:
    103
    Registriert seit:
    09.05.2010
    schau dir die settings des widgets halt mal an... da kannst du die kapazität des akku einstellen ;)

    und unter dem button "view history" siehst du dann genau von wann bis wann er um jeweils x prozent gesunken ist.

    dazwischen sind zwar auch immer stromverbrauchszahlen, aber die kann ich mir erst in ner stunde genauer ansehen... dann vergleiche ich mal die nacht mit den jetztigen tagsüber werten. weil evtl (habe ich weiter oben geschrieben) sind diese stromangaben relativierbar.

    nächstes mal bitte aber einen extra threat eröffnen wo es um fragen um diese app geht, ich mag das hier zwecks übersicht echt so knapp wie möglich halten... evtl. mag ein mod so einen threat anlegen und die beiden posts auslagern?!
     
  11. JB83, 09.04.2011 #11
    JB83

    JB83 Fortgeschrittenes Mitglied

    Beiträge:
    294
    Erhaltene Danke:
    29
    Registriert seit:
    09.03.2011
    Ich meine, man kann das Problem relativ gut auf den Bildschirm eingrenzen, wenn man die Themen im Forum hier von Anfang an mitverfolgt hat, oder?
    Von einer guten Standby-Zeit berichtet so ziemlich jeder. Wenn dat Dingen aber an ist, hat es einen ziemlich hohen Verbrauch, unabhängig von Nutzung oder Apps etc.!
     
  12. space79, 09.04.2011 #12
    space79

    space79 Threadstarter Erfahrener Benutzer

    Beiträge:
    238
    Erhaltene Danke:
    103
    Registriert seit:
    09.05.2010
    1155 bis 1305: 1% (69% bzw. 70%) Akkudrain. Zwei SMS empfangen und hin und wieder auf das Display gesehen.

    Nun werde ich die CWM Beta3 installieren, ein Backup machen und dann die beiden Fixes für das Stock-ROM installieren.

    Mal sehen ob und was sich dann ändert....

    Stand nach drei geschriebenen SMS zur jetzt-Zeit: 68% Akkurestkapazität

    EDIT: Ich musste es tun (zwecks vorher nachher Vergleich) und habe Quadrant Standart installiert: 2511 Pkt.
     
    Zuletzt bearbeitet: 09.04.2011
  13. space79, 09.04.2011 #13
    space79

    space79 Threadstarter Erfahrener Benutzer

    Beiträge:
    238
    Erhaltene Danke:
    103
    Registriert seit:
    09.05.2010
    So, nun habe ich folgendes gemacht:

    Nochmal ne SMS geschrieben ^^ (höhö), dann den CWM Beta3 installiert, Daten vom PC auf die SD verschoben und geflasht:

    1. Stock Battery Percentage Mod
    2. Stock Camerbrigthness and Camcorder No_Sound Fix r1

    Reboot (Habe den Speedfix vergessen :D), Normaler Betrieb, kopieren der r2 des Speedfixes auf die SD, 3.2 wieder Recovery und installation des

    3. Stock Speedfixes r2

    Bei Quadrant kommt nun folgendes heraus: 2852 Pkt.

    Akku steht nun als Zwischenstand bei 65% (1335 Uhr)
     
    Zuletzt bearbeitet: 09.04.2011
  14. fighterchris, 09.04.2011 #14
    fighterchris

    fighterchris Ehrenmitglied

    Beiträge:
    7,270
    Erhaltene Danke:
    1,487
    Registriert seit:
    16.08.2010
    Phone:
    LG G2
    @space79 ich dachte du machst ne Log von einer normalen Benutzung (ohne Flashen usw) somt find ich das dann gar nicht mehr so aussagekräftig ,da das X2 ja schon wieder für ein paar Min am Ladegerät hing und keiner weis wieiviel % Akku geladen wurden.
     
  15. space79, 09.04.2011 #15
    space79

    space79 Threadstarter Erfahrener Benutzer

    Beiträge:
    238
    Erhaltene Danke:
    103
    Registriert seit:
    09.05.2010
    Keine Angst, die paar Sekunden die ich die Kiste am USB Port hängen habe kannst du getrost komplett vernachlässigen. Der Port ist so schwach dass da kaum was in den Akku geht.

    Und wie du siehst musste ich das Tele sogar zwei mal booten zum flashen und habe den Quadrant auch zweimal laufen lassen.

    Beim laden ist die Energieeaufnahme nicht annähernd so effizient wie beim leeren.

    Und am USB hing es für weniger als 30 Sekunden Gesamt. Denn die Files haben nur ganz wenige MB. Auch der CWM ist innerhlab von wneigen Sekunden installiert (hier wird ja auch Akku verbraucht - wenn auch Saft seitens des USB kommt.

    Im Endeffekt hält sich das minimalst pro USB Stromzufuhr die Waage ;)

    Ich bereite hier alles immer vor und versuche dann so schnell wie möglich zu sein :D

    Mit diesem "Log" geht es mir in erster Linie um den Drain im Standby. Dass es klar sein sollte dass je nach Masse an Anwendungen der Akku unter natürlichem Schwund leidet ist klar.

    Ich will herausfinden wer der bzw. die Übeltäter sind, die den Standby so mies runterziehen.
     
  16. fighterchris, 09.04.2011 #16
    fighterchris

    fighterchris Ehrenmitglied

    Beiträge:
    7,270
    Erhaltene Danke:
    1,487
    Registriert seit:
    16.08.2010
    Phone:
    LG G2
    @space79 ok alles klar . Hatte die letzten Tage selbst Probleme mit dem Akku , immer innerhalb 12 Std leer. Nun hab ich einfach mal Google Sync (Kontakte ,Gmail) abgeschaltet und nun hab ich innerhalb 6Std 3 % Akku verloren. Habs auch zwischendurch benutzt
     
  17. space79, 09.04.2011 #17
    space79

    space79 Threadstarter Erfahrener Benutzer

    Beiträge:
    238
    Erhaltene Danke:
    103
    Registriert seit:
    09.05.2010
    Aaaah :) Siehe da, und noch ein weiterer Hinweis :D Seeeehr schön :D

    Wobei ich es bei mir durchgehend an habe. Denn ich nutze das Teil ja geschäftlich. Hier synchronisiere ich nämlich den Kalender zwischen Online, Handy und Outlook.

    Ist schon komisch das ganze. Es wird sich doch ein schuldiger finden lassen müssen -.-

    Was mir beim Akkuwidget diese Tage bereits aufgefallen ist, ist dass wenn einmal eine höhere Belastung auf den Akku drückt, zeigt das Widget bei den nachfolgenden Aktualisierungen (immer im fünf Minuten Takt) sehr hohe Verbrauchswerte an, der Akkuladezustand (in Prozent) bleibt aber gleich.

    Jetzt steht (obwohl einiges als Verbrauch da steht) er immer noch bei 65% (seit ner halben Stunde). Mal gucken wie lange noch. Immerhin schaue ich ja alle zehn Minuten aufs Display bzw. ins Log, da muss die Kiste ja aus dem Sleep raus.

    Wenn das nun dennoch ne Stunde bei einem Prozent bleibt, erlaube ich mir mal meine eMail Konten (Ich nutze erstmal die Stock App) einzurichten und auf stündliche Synchro zu gehen.

    Parallel dazu werde ich dann Facebook (Twitter lasse ich erstmal außen vor) aktivieren und ebenfalls auf Stündlich stellen. Alles ohne Widgets versteht sich....
     
  18. space79, 09.04.2011 #18
    space79

    space79 Threadstarter Erfahrener Benutzer

    Beiträge:
    238
    Erhaltene Danke:
    103
    Registriert seit:
    09.05.2010
    So, eine weitere Stunde ist um (eine Logstunde) und der Akku steht immer noch bei 65%. Ich denke dass er gleich auf 64% abfällt, aber nun werde ich kurz mal loslegen und dann DIESEN Threat editieren... EDIT: Hielt sogar noch fünf Minuten bei Display + Market usw ^^.

    Bisher kann ich aber aussagen dass durch die Speed Fixes von Paul (MoDaCo) wohl kein Drain verursacht wird. Der Akku Mod ist, sowie der Camerabrightness + Camcordersound Fix wohl auch ok!

    Was habe ich gemacht:

    1. Facebook aktivieren + Sync auf eine Stunde
    2. eMail Accounts (Stock App) einrichten + Sync [lässt sich nicht einstellen -.-]
    3. TheftAware installieren, einrichten und aktivieren.

    Stand des Akkus nach installationen um 1455 bei 61% wobei ich denke dass sich das gleich bei 60% einfinden wird....

    Bisher war das Display ~16 Minuten an, ca. sechs SMS gesendet und empfangen, immer mal wieder in die BatteryWidget App gesehen und eben zuvor beschriebene Flash / Root / etc. Aktionen.

    Der Akku läuft nun also bei unterdurchschschnittlicher Nutzung bereits 14,5h. Und hat noch ~60% Restkapazität, gestartet bei 82%!!!

    Wenn ich das Umrechne komme ich auf einen Standby (bei sehr leichter Nutzung über den Gesamten Zeitrum) von ~66h. Allerdings hat er in der Nacht ja nur 3% gezogen, was inzwischen hinfällig sein dürfte. Denn dies entspricht laut Log allen fünf Minuten 2mA Verbrauch. Nun kann ich im Leerlauf von 5mA Verbrauch ausgehen. Dies entspricht ca. 1% pro Stunde. Ein reiner, durchgehender Standby sollte also (theoretisch) bis zu 100 Stunden (~4 Tage) möglich sein.

    Schau 'mer mal was nun mit Facebook 1h sync und Stock-eMail rauskommt...

    Update: 1500 @ 60%
     
    Zuletzt bearbeitet: 09.04.2011
  19. eddyrussak, 09.04.2011 #19
    eddyrussak

    eddyrussak Neuer Benutzer

    Beiträge:
    2
    Erhaltene Danke:
    0
    Registriert seit:
    09.04.2011
    Was haben alle so große Probleme mit dem Akku ??

    So wie ich das Handy bekommen habe (also ohne root oder sonst was zu ändern) hält der akku locker einen tag mit 3-4Stunden Musik ao 1Stunde i-net
    Immer wieder zwischen durch spiele spielen
    und wenn ich um so 16uhr wieder daheim bin is akku noch bei mehr als 60% :love:

    bekomme den abend selten ganz leer...
     
  20. space79, 09.04.2011 #20
    space79

    space79 Threadstarter Erfahrener Benutzer

    Beiträge:
    238
    Erhaltene Danke:
    103
    Registriert seit:
    09.05.2010
    So, nun, innerhalb der letzten Logstunde sind gute 2% des Akkus drauf gegangen, eben beim ablesen das 3te Prozent. [Ich gehe von 2,5% / h aus]

    Damit komme ich (weil ich ja nicht hunderte von Varianten durchtesten mag) zum STOCK-ROM-SCHLUß, dass der Akku bei aktivierten Internetdiensten, welche unbekannt bis Stündlich abrufen den Akkudrain im Standby verdoppeln oder gar verdreifachen.

    Das macht dann bis zu 50h Standby mit einem einigermaßen wenig genutzen, mit dem Internet synchronisierenden OS.

    Da die Praxis aber oft anders aussieht, man ja surft, Apps nutzt usw, gehe ich davon aus dass der Akku bei mittlerer Nutzung einen Tag überstehen kann. Performancehungrige Spiele sind hier natürlich nicht einbezogen.

    Der nächste Test kommt nun an MoDaCo Fr10....
     

Diese Seite empfehlen