1. Nimm jetzt an unserem Uhans - 3. ADVENT - Gewinnspiel teil - Alle Informationen findest Du hier!

Gerät nicht kompatibel

Dieses Thema im Forum "Android App Entwicklung" wurde erstellt von StefMa, 06.11.2011.

  1. StefMa, 06.11.2011 #1
    StefMa

    StefMa Threadstarter Gewerbliches Mitglied

    Beiträge:
    2,054
    Erhaltene Danke:
    413
    Registriert seit:
    16.10.2010
    Hallo,

    meine App im Market, sagt auf Unterschiedlichen Geräten, dass diese nicht kompatibel ist.
    Ich frage mich warum (Kenne dieses Phänomän auch nicht)..
    Woran liegt das?

    Meine App soll natürlich für ALLE Geräte kompatibel sein, denn sie ist nicht wirklich änders bei verschiendene Auflösungen (Habe gelesen, dass die Meldung wegen der Auflösung erscheint).

    Meine Manifest:
    Code:
        <uses-sdk
        	android:minSdkVersion="10"
        	android:targetSdkVersion="10"
        	android:maxSdkVersion="14"/>
    .
    .
    .
    .
       	<supports-screens 
       		android:anyDensity="true"
            android:smallScreens="true"
            android:normalScreens="true"
            android:largeScreens="true"
            android:xlargeScreens="true"/>
    
    Sollte doch eigentlich funktionieren oder..?

    MfG Ice
     
  2. mradlmaier, 06.11.2011 #2
    mradlmaier

    mradlmaier Gewerbliches Mitglied

    Beiträge:
    158
    Erhaltene Danke:
    17
    Registriert seit:
    28.10.2011
    MinSdk schliesst doch auch Geräte aus?
     
  3. StefMa, 06.11.2011 #3
    StefMa

    StefMa Threadstarter Gewerbliches Mitglied

    Beiträge:
    2,054
    Erhaltene Danke:
    413
    Registriert seit:
    16.10.2010
    Hi,

    ein Gerät, von dem ich weiß dass es nicht geht hat 2.3.4.
    Die minSdk anforderungen sehen bei mir so aus:
    Code:
        <uses-sdk
        	android:minSdkVersion="10"
        	android:targetSdkVersion="10"
        	android:maxSdkVersion="14"/>
    
    MfG
     
  4. swordi, 06.11.2011 #4
    swordi

    swordi Gewerbliches Mitglied

    Beiträge:
    3,389
    Erhaltene Danke:
    441
    Registriert seit:
    09.05.2009
    hmmm... welches gerät ist das genau ?

    10 wäre 2.3.3+
     
  5. mradlmaier, 06.11.2011 #5
    mradlmaier

    mradlmaier Gewerbliches Mitglied

    Beiträge:
    158
    Erhaltene Danke:
    17
    Registriert seit:
    28.10.2011
    um das mal zu spezifizieren:
    minSdk etc. Bezieht sich auf das API-Level.

    Hier findest Du die Tabelle die API-Level Android Version gegenüberstellt:
    Android API Levels | Versions

    so, ich habe ein 3 monate altes Samsung Galaxy S, das mit Android 2.3.3 ausgeliefert wurde. Samsung verkauft die SGS offiziell aber noch mit Froyo (2.2).Schätze deine App installiert nur auf sehr neuen Geräten.

    Warum spezifiziert Du so ein hohes API Level? Benötigt deine App das tatsächlich? Ansonsten ist die Idee bei minSdk eigentlich so niedrig wie möglich zu sein.
     
    Zuletzt bearbeitet: 06.11.2011
  6. StefMa, 07.11.2011 #6
    StefMa

    StefMa Threadstarter Gewerbliches Mitglied

    Beiträge:
    2,054
    Erhaltene Danke:
    413
    Registriert seit:
    16.10.2010
    Hi,

    Also es ist ein Galaxy S Plus mit 2.3.4...
    Auf dem S2 mit der selben Version läuft es ohne Probleme.

    Werde dann mal die minSkd runterschrauven, denn unbedingt bauchen die Leute die Version nicht.

    Gruß

    Edit: laut Android market Statistik, wurde die App schon 5x auf dem S Plus installiert. Daher muss es ja wohl ein Problem des Handys sein oder..?

    Gesendet mit der Android-Hilfe.de-App
     
    Zuletzt bearbeitet: 07.11.2011
  7. swordi, 07.11.2011 #7
    swordi

    swordi Gewerbliches Mitglied

    Beiträge:
    3,389
    Erhaltene Danke:
    441
    Registriert seit:
    09.05.2009
    ja dann wohl eher.

    hast du vorher die app mit anderer signatur ( debug? ) mal installiert ?
     
  8. StefMa, 07.11.2011 #8
    StefMa

    StefMa Threadstarter Gewerbliches Mitglied

    Beiträge:
    2,054
    Erhaltene Danke:
    413
    Registriert seit:
    16.10.2010
    Hi,

    Das gerät ist nicht meinst, daher wurde die App auch nicht vorher schonmal installiert.

    Komisch, der Kunde hat auch kein root oder ROM drauf...

    Gruß

    Gesendet mit der Android-Hilfe.de-App
     

Diese Seite empfehlen