1. Nimm jetzt an unserem Uhans - 3. ADVENT - Gewinnspiel teil - Alle Informationen findest Du hier!

Probleme bei Rufnummern mit Ländervorwahl (+)

Dieses Thema im Forum "Motorola Defy Forum" wurde erstellt von Meischder, 04.12.2010.

  1. Meischder, 04.12.2010 #1
    Meischder

    Meischder Threadstarter Android-Hilfe.de Mitglied

    Beiträge:
    61
    Erhaltene Danke:
    2
    Registriert seit:
    04.12.2010
    Hallo,

    ich habe seit einigen Tagen ein Defy und komme jetzt nach stundenlangem Einrichten so langsam zu einem Punkt wo das Gerät (vorerst) einmal fertig ist. Alle Programme und Funktionen arbeiten nach meinen Bedürfnissen und die meisten Probleme konnte ich ausbügeln.

    Ein Problem ärgert mich aber noch sehr:

    Ich komme von der Nokia E-Series und hatte dort ein Thunderbird-SyncML-Konstrukt am laufen.

    Mit dem Umstieg auf Android habe ich dann sämtliche Kontakte aus Thunderbird in Google gepackt (Addon: Google Contacts) und von dort dann auf das Defy gesynct. Soweit so gut, ABER das Defy kommt scheinbar mit den Rufnummern nicht zurecht, die alle mit Ländervorwahl sind.

    1. Bei der Ansicht in Kontakte ist alles O.K.
    2. Will ich einen Kontakt weiterleiten (egal ob als Barcode, V-Card oder Sonstiges) lässt er bei allen Nummern das Plus (+) weg und gruppiert die gesamte Nummer unpassend mit Bindestrichen.
    So wird aus +49176123456 -> 491-761-23456
    3. Das gleiche Problem tritt auf beim Sync mit der Bluetooth-Freisprecheinrichtung im Auto.
    4. Bei Nummern im Feld "Pager" klappt es komischerweise. Das Plus (+) bleibt wo es sein soll und die Bindestrichen bleiben komplett weg.
    => Die Nummern sind unbrauchbar!

    Zu 3. habe ich einige Beiträge gefunden. Da wäre Android 2.1 die Lösung, was aber das Defy ja bereits besitzt.

    Gibt es zu diesem bescheuerten Verhalten eine Lösung oder gar eine Erklärung?
     
  2. mabe83, 04.12.2010 #2
    mabe83

    mabe83 Android-Hilfe.de Mitglied

    Beiträge:
    73
    Erhaltene Danke:
    3
    Registriert seit:
    13.11.2010
    Phone:
    Motorola Defy
    Hallo,

    ich kann dir zwar leider nicht direkt helfen, aber vielleicht ein paar Tipps geben. Ich verwende auch bei all meinen Rufnummern die entsprechende Ländervorwahl (mit +) und habe keine Probleme. Ich habe die Kontakte von meiner SIM importiert. Das heißt, auf Defy-Seite sollte alles soweit passen. Ich tippe daher auf ein Google Sync Fehler. Vielleicht eine fehlerhafte Zeichencodierung? Versuche doch mal bitte bei einem Kontakt das + durch 00 zu ersetzen. Also vor dem Importieren anstelle von +49xxx einfach nur 0049xxx schreiben.

    Willst du Kontakte von deinem Defy aus weiterleiten oder von deinem Vorgängergerät an das Defy?
     
    Zuletzt bearbeitet: 04.12.2010
  3. Meischder, 04.12.2010 #3
    Meischder

    Meischder Threadstarter Android-Hilfe.de Mitglied

    Beiträge:
    61
    Erhaltene Danke:
    2
    Registriert seit:
    04.12.2010
    Mit der Doppelnull (00) am Anfang klappts zwar mit der BT-FSE, aber die Gruppierung mit Bindestrichen beim Weiterleiten ist immernoch verschoben.
    Ehrlichgesagt würd ich auch lieber das Plus behalten anstelle der Doppelnull.

    Das gleiche Problem habe ich übrigens auch mit direkt im Defy neu erstellten Kontakten. Auch hier schneidet er mir das Plus am Anfang ab.
    Sogar wenn ich die Rufnummer direkt und unverändert aus der Anrufliste in einen neuen Kontakt verpflanze. Es wundert mich, dass es bei dir funktioniert?!

    Bei der Weiterleitung geht es mir eigentlich um den Fall, wenn ich mal Kontakte weitergeben will. Da ist es halt ärgerlich wenn die Leute abgehackte Telefonnummern gesendet bekommen.

    Es ist echt traurig wie nachlässig mit solchen grundlegeneden Smartphone-Funktionen bei den Herstellern umgegangen wird.
    Kindische Spielereien werden hingegen bis ins kleinste Detail entwickelt und perfektioniert. Verrückte Welt!

    Danke auf jeden Fall für die Antwort!
     
  4. mabe83, 04.12.2010 #4
    mabe83

    mabe83 Android-Hilfe.de Mitglied

    Beiträge:
    73
    Erhaltene Danke:
    3
    Registriert seit:
    13.11.2010
    Phone:
    Motorola Defy
    Ich habe eben einen Kontakt per Gmail weitergeleitet. Hier schneidet er bei mir auch das + weg. Bindestriche werden nicht hinzugefügt. Jedoch verwende ich in meinen Nummern keine Bindestriche.

    Echt interessant ... und voll blöd irgendwie. Das schaut mir stark nach einen ungewollten Feature aus.
     
  5. Meischder, 04.12.2010 #5
    Meischder

    Meischder Threadstarter Android-Hilfe.de Mitglied

    Beiträge:
    61
    Erhaltene Danke:
    2
    Registriert seit:
    04.12.2010
    Füg eine Nummer im Kontakt mal als "Pager" ein.
    Diese Nummern leitet er mir korrekt weiter.
     
  6. mabe83, 04.12.2010 #6
    mabe83

    mabe83 Android-Hilfe.de Mitglied

    Beiträge:
    73
    Erhaltene Danke:
    3
    Registriert seit:
    13.11.2010
    Phone:
    Motorola Defy
    Ja, kann ich so nur bestätigen. Scheint mir unlogisch und würde es daher als Bug deklarieren.

    Kennt sich jemand mit Bugmeldungen aus? Wo kann man das machen? Und betrifft das Motoblur oder eine andere Applikation?
     
  7. Meischder, 04.12.2010 #7
    Meischder

    Meischder Threadstarter Android-Hilfe.de Mitglied

    Beiträge:
    61
    Erhaltene Danke:
    2
    Registriert seit:
    04.12.2010
    Ich benutze übrigens Launcher Pro und habe anfangs die MotoBlur Registrierung übersprungen, falls das irgendwo von Relevanz bei der Kontakte-Anwendung sein soll.
     
  8. mabe83, 04.12.2010 #8
    mabe83

    mabe83 Android-Hilfe.de Mitglied

    Beiträge:
    73
    Erhaltene Danke:
    3
    Registriert seit:
    13.11.2010
    Phone:
    Motorola Defy
    Habe mir den Inhalt der Vcard angesehen. Der Fehler ist hier bereits enthalten. Das Defy macht demnach beim Export einen Fehler. Folgendes Beispiel verdeutlicht das Problem:

    BEGIN:VCARD
    VERSION:2.1
    N:Kontakt;Test;;;
    FN:Test Kontakt
    TEL;HOME;VOICE:431-112-233445566
    END:VCARD

    43 = Ländervorwahl (im Original mit Presign +)
    111 = Vorwahl des Netzbetreibers
    22, 33, 44, 55, 66 = Die Endbenutzernummer
     
  9. mabe83, 04.12.2010 #9
    mabe83

    mabe83 Android-Hilfe.de Mitglied

    Beiträge:
    73
    Erhaltene Danke:
    3
    Registriert seit:
    13.11.2010
    Phone:
    Motorola Defy
    Ich verwende Motoblur und habe selbiges Problem. Dann muss es direkt an der Kontakte-Export/Weiterleitung liegen.
     
  10. Meischder, 04.12.2010 #10
    Meischder

    Meischder Threadstarter Android-Hilfe.de Mitglied

    Beiträge:
    61
    Erhaltene Danke:
    2
    Registriert seit:
    04.12.2010
    Korrekt. Die BT-FSE wird da wohl die gleiche Schnittstelle nutzen wie die Weiterleitungsfunktionen, bzw. -tools.
     
  11. mabe83, 04.12.2010 #11
    mabe83

    mabe83 Android-Hilfe.de Mitglied

    Beiträge:
    73
    Erhaltene Danke:
    3
    Registriert seit:
    13.11.2010
    Phone:
    Motorola Defy
    Denke ich auch.
     
  12. pOOB73, 08.02.2011 #12
    pOOB73

    pOOB73 Android-Guru

    Beiträge:
    3,545
    Erhaltene Danke:
    1,408
    Registriert seit:
    19.07.2010
    Phone:
    Motorola RAZR HD
    Tablet:
    Google Nexus 7 (2013)
    Das Problem wurde mit Firmware 2.51.1 behoben.
     
    HNL bedankt sich.
  13. Johndoy, 24.07.2011 #13
    Johndoy

    Johndoy Neuer Benutzer

    Beiträge:
    20
    Erhaltene Danke:
    0
    Registriert seit:
    17.01.2011
    Phone:
    Motorola Defy
    Habe ich nach wie vor mit dem CyanogenMod.
     

Diese Seite empfehlen