1. Nimm jetzt an unserem Uhans - 3. ADVENT - Gewinnspiel teil - Alle Informationen findest Du hier!

The Way I do: Update auf Froyo

Dieses Thema im Forum "Motorola Milestone Forum" wurde erstellt von Soxes, 21.03.2011.

  1. Soxes, 21.03.2011 #1
    Soxes

    Soxes Threadstarter Gast

    Hallo zusammen,

    hier erkläre ich euch, wie ich bei meinem Update von Éclair (2.1) auf Froyo (2.2.1) vorgegangen bin, da es sehr viele Beschwerden über Probleme und Reboots gibt.

    Vorab erwähne ich, dass bei mir ALLES einwandfrei läuft und ich seit gestern Abend 20:30 h keinen einzigen Reboot oder andere Probleme mit der Firmware und dem Handy habe!

    1. Zuerst habe ich mein Handy im Recovery Modus gestartet (Bei Bootloadern unter der Version 90.78 ist dieser durch drücken der Kamera Taste und dem Einschaltknopf im ausgeschalteten Zustand zu erreichen. Ab 90.78 durch drücken der "X" Taste statt dem Kameraknopf).

    2. Dann habe ich mein Handy auf Werkseinstellungen zurückgesetzt.

    3. Anschließend habe ich mir RSD Lite heruntergeladen, installiert, sowie die FULL SBF (NICHT DIE SERVICE SBF) auf dieser Seite (sbf:milestone [And Developers]) zu 2.2.1 heruntergeladen.

    4. Nachdem das erledigt war, habe ich mein RSD Lite als Administrator ausgeführt, damit das Programm auch volle Rechte hat, und mir nicht mit einer Fehlermeldung um die Ohren fliegt.

    5. Anschließend wurde das Handy im Bootloader Modus gestartet (Handy aufschieben und die Taste nach oben bzw wenn es Hochkant steht nach rechts gedrückt, sowie den Einschaltknopf dazu gedrückt).

    6. Danach habe ich das Handy über USB mit dem PC angeschlossen.

    7. Daraufhin habe ich die SBF Datei im RSD Lite durch einen Klick auf den Durchsuchen Button (Button mit 3 Punkten "..." drauf) ausgewählt und auf starten geklickt.

    8. Ab dann lief der Flash Vorgang. Nach ca. 5 Minuten war mein Handy wieder hochgefahren und ich hatte Froyo aufgespielt ;)

    HINWEIß: ICH ÜBERNEHME KEINERLEI HAFTUNG DAFÜR, WENN EUCH DABEI DAS HANDY UM DIE OHREN FLIEGT!!!
    STELLT ALSO SICHER, DASS EUERE AKKULADUNG BEI ÜBER 50% LIEGT!


    In diesem Sinne.... ;)

    Soxes :)
     
    Zuletzt von einem Moderator bearbeitet: 21.03.2011
    gobot12 und siradlib haben sich bedankt.
  2. duddle, 21.03.2011 #2
    duddle

    duddle Android-Hilfe.de Mitglied

    Beiträge:
    105
    Erhaltene Danke:
    9
    Registriert seit:
    25.02.2011
    Das bedeutet:
    Bei dir gibt es keine Startverzögerung der Apps von 1-2 Sekunden
    Kein Warten von ca. 5 Sekunden bei der Rückkehr zum Startbildschirm
    Kein Neuaufbau des Desktops und Startmenus?

    ,

    Gesendet mit der Android-Hilfe.de-App
     
  3. siradlib, 21.03.2011 #3
    siradlib

    siradlib Android-Hilfe.de Mitglied

    Beiträge:
    75
    Erhaltene Danke:
    4
    Registriert seit:
    16.03.2011
    @Duddle: Bitte Soxes Beitrag lesen und verstehen! :rolleyes2:
    Er schreibt nur, dass er keine Probleme mit Reboots hat.

    Dass das MS etwas träge reagiert, ist kein Problem von Froyo an sich, sondern hat etwas mit der mangelnden (Rechen-/Speicher-) Leistung des Gerätes zu tun.

    Oder im übertragenen Sinn: Soxes schreibt, wie man problemlos Breitreifen, die bis 230 km/h zugelassen sind, auf seinen Ford Fiesta mit 75 PS aufziehen kann, da vielen Ford Fiesta-Fahrern die Reifen während der Fahrt von der Felge geflogen sind.
    Bei Soxes halten die Reifen jetzt zuverlässig- nur fährt sein Fiesta jetzt trotzdem keine 230 km/h...
     
  4. Soxes, 21.03.2011 #4
    Soxes

    Soxes Threadstarter Gast

    Selbst die Verzögerungen erscheinen bei mir nicht wirklich... O.o

    Gesendet von meinem Milestone mit der Android-Hilfe.de-App
     
  5. Zaphod, 21.03.2011 #5
    Zaphod

    Zaphod Android-Hilfe.de Mitglied

    Beiträge:
    66
    Erhaltene Danke:
    12
    Registriert seit:
    19.11.2009
    freut mich, dass es bei dir jetzt doch gut funktioniert...

    wie es aussieht, muss man froyo halt sauber neu installieren, und nicht einfach ein altes system updaten, dann scheint es ganz gut zu laufen..
     
  6. Gevatter, 21.03.2011 #6
    Gevatter

    Gevatter Neuer Benutzer

    Beiträge:
    4
    Erhaltene Danke:
    0
    Registriert seit:
    27.01.2010
    Moin moin,

    nach den ganzen Horror-Meldungen im Forum wollte ich erst gar nicht updaten.

    Ich habe es trotzdem gemacht

    - Werksreset
    - per USB Update draufgespielt
    - FERTIG

    Mein Milestone wurde nie gerootet oder übertaktet und hat auch keine tollen performance Apps installiert.

    Ich kann nur sagen bei mir läuft alles besser als vorher und bisher hatte ich noch nicht einen Absturz und ich kann keine wesentlichen Verzögerung bei der Benutzung feststellen.
     
  7. Soxes, 21.03.2011 #7
    Soxes

    Soxes Threadstarter Gast

    Ja aber ich hatte eben doch einen Reboot zu verzeichnen. Takt war 900 MHZ bei 52 Vsel... War aber wohl eher die geringe Taktzahl Schuld... Bin jetzt bei 800 MHZ und 50 Vsel.

    Und bis jetzt rennt alles sauber :)

    Weißt du zufällig von einem stabileren Froyo Kernel, ob es den gibt?

    Gesendet von meinem Milestone mit der Android-Hilfe.de-App
     
  8. JokerX, 22.03.2011 #8
    JokerX

    JokerX Neuer Benutzer

    Beiträge:
    12
    Erhaltene Danke:
    0
    Registriert seit:
    25.02.2010
    Möchte keinen extra Threat aufmachen, probier's erstmal hier.

    Habe das Problem, dass ich nicht in den Recovery-Modus des Steins komme. Per Kamerataste+Power startet der Stein zwar in die Recovery, bleibt aber auf einem Bildschirm hängen, wo ich ein Dreieck mit Ausrufezeichen sehe, davor ein liegendes Handy. Dann passiert nichts mehr. Kann das Handy nur per nochmaliges Drücken der Powertaste starten.
    Damit kann ich den Stein nichtmehr auf die Werkseinstellungen zurücksetzen. Möchte das aber vor Update auf 2.2.1, weil' ja scheinbar die sauberste Variante ist.

    Momentan hab ich 2.1.1 (ich glaube per OTA, is aber schon ne Weile her).
    Bootloader V. 90.73
    Gerootet per EasyRoot (hab's aber auch schon probiert, nachdem ich den Stein wieder Unroot gesetzt habe)

    Weiß da jemand ne Lösung ?

    (Das selbe Problem hab ich übrigens auch mir dem Rom Manager, da bringt er mir beim beim Reboot auf ClockworkRom bzw. beim Versuch, die SD-Karte zu partitionieren beim Neustart auch immer dieses Dreiecksymbol und startet dann einfach neu :/ )

    Danke.
     
  9. Soxes, 22.03.2011 #9
    Soxes

    Soxes Threadstarter Gast

    Ach hab ich vergessen zu sagen...
    Wenn dieses hübsche Bildchen da ist, dann die Lutstärketaste für lauter gedrückt halten und die Kamera Taste dann drücken.
    Dann mit dem dpad Factory Reset oder so auswählen ;)

    Gesendet von meinem Milestone mit der Android-Hilfe.de-App
     
  10. Guedeltubus, 22.03.2011 #10
    Guedeltubus

    Guedeltubus Junior Mitglied

    Beiträge:
    40
    Erhaltene Danke:
    0
    Registriert seit:
    20.03.2011
    Ist das jetzt nur für Handys mit root?
     
  11. Soxes, 22.03.2011 #11
    Soxes

    Soxes Threadstarter Gast

    Wie kommst du denn jetzt darauf???

    Gesendet von meinem Milestone mit der Android-Hilfe.de-App
     
  12. Guedeltubus, 22.03.2011 #12
    Guedeltubus

    Guedeltubus Junior Mitglied

    Beiträge:
    40
    Erhaltene Danke:
    0
    Registriert seit:
    20.03.2011
    Weil eon paar einträge vorher. Jmd. Sagte er hat root.
     
  13. -FuFu-, 22.03.2011 #13
    -FuFu-

    -FuFu- Android-Urgestein

    Beiträge:
    8,406
    Erhaltene Danke:
    3,148
    Registriert seit:
    17.03.2010
    Phone:
    Motorola Moto E 2.Gen
    der weg geht für Geräte mit und ohne root...
    wer vorher root hatte, muß danach natürlich neu rooten, anleitungen dafür gibt es ja genug hier im Forum...

    wie man in der recovery kommt, findet man auch in mehreren Anleitungen hier im Forum, ich werd das FAQ wohl mal weiter ausbauen müsse ;)
     
  14. prodamn, 22.03.2011 #14
    prodamn

    prodamn Erfahrener Benutzer

    Beiträge:
    207
    Erhaltene Danke:
    60
    Registriert seit:
    04.09.2010
    FroYo läuft gut!
    aber nur wenn es klein gehalten wird.
    wenn du updatetest OHNE wipe dann ist dass system zu voll und es läuft so gut wie nicht.

    machst du einen wipe und löschst eigentlich alles was löschbar ist läuft FroYo wie eine 1!

    sobald du dann aber ca. 20 apps installiert hast/egal ob auf intern oder extern/ kannst du alles vergessen! reboots,laggt ohne ende... musst ewig warten dass du etwas angezeigt bekommst... halt eben alle performance bugs.

    schon beschis*en. habe das auch aber nicht so ausgeprägt bei CM 7 bemerkt. eig. ebi allem ist das so aber bei Motorola's official FroYo ist dass am schlimmsten.
     
  15. JokerX, 23.03.2011 #15
    JokerX

    JokerX Neuer Benutzer

    Beiträge:
    12
    Erhaltene Danke:
    0
    Registriert seit:
    25.02.2010
    das einzige, was mich an froyo wirklich interessiert, ist app2sd. weiß jemand, ob man da trotzdem die sd-card partitionieren muss ?
    irgendwie klappt's bei mir via rom-manager nicht, sonst würd ich bei 2.1 bleiben. flash brauch ich nich.
     
  16. Biosman, 23.03.2011 #16
    Biosman

    Biosman Fortgeschrittenes Mitglied

    Beiträge:
    357
    Erhaltene Danke:
    34
    Registriert seit:
    20.06.2010

    sach mal hab ich nen knick in der Optik oder wurde 2.2 raus genommen? O_o
     
  17. -FuFu-, 23.03.2011 #17
    -FuFu-

    -FuFu- Android-Urgestein

    Beiträge:
    8,406
    Erhaltene Danke:
    3,148
    Registriert seit:
    17.03.2010
    Phone:
    Motorola Moto E 2.Gen
  18. Biosman, 23.03.2011 #18
    Biosman

    Biosman Fortgeschrittenes Mitglied

    Beiträge:
    357
    Erhaltene Danke:
    34
    Registriert seit:
    20.06.2010

    Danke FuFu...

    Ich habe grade ganz andere Probleme :(

    Wenn man kA 6 Monate lang nach dem System "Never Touch a Running System" lebt verlernt man alles... Ich hab nichtmal mehr nen Plan wie der "schei*" Recovery aufgeht... irgendwas mit Kamera + Power war das aber da kommt nurnoch das Dreieck.

    Komm mir hier vor wie der letzte noob ~.~

    Wenn ich mich schon zum Deppen mache gleich die nächste Deppen frage:

    2.2.1 ist die "Full" Version?
    2.2.1 (Service) die Update version?

    d.h. erstes? :)


    FuFu, helf mir mal^^ ich gimp hier rum :( Habe glaube noch die Recovery von TimeTurn drauf wenn das ding überhaupt noch funzt ~.~
     
  19. -FuFu-, 23.03.2011 #19
    -FuFu-

    -FuFu- Android-Urgestein

    Beiträge:
    8,406
    Erhaltene Danke:
    3,148
    Registriert seit:
    17.03.2010
    Phone:
    Motorola Moto E 2.Gen
    http://www.android-hilfe.de/anleitu...root-sbf-flashen-openrecovery.html#post474677
    da steht wie man in die Recovery kommt ;) und RSD Lite anleitung ist da ja auch noch bei ^^

    die full löscht alle deine Apps, einstellungen und daten
    bei der service bleiben deine apps, daten und einstellungen erhalten

    und nutz nach möglichkeit eine aktuelle OR, entweder die originale oder die Androidiani (links sind hier irgendwo im forum)
     
  20. JokerX, 24.03.2011 #20
    JokerX

    JokerX Neuer Benutzer

    Beiträge:
    12
    Erhaltene Danke:
    0
    Registriert seit:
    25.02.2010
    sry für weiter offtopic.
    wollt nur sagen, dass ich die app to sd jetzt mit link2sd und patitionierung mit gpartet hinbekommen habe. kann ich jetzt gottseidank erstmal bei 2.1 bleiben.

    danke trotzdem an den threaderöffner für seine erläuterung. vielleicht bracuh ich's ja doch noch irgendwann.
     

Diese Seite empfehlen