1. Nimm jetzt an unserem Uhans - 3. ADVENT - Gewinnspiel teil - Alle Informationen findest Du hier!

XXJPK, Exchange und das Zertifikatsproblem

Dieses Thema im Forum "Root / Hacking / Modding für Samsung Galaxy S" wurde erstellt von iOlli, 09.10.2010.

  1. iOlli, 09.10.2010 #1
    iOlli

    iOlli Threadstarter Android-Hilfe.de Mitglied

    Beiträge:
    130
    Erhaltene Danke:
    3
    Registriert seit:
    25.09.2009
    Hallo Zusammen,

    ich versuche seit Tagen, mein SGS mit JPK an einem Exchange-Server anzumelden, dessen Zertifikat durch das Unternehmen selber unterzeichnet wurde. Trotz setzen der Option "Jedes Zertifikat akzeptieren" weigert sich das SGS mit dem Exchange-Server zu connecten.

    Leider bietet Froyo nur die Möglichkeit PKCS12-Zertifikate zu importieren. So ein Zertifikat gibt der Admin aber nicht raus, weil es auch die privaten Schlüssel des Servers enthält.

    Im Netz findet man einen Fix für das HTC Hero, wo einfach die Email.apk der 2.1er-Version verwendet wird. Das funktioniert beim SGS leider nicht.

    Kennt jemand eine Möglichkeit, wie ich das DER- bzw. Base64-Zertifikat ins SGS bekomme?

    Froyo ist so leider für mich nicht nutzbar.

    Grüße und Danke
    Olli
     
  2. ewok666, 09.10.2010 #2
    ewok666

    ewok666 Android-Hilfe.de Mitglied

    Beiträge:
    87
    Erhaltene Danke:
    2
    Registriert seit:
    17.05.2010
    Ich habe auch JPK und habe das problem definitiv nicht. Mein Server hat kein richtiges Certificate on trotzdem synced mein Galaxy Email ohne probleme.
     
  3. iOlli, 09.10.2010 #3
    iOlli

    iOlli Threadstarter Android-Hilfe.de Mitglied

    Beiträge:
    130
    Erhaltene Danke:
    3
    Registriert seit:
    25.09.2009
    Hi,

    benutzt ein Custom-ROM oder Standard JPK?

    Bei mir geht wirklich nicht. Ich habe JPK mehrmals neu installiert jedesmal mit kompletten Wipe. Keine Chance.
    Bei XDA-Developers und einigen Blogs habe ich dann lesen dürfen, dass Froyo bei Exchange-Sync anscheinend nur noch Zertifikate von bekannten Authorisierungsstellen zulässt. Die User haben da das gleiche Problem. Mache ich ein Downgrade auf irgend eine 2.1er-Version, funktioniert es sofort.

    Ach ja, wir nutzen die neueste Exchange-Version (alle aktuellen Updates sind eingespielt). Und was auch wichtig ist, mit dem Zertifikat werden auch die Sicherheitsrichtlinien gesetzt (z. B. Vergabe einer Passphrase als Pflicht).

    Grüße
    Olli
     
  4. sphoenixcompany, 09.10.2010 #4
    sphoenixcompany

    sphoenixcompany Erfahrener Benutzer

    Beiträge:
    151
    Erhaltene Danke:
    11
    Registriert seit:
    26.08.2010
    Das wäre ja alles andere als übel. Wenn dem wirklich so ist. Hatte das problem schon bei der JM8 da konnte ich auch das activesync konto nicht mehr einrichten. Bin dann wieder auf die JM5 und dann ging es sofort.
     
    Zuletzt bearbeitet: 09.10.2010
  5. MaxMad, 10.10.2010 #5
    MaxMad

    MaxMad Android-Hilfe.de Mitglied

    Beiträge:
    85
    Erhaltene Danke:
    35
    Registriert seit:
    16.08.2010
  6. ewok666, 11.10.2010 #6
    ewok666

    ewok666 Android-Hilfe.de Mitglied

    Beiträge:
    87
    Erhaltene Danke:
    2
    Registriert seit:
    17.05.2010
    Standard JPK aber bei mir laeuft noch Exchange 2003 ;-) Wahrscheinlich ist das der Grund das ich keine Probleme habe.......
     
  7. iOlli, 11.10.2010 #7
    iOlli

    iOlli Threadstarter Android-Hilfe.de Mitglied

    Beiträge:
    130
    Erhaltene Danke:
    3
    Registriert seit:
    25.09.2009
    Das hatte ich schon probiert. Danach lief die E-Mail-App gar nicht mehr und ich konnte auch die alte Version nicht mehr herstellen. Nach diesem Versuch habe ich dann das Gerät neu flashen müssen, um wieder eine funktionierende E-Mail-App zu haben.
    Anscheinend funktioniert das nur bei einigen HTC-Geräten.

    Dennoch Danke.
    Olli
     
  8. iOlli, 14.10.2010 #8
    iOlli

    iOlli Threadstarter Android-Hilfe.de Mitglied

    Beiträge:
    130
    Erhaltene Danke:
    3
    Registriert seit:
    25.09.2009
    Hallo,

    habe es nun hinbekommen, dass unter Froyo (JPM) Exchange mit selbst unterzeichneten Zertifikaten funktionieren.

    1. Exchange erstmal unter eine 2.1er soweit einrichten (z. B. JM8), dass der Sync/Push funktioniert.
    2. Nun mittels Kies oder Odin auf Froyo (z. B. JPM) updaten.

    Das Problem mit den selbst unterschriebenen Zertifikaten besteht weiterhin. Aber bei einem Update scheinen die zuvor akzeptierten Zertifikate übernommen zu werden.
    Ich habe mir dann den Spaß gemacht, mein Gerät auf JM8 zurück zu bringen mit einer kompletten Neupartitionierung. Danach waren die Exchange-Einstellungen komplett weg. Dann auf JPM. Danach war es nach wie vor nicht möglich ein selbst unterschriebenes Zertifikat beim Einrichten einer Exchange-Verbindung zu übernehmen. Dann wieder ein Downgrade auf JP8, Exchange komplett eingerichtet, update via Odin 1.3 auf JPM und schon funktioniert es.

    Ich hoffe ja, dass Samsung da nachbessert. Ich habe es noch mal mit einem Desire probiert. Hier hat 2.2 kein Problem mit derlei Zertifikaten.

    Wichtig: Ein Full Wipe macht JPM für Exchange mit oben genannten Zertifikaten unbrauchbar.

    Grüße
    Olli
     
  9. iOlli, 20.10.2010 #9
    iOlli

    iOlli Threadstarter Android-Hilfe.de Mitglied

    Beiträge:
    130
    Erhaltene Danke:
    3
    Registriert seit:
    25.09.2009
    Moin, moin,

    nach ca. einer Woche mit Froyo (JP6) bin ich nun wieder zu 2.1 (JM9) zurück.
    Damit funktioniert jetzt Exchange immerhin fast! Leider wird ein zweiter Kalender (privat) eines Exchanges-Accounts nicht synchronisiert.

    Aber ein kleiner Hinweis sei mir noch gestattet. Das hier beschriebene Problem mit den Zertifikaten besteht anscheinend nur bei Samsung. Ich hatte die Möglichkeit es mit einem HTC Desire (2.2) zu testen. Damit funktioniert es einwandfrei. Sogar die Kalender werden richtig synchronisert.


    So leid es mir tut, aber was Samsung da abgeliefert hat ist an Grausamkeit nicht zu überbieten... Das SGS geht demnächst in die Bucht...

    Grüße
    Olli
     
  10. sphoenixcompany, 20.10.2010 #10
    sphoenixcompany

    sphoenixcompany Erfahrener Benutzer

    Beiträge:
    151
    Erhaltene Danke:
    11
    Registriert seit:
    26.08.2010
    Ich bin auch von der JPM zurück auf die JM5. Den bei der JM5 Version habe ich als einziges nicht den im Anhang zu sehenden Fehler. Und wenn das Offizielle Froyo von Samsung kommt und der Fehler da auch ist. Werde ich das SGS zurückgeben. Denn mit der JM5 funktioniert alles (fast).
     

    Anhänge:

    Zuletzt bearbeitet: 20.10.2010

Diese Seite empfehlen