[Diskussion] [ROOT Anleitung] Kindle Fire HD 7" (2013) 11.3.2.1 & 11.3.2.2

  • 419 Antworten
  • Neuester Beitrag
Diskutiere [Diskussion] [ROOT Anleitung] Kindle Fire HD 7" (2013) 11.3.2.1 & 11.3.2.2 im Amazon Kindle Fire HD 7 (Soho) / (Modelle ab 10/2013 ohne Front-Cam) Forum im Bereich Amazon Forum.
I

Ivelios

Neues Mitglied
Hallo alle zusammen,

ich bin neu hier, hätte aber gleich ein paar Fragen zum rooten meines Kindle mit der Version 11.3.2.1.

Ich Probiere jetzt schon den dritten Tag lang, das Teil zu rooten.
Alle notwendigen Daten hierzu habe ich mir besorgt und ein Factory-Kabel habe ich mir selbst gebaut (funktioniert auch einwandfrei).

Nun zu meinem Problem:
Wenn mein Kindle im Fastboot-Modus ist und ich das Script (runme.bat) starte, dann steht da:

Device connected. Downgrading boot
< waiting for device >

Das Problem ist nur, dass sich dann nichts tut. Die gleiche Meldung kommt übrigens auch, wenn ich das Script starte, ohne dass der Kindle angeschlossen ist.

Wenn der Kindle eingeschaltet ist und ich dann über die Konsole "adb devices" eingebe, dann listet er dieses auch auf, aber wenn ich das gleiche im Fastboot-Modus mache, wird nichts angezeigt.

Ich weiß aktuell nicht weiter, kann mir hier jemand helfen?

Noch ein paar kleine Infos:
-die adb drivers habe ich installiert
-das Script habe ich als Admin ausgeführt
-das self made Kabel habe ich mehrmals durchgeprüft, mit dem ist alles in Ordnung
 
S

schwix

Erfahrenes Mitglied
Mach einmal folgendes:

Öffne eine Adminkonsole und gib den befehl:

fastboot -i 0x1949 flash boot old-boot-prod.img

manuell ein.
 
Keinbockwurst

Keinbockwurst

Lexikon
Vielleicht sind es nicht die richtigen Treiber? Probier es mal unter Linux! Mach am besten eine Knoppix Live-CD oder so. :)
 
J-P

J-P

Ehrenmitglied
Die Meldung "Waiting for device" ist absolut ok, nur deine Vorgehensweise scheint falsch zu sein...

Versuch bitte mal folgende Vorgehensweise:


  • Kindle ausgeschaltet (heruntergefahren), Fastbootcabel am Kindle angeschlossen aber noch NICHT mit dem PC verbunden
  • das Script (runme.bat) starten, dann erscheint "Waiting for device" am PC
  • JETZT erst den Kindle mit dem Fastbootcable und den PC verbinden, MEHR nicht, denn der Kindle startet automatische und (aufgrund des Fastbootcable's ) erscheint der FastbootModus auf dem Kindle.
JETZT sollt das Script auch deinen Kindle erkennen und die gewünschten Ausführungen zulassen....

mfg

J-P
 
I

Ivelios

Neues Mitglied
@ schwix:

das direkte eingeben von "fastboot -i 0x1949 flash boot old-boot-prod.img" bringt bei eingestecktem Gerät auch nur die Meldung "< waiting for device >" mit sich

@ J-P:

Genau so habe ich das auch schon mehrere male probiert. Funktionieren tut es leider nicht.
Egal was ich mache, es kommt immer folgendes (siehe Bild im Anhang):
Device connected. Downgrading boot
< waiting for device >

Mich wundert, dass das script immer die Meldung "Device connected" bringt, selbst wenn gar nichts angeschlossen ist. Kann es sein, dass hier etwas falsch erkannt wird?

@ Keinbockwurst:

Hab leider kein Linux da um dies schnell zu probieren.


Vielen Dank an euch für die schnellen Antworten.
 

Anhänge

J-P

J-P

Ehrenmitglied
hallo Ivelios,

EDIT: überprüf mal die command-line (Admin-Konsole), ist der Pfad für die adb- und fastboot-Befehle identisch ?

ansonsten.....

da das Script wiederum auf das Gerät wartet aber bislang noch nichts passiert - eine Eingabeaufforderung seitens des Gerätes erscheint offensichtlich nicht ?- , versuch doch folgendes:

Schalte den Kindle komplett ab, FastbootCable vom PC trennen und anschließend, wie bereits zu Beginn, das FastbootCable erneut anschließen....

Evtl. erkennt er deinen Kindle dann erneut und beginnt mit der Ausführung.

mfg

J-P
 
Zuletzt bearbeitet:
S

schwix

Erfahrenes Mitglied
Hast du noch einen rechner auf dem XP läuft?
Da ging es bei mir reibungslos.

Wenn nicht:

Wenn der kindle im FastbootModus angeschlossen ist, schau in deinem PC mal unter "Geräte und Drucker"
Taucht der Kindle bei dir da als Kindle auf oder als "Soho-iwas"? Steht an dem gerät ein Ausrufezeichen?
Wenn ja, installier manuell über den gerätemanager für das Gerät den ADB Treiber.
 
D

Dennfr3d

Neues Mitglied
Ich hab jetzt den Schritt "Rooten" befolgt.
Auf dem Kindle erschien auch eine Meldung oben Links... irgendwas mit "Done"

Jetzt habe ich aber das Problem, das das Kindle nicht mehr startet.
Wenn ich es einschalte, dann erscheint im Bildschirm wie üblich Kindle Fire aber dann passiert weiter nichts mehr.

Gibts da ein Trick ?


Gruß Dennis
 
S

schwix

Erfahrenes Mitglied
Guck mal in der Anleitung ganz unten bei FAQ.

Das Script ist bei dir nach dem flashen des alten Bootimages nicht weitergelaufen.
Das Problem hatte ich unter Windows 7 auch, unter XP lief alles ohne Probleme.
 
D

Dennfr3d

Neues Mitglied
Habe den Befehl ausgeführt, fastboot -i 0x1949 flash boot new-boot-prod.img
dann öffnet sich eine Auswahl von Optionen. Da blick ich nicht durch.
Im Geräte Manager zeigt er mir auch Kinde Fire an aber unter "Geräte und Drucker" steht lediglich Soho-PVT-Prod-07 ist aber kein Ausrufezeichen dran und wenn ich den Treiber übern Gerätemanager aktualisieren will, steht das der Treiber aktuell ist.

*edit*

hat jetzt Funktioniert
 
Zuletzt bearbeitet:
J-P

J-P

Ehrenmitglied
hallo Dennfr3d,

hört sich gut an :thumbup:

Erklär aber bitte trotzdem noch einmal kurz, was du getan hast, damit es funktionierte. Nachfolgende Leser werden es dir möglicherweise danken....:lol:

mfg

J-P
 
D

Dennfr3d

Neues Mitglied
Falscher Alarm. Ich konnte lediglich mit dem Befehl mein Kindle wieder starten. Das rooten funktioniert nach wie vor nicht.... hinzu kommt das mein Browser keine Internet Seiten mehr öffnet..... Emails werden abgerufen und steam ist Online. Schreibe vom Kindle in tapatalk. Ich dreh durch....
 
I

Ivelios

Neues Mitglied
@ J-P:

Ja, hat alles den gleichen Pfad.
Das mit dem wiederholten einschalten habe ich auch probiert, funktioniert leider nicht.

@schwix:

ne, hab leider nur Win7 Rechner hier.

Jetzt vielleicht das ausschlaggebende, wenn der kindle im Fastboot-Modus ist, dann steht im Geräte Manager "Soho-PVT-Prod-07" und es ist natürlich auch noch ein Ausrufezeichen dran. Allerdings weiß ich nicht, welche Treiber ich hier manuell installieren soll.

Die benötigten Treiber müsste ich doch mit der KindleDriver.exe alle installiert haben, oder?

Danke euch nochmals
 
D

Dennfr3d

Neues Mitglied
@ Ivelios

Du musst im Gerätemanager auf Treiber aktualisieren gehen anschließend auf "Auf dem Computer nach Treibersoftware suchen" drücken und den Pfad angeben wo du die adb Datei entpackt hast. Die war mit in der 11.3.2.1-root.zip
 
S

schwix

Erfahrenes Mitglied
@Dennfr3d

Der Befehl flasht nur das ursprüngliche Bootimage wieder zurück.

Das Script ist ja nicht durchgelaufen, ergo auch kein root. Warum genau das
nicht geht weiß ich nicht. Auf jeden fall müsste nach dem ersten Flashvorgang
eigentlich wieder eine ADB verbindung aufgebaut werden. Wird sie aber nicht, darum läufts Script nicht weiter.
 
Zuletzt bearbeitet:
D

Dennfr3d

Neues Mitglied
schwix schrieb:
Mach einmal folgendes:

Öffne eine Adminkonsole und gib den befehl:

fastboot -i 0x1949 flash boot old-boot-prod.img

manuell ein.
der Befehl wird bei mir ausgeführt. aber das Kindle startet danach nicht und ich muss den new-boot-prod wieder installieren um das Kindle starten zu können.
In meiner Umgebung gibts es weit und weit kein XP Rechner mehr.
Habe schon probiert die RunMe.bat im Kompatibilitätsmodus am laufen zu kriegen. Aber das war ein Schuss in den Ofen

Und noch ne andere Frage:

Wenn das Rooten geklappt hat, bleibt das Kindle dann im Fastboot Modus oder startet es selber neu ?
 
S

schwix

Erfahrenes Mitglied
Du könntest mal versuchen, die ganze Befehlskette Manuell einzugeben:


Code:
fastboot -i 0x1949 flash boot old-boot-prod.img
jetzt warten bis auf dem bildschirm ...Done steht, und das USB-Erkannt Sound von Windows kam!

Code:
fastboot -i 0x1949 continue

adb push su /data/local/tmp/

adb push rootme.sh /data/local/tmp/

adb push exploit /data/local/tmp/

adb shell chmod 755 /data/local/tmp/rootme.sh

adb shell chmod 755 /data/local/tmp/exploit

adb shell /data/local/tmp/exploit -c "/data/local/tmp/rootme.sh"

adb reboot
Warten bis du wieder im Fastboot bist

Code:
fastboot -i 0x1949 flash boot new-boot-prod.img
warten bis wieder "done" da steht

Code:
fastboot -i 0x1949 continue

adb shell
und in der shell dann:

Code:
su
mount -o remount rw, /system
cd /system/app/
rm com.amazon.dcp.apk
rm com.amazon.dcp.odex
rm *dtcp*
 
D

Dennfr3d

Neues Mitglied
Funktioniert leider nicht


uploadfromtaptalk1395077203135.jpg
 
P

P3I7

Neues Mitglied
Guten Abend,
wir versuchen nun auch schon ein paar Tage den Flash eines Kindle Fire Hd 2013. Gestern Abend löteten wir uns ein Factory Cable zusammen. Nun haben wir das Problem das im Geräte Manager "Soho-PVT-Prod-07" angezeigt wird aber der Treiber sich nicht hinzufügen lässt. Weder durch die Adb driver Installation noch durch manuelle Eingabe. Das Gerät wird im fastboot Modus leider auch nicht unter Adb devices gefunden. Startet man die runme Datei bleibt immer < waiting for device >. Weiß vielleicht jemand Rat?