Android Studio Gradle Problem

B

Beka1801

Neues Mitglied
Threadstarter
Hallo,

ich habe ein altes Projekt gefunden und wollte dies jetzt mit meinem neuen Android Studio öffnen. Beim Starten des Projekts kommt diese Fehlermeldung:
gradle.PNG


Wie kann ich das beheben?
Danke für die Hilfe im voraus.
 
swa00

swa00

Moderator
Teammitglied
Hallo
Wie kann ich das beheben?
Das steht da schon alles im klartext

compile und testcompile ist obsolete - also veraltet
complie also ersetzen durch implementation

usw
 
D

deek

Stammgast
Wobei das erstmal nur warnings sind.
Klappt mal das "Run tasks auf", das hat das rote Ausrufezeichen. Dort sollte stehen was gefailed ist.
Allgemein muss man sagen, dass es leider extrem pain ist alte Projekte aufzumachen oder über viele Versionssprünge hinweg gradle und das Android Plugin zu updaten...
 
numanoid

numanoid

Stammgast
Vermutlich hat Google schon im Android Studio einbauen lassen, dass eine kleinere Target-Version gar nicht mal mehr kompilieren. Macht auch Sinn, da sie beim Hochladen in den PlayStore eh nicht mehr akzeptiert werden.

Ab dem 1. August 2018 hatte man die mindest Target-Version auf 26 gesetzt. Ab 1. August 2019 wird es dann die 28 sein.

Das bedeutet immer viel Pflegeaufwand. Denn gewisse APIs sind dann schon obsolete geworden, und man muss diese Umschiffen, oder Weichen im Code einbauen. Evtl. braucht man spezielle Support-Libraries um ältere Versionen denoch weiter zu unterstützen, etc.

Mir ist das auch ein Graus. Grosse Entwickler-Schmieden passen natürlich ihre Apps dauernd an neuere APIs an. Die haben dann auch keine grossen Sprünge zu bewältigen. Ich habe noch Apps im PlayStore die mit Eclipse entwickelt sind. Das würde einiges an Arbeit bedeuten, die nach Android Studio und dann an API 26/28 anzupassen. Zum Glück hab ich nicht vor etwas an diesen Apps zu machen, und existierende Apps können so bleiben. Nur Updates und neue Apps müssen sich daran halten.
 
Oben Unten