Problem bei "new Android Application"

  • 8 Antworten
  • Neuester Beitrag
Diskutiere Problem bei "new Android Application" im Android App Entwicklung im Bereich Betriebssysteme & Apps.
C

coldickson

Neues Mitglied
Hallo, ich brauche bitte dringend Hilfe sonst komme ich nicht weiter. Bin ganz neu bei App Android Programmieren und schon bekomme ich Kopfsschmerzen :confused2::confused2:

ich wollte eine "new Android Application Project erstellen. Schon beim "new Android Application" erscheint die Fehlermeldung:

"This template requires a build target API version of at least 14, and the current version is 7".

ich habe auch den niedrigsten Wert genommen bzw. 1.5

target sdk: API 17. Android 4.2
Compile with: API Android 2.1

trotzdem bekomme ich diesen Fehler, dieses Mal:

"template requires a minimum SDK version of at least 7, and the current min version is 3"

Wie berechnet er sein current min Version?

Was sollte ich dabei achten?

MfG
 
S

swordi

Lexikon
das template wird erstellt, damit es auf minimum 14 läuft - Android 4.0

Musst ein anderes Template nehmen oder keines damit du ältere versionen unterstützen kannst. Ich sag dir im schlimmsten Fall solltest bis 2.3 runter gehen. aber mittlerweile fährt man schon gut, wenn man alles ab 4.0 unterstützt.
 
C

coldickson

Neues Mitglied
swordi schrieb:
das template wird erstellt, damit es auf minimum 14 läuft - Android 4.0

Musst ein anderes Template nehmen oder keines damit du ältere versionen unterstützen kannst. Ich sag dir im schlimmsten Fall solltest bis 2.3 runter gehen. aber mittlerweile fährt man schon gut, wenn man alles ab 4.0 unterstützt.
Hallo Swordi,

Danke dir für deine Antwort.

Was meinst du damit? Wenn ich eine neue Android Application anlegen moechte, muss ich alle Felder ausfüllen. wie sollte ich diese felder ausfüllen?
 
S

swordi

Lexikon
ja dann wähl min sdk = 14 - und schon läufts

target sdk nimmst die aktuellste
 
C

coldickson

Neues Mitglied
swordi schrieb:
ja dann wähl min sdk = 14 - und schon läufts

target sdk nimmst die aktuellste


Danke dir.

Hat funktioniert.

Ist es normal dass ich schon beim Öffnen von Eclipse eine Menge von Error bekomme?

Ich hatte vor kurz angefangen Java zu programmieren. Dann habe ich alle Code Dateien gelöscht, eine neue Android Application Projekt erstell.




Hat das etwas damit zu tun?

Danke
 

Anhänge

Zuletzt bearbeitet:
C

coldickson

Neues Mitglied
Ausserdem wo liegt der Unterschied zwischen : "activity_Main.xml" und "Fragment_main.xml ?
 
C

coldickson

Neues Mitglied
Danke Markus
 
S

swordi

Lexikon
sämtliche fragen, die ein anfänger haben kann sind hundertfach auf google zu finden.

da müssen anfänger seit über 4 jahren durch ;)
 
Ähnliche Themen - Problem bei "new Android Application" Antworten Datum
1
0
25