Ihr fandet Locale super? Dann werdet Ihr Tasker lieben!

  • 3.673 Antworten
  • Neuester Beitrag
Diskutiere Ihr fandet Locale super? Dann werdet Ihr Tasker lieben! im Automatisierung - Tasker im Bereich Tools.
Status
Für weitere Antworten geschlossen.
derHaifisch

derHaifisch

Dauergast
Tiger-Chrisi schrieb:
Also dachte ich mir, dass ich mir mit Tasker was bastle, damit mein "home-Profil" greifen kann.

Ich habe jetzt folgendes gemacht:

Context: Wifi near
Enter Task: Wifi toggle - wait 10 seconds - Wifi On
exit Task: Wifi off
Das Wifi Toggle im Enter Task kannst Du weglassen, da ja schon gesagt wurde, das toggle einfach nur umschalten heißt.
Das mit dem Wait kannst Du vielleicht mal so lassen, allerdings würde ich das Wifi On vor dem Wait machen. Denn das Wait vor dem On heißt nur, dass es nochmal 10 Sekunden länger dauert mit der Verbindung zum Netzwerk.
"Mein" Wait bleibt dann nicht am Ende alleine, sondern es folgt dann, wenn Du wirklich Probleme mit dem Connecten hast, noch ein "Wifi Connect". Ich habe kein Androidhandy hier, deswegen weiß ich nicht genau wo das zu finden ist. Ich meine auch unter Net, dann unter Wifi Net, da steht was von Connect/Reconnect... vielleicht probierst Du das mal aus, dann düftest Du Tasker dazu zwingen sich nochmal mit dem Netzwerk zu verbinden, wenn nicht eh schon geschehen.
Tiger-Chrisi schrieb:
Anderes Thema. Ich hab gerade die Anleitung für "Handy wird stumm, wenn es aufs Gesicht gedreht wird" ausgeführt und es klappt super. (Auch wenn mir die Logik der einzelnen Schritte nicht immer ganz klar ist *gg*) Jetzt hätte ich gerne noch, dass das Handy auch aufhört zu vibrieren, weil das auf einem Tisch ziemlich laut brummt. Also habe ich einfach die Funktion "Vibrate on Ringer - Off " bei "Ringer Volume 0" hinzugefügt und was soll ich sagen??? Es funktioniert natürlich nicht, das Handy vibriert immer noch. Warum kriege ich nicht mal so einfache Dinge hin???
Hmm, da weiß ich jetzt so keine Lösung. Hätte das auch so gemacht wie bei Dir. Wenn ich meinen Stein wiederhabe, kann ich das mal probieren.
 
derHaifisch

derHaifisch

Dauergast
fant0mas schrieb:
weil du auf vibrieren AN (vibrate on) und lautlos (ringer off) gestellt hast.
du müsstest auf "vibrate off" stellen ;) gibt auch glaub ich irgendwo "silent mode - ON" als task, da müsste (!) dann vibrieren aus, und telefon auf komplett lautlos sein (ausser media volume, die ist seperat).
Sie hat doch Vibrate off gemacht. *gg* Da steht nur "Vibrate on Ringer", so heißt der Task nunmal. :p
Silent Mode habe ich mit Vibration on im Kopf. Kann mich aber auch täuschen.
fant0mas schrieb:
ich habe mein "Wifi Home" -Profil inzwischen etwas anders gelöst, zwar uneleganter und nciht 100% so genau, aber dafür zuverlässiger:
ich benutze die condition "Cell near", und lasse einfach WLAN einschalten - dann connected er sich automatisch, sobald mein router in die nähe kommt.
Ist aber leider nur eine (gute) Alternative, wenn die Funkzellen klein genug sind, bzw. die unterschiedlichen Orte weit genug weg sind.
 
Tiger-Chrisi

Tiger-Chrisi

Stammgast
derHaifisch schrieb:
Das Wifi Toggle im Enter Task kannst Du weglassen, da ja schon gesagt wurde, das toggle einfach nur umschalten heißt.
Das mit dem Wait kannst Du vielleicht mal so lassen, allerdings würde ich das Wifi On vor dem Wait machen. Denn das Wait vor dem On heißt nur, dass es nochmal 10 Sekunden länger dauert mit der Verbindung zum Netzwerk.
"Mein" Wait bleibt dann nicht am Ende alleine, sondern es folgt dann, wenn Du wirklich Probleme mit dem Connecten hast, noch ein "Wifi Connect". Ich habe kein Androidhandy hier, deswegen weiß ich nicht genau wo das zu finden ist. Ich meine auch unter Net, dann unter Wifi Net, da steht was von Connect/Reconnect... vielleicht probierst Du das mal aus, dann düftest Du Tasker dazu zwingen sich nochmal mit dem Netzwerk zu verbinden, wenn nicht eh schon geschehen.
.
Ich habs jetzt mal so gemacht:

- Wifi: set off
- Wait 5 sec (könnte auch mehr sein. Sooo eilig ist das nicht, wenn ich heim komme)
- Wifi: set on
- Wifi Net: action reconnect (zur Sicherheit)

So sollte es dann ja wohl funktionieren.


derHaifisch schrieb:
Sie hat doch Vibrate off gemacht. *gg* Da steht nur "Vibrate on Ringer", so heißt der Task nunmal. :p
Silent Mode habe ich mit Vibration on im Kopf. Kann mich aber auch täuschen.
.
Da bin ich aber erleichtert, dass ich wenigstens DAS richtig verstanden hatte. (Ich dachte schon ich bin zu doof für Tasker :rolleyes2:) Ich hab das mit "Vibrieren beim Klingeln" übersetzt und dann eben auf Off gesetzt. Aber da kam beim Einrichten auch eine Meldung (Warnung) unter welchen Umständen das nicht funktioniert. Aber das habe ich wieder nur zur Hälfte verstanden und gehofft, dass es trotzdem klappt.
Du kannst es Dir ja mal vormerken und ausprobieren, wenn Du Dein Handy wieder hast.

LG Chrisi
 
derHaifisch

derHaifisch

Dauergast
Tiger-Chrisi schrieb:
So sollte es dann ja wohl funktionieren.
So könnte das funktionieren, auch wenn das vielleicht schon fast zu viel des Guten ist. Aber wenn es klappt, ist es doch egal. Ich kann ja schlecht bei Dir vor Ort testen. :)
Tiger-Chrisi schrieb:
Du kannst es Dir ja mal vormerken und ausprobieren, wenn Du Dein Handy wieder hast.
Mache ich, wenn ich es nicht vergesse. Du könntest aber vielleicht hier mal schreiben welcher Fehlermeldung kommt, wenn Du das so machst. Die dürfte ja nochmal kommen, wenn Du einfach einen weiteren Task erstellst.
 
Georgius

Georgius

Dauergast
Hab jetzt 2 Profile erstellt (Face up und down) die das vibrieren ausschalten. Im Hosensack liegt das Handy wohl nie Waagerecht.

Edit: Muß mal schaun wie das beim sitzen ist.
 
P

pseudoreal

Dauergast
derHaifisch schrieb:
Ich habe das verlinkte Profil dementsprechend abgeändert.
was ich noch nicht verstehe, warum hast du beim Profil für WLAN an, wenn man zu Hause ist, das mit WiFi Toogle realisiert?

Ich verstehe das so:
wenn in der nähe der zelle, dann mach das wifi near profil an. Dieses würde normalerweise WLAN an machen, toggelt aber periodisch auch manchmal das WLAN?

Gruß,
Sasa
 
derHaifisch

derHaifisch

Dauergast
pseudoreal schrieb:
was ich noch nicht verstehe, warum hast du beim Profil für WLAN an, wenn man zu Hause ist, das mit WiFi Toogle realisiert?
Ich habe vorsichtshalber da mal ein WLAN mit eingebaut, weil ich jetzt nicht weiß wie Tasker bei Wifi Near reagiert, wenn ein Netzwerk in der Nähe ist mit dem es sich verbinden soll. Nicht, dass dann auch Wifi immer ein und ausgeschaltet wird, und die Verbindung abreißt. Da ich selber kein WLAN zu Hause habe, kann ich das nicht überprüfen. Und bei meinen Eltern im Netz habe ich das nie getestet.
 
nelty

nelty

Stammgast
Hierdurch wird die Akku-Safe-Funktion von Juicedefender ersetzt und Juicedefender muss nicht mehr genutzt werden. Vorallem interessant für Leute, die Tasker sowieso immer laufen haben. Außerdem per Tasker natürlich mit Tasks für automatische Verbindung mit Wlan etc. wunderbar kombinierbar.

Hierfür sind drei Profile notwendig

Profil "Display Aus"

Context:
Event: Display Off
State: Not Wifi connected ("Wifi Connected", dann Checkbox "Invert")

Optional für Apps bei denen Inet IMMER an bleiben soll (z.B. Messenger):
Application: App(s) auswählen, Checkbox auf "not"

Task:
Net: Mobile Data Off
Net: Auto-Sync Off

Profil "Display An"

Context:
Event: Display On
State: Not Wifi connected ("Wifi Connected", dann Checkbox "Invert")

Task:
Net: Mobile Data On
Net: Auto-Sync On

Profil "Daten-Check"

Context:
Time: Beide Checkboxen neben den Uhrzeiten entfernen, dafür Checkbox auf "repeat" und entsprechendes Intervall wählen (mein Vorschlag: 15 Minuten)
Event: Display Off
State: Not Wifi connected ("Wifi Connected", dann Checkbox "Invert")

Task:
Net: Mobile Data On
Net: Auto-Sync On
Tasker: Wait: 1 Minute
Net: Mobile Data Off
Net: Auto-Sync Off
 
Zuletzt bearbeitet:
Tiger-Chrisi

Tiger-Chrisi

Stammgast
derHaifisch schrieb:
So könnte das funktionieren, auch wenn das vielleicht schon fast zu viel des Guten ist. Aber wenn es klappt, ist es doch egal. Ich kann ja schlecht bei Dir vor Ort testen. :) .
Naja, ich bin mir nicht ganz sicher, ob es richtig funktioniert. Ich gestern drei mal nach Hause gekommen. Beim ersten mal hat es sich nicht verbunden. Dann hab ich aber gesehen, dass ich W-lan am Handy ganz ausgeschaltet hatte und dachte mir, dass Tasker dann evtl nicht nach Wifi near suchen kann. Also habe ich w-lan manuell eingeschaltet und konnte sehen, wie das Profil ablief. (erst ausschalten und dann einschalten).
Dann wollte ich das noch mal testen und bin eine Runde um den Block gegangen. Irgendwann verschwand zwar das Wlan-Symbol vom Handy, aber das Profil war immer noch aktiv (= mit grünem Rahmen) Das dauerte dann eine Weile, bis der Rahmen sich ausschaltete. (Wie weit kann Tasker denn das Wlan scannen?)
Als ich dann nach Hause kam, hat es sich sofort verbunden und als ich Abends noch mal weg war und dann nach Hause kam auch.

Heute Morgen habe ich das Handy in die Hand genommen und geschaut, und da war Wlan nicht verbunden. Ich dachte, dass es wohl Probleme damit gab, dass mein Netz zu Hause zwischen 24 und 6 Uhr ausgeschaltet ist. Aber dann habe ich mein Wetter-Profil kontrolliert und habe festgestellt, dass heute Morgen schon aktualisiert wurde. Also muss Wlan verbunden gewesen sein.
Sehr mysteriös das Ganze..... Ich werde mal weiter beobachten.

derHaifisch schrieb:
Mache ich, wenn ich es nicht vergesse. Du könntest aber vielleicht hier mal schreiben welcher Fehlermeldung kommt, wenn Du das so machst. Die dürfte ja nochmal kommen, wenn Du einfach einen weiteren Task erstellst.
Die "Fehlermeldung" war ja eigentlich keine, sondern nur eine Info. Diese Infos kommen aber nur ein mal, wenn Tasker neu installiert ist und man eine Funktion zum ersten Mal ausführt. Auch wenn ich auf "Hilfe" drücke, kommt die Meldung nicht mehr. Vielleicht siehst Du sie ja, wenn Du Dein Handy zurück hast und die Funktion mal ausführst.

LG Chrisi
 
Tiger-Chrisi

Tiger-Chrisi

Stammgast
Georgius schrieb:
Hab jetzt 2 Profile erstellt (Face up und down) die das vibrieren ausschalten. Im Hosensack liegt das Handy wohl nie Waagerecht.

Edit: Muß mal schaun wie das beim sitzen ist.
Und verrätst Du uns auch wie Du das eingestellt hast, dass das Handy auch aufhört zu vibrieren?
 
derHaifisch

derHaifisch

Dauergast
Tiger-Chrisi schrieb:
Und verrätst Du uns auch wie Du das eingestellt hast, dass das Handy auch aufhört zu vibrieren?
Sag mal... wenn Du Dein komisches Setting Profiles komplett ausschaltest, funktioniert dann die Option Vibrate On Ringer Off?
 
Tiger-Chrisi

Tiger-Chrisi

Stammgast
derHaifisch schrieb:
Sag mal... wenn Du Dein komisches Setting Profiles komplett ausschaltest, funktioniert dann die Option Vibrate On Ringer Off?
Ich bin ja offen für alles. Habe gerade ALLE (!!) Profile in SP gelöscht. (Natürlich vorher Backup gesichert)
Aber es vibriert immer noch. Also mein komisches SP ist nicht Schuld :tongue:
 
derHaifisch

derHaifisch

Dauergast
Dann deinstallier SP doch gleich auch mal hinterher... und wenn es schonmal vom Handy weg ist, belasse es dabei. :D
Quatsch, ich mache nur Spaß, wollte nur eine mögliche Fehlerquelle ausschließen.
Im Tasker-Forum gibt es aber wohl noch mehr mit dem Problem. Habe aber jetzt nicht die Zeit mich da einzulesen.
 
Tiger-Chrisi

Tiger-Chrisi

Stammgast
derHaifisch schrieb:
Im Tasker-Forum gibt es aber wohl noch mehr mit dem Problem. Habe aber jetzt nicht die Zeit mich da einzulesen.
Tja und ich habe nicht die nötigen Englisch-Kenntnisse. Aber egal. Dann muss ich es eben auf eine weiche Unterlage legen, wenn ich es rumdrehe.

Vielleicht erfahren wir ja noch von @georgius, wie er es angestellt hat.
 
derHaifisch

derHaifisch

Dauergast
Vielleicht liegt es auch an Deinem Handy, dass da etwas übersteuert wird, denn ich hatte nie Probleme mit der Vibration. Vielleicht könntest Du es so machen... erst Silent Mode auf On, dann Vibrate On ringer auf Off. Ist aber auch nur geraten.
 
Tiger-Chrisi

Tiger-Chrisi

Stammgast
Nee, das klappt auch nicht. Naja, egal!

Neues Spiel neues Glück: Ich habe Deine Anleitung für die Rufnummernunterdrückung ausprobiert. (Ja, Du siehst, ich bin fleißig am üben) Aber.... wie soll es anders sein? Es funktioniert nicht. Ich habe jetzt zwar das Icon für das Widget auf dem Homescreen, aber es passiert nichts, wenn ich drauf drücke. Ich habe eigentlich alles so gemacht wie in der Anleitung, nur das if if habe ich nicht gefunden, bei mir war nur einmal "if" anzuwählen und da konnte ich gleich die Variable eingeben.

Ich kann das ja auch nicht mehr aufrufen um zu sehen, ob ich was falsch gemacht habe, oder?

LG Chrisi
 
derHaifisch

derHaifisch

Dauergast
Hast denn nur Du diese Probleme, oder haben andere die auch? (Dir Frage ging jetzt an alle. :D)
Tiger-Chrisi schrieb:
Ich kann das ja auch nicht mehr aufrufen um zu sehen, ob ich was falsch gemacht habe, oder?
Das geht derzeit so nicht, Du müsstest das komplette Widget neu machen. Dem kannst Du aber entgegenwirken, indem Du in Tasker erst unter Tasks (dort wo Du auch "New" machst, für neue Profile) den entsprechenden Ablauf abspeicherst, und diesen dann für das Widget auswählst. Dann kannst Du auch nachträglich diesen Task ändern, und das wird dann für das Widget übernommen.
 
schmarti

schmarti

Stammgast
Beta 5
 
Tiger-Chrisi

Tiger-Chrisi

Stammgast
Hallo an Alle,

ich habe schon wieder zwei Fragen.

1.) Mein Tasker verlangt eine "Validation". Ich hatte ja erst die 7-Tage-Testversion. Aber ich dachte, mit dem Kauf des Programmes wäre jetzt alles erledigt. Was will der jetzt von mir?

2.) Ich bin einfach zu doof. Ich kann nicht mal die einfachsten Tasks erstellen. Ich hätte gerne einen Task, der mir immer, wenn ein Termin im Kalender steht, diesen per Popup anzeigt.
Ich dachte, dass ich mich da schon durchwurstele, aber ich finde nicht mal den Anfang. Wo kann ich den Context "Wenn Eintrag im Kalender" eingeben?

LG
Chrisi
 
derHaifisch

derHaifisch

Dauergast
Tiger-Chrisi schrieb:
ich habe schon wieder zwei Fragen.
zu 1.
Du solltest Dir ein Backup von Deinen Profilen machen, und dann die Market-Version installieren. Die Test-Version erst deinstallieren. Danach spielst Du Dein Backup wieder ein.
zu 2.
Unter Event gibt es die Action "Calendar Entry", wenn ich mich jetzt richtig erinnere. Darüber kannst Du Popups öffnen lassen.
Allerdings ist es auf die schnelle nicht so einfach das als Popup anzuzeigen. (Es gibt keine Variable mit dem Kalenderinhalt) Das heißt, es wäre möglich, mit sehr viel Aufwand. Da bist Du dann mit einer Benachrichtigung besser bedient, oder mit einem Kalenderwidget, oder aber mit einem einfachen Popup Termin vorhanden, bzw. wenn es einen Termin gibt, dann öffne den Kalender.
 
Status
Für weitere Antworten geschlossen.