Lockscreen mit Tasker deaktivieren

  • 27 Antworten
  • Neuester Beitrag
Diskutiere Lockscreen mit Tasker deaktivieren im Automatisierung - Tasker im Bereich Tools.
X

xeenon

Stammgast
Hallo,

Seitdem ich mein s3 habe spiele ich sehr viel mit nfc Rum. So habe ich z. B. Zuhause im wohnzimmer einen tag fürs Zuhause Profil (WLAN ein usw.) und an der Türe einen tag für eben Einstellungen die für draußen gelten. WLAN aus blabla.

Nun suche ich noch eine Möglichkeit meinen lockscreen zu deaktivieren. Wenn ich Zuhause bin finde ich es lästig ständig meinen pin eingeben zu müssen. Im Prinzip habe ich schon was gefunden.

Für Tasker habe ich ein plug in gefunden (secure settings) mit der ich keyguard deaktivieren kann. Funktioniert prima. Allerdings nur ein paar Minuten. Irgendwann, wenn ich dann wieder auf den home screen gehe kommt die pin eingabe. Und ab dann ist der lockscreen wieder aktiv.

In der Einstellung von secure settings gibt es bei keyguard eine Option 'running in background'. Es macht keinen Unterschied ob ich das aktiviert habe oder nicht.

Ich nutze die stock Rom 4.0.4, allerdings gerootet.

Kann mir da jemand weiterhelfen?

Grüße

Gesendet von meinem GT-I9300 mit Tapatalk 2
 
N

naturelle

Gesperrt
App "Entsperren mit Wifi"
 
X

xeenon

Stammgast
Das funktioniert nicht. Da das mit Zuhause nur ein Beispiel war. Das selbe benötige ich für die Arbeit und bei meinen Eltern. Bei beiden kein WLAN.

Gesendet von meinem GT-I9300 mit Tapatalk 2
 
m505

m505

Experte
mit der Keyguard-Funktion kann ich Dir leider nicht weiterhelfen.
Kann Dir aber eine Alternative vorschlagen:
Ich sperre via Secure Settings mit Password/Pin

- Enabled Pin Code --> Set Pin
- Disabled --> Clear Password

Damit sperre/entsperre ich automatisch (z.B. Nachtsperre oder per SMS) und habe zusätzl. noch ein Toggle-Widget auf dem Homescreen zum manuellen umschalten bei Bedarf
 
X

xeenon

Stammgast
Hey. Das ist zwar nicht 100 Prozentig das was ich gesucht habe, aber auch mit der Lösung bin ich vollends zufrieden

Gesendet von meinem GT-I9300 mit Tapatalk 2
 
4

4ndr0

Experte
Dann muss ich aber von Pattern auf Pin-Lock umschalten, oder?

Ich habe nämlich dasselbe Problem. Habe das mittlerweile schon doppelt gemoppelt, siehe Bild.

Ich muss regelmäßig manuell das Profil deaktivieren und wieder aktivieren, damit es wieder eine Weile lang funktioniert. Das Problem muss sich doch irgendwie lösen lassen?
\\
naturelle schrieb:
App "Entsperren mit Wifi"
Hat bei mir lange Zeit wunderbar ihren Job erfüllt, seit dem Update auf JB möchte die App nur noch mit PIN Unlock funktionieren. Pattern Unlock ist angeblich nicht möglich, das liegt an Android. Sagt die App. Auf GB ging es seltsamerweise. Wenn du nen Tipp hast, würde ich die paar € auch gerne investieren und die Pro-Version kaufen. Instruct me please :)
 

Anhänge

Zuletzt bearbeitet:
N

nufnufnuf

Neues Mitglied
"Pattern Lock" geht nur noch mit root.
Dann nicht die Funktion "keyguard" nutzen, sondern die Secure Settings Funktion "Pattern Lock" aus dem root-Funktionen-Abschnitt.
 
4

4ndr0

Experte
nufnufnuf schrieb:
nicht die Funktion "keyguard" nutzen, sondern die Secure Settings Funktion "Pattern Lock" aus dem root-Funktionen-Abschnitt.
Funktioniert leider auch nicht, dann ist zwar Pattern Unlock aus, aber ich bekomme immer noch den Lockscreen, wenn ich das Display aktiviere.
 
X

xeenon

Stammgast
Hey,

Das mit dem lockscreen bekommst nicht weg, zumindest hab ich es nicht geschafft. Ich bin aber schon mal damit zufrieden nicht mehr meinen 8 stelligen pin Zuhause eingeben zu müssen.

Gesendet von meinem GT-I9300 mit Tapatalk 2
 
4

4ndr0

Experte
Naja es klappt ja wunderbar mit Keyguard disable. Leider nur eine begrenzte Zeit, ca jede halbe Std. muss ich das Profil deaktivieren, speichern, wieder aktivieren, speichern. Dann klappt es wieder. Sehr seltsam.

Mir ist allerdings gerade ein genialer Einfall gekommen, weiss nur noch nicht wie ich ihn umsetzen soll:

Sobald ich mit meinem WLAN verbunden bin, soll Tasker alle 20 Min das Profil de- und wieder aktivieren :)

Hat jemand nen Tipp? Ich finde nur die Option, Tasker komplett zu deaktivieren.
 
X

xeenon

Stammgast
Das sollte eigentlich klappen. Finde ich aber weniger optimal weil ja dann das ganze in einer Endlosschleife läuft.


Gesendet von meinem GT-I9300 mit Tapatalk 2
 
4

4ndr0

Experte
Yay, danke so sollte es funktionieren. Hoffentlich. Wenn dir ne Alternative einfällt, her damit. Ich teste das jetzt erst mal so :)
 
X

xeenon

Stammgast
Ich bin damit zufrieden. Hab ja auf dem lockscreen meine schnellstarter.

Gesendet von meinem GT-I9300 mit Tapatalk 2
 
Troya

Troya

Stammgast
Ich habe auch mal was probiert:
Der Text ist aus Tasker exportiert, kannst du das Lesen/verstehen?

Profil: Test (31)
Status: WiFi Verbunden [ SSID:* MAC:* IP:* ]
Eingang: Test Task (37)
A1: Warte [ MS:0 Sekunden:0 Minuten:20 Std.:0 Tage:0 ]
A2: Wi-Fi [ setzen:Umschalten ]
A3: Wi-Fi [ setzen:Umschalten ]

Wenn mit WLAN verbunden, warte 20 Minuten und schalte dann einmal das WLAN um.

Mit dem umschalten umgeht man schon mal das Problem falls der Task noch läuft und man mittlerweile das WLAN selber verlassen hat.Dann geht es nur kurz an und wieder aus.

Soweit ich das grade mit meinen müden Augen so sehe könnte es funktionieren :sly:
---
Motorola Defy | 1200MHz@62vsel | Android 2.3.5 CM7.1
 
A

alexhager

Neues Mitglied
Ich habe heute Tasker installiert und war ganz begeistert von der Idee, das PIN-Lock automatisch deaktivieren zu können, sobald ich im eigenen WLAN bin.
Leider stoße ich auf dasselbe Problem wie ihr offenbar auch und wenn ich das richtig verstehe, habt ihr auch keine wirkliche Lösung, sondern eher Workarounds gefunden?

Mir ist schon klar, dass der Tasker-Hersteller nichts dafür kann, wenn Android immer wieder verschlimmbessert wird, aber etwas seltsam finde ich es schon, dass dieser an sich einfach klingende Task (für den es ja auch Anleitungen gibt) einfach nicht zu funktionieren scheint, zumal Tasker ja keine gerade vergleichsweise billige App ist.

Wenn das früher funktionierte, frage ich mich schon, warum hier (wohl androidseitig?) verschlechtert wurde?

Ich habe übrigens nicht gerootet, also vielleicht habe ich noch weniger Chancen, dass es bei mir funktioniert, als User mit Rootrechten. Ich kenne mich da aber auch gar nicht aus und würde das Rooten eigentlich gerne vermeiden.


Hier ein anderer Thread, den ich zum Thema vorhin geöffnet habe, ehe ich diesen hier fand. Vielleicht ist's ja ganz gut, das Problem wachzurufen und evtl. eine Lösung zu finden?
 
C

Chillmann

Stammgast
Hi,

habe kürzlich beim stöbern Unlock Keyguard Ad gefunden. Mit normalem Wisch-Lockscreen als auch mit PIN habe ich es erfolgreich getestet. Versuch halt mal dein Glück :thumbup:


Gruß

Chillmann
 
zwantE

zwantE

Experte
wollte das gerade mal testen, aber was muss denn alles bei sent intent ausfüllen? da steht überall nur optional.
 
E

ebayviper

Stammgast
Mit der neuesten Beta von Tasker samt Security Settings, beide als Administratoren und Beidenungshilfen eingestellt funktionierts doch ohne Probleme.

Hab jetzt zwar nicht "bei bekannten Wlan", sondern einfach per Location (ohne GPS) gemacht, aber funktioniert seit Wochen perfekt.

Ich hab den Eingangstask erstellt mit Passwort löschen. Lieber ist bei nichtausführen des Tasks zu Hause die Sperre dirn, als draußen keine Sperre.
BIsher aber alles tadellos.
 

Anhänge

C

Chillmann

Stammgast
zwantE schrieb:
wollte das gerade mal testen, aber was muss denn alles bei sent intent ausfüllen? da steht überall nur optional.
Der Befehl muss nur in die erste Zeile. Alles andere kann frei bleiben.


Gruß

Chillmann
 
A

alexhager

Neues Mitglied
Dank einiger User, v.a. cramu, habe ich eine Lösung gefunden, die bei mir zu funktionieren scheint.

Dazu braucht man tasker und secure settings, sonst nichts. Root ist offenbar keine Voraussetzung.

Bei Interesse siehe hier.
 
Ähnliche Themen - Lockscreen mit Tasker deaktivieren Antworten Datum
1
3
0