Wifi Call

  • 53 Antworten
  • Neuester Beitrag
Diskutiere Wifi Call im Automatisierung - Tasker im Bereich Tools.
Spardas

Spardas

Experte
Salü zusammen. Nach dem micht jetzt auch Googel hasst, werfe ich meine Frage mal hierrein.
In meiner Wohnung habe ich ganz miesen Cellempfang (hackt und stottert beim telefonieren). Therotisch kann meine S7 auch Wificall, das es aber nur dann aktiviert wenn wirklich nicht mehr an Cell-Strichen da ist.
Gibt es eine Möglichkeit das man mit Tasker das Wificall aktiviert wenn man im W-Lan verbunden ist?
PS.: Ich weiss das man es mit Secure App und Flugmodus erzwingen kann, aber Flugmodus ist keine Option für mich.
Greez
Spardas
 
Spardas

Spardas

Experte
Salü zusammen. Ich push das Thema mal mit neuen Erkenntnissen.
Im Tasker Plugin Secure Settings - Aktion - Device Setting - Global gibt es einen Eintrag Namens wifi_call_preferred zu deutsch wifi call bevorzugt. Der Standardwert war bei mir 2
Ich haben den Wert mit 0 / 1 / 1000 / on / enable getestet doch es ändert sich rein gar nichts. Egal welcher Wert, Wificall wir nur mit Flugmodus oder absolutem totem Netz an geschaltet.
Zu diesem Thema Aussert sich auch Google sehr spärlich. Eventuell weiss aber ein helles Köpfchen von euch wie ich an mein Ziel komme.
Gruss Spardas
 
Zuletzt bearbeitet:
schmetty2

schmetty2

Stammgast
Hallo,

was spricht denn gegen den Flugmodus? Bei aktiviertem WLAN und Sync sollten doch alle Benachrichtigungen durchkommen.

mfg
 
Spardas

Spardas

Experte
Es ist die umständlichkei. In meiner Wohnung habe fast keine Empfang. Und umgekehrt auf dem Balkon Wlan. Ein Raucher prooblem ;)
 
maxe

maxe

Ehrenmitglied
Ich würde das Thema gerne noch mal hoch holen. @Spardas hast du da was erreichen können? Hab die selben Anforderungen: Wenn im Wlan, dann Wifi Calling aktivieren.
 
Spardas

Spardas

Experte
@max-de
Nein leider nicht. Man kann es wirklich (beim Samsung S7) nur mit dem Flugmodus erzwingen.

Anscheinden ist es auch Software abhängig. Bei Android von meinem Anbieter habe ich Wifi Call angeboten. Bei meinem Custom Rom (Helios 7.27) kann ich die Option zwar per Activität aufrufen, aber beim einschalten passiert nix.
Der Eintrag wifi_call_preferred gibt es gar nicht.
 
Spardas

Spardas

Experte

Anhänge

  • Mobiles_Signal_Messen__Wert_dBm.tsk.zip
    780 Bytes Aufrufe: 92
maxe

maxe

Ehrenmitglied
Ich muss hier noch mal rein grätschen ...
Ich würde gerne über Tasker regeln, wenn ich @Work bin, dass dann automatisch WiFi Calling deaktiviert wird. Finde dazu aber leider überhaupt nix.
 
Spardas

Spardas

Experte
@max-de
Versuchs mal so. Leider geht bei meinem Custom Rom das wifi call nichtmehr.
Autotools - Secure Settings - Custom Settings:
setting typ = global
Name = wifi_call
Input typ = int oder String
Value = 0
 
maxe

maxe

Ehrenmitglied
werde ich versuchen, danke. Rückmeldung kommt ;-)
-- Dieser Beitrag wurde automatisch mit dem folgenden Beitrag zusammengeführt --
Funktioniert leider nicht :crying:
 
Spardas

Spardas

Experte
@max-de
Hast du denn wert wifi_call mal ausgelesen ober sich geändert?
 
maxe

maxe

Ehrenmitglied
Ich habe jetzt noch mal ein bisschen rum getestet. "wfc_ims_mode" wäre vielleicht passend, benötigt aber wohl root.
 
Spardas

Spardas

Experte
@max-de
Hmm aber Autotools mit ADB rechten kann doch alles setzten.

Hast du den Eintrag überhaupt?
 
maxe

maxe

Ehrenmitglied
@Spardas
du meinst diesen hier?
Code:
adb shell pm grant com.joaomgcd.autotools android.permission.WRITE_SECURE_SETTINGS
Den hab ich gesetzt.
 
Spardas

Spardas

Experte
@max-de
Ja Genau
Hab noch A5 ohne root. Mal sehen ob das Wifi call hat, dann kann ich das mal testen. Melde mich wieder ;)
 
maxe

maxe

Ehrenmitglied
stimmt, der Artikel liest sich echt so.
Ich habe momentan eh keine Idee mehr.

Evtl ist es eh nur noch mit Root möglich.
 
Spardas

Spardas

Experte
@max-de
Update wir haben beide recht :)
Mein Rermin 4x Custom Rom Android 8, hat beides, WiFi call und Bevorzugung :)

global
wfc_ims_enable = 0(aus) 1(ein) wificall
wfc_ims_status = 1(mobil bevorzugt) 2(WiFi bevorzugt)
wfc_ims_romanig_status= Bevorzugung im Ausland
 

Anhänge

Zuletzt bearbeitet:
maxe

maxe

Ehrenmitglied
nichts davon switched bei mir über AutoTools WiFi-Calling um. Schade aber danke.
 
Spardas

Spardas

Experte
Ich habe mit Magisk Tasker die Root rechte entzogen.
und via
Autotools - Secure Settings - Custom Settings:
setting typ = global
Name = wfc_ims_enable
Input typ = int
Value = 0

Kann ich Wlan Anrufe ein und aus schalten.
 

Anhänge

  • Wifi_Call.tsk.zip
    1,2 KB Aufrufe: 113