[CM13]Marshmallow 6.0.1 für Chuwi hi8 Pro 64bit

  • 114 Antworten
  • Neuester Beitrag
Diskutiere [CM13]Marshmallow 6.0.1 für Chuwi hi8 Pro 64bit im Chuwi Hi8 Forum im Bereich Chuwi Forum.
tki

tki

Stammgast
[CM13]Marshmallow 6.0.1 für Chuwi hi8 Pro 64bit

Marshmallow für unser hi8pro 64bit nach SN 32G221608XXXXX (
in der Betatphase für User freigegeben)

Die anderen Hi8pro werden ein angepasstes Boot.img brauchen, testen konnte ich das auf den 32bit Geräten nicht.
Wer es testen will, auf seinem 32bit Gerät, muss mir die Boot.img und System.img aus dem Updatepaket zukommen lassen.
Bei dem ROM handelt es sich um eine stark veränderte Version von hier
LineageOS 13 (Android 6.0.1)

Was läuft:

Wlan
Bluetooth (Audio getestet)
USB-Speicher
USB-ADB
USB-OTG (mit einer Tastatur getestet)
Multitouch
Lagesensor
Kamera ???
(ab und an Abstürze in der App)
Software und Hardware Homebutton
uswusf.


Was geht nicht:

Deep Sleep
Kabellose Übertragung


Was ist besser gegenüber dem Lollypop von chuwi:

Im Antutu Test fast 2000 Punkte mehr an Leistung
BT Audio ohne Störung beim Streaming, (unter Lollypop hatte ich mit meinem Kopfhörer immer Unterbrechungen, meine Erfahrung)
microSD kann als Interne Speichererweiterung genutzt werden
Xposed Framework läuft


Was ist schlechter gegenüber Lollypop:

Kabellose Bildübertragung??? (kann ich mangels Empfänger nicht testen)
Kamera


Ein paar Bilder vom ROM





Anleitung:
Für Schäden an der Hardware, durch Eigenverschulden oder Probleme mit der Software bzw. beim Flashen, übernehme weder ich noch Android-Hilfe.de die Verantwortung oder eventuelle Kosten.

ich kann nur dazu raten vor dem Flashen das alte Android mit twrp zu sichern, kann sehr hilfreich sein bei Problemen


1. Zu allererst [RECOVERY] TWRP 3.0.2.0 Recovery für Hi8 Pro 64Bit aufspielen, Anleitung ist im Tool hinterlegt.

2. Google Apps The Open GApps Project und das ROM File-Upload.net - chuwihi8pro64bitcm13_20170311.zip runterladen und auf Externe SD, USB-Stick oder Internen Speicher kopieren ( Zip nicht auspacken)

3. Tablet in den Recovery-Mode booten

4. im Twrp die Daten (sehr wichtig, sonst läuft's nicht rund), und System löschen, im erweiterten Löschen-Menu

5. Im Twrp-Hauptmenu unter Neustart, das Recovery neu starten und warten bis es neu gestartet ist

6. Unter Install den Speicher auswählen, dann zuerst die chuwihi8pro64bitcm13_xxxxxxxx.zip installieren (dauert gut 15-20min ohne das sich am Bild etwas ändert) danach die Google-Apps installieren und System neu starten, der erste Start dauert etwas länger.

7. Alle Arten von Fehlern hier berichten, Willywusel01 und ich, können nicht auf alles achten, manche Funktionen nutzen wir halt nicht, da ist es wichtig wenn alle dabei helfen dieses Android besser zumachen.


Root ist in CM13 eingebaut und kann über die Entwickleroptionen aktiviert werden.


Ich möchte KonstaT von MoDaCo News - MoDaCo ganz herzlichst danken, für die Erlaubniss seinen CM13 Port zu verwenden .
Das hat mir eine Menge Arbeit gespart.
Auch möchte ich willywusel01 danken, der seine Freizeit geopfert hat um mir bei diesem Projekt zu helfen, ohne an Lob und Tadel zusparen


Zum Portieren mussten sämtliche Treiber für Wlan, BT, Kamara, Touchscreen, und Lagesensor sowohl im Kernel als auch im System geändert werden, so wie diverse xml`s.
Wer also meint er könne einfach das CM13 von dem Link oben einfach so aufspielen, kann froh sein wenn das Tablet nacher noch läuft, ich weiß wovon ich rede


Gruß
Tki
 
Zuletzt bearbeitet:
H

hanshi10plus

Neues Mitglied
Erfahrungen auch mit dem Chuwi Hi 10 plus? Bei mir startet das RemixOS nicht, Windows schon. Mit LineAgeOS habe ich Erfahrungen für Galaxy S2/S3/S5. Gibt es Tipps
 
tki

tki

Stammgast
LineageOS 13 (Android 6.0.1) in der Beschreibung steht, das es auch für das Hi10 plus ist.
Kannst du das mal näher beschreiben was du meinst, hast du RemixOS neu installiert oder war das schon drauf? meine mich zu erinnern das das Tablet mit beiden Android Versionen angeboten wird. Hast du TWRP geflasht, und seitdem geht es nicht mehr? Etwas an den Partitionen geändert?

wie du siehst, bitte etwas genauer beschreiben was passiert ist, vielleicht kann ich dir helfen.

Beim hi8 ist es so, das in der Boot.img ro.secur aktiviert ist, das hatte zur folge das Android nicht mehr startete, sobald irgendwas an den Androidpartitionen geändert wurde, ein simples zugreifen hatte schon gereicht, selbst der Start von twrp aus dem RAM reichte, das Android nicht startete.
Bei meinen twrp`s habe ich ro.secure abgeschaltet.

Gruß
tki
 
Zuletzt bearbeitet:
H

hanshi10plus

Neues Mitglied
Chuwi hi 10 plus kommt von Haus aus als DualBoot mit Remix OS und Windows 10 Home. Das Problem ist, die Systempartition von Windows 10 ist nur 100 MB groß und verweigert dadurch das WindowesUpdate 1607. Wenn man beim Update nicht aufpasst, wartet man beim Neustart ewig, bis Chuwi die alte Version wiederhergestellt hat. Also die Ursache / Startpartition von 100 auf 450 MB vergrößert und alles war in Ordnung. RemixOS und Windows 10 liefen auch mit der Version 1607 parallel nebeneinander. Nun startet nur noch Windows und RemixOS hängt sich bei der Wahl des zu startenden BS auf, warum auch immer. Derzeit geht es nur nach der LösungsVariante --> Android drauf und dann muss Windows neu nachinstalliert werden oder auf RemixOS pfeifen und nur noch mit Windows 10 das Tablet benutzen!
 
tki

tki

Stammgast
so wie ich lese, hast du Treiber zum flashen schon installiert, und die Updates runtergeladen.
Wenn du mir die Boot.img aus dem Android-Updatepaket zu schickst, kann ich die bearbeiten, oder ich erkläre dir wie das geht.
Die geänderte Boot.img wird mit fastboot geflasht, und dein Remix sollte wieder laufen, hoffe ich
 
W

willywusel01

Ambitioniertes Mitglied
So, ich hab's mal dirty drüber installiert, läuft soweit ganz gut und absturzfrei, nachdem zickige Apps aus der Vorinstallation deinstalliert und neu installiert wurden.

Wie bereits angekündigt funktioniert der Homebutton nicht, und auch der viereckige Button daneben zeigt auch keine Funktion. Entwicklermodus konnte ich nicht freischalten, rooten gibt aber mittels TWRP. Die obere Statusleiste funktioniert zwar, zeigt aber nichts außer Zeit/Datum, WLAN (Bluetooth nicht), Akkustand an. Man kann auch nicht z.B. das Wlan ein und ausschalten, Bildschirmübertragung, und auch nicht direkt ins Windows wechseln.

Kamera läuft, aber nicht stabil. Wenn man eine Aufnahme gemacht hat, geht nichts mehr, man kommt auch nicht in den Launcher zurück. Man muss auch die andere Kamera umschalten, dann kommt die Kameraapp wieder ins laufen.

Drahtlose Bildschirmübertragung funktioniert nicht, es wird auf dem Fernseher nur ein schwarzes Bild angezeigt. Bluetooth Dateiübertragungen funktionieren ebensowenig.

Trotz der bisher gefundenen Einschränkungen ein sehr guter früher Release, danke tki!
 
tki

tki

Stammgast
Hi Wilywusl01,
Danke für das Feedback, die meisten Fehler liegen vermutlich am dirty install, andere Android Version und anderen Struktur,CM13 halt
Nach einem Reset sollte das meiste laufen .
Entwickleroptionen kann ich einschalten,
Kamera APP, nach mehr maliger Benutzung läuft sie Stabil, einfrieren tut sie nur am Anfang.
der Viereckige Button sollte auch funktioniere, (dirty install ? Cooles Wort kannte ich vorher nicht ☺)
Homebutton , ist bekannt, da suche ich noch in der SytemUi, ist beim geklauten ROM auch so.
Bluetooth, wird bei mir angezeigt, (dirty install)
Bildschirm Übertragung hatte ich nicht getestet


Danke für das erste Feedback
Tki
 
W

willywusel01

Ambitioniertes Mitglied
Ich habe jetzt noch mal von Null angefangen. Kamera APP funktioniert jetzt sauber, Entwickleroptionen lassen sich auch freischalten, der viereckige Button funktioniert jetzt auch. :) Ja, manchmal hat dirty install halt Nebenwirkungen ;) Auf meinem alten Galaxy Tab2 bin ich von Kitkat auf Marshmallow auch dirty gegangen, bisher keine Probleme.

An der oberen Statusleiste hat sich nichts geändert, Bluetooth wird beim Runterziehen nicht angezeigt, ebenso keine Benachrichtigungen etc. Die Statusleiste auf dem Screenshot ist alles, was kommt, weiter runterziehen kann man ich sie nicht... und die kabellose Bildschirmübertragung macht weiterhin schwarzes Bild, mit Kabel funktioniert sie aber :)

Soweit aber immer noch stabil...
 

Anhänge

tki

tki

Stammgast
Screenshot_20170307-160311.png

So siehts bei mir aus,
Bluetooth geht bei mir, BT Audio sogar besser als beim Lollipop


Nachtrag: Statusleist geht nur sporadisch, im Moment geht sie bei mir nicht
Hab es im ersten Post auf die Zumachenliste geschrieben
 
Zuletzt bearbeitet:
W

willywusel01

Ambitioniertes Mitglied
Siehst Du noch Potential beim Standbymodus? Laut meiner Schätzung ist der Akku im Standbymodus innerhalb von 8 Stunden leer. Angeblich hat Marshmallow ja besondere Energiesparmaßnahmen an Board... aber vielleicht nicht für x86...?!
 
tki

tki

Stammgast
Sind 16 Stunden, habe nachgemessen, das Problem liegt vermutlich am verwendeten Lollypop kernel und dessen Hardware Treiben.
Beim Vi10 plus, woher das CM ürsprünglich stammt, wurde der Kernel neu erstellt, beim hi8 leider nicht möglich, die Sourcen fehlen.
Aber ich glaube das man da trotzdem noch was rausholen kann.
Dafür hält der Akku im Betrieb länger, meinem Gefühl nach.
 
W

willywusel01

Ambitioniertes Mitglied
Ich glaube, dass die CPU nie in Deep-Sleep geht. Zumindest lt. CPU-Spy nicht. Für die Hometaste gibt es zwei Workarounds, einmal die App "Simple Control", oder einfach auf das Quadrat drücken, dann auf Home, dann kommt man auf den Homescreen zurück.
 
W

willywusel01

Ambitioniertes Mitglied
Kann jemand mal mit dem original rom gegenchecken, was cpu spy nach längerer Zeit standby rausschmeißt?
 
tki

tki

Stammgast
Das Home Button Problem, ist ein allgemeines Marshmallow Problem, was immer wieder bei einzelnen Leuten auftaucht, egal welche Hardware.
Es gibt unterschiedlich Lösungen, die bei mir alle nicht geholfen haben.

Lege ich aber einen neuen User an, dann geht der (Software) Home Button so, wie er es soll, im Gastmodus auch.
Im Besitzermodus geht er aber nicht.
 
tki

tki

Stammgast
Ich habe noch mal ganz von vorn begonnen und ein neues Build erstellt.

Software -Homebutten, Taskleiste nachuntenziehen, und Speerbildschirm (jetzt wo er geht , ist mir aufgefallen das er nicht ging :) ), App-Benachrichtigungen gehen jetzt auch,
@willywusel01, link kommt per PN, bei mir ging es mit dirty install, Systempartition vorher löschen, gapps anschließend installieren.
 
tki

tki

Stammgast
So, nur noch 2 Dinge auf der Todo,

Kabellose Übertragung geht, Lösung:
Entwickleroptionen freischalten, in diese gehen, ziemlich weit runterscrollen und HW-Overlays deaktivieren einschalten, dann klappt die Übertragung.

Jetzt fehlen noch:
Standby verbrauch optimieren,
Hardware Homebutten (Software geht)
 
tki

tki

Stammgast
Hardwarehomeknopf geht
 
K

karlkoxx

Neues Mitglied
Hallo zusammen,

als erstes möchte ich einmal einen dicken Dank aussprechen das sich jmd. dem Thema Andoid 6 und Chuwi Hi8 Pro 64 Bit angenommen hat. Wie lange habe ich dem entgegengefiebert :)

Ich freue mich schon darauf wenn die Custom Rom Final Status erreicht hat und ich sie endlich aufspielen kann.

Ich hab bei der aktuellen den Root noch nicht hinbekommen bin aber zuversichtlich das es die Tage funktioniert.

Wird es auch möglich sein nur Android aufzuspielen?

Ich möchte gerne auf Windows verzichten, da ich das bei einem 8 - Zoll Tablet etwas "übertrieben" finde.

Kann man irgendwie unterstützen?

Gruß

David
 
tki

tki

Stammgast
Hallo karlkoxx,
willkommen im Forum, welches hi8 pro hast du? 32Bit oder 64bit?
Es ist schon möglich nur Android zunutzen, aber mit Arbeit verbunden.
 
K

karlkoxx

Neues Mitglied
Ich habe ein 64 bit hi8 pro. Nach der Auslieferung habe ich ein Windows 10 clean installiert gemacht. Abschliessend die verbleibenden Treiber nach installiert. Hat alles gut funktioniert. Nur wie gesagt ich finde Windows 10 auf einem 8 Zoll nicht wirklich passend.