[OS] FreeYourMind 1.4.1 - Black'n White

  • 179 Antworten
  • Neuester Beitrag
Diskutiere [OS] FreeYourMind 1.4.1 - Black'n White im Custom-ROMs für Huawei Ascend Y300 im Bereich Root / Custom-ROMs / Modding für Huawei Ascend Y300.
M

minotaurus

Gast
@moddingg33k & Tzul: Danke für die Hinweise. Die Framerate ist wirklich sehr bescheiden und ich bin am überlegen ob ich beim nächsten Update wieder zurück auf die alten media.profiles gehe. Ich hänge die mal an, einfach unter System/etc austauschen.

Was mich etwas irritiert ist die Sache mit dem Radio. Das läuft bei mir perfekt, auch ist der Eintrag in der build.prop vorhanden. Ich lade es einfach selbst nochmal runter und schaue mir da die prop an.
 

Anhänge

  • media_profiles.zip
    3,8 KB Aufrufe: 120
Zuletzt bearbeitet von einem Moderator:
T

Tzul

Stammgast
minotaurus schrieb:
Was mich etwas irritiert ist die Sache mit dem Radio. Das läuft bei mir perfekt, auch ist der Eintrag in der build.prop vorhanden. Ich lade es einfach selbst nochmal runter und schaue mir da die prop an.
Sorry, mein Fehler! Ja, "ro.config.fm_type=libqcomfm_if" stand in deiner build.prop. Muss ich aus Versehen gelöscht haben, als ich ein paar Änderungen an der Datei vorgenommen habe.


Nachtrag:
Folgende Einträge in der build.prop sind doppelt - moddingg33k hat schon ein paar aufgezählt.
Code:
audio.legacy.postproc=true
lpa.decode=true
media.stagefright.enable-meta=false[COLOR=Red]/[/COLOR]true
net.tcp.fin.aggregation = 1
net.webkit.cache.maxdeadsize = 4194304
net.webkit.cache.mindeadsize = 4194304
net.webkit.cache.size = 12582912
net.webkit.setpri = 1
persist.sys.main_storage=internal_sd
ro.camera.sound.forced=0[COLOR=Red]/[/COLOR]1
ro.config.AM_PM_STYLE=1
ro.config.hw.usedtime.statis=1

Und für folgende Einträge schlage ich die angegebenen Werte aus der Originaldatei von Huawei vor:
Code:
ro.product.board=U8833-1
ro.config.hw_browser_ua2g=http://wap1.huawei.com/uaprof/HuaweiY300-0100GPRS.xml
ro.config.hw_browser_ua3g=http://wap1.huawei.com/uaprof/HuaweiY300-0100WCDMA.xml
debug.composition.type=dyn
PS: Der Wert von ro.build.version.emui steht noch auf FreeYourMind_v.1.3
 
Zuletzt bearbeitet:
M

minotaurus

Gast
Wäre nett wenn jemand, der die build.prop bereinigt hat diese hier mal zur Verfügung stellen könnte. Ich weis nicht wie ich die kommenden Tage dazu komme. Da ich meinen PC aufgrund von Wechsel auf SSD neu aufsetzten muss.

Gesendet von meinem Nexus 7 mit der Android-Hilfe.de App
 
M

MRay

Neues Mitglied
Erstmal danke für die Arbeit mit der ROM, minotaurus

und

hier ist die "bereinigte" build.prop
 

Anhänge

  • build.zip
    4,6 KB Aufrufe: 131
J

jammin

Neues Mitglied
minotaurus schrieb:
@moddingg33k & Tzul: Danke für die Hinweise. Die Framerate ist wirklich sehr bescheiden und ich bin am überlegen ob ich beim nächsten Update wieder zurück auf die alten media.profiles gehe. Ich hänge die mal an, einfach unter System/etc austauschen.

Was mich etwas irritiert ist die Sache mit dem Radio. Das läuft bei mir perfekt, auch ist der Eintrag in der build.prop vorhanden. Ich lade es einfach selbst nochmal runter und schaue mir da die prop an.
... eigenartig, nachdem ich die Dateien ausgetauscht habe kann ich nur noch die "MMS"-Auflösung wählen.
Muss ich nachträglich noch etwas zurücksetzen?
 
M

minotaurus

Gast
Hast du im Gerät getauscht? Lösche mal im TWRP den Cache und den Dalvik Cache. Andernfalls müsste ich mir das nochmals genauer ansehen.

Gesendet von meinem Nexus 7 mit der Android-Hilfe.de App
 
J

jammin

Neues Mitglied
minotaurus schrieb:
Hast du im Gerät getauscht? Lösche mal im TWRP den Cache und den Dalvik Cache. Andernfalls müsste ich mir das nochmals genauer ansehen.

Gesendet von meinem Nexus 7 mit der Android-Hilfe.de App
Die zwei Dateien habe ich getauscht allerdings dummerweise kein Backup gemacht. Cache habe ich ebenfalls gelöscht.
Nun hat es nicht nur die Kamera zerschossen sondern ich kann auch keinerlei Musikdatei wiedergeben.
 
M

minotaurus

Gast
Installiere einfach nochmals die v.1.4 drüber und lösche wieder Cache und Dalvik. Dann sollte zumindest wieder alles funktionieren und du verlierst keine Daten. Mit der Camera muss ich dann mal schauen.

Der ursprüngliche Beitrag von 19:59 Uhr wurde um 21:45 Uhr ergänzt:

Update auf 1.4.1:
mit bereinigter "build.prop"

Nochmals Danke an moddingg33k, Tzul und MRay für die Mitarbeit.
MRay hat die neue "build.prop" gespendet.
 
M

MRay

Neues Mitglied
Vielleicht darf ich noch einen kleinen Verbesserungsvorschlag machen:

Statt die Installation bezüglich der notificationbar für o2 und die frei verkäuflichen Geräte unterschiedlich zu gestalten, könnte man doch einfach die Ordner der cust-Partition für beide Geräte gleich in die ROM packen.

Da man die "cust-Partition" sowieso nicht als Speicherort verwendet, ist das zusätzliche knappe MB auch keine "Platzverschwendung".

So wurde es z.B. bei Ottis B176 Base-Rom auch gehandhabt.

(Modifizierter Otti-Mod als Anhang)
 

Anhänge

  • notificationbar_all_MOD.zip
    369,6 KB Aufrufe: 279
M

minotaurus

Gast
Hätte man auch mal drauf kommen können, vielen Dank.

Hast du schon getestet? Habe derzeit LeWa drauf. Aber wenn du sagst es funzt, wird es so übernommen.
 
M

MRay

Neues Mitglied
Ja (ich habe die "nicht-o2 Version").

Das erste was ich vor dem Flashen immer gemacht habe, ist den kompletten cust-Ordner aus der B176 (darin ist sowohl o2 als auch weu etc. vorhanden) in das Freeyourmind_xy.zip zu kopieren und damit war die notoficationbar sofort da.

Regionen-Ordner wie "sea" oder "mea" kann man allerdings wohl wirklich getrost löschen, da "wir hier" wohl nur den o2 und den weu Ordner brauchen.
 
Zuletzt bearbeitet:
shakrazam

shakrazam

Fortgeschrittenes Mitglied
Hallo. Ich habe keinen Zugriff (mehr?) auf live wallpaper. Ist das normal? FYM 1.4

Okay hat sich erledigt. GHabe den Live wallpaer picker installiert.
danke :)
 
Zuletzt bearbeitet:
M

minotaurus.a.d.

Gast
Ich habe die Links wieder "frei" gegeben. Nachdem ich seit gestern Abend ca. 300 E-Mails aus aller Welt, mit der bitte um Freigabe, erhalten habe. Wäre dies nicht fair gewesen. Da ich nicht weis in welchen Foren die Roms noch verlinkt wurden.
Es wird hier, in diesem Forum, aber keinerlei Hilfestellung von meiner Seite mehr erfolgen. Auch wenn die Sperre nur temporal ist, sehe ich es nicht ein mich weiterhin hier mit unverschämten Anfängern herum zu ärgern, welche noch zu bequem sind aufgrund einer Hilfestellungen sich 3-4 Postings durchzulesen.

Gesendet von meinem Nexus 7 mit der Android-Hilfe.de App
 
T

Tubbs

Neues Mitglied
Oh je. Was ist denn hier seltsames passiert? Ich hoffe, du entwickelst FreeYourMind trotzdem weiter. Vielen Dank jedenfalls für deine bisherige Arbeit - ohne dich hätte ich mein y300 nur halb so lieb :)
 
shakrazam

shakrazam

Fortgeschrittenes Mitglied
Hallo Leute.
Ich habe seit geraumer Zeit einige Problem, mit denen ich eigentlich auch nicht mehr leben möchte.
Ich denke, dass diese Erscheinungen nicht direkt mit FYM zusammenhängen, aber ich benutze FYM von Minotaurus seit mehreren Wochen und bin sehr zufrieden, deshalb dachte ich, vielleicht hier wäre die richtige Stelle um mein Anliegen zu erwähnen. Ausserdem hoffe ich das das, was Minotaurus so verärgert hat, inzwischen Vergangenheit ist, und er uns erhalten bleibt. Ich möchte mich an dieser Stelle nochmals bedanken für seine überaus engagierte und selbstlose Hilfe die er hat jedem Forumteilnehmer zukommen lassen, ganz ungeachtet wie "dumm" die Frage auch war. Ich nehme an, dass er irgendwann keine Lust und Zeit mehr hatte, das alles zu bewältigen - wofür ich in JEDEM FALL Verständnis hätte.

Der ursprüngliche Beitrag von 16:08 Uhr wurde um 16:30 Uhr ergänzt:

Huch! Ganz vergessen: also meine Probs:
1. Apps, die man zu Standartanwendungen erkort, werden nie als solche defeniert. Das heißt, die Abfrage: "Welche App willst du benutzen? - Nur einmal. / Immer" erfolgt jedesmal aufs Neue!
Habe schon alles versucht. Cache und Daten der betreffenden apps gelöscht, restart usw. - Nichts!

2. Wenn der interne Browser aus einer App gestartet wird. Zum Beispiel ein Link in Gmail oder ein Nachrichten link in taptu, dann passiert es immer, das der Browser nach ca. 5-10 Sekunden sich verabschiedet und man zurückfällt auf die App, die davor gestartet war (also in unserm Bspl. Gmail bzw. Taptu). Als ob man also die HW Zurück-Taste gedrückt hätte. Dies tritt nicht immer auf aber in 80 Prozent der Fälle. Bleibt der Browser aber stabil, und man möchte nach dem Lesen der verlinkten Seite wieder zurück im die App, dann heißt es immer: "xyz app musste leider beendet werden"
Ich weiß wirklich nicht mehr weiter und möchte nicht nochmal alles neu aufsetzen. Bin leider nicht so versiert, aber könnte es mit dem journal - Cache oder so zusammenhängen?
Bin für jede Hilfe dankbar.
Lg
 
C

c01v1p4q

Neues Mitglied
Vielen Dank für diesen ROM. Er hat mir viel Arbeit erspart das Telefon in einen funktionsfähigen Zustand zu versetzen. Ich bin wirklich extrem sauer auf Huawei, dass die mir mein Betriebssystem so dermaßen zerschossen haben. Je weiter ich komme, desto mehr eingebastelte und sinnlose Dinge fallen mir auf, die man erstmal wieder rückgängig machen muss.

Mir ist aufgefallen, dass 2 Einstellungen in den Systemeinstellungen nicht angezeigt werden:
window animation scale (1.0)
transition animation scale (1.0)

Ich habe das ganze so gelöst:
Code:
adb shell
su
cp /data/data/com.android.providers.settings/databases/settings.db /sdcard/
^C
adb pull /sdcard/settings.db settings.db
sqlite3 settings.db
UPDATE system SET value=0.0 WHERE name in ("transition_animation_scale", "window_animation_scale", "animator_duration_scale");
.quit
adb push settings.db /sdcard/settings.db
adb shell
su
cp /sdcard/settings.db /data/data/com.android.providers.settings/databases/settings.db
chmod 660 /data/data/com.android.providers.settings/databases/settings.db
chown system:system /data/data/com.android.providers.settings/databases/settings.db
Danach Telefon poweroff & poweron und alle Systemanimationen sind aus.

Beim starten wurde mir irgendwas von updating your phone erzählt und beim ersten Versuch (mit 775 root:root auf der Datei) hing es sich erst auf und nach direkter Korrektur mit adb shell waren die Änderungen in der DB weg. Ich hoffe mal nicht, dass Huawei irgendwelchen dämlichen Scheiß in den Kernel oder sonstwo gepastet hat, der diese Einstellungen überwacht und wieder rückgängig macht. Zutrauen würde ich es denen... Ich habe mittlerweile echt Angst, dass das Ding irgendwann plötzlich automatisch einen Wipe durchführt, weil Huawei meint, dass das so richtig ist und folglich haben die ihren Schadcode auch dort versteckt wo man ihn nicht findet. G300 - da war die Welt noch in Ordnung!


Vielleicht kann der Autor des ROMs ein wenig darüber sagen, wie sauber der ROM wirklich ist was Huawei angeht und ob vielleicht noch gefährliche Überraschungen wie automatische Herstellerupdates zu befürchten sind?
 
Zuletzt bearbeitet:
C

c01v1p4q

Neues Mitglied
Ich wollte das "no wallpaper" app benutzen, als mir auffiel, dass es die Kategorie live wallpapers nicht gibt und das wallpaper auch sonst nirgendwo ist. Das gleiche Problem mit einem ähnlichen Wallpaper, dass ich anschließend installiert habe. Es liegt auch nicht am Launcher. Wahrscheinlich hat das wieder Huawei verbockt ..
 
Andy

Andy

Ehrenmitglied
LiveWallpapers.apk und LiveWallpapersPicker.apk in /system/app vorhanden? Wenn dann wurden diese evtl. für diese ROM dort rausgelöscht?

Kann ja ganz klar Huawei verbockt haben, wenn der Rom Ersteller diese .apks zur Entschlackung gelöscht hat. :rolleyes:
 
Zuletzt bearbeitet:
squarius

squarius

Neues Mitglied
Das klingt alles nach selbst gemachten Problemen bzw. nicht vorhandenen.

Zum Beispiel:
Beim starten wurde mir irgendwas von updating your phone erzähl
Macht er nach jeden Dalvik/Cache-Wipe.

LiveWallpapers.apk und LiveWallpapersPicker.apk sind nicht in FreeYourMind vorhanden. Mit Absicht.


Vielleicht doch nur ein schlechter Trollversuch gegen Huawei oder ist man sehr gefrustet wegen irgendeines Missverständnisses?

PS: Ich meins nicht böse, aber mir kommt das alles sehr merkwürdig vor.
 
Zuletzt bearbeitet: