Mitglieder surfen ohne Werbung: Jetzt kostenlos registrieren!

[ROM] CyanogenMod 7.2.0-RC1

  • 453 Antworten
  • Neuester Beitrag
Diskutiere [ROM] CyanogenMod 7.2.0-RC1 im Custom-ROMs für Huawei Ideos X3 im Bereich Root / Hacking / Modding für Huawei Ideos X3.
Silverblade

Silverblade

Stammgast
fuchsteufel schrieb:
Dem Blog von cyanogenmod nach zu urteilen hat CM-7.2 den final status erreicht. Da werde ich bei Gelegenheit mal den Compiler anwerfen ;)
Und dafür lieben wir DICH! :)
 
S

semml

Neues Mitglied
drohnen1 schrieb:
.... ihn runter machen weil ich mein gps nicht einschalten...
Ich hatte zu Anfang auch schwirigkeiten mit dem GPS. Bei mir hat immer ein permission fix im recovery Abhilfe gebracht.
 
toidi

toidi

Ambitioniertes Mitglied
Ich habe ein Problem. Ich komme nicht mehr in die Recovery.

Sobald ich in die Recovery booten will, kommt nur das Huawei Logo und dann Freeze. Ich muss dann den Akku entfernen damit ich wieder normal booten kann.

Installiert ist diese Rom hier, dazu der SuperCharger.
Rom Manager v5.0.0.7
CWM 5.0.2.8

CWM neu installieren über den Rom-Manager hat nichts gebracht.

Was kann ich jetzt noch tun?
 
A

adefigo

Neues Mitglied
toidi schrieb:
CWM neu installieren über den Rom-Manager hat nichts gebracht.
War es nicht so, das der Rom-Manager beim X3 nicht funktioniert?

Versuche CWM über fastboot neu zu flashen.
 
ElTonno

ElTonno

Experte
Das cwm über den RomManager zu installieren war wohl das dümmste überhaupt!
Wenn man lesen könnte würde man sehen das im RomManager U8150 steht und nicht U8510.
----
CWM neu installieren:

-Handy ausschalten
-in den Fastboot booten
-per Eingabeaufforderung:
1) fastboot erase recovery
2) fastboot flash recovery recovery.img
3) fastboot reboot
 
toidi

toidi

Ambitioniertes Mitglied
Danke für die Hilfe, flashen über Fastboot hat geklappt. Selbst wenn man so "dumm" und "analphabetisiert" ist, wie ich ;)
 
ElTonno

ElTonno

Experte
Ja sorry ^^, aber wurde schon seeeehr oft diskutiert das der RomManager beim X3 nur Unheil bringt xD
 
Sturmhsvhsv

Sturmhsvhsv

Stammgast
is ja schon vielen passiert
ausserdem gabs internetseiten die das gerät getestet hatten die den zahlendreher drin hatten! also aus u8510 ist halt dann u8150 geworden :)
 
maxmueller62

maxmueller62

Ambitioniertes Mitglied
Moin,
nochmal ´ne kurze Frage:
X3 wird über OnScreenMenü ausgeschaltet, geladen und dann kommt beim Einschalten das CWM-Menü, wo man erstmal "reboot" drücken muss.
Kann dieses Verhalten unterbunden werden und das Handy immer normal gestartet werden ???
 
A

angbor

Fortgeschrittenes Mitglied
Im Menü Neustart in Recovery ausgewählt? X3 am Ladekabel hängen? Warum nutzt du nicht CM 7.2 stable?
 
A

adefigo

Neues Mitglied
maxmueller62 schrieb:
Kann dieses Verhalten unterbunden werden und das Handy immer normal gestartet werden ???
Nein, das ist ein Feature von CWM.
 
A

angbor

Fortgeschrittenes Mitglied
Wenn das x3 nicht am Ladekabel hängt und trotzdem unbeabsichtigt ins CWM neustartet, ist das kein 'Feature'.
 
Time_Bandit

Time_Bandit

Experte
maxmueller62 schrieb:
X3 wird über OnScreenMenü ausgeschaltet, geladen und dann kommt beim Einschalten das CWM-Menü, wo man erstmal "reboot" drücken muss.
Kann dieses Verhalten unterbunden werden und das Handy immer normal gestartet werden ???
Man muss das Handy beim Laden aber auch nicht zwingend ausschalten.

Unterbinden kannst du es nur mit dem flashen des original Recovery (nicht empfehlenswert).

Als "Feature" würde ich es auch nicht unbedingt bezeichnen. Scheint eher ein Fehler der CWM zu sein.
 
maxmueller62

maxmueller62

Ambitioniertes Mitglied
angbor schrieb:
Im Menü Neustart in Recovery ausgewählt? X3 am Ladekabel hängen? Warum nutzt du nicht CM 7.2 stable?
Nein, "Ausschalten" gewählt.
Bin eigentlich zufrieden mit RC1 und nochmal 3 X3s neu einrichten :scared:
Ich würde dieses Verhalten auch nicht als "Feature" bezeichnen, ich wähle "Ausschalten" und dann sollte beim Wiedereinschalten (egal ob mit Ladekabel oder nicht) das X3 normal booten.
Ist dieses Verhalten beim "CM 7.2 stable" denn jetzt in Ordnung???

Ich muss mal nachsehen, welche Version vom CWM drauf ist...
 
Zuletzt bearbeitet:
jettec8898

jettec8898

Stammgast
Die 7.1 ist mit der 7.2 stable updatebar (soviel ich weiß)
Sprich kein neu einrichten

Gesendet von meinem U8510 w/ M.E.R. mit Tapatalk 2
 
ElTonno

ElTonno

Experte
Eigendlich so:
- onscreenmenü -> "ausschalten"
- "power" drücken zum einschalten, läuft durch ohne halt beim recovery

- onscreenmenü -> "neu starten"
- x3 rebootet, hält auch nicht im recovery

---
Ja manchmal ist das Feature beim cwm-Recovery schon etwas nervig ^^.
Ganz sinnvol ist es aber wenn das X3 keinen Mucks mehr macht und du es nur kurz an die Strippe hängen musst um ins CWM zukommen.
 
Zuletzt bearbeitet:
Time_Bandit

Time_Bandit

Experte
ElTonno schrieb:
Ganz sinnvol ist es aber wenn das X3 keinen Mucks mehr macht und du es nur kurz an die Strippe hängen musst um ins CWM zukommen.
Da sollten Vol[+] & Power aber auch (immer) funktionieren. Es sei denn es liegt an den Microschaltern ein Defekt vor.

Aber wie gesagt, zum Laden braucht es gar nicht abgeschaltet zu werden. Wenn notwendig ein Neustart durchführen. Zum Stromsparen reicht der Flugmodus immer.

@Max
Das Verhalten der CWM ist nicht ROM abhängig. Auch an der Version der CWM ändert das Verhalten nichts.
 
Silverblade

Silverblade

Stammgast
Ich schalte mein X3 nie ab! Außer der Akku geht alle was bis heute genau 2x passiert ist! Dein X3 ist ein kleiner PC den stört es nicht 300+ Stunden zu laufen ;) Neustarten lohnt nur wenn die Performance in die Knie geht und nix mehr hilft !
 
F

fuchsteufel

Fortgeschrittenes Mitglied
Also, der magische Boot-Mechanismus funktioniert so:
Dem Systemcall reboot(), wird ein Parameter mitgegeben der den Grund für den Reboot enthält. Dieser Parameter wird dann an einer definierten Stelle im Speicher abgelegt wo ihn auch der Bootloader wieder auslesen kann und dann entsprechend reagiert. Wenn man also auf der Kommandozeile reboot bootloader eingibt landet man im Bootloader bei reboot recovery im CWM und bei reboot boot startet das System.
Schaltet man das Gerät aus geht der Grund für den Reboot verloren weil der Speicher ja stromlos ist. Schaltet man das Gerät dann wieder ein erkennt der Bootloader ja welcher Knopf gedrückt wurde und bootet das System. Steckt man hingegen das Ladekabel an, und jetzt kommt der Clou ;), startet der Bootloader IMMER das Recovery-Image.
Beim originalen Recovery von Huawei ist aber noch ein Tool mit drin das sich charge nennt, das wird dann an stelle des Tools recovery gestartet wenn der Bootloader dem Kernel das charge_flag mitgegeben hat. Wenn man sich mal die Kernel-Messages anschaut sieht man folgendes
Code:
<6>[0, swapper] [    0.000000] Initializing cgroup subsys cpu
<5>[0, swapper] [    0.000000] Linux version 2.6.35.7-perf (android@localhost) (gcc version 4.4.3 (GCC) ) #1 PREEMPT Fri Jun 10 10:34:45 CST 2011
<4>[0, swapper] [    0.000000] CPU: ARMv6-compatible processor [4117b365] revision 5 (ARMv6TEJ), cr=00c5387f
<4>[0, swapper] [    0.000000] CPU: VIPT aliasing data cache, VIPT aliasing instruction cache
<4>[0, swapper] [    0.000000] Machine: HUAWEI U8510_1 BOARD
<4>[0, swapper] [    0.000000] parse_tag_mem32: addr=0x10200000, size=0xd200000
<7>[0, swapper] [    0.000000] parse_tag_frame_buffer: fb addr= 0x1d400000, size=0x100000
<7>[0, swapper] [    0.000000] parse_tag_lcd_id: lcd_id = 0x2
<7>[0, swapper] [    0.000000] parse_tag_camera_id: camera_id = 0x0
<7>[0, swapper] [    0.000000] parse_tag_ts_id: ts_id = 0xffffffff
<7>[0, swapper] [    0.000000] parse_tag_sub_board_id: sub_board_id = 0x4
<7>[0, swapper] [    0.000000] parse_tag_charge_flag: charge_flag = 0x1
<7>[0, swapper] [    0.000000] parse_tag_lcd_y_res_flag: lcd_y_res = 480
<7>[0, swapper] [    0.000000] parse_tag_boot_mode_id: usb_mode_id = 0x1
<6>[0, swapper] [    0.000000] Partition (from atag) boot -- Offset:190 Size:28
<6>[0, swapper] [    0.000000] Partition (from atag) recovery -- Offset:1be Size:28
<6>[0, swapper] [    0.000000] Partition (from atag) misc -- Offset:1e6 Size:a
<6>[0, swapper] [    0.000000] Partition (from atag) splash -- Offset:1f0 Size:3
<6>[0, swapper] [    0.000000] Partition (from atag) system -- Offset:1f3 Size:5d0
<6>[0, swapper] [    0.000000] Partition (from atag) cache -- Offset:7c3 Size:1f8
<6>[0, swapper] [    0.000000] Partition (from atag) userdata -- Offset:9bb Size:505
<6>[0, swapper] [    0.000000] Partition (from atag) userdata2 -- Offset:ec0 Size:a0
<6>[0, swapper] [    0.000000] Partition (from atag) cust -- Offset:f60 Size:a0
<4>[0, swapper] [    0.000000] cmdline: console=ttyDCC0 androidboot.hardware=huawei mtdparts=msm_nand:5M@0x3200000(boot),5M@0x37C0000(recovery),1280k(misc),384k(splash),150M(system),63M(cache),-(userdata) androidboot.localproppath=o2/de androidboot.network=umts androidboot.swtype=normal androidboot.mode=recovery mem.size=256M
In Zeile 12 steht das charge_flag auf 1 und in der letzten Zeile, ganz am Ende, der Boot-Mode. Den Zustand dieses Flags kann man sich dann auch noch in /proc/app_info anschauen:
Code:
~ # cat /proc/app_info 
APPSBOOT:

KERNEL_VER:

FLASH_ID:
Hynix-0x5510bcad
board_id:
MSM7X27_U8510_1.VerE
lcd_id:
TIANMA HX8357B
cam_id:
0
ts_id:
0
hw_version:

charge_flag:
1
compass_gs_position:
COMPASS_TOP_GS_TOP
wifi_name:
WIFI_BROADCOM
Und in der Tat wenn man sich die Strings in beiden Tools aus dem original Recovery-Image anschaut prüfen sie dieses Flag
Code:
fuchsteufel@LinuxWiesel:/tmp$ strings boot.img-ramdisk/sbin/charge |grep app_info
/proc/app_info
power_charge flag from app_info is: %d
fuchsteufel@LinuxWiesel:/tmp$ strings userdata.img-ramdisk/sbin/recovery |grep app_info
/proc/app_info
power_charge flag from app_info is: %d
Was ist nun die Konsequenz daraus ? Man müsste mal das CWM so anpassen das es genau wie das original statt des Recovery-Tool das Tool charge startet wenn dieses Flag gesetzt ist.
So, ich hoffe Klarheit geschaffen zu haben :D
 
Maniaxx

Maniaxx

Stammgast
Wie kommt man an das Kernel log? /proc/kmsg kann ich nicht auslesen.

Edit: Wobei.. im CWM funktioniert's.
 
Zuletzt bearbeitet: