Massive Probleme bei CM7-Installation -> kein Anfänger, brauche Expertenhilfe..!

  • 19 Antworten
  • Neuester Beitrag
Diskutiere Massive Probleme bei CM7-Installation -> kein Anfänger, brauche Expertenhilfe..! im Custom-ROMs für Motorola Defy im Bereich Root / Hacking / Modding für Motorola Defy.
D

doerri

Ambitioniertes Mitglied
Guten Abend,

ich bin mittlerweile ziemlich verzweifelt, weil ich mir mein folgendes Problem nicht erklären kann.


Ich erhielt mein Defy heute von dat-repair zurück, geflasht mit der 2.2.2 Froyo DACH.
Ich hatte zuvor schon mehrfach CM7 aufgespielt, auch schon als Nandroid-Backup (ist nicht die erste Reparatur die es hinter sich hat).


Ich installierte also zunächst sndinit und rootete es. Merkwürdigerweise wechselte das DEFY direkt nach dem ersten Neustart in den Bootloader (USB Debug davor natürlich deaktiviert, alles getreu nach Anleitung). Früher startete es ganz normal das originale Betriebssystem. Erst nach einem Wechsel der Booteinstellung auf "normal" fuhr es richtig hoch.

Nach dem 2. Neustart installierte ich dann die aktuelle CM7 Version
(ich habe auch noch ältere Versionen probiert, ebenso wie ein Fullbackup was früher schon funktioniert hat!).


Aber egal was ich anstellte, CM7 wollte und will nicht laufen.

Es erscheint für etwa 5 Sekunden das originale Motorola Logo, dann wird die LED kurz blau, wechselt 1 Sekunde direkt zu grün und anschließend startet das DEFY neu. Dieser Vorgang wiederholt sich.

Es scheint, als könne CM7 garnicht erst korrekt installiert werden. Der Installationsvorgang wird jedoch immer successfull abgeschlossen.



Was ich schon alles gemacht hab:

- 2 verschiedene FROYO-Versionen geflasht
- 3 Versionen von sndinit (1.4.2, 1.6.1 und 1.8.3) getestet
- sämtliche Wipes die man durchführen kann sowohl vor und nach dem Flashen und Installieren von CM7
- mehere Versionen von CM7 installiert
- ein Nandroid-Fullbackup mit sndinit direkt auf die original Froyo eingespielt
- sämtliche Boot-Varianten von sndinit ausprobiert (snd-init, second boot, default usw.)



Egal was ich mache, sobald CM7 installiert ist, weigert sich das DEFY länger als 7 Sekunden zu booten. Es kommt mir so vor, als hätte dat-repair da eine Sperre installiert, die den Mod erkennt und das Booten verweigert.

Ich habe das Handy schon mehrfach erfolgreich geflasht, hatte nie Probleme, und ich hab die gleichen Versionen sowohl von sndinit als auch CM7 genommen, mit denen es vor der Reparatur auch ging...





Ich hoffe ihr könnt mir helfen!


Liebe Grüße
 
ABBolle

ABBolle

Stammgast
doerri schrieb:
Ich installierte also zunächst sndinit und rootete es. Merkwürdigerweise wechselte das DEFY direkt nach dem ersten Neustart in den Bootloader (USB Debug davor natürlich deaktiviert, alles getreu nach Anleitung). Früher startete es ganz normal das originale Betriebssystem. Erst nach einem Wechsel der Booteinstellung auf "normal" fuhr es richtig hoch.
Ich bin jetzt nicht der Experte, den du suchst. Aber hier kann ich schon mal sagen, dass das bei mir genauso und daher meiner Meinung nach normal ist.

Welche Recovery hast du denn aus 2nd-Init installiert? Die "stable for CM-based ROM", 0.6.1?
 
D

doerri

Ambitioniertes Mitglied
korrekt, die CM-Stable 0.6.1, als die nicht ging die 0.8.3 die man dort auswählen konnte. Zuletzt dann die 1.4.2 DEFY Version die man hier bei jeder CM7-Anleitung herunterladen kann.


Ich dachte zunächst, es liegt an sndinit, aber selbst die Version, mit der ich mind. 5x CM7 installiert hatte, funktioniert. Und ich hab alles genau so gemacht, wie sonst auch.
 
R

RATTAR

Gast
Ich würde so vorgehen.
  1. CE Deblur flashen
  2. Rooten mit SuperOneClick
  3. Defy-2nd-Init 1.4.2 installieren
  4. USB-Debugging permanent anlassen
  5. Unbekannte Quellen aktivieren
  6. Dem ROM-Manager installieren und einrichten, den ROM-Manager ins Recovery booten lassen
  7. CM7 installieren

EDIT:
Wenn sich Defy-2nd-Init weigert versuche es mal mit der Version aus diesem Thread

Uraltes CWMR

nochmal EDIT:
Dein Windows mag SuperOneClick wahrscheinlich schon, nur deine Internetsecurity ich vermute Kaspersky mag kein SuperOneClick.
 
Zuletzt bearbeitet von einem Moderator:
D

doerri

Ambitioniertes Mitglied
Ich probier grade noch folgenden Ansatz.
Ich habe bisher immer mit Gingerbreak 1.20 gerootet (weil mein Windows SuperOneClick nicht mag). Mir ist aber grade aufgefallen, das ein Programm, welches ich auf der originalen Froyo testweise installiert hatte, keine Rootrechte hatte, obwohl ich diese mit SU zugewiesen hab.

Ich hab jetzt erneut mit SuperOneClick und einem anderen Rechner gerootet. Vielleicht geht das ja...


@RATTAR: Danke für deine Idee, ich werde die ausprobieren.
Ich frage mich nur, warum es urplötzlich nicht mehr geht. Es ist die gleiche Froyo FW und die gleiche sndinit-Version, und das DEFY stellt sich quer...



EDIT: Selbes Problem trotz Root mit SuperOneClick
 
Zuletzt bearbeitet:
D

doerri

Ambitioniertes Mitglied
Nein, mein Windows 7 64bit weigert sich wehement, mein DEFY zu erkennen. Flashtreiber sind korrekt installiert. Es wird auch kein MotoHelp mitinstalliert (das blaue Symbol in der Taskleiste gibts also garnicht).

Ich kann ebensowenig flashen, weil es einfach nicht erkannt wird. Hab Windows auch schon mehrfach neu aufgesetzt, daran liegts nicht. Wohl eher an einem Hardwarekonflikt. Firewalls und VIrenprogramme sind erst garnicht vorhanden (auch die von Windows deaktiviert).
 
T

t1MzN

Fortgeschrittenes Mitglied
ich versuch mal nen ganz anderen ansatz... die cm7.zip oder wie sie auch immer heißen mag, mal "neu" auf die speicherkarte gepackt? :D
 
R

RATTAR

Gast
Wenn Windows dein Handy nicht erkennt, gehe in den Gerätemanager von Windows, klicke auf Ansicht > Ausgeblendete Geräte anzeigen und entferne alle grau unterlegten Geräte die du findest.

Oder probiere einen der USB-Ports direkt am Computer, oder dein Datenkabel ist defekt.

Hattest du vorher Kaspersky im Einsatz, wenn ja dann hole dir auf der Homepage von Kaspersky mal den kavremover.
 
Zuletzt bearbeitet von einem Moderator:
D

doerri

Ambitioniertes Mitglied
Ich hab gestern Windows komplett neuinstalliert. Das erste was ich nach Sound/Grafiktreibern installiert hab, warn die Defy-Treiber + Tools... keine Chance. Hab daran schon mind. 10 Stunden rumprobiert, und ich bin definitiv kein Computerlaie. Hab einen älteren P35 Chipsatz, evnt. auch ein Treiberkonflikt mit dem AHCI-Treiber von Intel.. keine Ahnung. Spielt ja auch keine Rolle, hab für sowas ja noch einen Rechner mit XP, da klappts problemlos.


@ t1MzN:

Da ich mehrere Versionen von CM7 probiert hab, hat sich das ja schon ausgeschlossen. Zudem hab ich ja bei dem Fullbackup, was zuvor funktionert hat, eine volles CM7 inkl. Apps und Configs probiert.

@RATTAR:

dein Vorschlag funktioniet ebensowenig. Kaum ist CM7 drauf, geht nichts mehr. -.- das kanns doch nicht sein.
 
R

RATTAR

Gast
Wenn CM7 momentan nicht geht, könntest du ja bis eine Lösung gefunden wird, auf eine geleakte Gingerbread umsteigen, wie z.B. die hier:
https://www.android-hilfe.de/forum/...m-gingerbread-2-3-4-720p-blur-ger.130257.html
Bei dieser Gingerbread musst du die Boot-Sequenz sowieso auf normal stellen.

Und was ich mir noch vorstellen könnte, ist vielleicht die Taktfrequenz bzw. die Voltzahl zu hoch oder zu gering.
 
Zuletzt bearbeitet von einem Moderator:
airwolf1544

airwolf1544

Fortgeschrittenes Mitglied
Original Speicherkarte drin? Oder vielleicht ne neuere mit ner höheren Geschwindigkeit? Es gibt Probleme bei Class 8 und Class 10. Manche Class 6 mögen auch nicht. Evtl liegts ja daran...
 
Casius

Casius

Dauergast
So blöd es klingt, ich wollte mal wieder in die CM7 Welt eintauchen und
gucken was sich so getan hat. Es hat sich dann soviel getan, dass nach der
blauen LED jedesmal ein Neusstart folgte. Die Neuste 2ndinit wird benutzt
und alle wichtigen Vorgehensweisen befolgt.

Nach einwenig hin und her stöbern, war eine ältere Froyoversion der
Attentäter.

Ich habe dann das Froyo hier installiert:
Android 2.2.2 Froyo 3.4.2 179.2 CE Retail DeBlur
Und das Problem war gelöst ;)

Im übrigen hat Rattar vollkommen Recht:
Gingerbread ROM 2.3.4/4.5.1-134 ist in meinen Augen die
derzeit beste Gingerversion, die man für das Defy bekommen kann. :cool2:
Eine rote Kameralinse ist dafür allerdings Voraussetzung.
 
Zuletzt bearbeitet:
Defy@1.1Ghz

Defy@1.1Ghz

Stammgast
Casius schrieb:
Im übrigen hat Rattar vollkommen Recht:
Gingerbread ROM 2.3.4/4.5.1-134 ist in meinen Augen die
derzeit beste Gingerversion, die man für das Defy bekommen kann. :cool2:
Dem stimme ich vollkommen zu. Noch besser dürfte es wohl erst im September werden, wenn das Defy+ draußen ist und wir die fertige ROM kriegen :)

Gruß
 
ABBolle

ABBolle

Stammgast
Casius schrieb:
Im übrigen hat Rattar vollkommen Recht:
Gingerbread ROM 2.3.4/4.5.1-134 ist in meinen Augen die
derzeit beste Gingerversion, die man für das Defy bekommen kann. :cool2:
Eine rote Kameralinse ist dafür allerdings Voraussetzung.
Mh... ist nicht schön zu hören, wenn man das SOC-Modul mit der grünen Linse hat. :( Naja, man soll ja mit dem zufrieden sein, was man hat... Und da ich die Ginger noch nicht testen konnte, weiß ich auch nicht, was mir entgeht. :)

MfG ABBolle
 
R

RATTAR

Gast
@ABBolle

Die Gingerbread läuft mit der SOC, es muss nur der Greenbread-Fix installiert werden, der einzige Nachteil dabei ist halt das durch den Froyo-Teil im Greenbread-Fix die vierte Leistungsstufe gekappt wird.

@doerri:
Du könntest versuchen die CM7.1-RC1 BOOT179 110716 zu installieren, da diese auf jeden Fall einen Boot-Kernel enthält.
 
Zuletzt bearbeitet von einem Moderator:
K

kadofl

Neues Mitglied
Hab das selbe Problem wie doerri.
Bin eigentlich ein geübter CM7-Nutzer und wollte mal wieder den Knochen komplett neu aufsetzen.
Hab alles probiert was doerri auch probiert hat. Ich verstehs nicht!

Normale Froyo mit SBF läuft super...

UPDATE:
Ich vermute ich hab das Problem gefunden. Als ich mein Defy neustarten ließ hab ich nur 2mal bis in den Bootloader gebootet und nich in das Stock/Normale System. Habs aber noch nicht probiert.
Naja trotzdessen hab ich jetzt einen Grund "MIUI Defy Pikachu Edition" auszuprobieren. ;)
Ich hoff mal es funktioniert.

UPDATE 2:
War scheinbar wirklich das 2mal Normal Booten + Deaktivieren des USB-Debugging. MIUI läuft.
 
Zuletzt bearbeitet:
Casius

Casius

Dauergast
Mui ist schon nicht schlecht. Die Rom besitzt "fast" alle Vorzüge von CM7 und
ist zudem keinen Deut langsamer. Im Übrigen ist Mui nicht so langweilig und
es wurden sich viele Gedanken zwecks der Strukturierung der Menüs und
Einbindungsmöglichkeiten von Themes gemacht. CM7 ist da mehr ein klassisches
Gingerbread. Bis auf das Cyanogenmenü mit einigen Expertensettings, ist es eine
schlichte Gingerrom. Aber aufjedenfall nicht schlecht! Immerhin wird CM7 als
Vorlage für manche Customroms, wie auch z.B. Mui oder WajkIUI und etc. genommen.

Einsteinno (jemand hier aus dem Forum), gibt sich sehr viel Mühe, dass MIUI
seinen festen Platz in Defy-Deutschland hat und auch behält.


Wer die 134er wegen der grünen Linse nicht nutzen kann, ist in meinen
Augen bei Mui gut aufgehoben.
 
Zuletzt bearbeitet:
DarkGenesis

DarkGenesis

Stammgast
-Anleitung 2-
Reparatur der beschädigten CM7-Installation

Fehlersymptome:
  • Der Bildschirm wird schwarz nach dem Motorola-Logo, 2nd-Init ist nicht gesetzt <--- ja

  • Das Motorola-Logo ändert sich nach ca. 2 Minuten nicht, es wurde kein FactoryReset gemacht <--- kann ich nicht machen

  • Die CM7-Animation startet ständig neu, und das nach mehr als 15 Minuten, es wurde kein FactoryReset gemacht <--- Kommt nicht
Navigation im ClockWorkModRecovery
Navigiert wird mit den Lautstärketasten, bestätigt wird mit der Powertaste.​

Befehlsfolge zur Reparatur:
  • Drücke beim Aufleuchten der blauen LED die untere Lautstärketaste, Das Menü von ClockWorkModRecovery erscheint

  • Bestätige beim Eintrag +Boot --> mit der Powertaste

  • Navigiere auf den Eintrag 2nd-Init, und wähle diesen mit der Powertaste aus, gehe mittels Auswahl von –Go Back – wieder auf die Startebene von ClockWorkModRecovery <--- ja

  • Navigiere zum Eintrag +Recovery--> und bestätige mit der Powertaste <--- ja

  • Jetzt navigierst du auf den Punkt [CustomRecovery] (Auf keine Fall zu StockRecovery) und bestätigst mit der Powertaste <--- ja kommt aber beim starten das:
  • "CWM-based Recovery v4.0.1.4
    E:can´t mount /chache/recovery/command
    E:can´t mount /chache/recovery/log
    E:can´t open /chache/recovery/log
    E:can´t mount /chache/recovery/last_log
    E:can´t open /chache/recovery/last_log "

  • In diesem Untermenü wählst du den Eintrag – wipe data/factory reset aus und führst diesen Befehl – Yes – delete all user data aus, danach gehst du mittels +++++Go Back++++ wieder eine Ebene höher <--- kommt ein error
  • "-- Wiping data...
    Formatting /data...
    Error mounting /data! <-------DA
    Skipping format...
    Formatting /cache...
    Formatting /sd-ext...
    Formatting /sdcard/.android_scure...
    Data wipe complete."

  • Gehe jetzt so oft mittels Go Back eine Ebene höher bis ein Menü mit dem Punkt advanced erscheint <--- ja

  • Wähle jetzt das Menü advanced aus, in dem Untermenü wähle zuerst das Menü –wipe Dalvik Cache aus, dort Yes – Wipe Dalvik Cache und lösche den Dalvik Cache <--- geht nicht das "Yes – Wipe Dalvik Cache" kommt nicht...


clockworkmod - recovery.log :

Starting recovery on Sat Aug 27 15:57:44 2011
can't open /dev/tty0: No such device or address
framebuffer: fd 19 (480 x 854)
CWM-based Recovery v4.0.1.4
recovery filesystem table
=========================
0 /tmp ramdisk (null) (null)
1 /boot emmc /dev/block/mmcblk1p15 (null)
2 /cache ext3 /dev/block/mmcblk1p24 (null)
3 /data ext3 /dev/block/mmcblk1p25 (null)
4 /system ext3 /dev/block/mmcblk1p21 (null)
5 /sdcard vfat /dev/block/mmcblk0p1 /dev/block/mmcblk0

W:Unable to get recovery.fstab info for /sd-ext during fstab generation!
I:Completed outputting fstab.
I:processing arguments.
W:failed to mount /dev/block/mmcblk1p24 (Invalid argument)
E:Can't mount /cache/recovery/command
I:Checking arguments.
I:device_recovery_start()
Command: "/sbin/recovery_stable"

ro.secure=1
ro.allow.mock.location=0
ro.debuggable=0
persist.service.adb.enable=0
ro.factorytest=0
ro.usb_mode=normal
ro.bootmode=reboot
ro.baseband=unknown
ro.carrier=unknown
ro.bootloader=0x0000
ro.hardware=jordan_umts
ro.revision=0

I:Checking for extendedcommand...
I:Skipping execution of extendedcommand, file not found...
W:failed to mount /dev/block/mmcblk1p24 (Invalid argument)
E:Can't mount /cache/recovery/log
E:Can't open /cache/recovery/log
W:failed to mount /dev/block/mmcblk1p24 (Invalid argument)
E:Can't mount /cache/recovery/last_log
E:Can't open /cache/recovery/last_log
W:failed to mount /dev/block/mmcblk1p24 (Invalid argument)
W:Can't unlink /cache/recovery/command

-- Wiping data...
Formatting /data...
I:/data is not safe to format
I:Erasing from device...
W:failed to mount /dev/block/mmcblk1p25 (Invalid argument)
Error mounting /data!
Skipping format...
Formatting /cache...
I:Formatting unknown device.
I:Formatting ext3 device.
****************************************
hijack /sbin/mke2fs.. original file: /sbin/mke2fs.bin
****************************************
mke2fs 1.41.10 (10-Feb-2009)

Warning! Your mke2fs.conf file does not define the ext3 filesystem type.
You probably need to install an updated mke2fs.conf file.

Filesystem label=
OS type: Linux
Block size=1024 (log=0)
Fragment size=1024 (log=0)
Stride=0 blocks, Stripe width=0 blocks
51200 inodes, 204800 blocks
10240 blocks (5.00%) reserved for the super user
First data block=1
Maximum filesystem blocks=67371008
25 block groups
8192 blocks per group, 8192 fragments per group
2048 inodes per group
Superblock backups stored on blocks:
8193, 24577, 40961, 57345, 73729

Writing inode tables: 0/25 1/25 2/25 3/25 4/25 5/25 6/25 7/25 8/25 9/2510/2511/2512/2513/2514/2515/2516/2517/2518/2519/2520/2521/2522/2523/2524/25done
Creating journal (4096 blocks): done
Writing superblocks and filesystem accounting information: done

This filesystem will be automatically checked every 23 mounts or
180 days, whichever comes first. Use tune2fs -c or -i to override.
The filesystem already has a journal.
tune2fs 1.41.10 (10-Feb-2009)
Setting current mount count to 1
Formatting /sd-ext...
Formatting /sdcard/.android_secure...
I:Formatting unknown device.
Data wipe complete.
I:/data is not safe to format
I:/system is not safe to format
W:failed to mount /dev/block/mmcblk1p25 (Invalid argument)
Error mounting /data!
W:failed to mount /dev/block/mmcblk1p25 (Invalid argument)
Error mounting /data!
/tmp/recovery.log was copied to /sdcard/clockworkmod/recovery.log. Please open ROM Manager to report the issue.
 
R

RATTAR

Gast
@DarkGenesis

Hast du ein nandroid-Backup?
Wenn, ja dann baue CM7 komplett neu auf.
Gehe mal im CWM auf Mounts and Storage und mounte das Data-Verzeichnis

Ein Nandroid-Backup ist ein komplette Sicherung deines Handys mit CWM (Backup and Restore).
Am besten ist es du baust dein CM7 nochmal komplett von vorn wieder auf, dazu gehst du in den Bottloader,
Akku raus > Powertaste und Lautstärketaste oben gedrückt halten > dabei Akku rein > Bootloaderschirm erscheint
flashst die froyo neu, rootest, installierst CWM, und spielst gleich die letzte nigthy-boot ein + die gapps.
 
Zuletzt bearbeitet von einem Moderator:
DarkGenesis

DarkGenesis

Stammgast
RATTAR schrieb:
@DarkGenesis

Hast du ein nandroid-Backup?
Wenn, ja dann baue CM7 komplett neu auf.
Gehe mal im CWM auf Mounts and Storage und mounte das Data-Verzeichnis


ah nein was ist das >_< ?

ich dachte ich mach wieder das original trauf weis aber nicht wie ich jetzt vorgehen soll

"mounte das Data-Verzeichnis" geht nicht kommt Error