Mitglieder surfen ohne Werbung: Jetzt kostenlos registrieren!

[ROM][P51XX][4.4.x] SlimKat

  • 849 Antworten
  • Neuester Beitrag
Diskutiere [ROM][P51XX][4.4.x] SlimKat im Custom-ROMs für Samsung Galaxy Tab 2 - 10,1 Zoll (5100/5110) im Bereich Root / Custom-ROMs / Modding für Samsung Galaxy Tab 2 - 10,1 Zoll (5100/5110).
misterx31

misterx31

Lexikon
:thumbsup:schneller ....:lol:
 
Mr.Mario

Mr.Mario

Fortgeschrittenes Mitglied
Ich habe derzeit noch die Build 9.3 drauf, wenn ich auf die aktuelle 9.10 updaten möchte, kann ich diese einfach im TWRP flashen oder muss ich das System neuaufsetzen?
 
Prime Evil

Prime Evil

Erfahrenes Mitglied
Kannst du im TWRP drüberflaschen.
Dann Cache und Dalvic Cache wipen und neustarten !
 
Andi_K

Andi_K

Ehrenmitglied
Hi,

nach etwa 1,5 Jahren mit der 9.0 [sic ;-)] build hab ich meinem Tab gestern mal ne Frischzellenkur gegönnt und auf die 9.12 upgedated. Nach der langen Zeit natürlich ganz sauber mit Full Wipe.

Wie erwartet läuft das Ding sehr flüssig und reibungslos. Deshalb zuallererst mal ein ganz dickes Danke an Dich, @Android-Andi34, dass Du Dich so liebevoll um unseren Oltimer kümmerst!!!

Leider vermisse ich aber in den Entwickleroptionen (die ich freilich aktiviert habe) die Root-Option.
Übrrsehe ich da was, oder ist die dort nicht mehr zu finden?

Schönen Gruß
Andi
 
misterx31

misterx31

Lexikon
Moin @Andi_K

Nööö, hast nix übersehen....Rootzugriff gibt es nicht in den Entwickleroptionen....
...lad dir bitte die SuperSU.zip runter und flash diese im Recovery (Backup nicht vergessen!)
 
Andi_K

Andi_K

Ehrenmitglied
OK, danke. Werd ich dann morgen mal machen.
Aber früher war das bei dieser Rom doch so, dass man Root nur in den Entwickleroptionen einschalten musste, oder?

Schönen Gruß
Andi
 
A

Android-Andi34

Lexikon
Hey Andi!
Die Su binary hat eine Sicherheitslücke die nur per Kernel Workarounds umgangen werden kann, deshalb hab ich Superuser jetzt rausgeschmissen - ich Release nur noch Sicherheitsupdates, macht also Sinn.

Solche Sachen sollten nicht über workarounds gefixt werden, LineageOS Team hat die Lücke aber bisher nicht anders schliessen können...
 
Andi_K

Andi_K

Ehrenmitglied
Hi,

OK, danke.
Wenn ich Dich richtig verstehe, dann kommt SlimKat mittlerweile also ungerootet daher, wenn ich nicht separat die von misterx31 verlinkte SuperSU flashe, richtig?
Das würde dann für mich eigentlich auch passen, im Grunde brauche ich Root eigentlich nicht wirklich.
Ich war nur etwas verunsichert, weil ich im TWRP nach dem Flash gefragt wurde, ob ich das Gerät denn rooten möchte. Das habe ich aus reiner Gewohnheit per Swipe bestätigt, und war daher davon ausgegangen, dass Root-Rechte vorhanden sind. Deshalb war ich etwas beunruhigt als ich keine Möglichkeit finden konnte, diese angenommen Root-Rechte zu kontrollieren...

Schönen Gruß
Andi
 
A

Android-Andi34

Lexikon
TWRP kann SuperSU installieren, hab ich aber noch nie genutzt. Haha. Wenn ich root brauche flashe ich SuperSU per ZIP bzw. Auf neuen Android Version Magisk Manager.
 
Andi_K

Andi_K

Ehrenmitglied
Die Frage ist nur, weshalb TWRP mich fragt ob es SuperSU installieren soll, und ich das auch ohne Fehlermeldung bestätigen kann, wenn offenbar keine SuperSU.zip vorhanden ist. Zumindest habe ich keine auf's Gerät kopiert, und in Deiner build ist ja wenn ich Dich richtig verstehe auch keine enthalten.

Sorry, für die vielen Rückfragen, aber ich möchte entweder ein sauber gerootetes Gerät haben, oder ein nicht gerootetes. Aber nix halbgares dazwischen.
Würdest Du sagen, dass das jetzt bei mir so passt, wenn an flashbaren Dateien lediglich Deine build sowie die Nano GApps (von Open GApps Project) vorhanden waren?
Oder sollte ich die ROM nochmal dirty drüber flashen und die Frage ob ich rooten will im TWRP dann verneinen?

Schönen Gruß
Andi
 
A

Android-Andi34

Lexikon
K.A. was TWRP gemacht hat. Eigentlich schiebt es die SuperSu.apk (ist im TWRP mit drin) auf system/apps oder system/priv-apps.

Wenn kein SuperSU im Launcher sichtbar ist, dann hat's TWRP anscheinend nicht hinbekommen.
 
SaschaKH

SaschaKH

Ehrenmitglied
Von rooten über die eingebaute Funktion in TWRP kann ich nur abraten. Im besten Fall funktioniert es wirklich mal, oft funktioniert es einfach nicht, im schlimmsten Fall bootet das Phone nicht mehr. Liegt wohl daran dass TWRP eine zu alte Version verwendet. Denke mal das Du es einfach so lassen kannst.

Andi_K schrieb:
Oder sollte ich die ROM nochmal dirty drüber flashen und die Frage ob ich rooten will im TWRP dann verneinen?
Wäre wohl die sauberste Lösung.
 
Andi_K

Andi_K

Ehrenmitglied
Danke, dann mach ich das.
Wäre es evtl besser vorher die System Partition zu wipen?
Oder macht das hier keinen Unterschied?

Schönen Gruß
Andi
 
SaschaKH

SaschaKH

Ehrenmitglied
Könnte mir nicht vorstellen das es einen Unterschied macht.
 
Andi_K

Andi_K

Ehrenmitglied
Danke nochmal.
Hab's jetzt nochmal drüber geflasht und das rooten im Recovery verneint, somit wird nun denke ich alles passen.

Schönen Gruß
Andi
 
P

Printer

Fortgeschrittenes Mitglied
Hallo und guten Abend zusammen,
Ich habe ein altes tab 2.1 wifi mit TWRP und Andy's slimkat. Lief bisher echt klasse!
Im Urlaub passierte es auf einmal " die google play Dienste wurden beendet".
Als ich danach andere Apps öffnen wollte, das gleiche Spiel ,
Mail wurde beendet, spiele wurden beendet usw.usw.

Mehrere Neustarts brachten leider nichts und so entschloss ich mich,
das vor 2 Monaten, vom einwandfrei laufenden System, gemachte
Backup einzuspielen. Die Vorfreude war groß- aber nicht von Dauer.

Das gleiche Problem !

Hat jemand von Euch eine Idee ??

Danke im Voraus für evtl. Antworten

Viele Grüße vom Printer
 
SaschaKH

SaschaKH

Ehrenmitglied
Soetwas ist wahrscheinlich ein Problem der GApps. Da kann es helfen nochmal neu zu flashen, also mit der gleichen Version der ROM (oder wenn es das gibt, einer neueren Version) und einer neueren Version der GApps.
 
P

Printer

Fortgeschrittenes Mitglied
Danke für den Tipp, hat aber
leider nicht geholfen .

Ich werde das Tab wohl plattmachen und versuchen,
eine andere Rom zu flashen.

Viele Grüße vom Printer
 
P

Printer

Fortgeschrittenes Mitglied
Hallo nochmal ,
das ganze hat mir keine Ruhe gelassen und ich hab das tab platt gemacht und dann versucht,
leider erfolglos, die neue slim7 zu Flaschen.Da hatte ich leider immer eine Fehlermeldung.

Dann hab ich nochmal alles gewiped und zum gefühlt 100ten Mal mein altes backup
geflasht. W-lan war ausgeschaltet. Dann hab ich`s über Nacht richtig vollbeladen und heute
Morgen gestartet. W-lan eingeschaltet.....und dann ging`s los:
Mail wurde beendet, es dateiexplorer wurde beendet, slim launcher wurde beendet....
also alles .
Hab mich dann mit'm Kaffee hin gesetzt und hin- und her über legt - ohne Resultat.

Dann schau ich auf's tab und es gibt ZUM ERSTEN MAL !!!
unzählige Meldungen, daß diese und jene APP nicht gestartet werden konnte,
Weil erst die Play Dienste aktualisiert werden müssen.

Das hat dann seeehhrr lange gedauert. Gleich danach einen Neustart und das war's!

Alles läuft wieder sehr smooth und ohne Abbrüche. Puhh

Ich hab das hier beschrieben, falls noch andere dieses eigentlich unerklärliche
Phänomen haben. Hoffe, es hilft.

Viele Grüße vom printer