Wlan Problem

  • 132 Antworten
  • Neuester Beitrag
Diskutiere Wlan Problem im HTC Magic Forum im Bereich Weitere HTC Geräte.
W

wurzel99

Neues Mitglied
Hallo
mein Magic läuft unter der Ver. 2.2.1

und ich hab ein seltsames WLAN-Problem.

Ich kriege von meinem WLAN-router die IP zugewiesen, kann auch die apps starten aber die kriegen entweder keine oder nur sehr zöglich daten - und schmieren irgendwann ab.
Andere REchner kommen über den gleichen AP problemlos an Daten.

Leider kann ich dem Magic kaum Infos entlocken - mehr als die IP wird mir nicht angezeigt. Ein ipconfig für Android hab ich noch nicht gefunden

gibt es da ein paar Insider-Tipps

Schon mal vielen Danke

Wurzel
 
Steppo

Steppo

Experte
Schau mal unter den WLan Einstellungen nach und zwar: Menü -> Erweitert Dort müsstest du auf deine Frage Antwort bekommen.

Sent from my Oldtimer using Tapatalk
 
W

wurzel99

Neues Mitglied
Danke für den Hinweis. Die Ecke kannte ich schon. Da stehtnur was zu den Standby-Richtlinien, die Mac-Adresse und dann kann ich für eine statische ip Gateway/netmask usw eingeben. Das will ich nicht.
Es muss doch möglich sein für die aktive Einstellung gerade aktiven Daten à la ifconifg einzusehen.

Oder? gibt es vielleicht eine Konsole die man öffenen kann .. aber da fehlt mir dann die Tastatur .. ?

mfg

Wurzel
 
Varroc

Varroc

Erfahrenes Mitglied
wurzel99 schrieb:
Oder? gibt es vielleicht eine Konsole die man öffenen kann ..
Selbstverständlich gibt es die. Such mal im Market nach dem Terminal Emulator (oder einer vergleichbaren App). Dieser Funktioniert ganz wunderbar mit der on-screen tastatur.

Ich weiß allerdings nicht, ob dich dies sonderlich weiterbringt. Der ifconfig Befehl steht unter Android nicht zur Verfügung, ich weiß ehrlich gesagt auch nicht, welche Befehle ohne Busybox überhaupt vorhanden sind. Ansonsten liefert netcfg schonmal grundlegende Informationen.
 
D

diodios

Neues Mitglied
Moin moin.
Ich hab ein problem nach update auf original vodafone 2.2.1 software geht wlan nicht mehr, genau gesagt geht es es findet meine router und nachdem ich mein passwort eingebe bekommt mein Magic keine IP adresse.mit 1.6 ging es ohne problemme und meine G1 hat auch keine probleme.
Vorher 32B Magic:
HBOOT 1.33.0013
Radio 2.22.19.261
Rom 1.6

Nachdem Update:
HBOOT 1.33.0013
Radio 2.22.28.25
Rom 2.2.1
Baseband-Version62.50SJ.20.17U_2.22.28.25
kernel 2.6.32.9-27237-gbe746fb
Build FRG83D

Ich hab das Update einmal per OTA und nochmal mit SD Karte gemacht.
Trozdem das gleiche prob.
Sollte ich vieleicht andere radio probieren und wie ?
Danke im voraus

Ich hab erst jetzt festgestellt das daten verbindung über O2 auch nicht klappt!!!
 
Zuletzt bearbeitet:
D

diodios

Neues Mitglied
Da ich keine antwort bekomme schreib ich weiter.
Ich hab gerade alles im handy von grund original hergestellt erst 1.5 mit
vf-sappimg-crc24-1.33.0007.nbh und weiter auf 1.6 und jetzt auf 2.2.1 von VF (Super schnell).
also alles neu aber habe immer noch keine netzverbindung über t-mobil (telefonieren geht) auch über wlan nicht er findet meine router Belkin N1 und versucht immer wieder IP Adresse zu bekommen.Mit alle andere versionen auch 1.5 oder 1.6 geht alles ohne problemme.
Also an alle profis BITTE HILF MIR
Soll ich wieder von vorn alles machen oder vieleicht nur Radio ältere version???
Jetziges Radio 2.22.28.25 und FRG83D 2.2.1 Vodafone
Please:huh:
 
Zuletzt bearbeitet:
R

rudi_mentaer

Fortgeschrittenes Mitglied
Moin diodios
Probier ma folgendes:
Im Router unter den WLAN-Einstellungen die Auswahl (sofern Du die hast) "WPA/WPA2 mit Pre-Shared key" treffen.
Die SSID auf Sichtbar stellen.
Im Magic unter den WLAN-Einstellungen ganz unten unter "WLAN-Netzwerk hinzufügen" die Prozedur durchziehen.
Wenn der Router das Magic findet und eine WLAN Verbindung zustande kommt, nach belieben die SSID im Router wieder auf unsichtbar stellen, oder eben nicht.
Solltest Du die SSID wieder auf unsichtbar stellen, wird das Magic kurzzeitig die WLAN-Verbindung verlieren, sollte sie jedoch nach kurzer Zeit selbstständig wieder herstellen.
Vielleicht hilfts ja.
 
G

gnometech

Stammgast
Und bezüglich des Mobilen Internets.
Schau mal unter Einstellungen -> Drahtlos & Netzwerke ->Mobilfunknetze -> Zugangspunke
ob dort die benötigten Zugangspunkte aufgelistet sind.
Kann sein dass sie bei den Updates verlorengegangen sind. Einfach wieder eintragen. Die Suche hier hilft bei den Infos für die Zugangspunkte
 
D

diodios

Neues Mitglied
Danke für euere antworten.
Ich werde langsam verückt ich hab alles probiert router einstelungen ikl.
Meine G1 liegt daneben mit CyanogedMod und laüft one probleme.
Ich hab gestern das Magic wieder von vorn bespielt also :
Firmware 1.5 Wlan geht mobilfunk verbindung auch.
1.6 Wlan geht mobilfunk verbindung auch
CyanogenMod -6.1.0-Ds Wlan bekommt keine ip adresse ich sehe das handy in meine router über mac adresse , das handy sieht den router verbindet für ip adresse aber bekommt keine übers mobilfunknetz geht jetzt.
Ich möchte aber keine 1.6 lieber die original 2.2.1
Ich denke aber es liegt nicht an dem Radio (alle obere rom haben 2.22.19.261)
ich werde versuchen andere roms und mal sehen
 
Steppo

Steppo

Experte
Dann flash dir doch eine gute 2.2.1 Custom-Rom. Damit bist du erstens, noch besser bedient & 2. werden deine Probleme vielleicht der Vergangenheit angehören.
 
D

diodios

Neues Mitglied
Aber die CyanogenMod -6.1.0-Ds ist doch 2.2.1 rom und Wlan ip abholen ging auch nicht.
Egal ich hab die :thumbsup: CyanogenMod -5.0.8-Ds :thumbsup: instaliert geht sofort alles .
Bis ich wieder die nerven hab um verschiedene rom zu probieren lass ich die drauf.
Die mädels als hintergund sind da auch drin.
Mfg. sakis
 
Steppo

Steppo

Experte
Also ich bin weiterhin mehr als Zufrieden mit Eclair. Froyo hatte ich damals drauf, war aber nicht so mein Fall.
Hab mir dann das Gingerbread Theme für Eclair konvertiert und brauch da jetzt auch kein 2.3 Rom für ;)

Sent from my Oldtimer using Tapatalk
 
mipfel

mipfel

Neues Mitglied
Hallo

nach einer Woche Besitz von einen Magic 32 B ist es mir immer noch nicht gelungen, über Wlan ins Internet zu kommen.
Über Vodaphone geht´s, jedoch bei Aktivierung von Wlan wird es erkannt, mit dem Router verbunden, alles bestens.
Auch am Router bin ich angemeldet.
Jedoch habe ich keinerlei Traffic. Google Seiten werden nicht angezeigt, da keine Netzverbindung da ist!

An der WPA2 Verschlüsselung kann es auch nicht liegen, bei offenen Netz der gleiche Mist.

Liegt das nun am Froyo 2.2.1, welches ich draufgezwickelt habe oder kann das andere (Bediener?) Ursachen haben?

Das Problem sitzt ja meist vor dem Rechner.

Vielen Dank
 
R

Rushness

Erfahrenes Mitglied
Automatische IP-Konfiguration beim Router ist an?
Diese ROM unterstützt W-Lan?
 
Steppo

Steppo

Experte
Aber nur meistens ;)

Setze dein Magic am besten mal auf Werkszustand zurück, damit könnte sich das Problem eventuell beheben lassen.

Ansonsten wird es wohl an deinem Router liegen. Wenn du eine Mac-Filterung verwendest schalte diese besser ab. Und auch die SSID sollte für deine Versuchszwecke nicht versteckt werden. Du kannst es auch in jetzigem Zustand bei einem Bekannten ausprobieren, sollte es dort funktionieren, musst du es nicht zurücksetzen und weißt das es am Router liegt. Falls nein, liegts dann wohl am Magic.

@it: Was da los? Warum brauch ich heut Morgen so lang ne Nachricht zu schreiben :D
 
mipfel

mipfel

Neues Mitglied
Habs jetzt mal im öffentlichen HotSpot ausprobiert, da geht es!

also kann es nur am Router liegen und dann bin ich wohl im falschen Forum.

Aber warum?
Es ist doch verbunden, mit guten Status und 54 Mbps-
Was braucht das Magic, was ein laptop nicht braucht?
MAC Filterung ist aus
SSID ist nicht versteckt

Beste Grüsse
 
Steppo

Steppo

Experte
Also es wird zu größter Wahrscheinlichkeit am Router liegen. Dazu kann ich dir aber nicht helfen.

Auf Werkszustand hast du noch nicht zurückgesetzt?! Versuchs dann, wenn du keinen anderen Ausweg mehr findest ;)
 
N

n1ck1355

Neues Mitglied
evtl wirklich dhcp am router ausgeschaltet?
dies würde bedeuten, dass du in das wlan netz eingebucht wirst,
aber von deinem router keine ip/subnetmask/gatway und dns zur
verfügung gestellt bekommst und somit auch keine webseiten etc. aufrufen kannst.
 
mipfel

mipfel

Neues Mitglied
Hallo

vielen Dank für die Tipps.

DHCP am Router ist ausgeschaltet, da DHCP am DSL Modem die Adressenvergabe managed.
Wenn ich im Wlan angemeldet bin, habe ich IP-Adresse usw.
jedoch kann ich von dort auf den Router oder sonst ein Gerät nicht pingen. Genausowenig kann das magic nicht angepingt werden.
3 von 4 Paketen gehen verloren.
Der Router war eher günstig- Longshine - aber er erfüllt die entsprechende 802.11 b und g.

Was braucht das Magic, das der Laptop nicht hat?

Fazit: ein neuer Router muss her!

Grüsse
 
digicom1

digicom1

Erfahrenes Mitglied
Morgen,

ein DSL Modem macht eigentlich keine IP Adressverwaltung(DHCP),
außer die für die WAN IP.


Wenn am Router DHCP aus ist mußt du am Magic eine IP/Gateway/DNS einstellen.
(welche IP bekommt/hat denn den Magic)

Wie sind denn die Einstellungen an deinem Notebook ? Nimm einfach mal die, damit funktioniert es ja.(dein Note darf dann aber nicht an sein)

Könntest auch einfach mal DHCP an machen und testen.

Gruß