USB-zu-Ethernet-Adapter-App

  • 47 Antworten
  • Neuster Beitrag
X

xlouk

Neues Mitglied
Vielen Dank für die umfassende Antwort.

In meinem Fall geht es nicht um ein MediaPad, sondern möglichst um eine allgemeine Lösung.

Hat google keine Standard LAN Adapter Hardware spezifiziert, für die die Pad Hersteller Treiber mit installieren müssen?

Wäre Deine Lösung auch für andere Tablets einsetzbar?
 
Zuletzt bearbeitet:
D

dfahren

Neues Mitglied
Threadstarter
Ok, eine allgemeine Lösung kann natürlich nur von Google kommen.
Soweit wie ich mich in den Android Sourcecode eingelesen habe, kann ich sagen, dass es "Rudimente" einer Ethernet-Unterstützung gibt, die aber nicht konsequent implementiert worden ist. Vielleicht ist das mit 4.2 besser, keine Ahnung.

Ich vermute Google macht das deswegen nicht, weil sie ggf. auf dem Standpunkt stehen "unsere Nexusse(?) sind die Hardwareplattform, die wir unterstützen und sonst nüschte." Alle anderen Hardware-Hersteller müssen die Treiber für ihre eigene Hardware selber stricken oder eben auf welche aus dem Linux-Kernel zurückgreifen und die ggf. anpassen.

Das Problem mit den x-tausend Adaptern da draußen ist leider auch, dass man die im Prinzip alle erstmal besorgen und dann jeden einzelnen Treiber dafür testen und ggf. zertifizieren müsste für eine Interessengruppe, die womöglich relativ klein ist. Das dürfte Google aus Prinzip kein großes Interesse dran haben....

Insofern müssen wir leider selbst Hand anlegen. Daher auch diese Android-Forks Cyanogen, ParanoidAndroid, etc...

Grüße!
 
D

dfahren

Neues Mitglied
Threadstarter
Yep, die hatte ich gestern auch schon im Visier. Keine Ahnung, was unsere "asiatischen Freunde" da wieder ausgeheckt haben. Muss ich mir mal ansehen. Leider kein Sourcecode. Insofern ist es schwer zu sagen, was sich da wohl verändert haben mag, aber Danke für den Hinweis.
 
D

dfahren

Neues Mitglied
Threadstarter
Es gibt mal wieder ne neue Version ...

Diese Version unterstützt nun Adapter mit dem Chip MOSCHIP 7830 / 7832 / 7730 sowie den Sitecom LN-030.

Probiert's mal aus und wenn es Fehler gibt, bitte mit Logs an mich per PN.

Danke und Grüße,
DFahren
 

Anhänge

  • USB2Ethernet-Helper.apk
    503.4 KB Aufrufe: 1.179
K

Khor

Neues Mitglied
Hey

Ich hab das hier mal verfolgt, allerdings glaub ich, dass es mit meinem delock usb to ethernet adapter nicht klappen wird.. Hab die Firmware von Huawei mal geladen, seh auch die Einstellung usb netzadapter, was allerdings nicht klappt :-/ Hat jemand einen Lösungsvorschlag...? Oder lieber einen anderen Adapter besorgen?
 
M

malenk

Neues Mitglied
Hatte mir vor einem halben Jahr den USB to Ethernet Adapter von Logilink UA0025C geholt und halb tot geärgert, weil ich ihn nicht mit dem MP zum Laufen brachte.
Die mittlerweile im Netz verfügbare geroutete Firmware(S7-302u, Android 4.0, C235B001, EN, Network Function) und die USB2Ethernet-Helper.apk vom 15.12 brachte dann den Durchbruch und
alles funktioniert tadellos.


Ein großes Dankeschön an dfahrern!


[FONT=&quot]malenk[/FONT]
 
D

dfahren

Neues Mitglied
Threadstarter
@Alle: Meine App läuft auf jeden Fall mit dem regulären Boot-Img von Huawei. Ob es mit der neuesten Firmware läuft, kann ich nicht sagen. Hab das noch nicht ausprobiert.

@Khor: Nenn mir doch mal die genaue Typbezeichnung von dem Delock-Stick, den Du hast. Wenn Du Details wie VID und PID von dem Stick hast, wäre das gleich noch viel besser. Wie kriegt man die? Folgendes in Windows: Stick in einen USB-Port einstecken. Dann kommt ggf. der Installationsassistent hoch. Immer auf Abbrechen klicken. Mit der rechten Maustaste auf "Arbeitsplatz" klicken, "Verwalten" auswählen. Dann in der linken Spalte "Geräte-Manager" auswählen. In der rechten Spalte auf das Gerät mit dem großen gelben Fragezeichen und dem kleinen gelben Ausrufezeichen mit der rechten Maustaste klicken. "Eigenschaften" auswählen, Reiter "Details" auswählen, auf diesem Welt dann in der Dropdown-Box "Geräteinstanzkennung" auswählen und im weissen Feld stehen dann (etwas kryptisch) die VID und die PID.

@Malenk: Gut zu hören, dass dieser Adapter bei Dir läuft. Hervorragend! Viel Spass damit.
 
T

tomsoccer0204

Neues Mitglied
Hallo zusammen,

ich wollte einmal nachfragen ob es auch möglich ist einen USB Ethernet Adapter mit dem Handy zu benutzen. Mein Handy Sony erricsson neo (MT15) ist gerootet und ich die App aus diesem Forum hier installiert, aber diese kommt nicht weiter als both host Adapter not found. Ich benutze den Adapter UA0025C von LogiLink. Mein Handy hat ICS 4.0.4 drauf und ist otg fähig. Also ist es generell möglich diese Handy mit einem USB Ethernet Adapter zu betreiben? Wenn ja kann mir vielleicht wer helfen die Treiber ein zu binden?
 
D

dfahren

Neues Mitglied
Threadstarter
Hallo allerseits,

also nochmal: Meine App funktioniert (leider) im Augenblick nur mit dem original Mediapad Kernel 3.0.8. Andere Kernel-Versionen (auch die ohne SMP bspw.) werden nicht unterstützt. Das ist Linux live. Der Treiber könnte es, aber leider nicht das zugrundeliegende Linux.

Trotzdem Euch allen einen guten Rutsch ins Jahr 2013!

DFahren
 
D

dfahren

Neues Mitglied
Threadstarter
Moin,

es gibt mal wieder eine neue Version von meiner App, die jetzt den DLINK DUB-E100 Rev. C unterstützt. Rev. A und B laufen bereits.

Viel Spass damit,

DFahren

P.S.: Ich häng jetzt die neue Version nicht mehr hier ein sondern nur noch im ersten Post im Forum von XDA-Developers.
USB-to-Ethernet Helper App - xda-developers
 
D

dfahren

Neues Mitglied
Threadstarter
@Khor: Der Treiber ist schon in der App, aber die VID/PID-Kombination noch nicht. Baue ich demnächst ein.

@4nubis: Ich meine der Treiber für die AX-Chips funktioniert auch mit Deinem Adapter. Was ich allerdings brauche und was Khor schon geliefert hat, ist die VID/Pid-Kombination. Wenn ich die habe, dann gibt's ne neue Version für Euch zum Ausprobieren.

Grüße!
 
4

4nubis

Neues Mitglied
Die VID und PID ist:

USB\VID_066B&PID_20F9&REV_0001
USB\VID_066B&PID_20F9


Danke für deine Mühe, freue mich schon drauf es zu testen :)

Edit:
Ich glaube nicht, dass er mit dem AX-Chiptreiber funktioniert, da er mit diesen auch nicht auf Ubuntu funktioniert.
Hier wurde eine passende .ko für Ubuntu hoch geladen : https://github.com/linuxerwang/HG20F9/archive/master.zip
Die .ko befindet sich in dem Ordner. Kannst du damit evt. was anfangen?
 
Zuletzt bearbeitet:
D

dfahren

Neues Mitglied
Threadstarter
Nein, mit der .ko-Datei kann ich nichts anfangen. Die will ich ja erst noch erzeugen ...
Das kann gut sein, dass es so out-of-the-box mit den Standard AX-Treibern nicht geht, ich muss noch die Treiber-Sourcen miteinander vergleichen. Das braucht aber seine Zeit und ich hab abends leider gerade nicht die Zeit dafür. Dauert also noch ein wenig.

Grüße,
DFahren
 
D

dfahren

Neues Mitglied
Threadstarter
Nach Vergleich der Treiber-Sourcen kann ich sagen, die sind bis auf winzige Kleinigkeiten identisch. Hätte mich jetzt auch schwer gewundert, wenn ein OEM plötzlich seine eigene Treiber schreiben lassen würde. Das kostet nämlich nen heiden Geld. Tatsächlich wurde nur ein neuer Eintrag zu der Liste der unterstützten Geräte hinzugefügt.

Neueste App wie gehabt im Thread bei XDA-developers. Link ein paar Postings weiter oben.

@4nubis: Bitte mal ausprobieren, ob's jetzt läuft und hier berichten.
@Khor: Das wundert mich jetzt ein bisschen, dass die App nicht bei Dir funktionierte. Es ist alles soweit eingetragen gewesen. Dieser DeLock-Adapter hätte eigentlich laufen müssen. Bitte nochmal ausprobieren und falls es nicht geht mit logcat und dmesg-Ausgabe hier posten. Danke!!!

Cheers, DFahren
 
Andro_Ida

Andro_Ida

Neues Mitglied
Hallo DFahren !
Erst einmal vielen Dank für Deine Arbeit auch im neuen Jahr !

Ich hatte mir noch einen 2.Adapter bei Amazon bestellt, der wollte auch nicht.

Aber jetzt siehe da, hab mir Deine letzte app (589kb) runtergeladen und alle Punkte

im Helper werden mit Haken versehen und die Verbindung steht.

Auch meine Peitsche mit Microstecker aus CHN tuts

Vielen Dank
Andro Ida
 
Zuletzt bearbeitet:
D

dfahren

Neues Mitglied
Threadstarter
Hi Andro Ida,

na, ist doch bestens! Das hört man gerne. Großartig. Viel Spass mit der App.

Grüße,
DFahren
 
K

Khor

Neues Mitglied
Hallo

Bei mir kommt folgendes:

Load appropate driver
Driver could Not bei installed! Please See Thema logs.

Was tun?
 
Oben Unten