TP9.7-1200QC - Android KitKat - beta2

  • 12 Antworten
  • Neuster Beitrag
H

hapee

Neues Mitglied
Threadstarter
Hi,
wie bereits angekündigt gibt es mit der beta2 die versprochenen Updates:
- Rear-Kamera richtig konfiguriert. Front-Kamera geht nicht. Treiber fehlt.
- Helligkeitseinstellung korrigiert (Screen wird nicht mehr schwarz)
- Anordnung und Größe der Icons im Launcher2 geändert.
- als Recovery ist jetzt ein custom TWRP 2.7.1.0 implementiert. Wer es noch nicht kennt, weitere Infos gibt es hier TWRP 2.7.1 (Recovery) SDK3.x
Zum Aufruf von Recovery gibt es folgende Möglichkeien: über ADB "adb reboot recovery" oder beim Starten des Tabs die Key-Kombi Vol- / Power lange drücken, bis das TWRP-Logo erscheint.

Den Download gibt es hier: hapee-tp971200qc-android-kk-beta2-20150620.zip
Geflasht wird über die PhoenixSuite. Hinweise dazu gibt es bereits unter diesem Thema https://www.android-hilfe.de/forum/i-onik-tablets.973/tp9-7-1200qc-android-kitkat-beta.681597.html/
Wer Probleme mit der PhoenixSuite bezgl. der USB-Anbindung hat, kann auch alternativ PhoenixCard verwenden. Hinweise zum Handling habe ich hier gepostet TP8-1200QC - Android KitKat - Beta-Version | Seite 2 - Android-Hilfe.de
 
Zuletzt bearbeitet:
H

hapee

Neues Mitglied
Threadstarter
Achtung gerade Bug im TWRP entdeckt:
beim Zurücksetzen auf Werkseinstellungen (wipe) wird auch die System Partition gelöscht. Android funktioniert dann nicht mehr. Update folgt.
 
H

hmf

Neues Mitglied
Habe ich leider festgestellt. Allerdings hatte ich immer noch keine Anzeige während des bootens oder im recovery. Ich hatte das zurücksetzen aus den Einstellungen probiert. Jetzt leider das Problem, dass ich entweder nicht mehr in den debug-mode komme oder die Treiber in Windows nicht mehr passen, denn die Phoenix-Suit erkennt kein Gerät mehr.
 
B

byte666

Neues Mitglied
Hy. Das geht ja superflott. :) Ich habs trotz Bug mal installiert und kurz durchgeklickt. Kamera geht, Helligkeit kann man das Display nicht mehr ausnocken (aber der Regler hat nen "sprung", vernachlässigbar)

Das einzige was mir aufgefallen ist... die äussere Iconreihe geht über den Bildschirm hinaus. Merkt man erst wenn man Apps installiert weil ja Android den ersten Platz links oben benutzt. Und man kanns auch Manuell da reinsetzen. In der v1 hatte man 7 Icons, jetzt sinds 8, aber wie gesagt die äusseren sind 50% abgeschnitten.

Ansonsten undglaublich stabil, kein vergleich zu Stockrom. Und der schlechte Akku ist verschmerzbar. Top Arbeit!!!!
 
H

hapee

Neues Mitglied
Threadstarter
Hier das gefixte TWRP Recovery im Anhang. Zum Installieren eine ADB-Verbindung aufbauen.
- Datei auspacken
- Über Command-Fenster eingeben
adb root
adb push twrp_271_tp971200qc.img /sdcard/twrp_271_tp971200qc.img
adb shell
cat /sdcard/twrp_271_tp971200qc.img >/dev/block/nandg
sync ;sync; sync
adb reboot

Leider funktioniert das TWRP nicht fehlerfrei, da beim Starten ein Display-Fehler auftreten kann und das Display bleibt dunkel.
In diesem Fall Power ca. 10 Sekunden drücken. Bleibt das Display immer noch dunkel, Vorgang wiederholen.
Das ist aber jetzt kein Problem von TWRP, sondern tritt bei jedem anderen Recovery auch auf.
Es handelt sich hier um einen Treiber-Fehler, den ich noch fixen muß.

Am besten funktiert es, wenn das Tab vorher ausgeschaltet wird und das Recovery mit der Tasten-Kombi Power/Vol- gestartet wird. Beim Beenden von TWRP wieder ausschalten.
 

Anhänge

  • twrp_271_tp971200qc.zip
    9.9 MB Aufrufe: 569
Zuletzt bearbeitet:
C

CliffDexter

Neues Mitglied
Moin hapee,

erst mal herzlichen Dank für Deine Mühe mit dem Custom ROM. Ich hab's seit gestern auch drauf, nachdem mein TP9,7-1200 nicht mehr zum Laufen kam. Das erste mal geflasht, ich war schon ein wenig nervös...

Wobei der erste Startbildschirm nach dem Kauf letzter Woche anders als der nach dem Zurücksetzen war (keine Kontoabfrage). Vielleicht hätte ich nie einen machen sollen...?

Trotzdem interessiert mich, warum die vordere Kamera so ein Problem ist. Müsste der Treiber nicht in der originalen Firmware vorhanden sein? Die rückwärtige Kamera konntest Du doch auch implementieren...?

Leider ist der Akku wirklich schlapp, dabei ist das Bild so knackig. ich befürchte, das Ding hält keinen 90 Minuten Film durch.

Hier hat doch ein anderer User im letzten August auch ein ROM gemacht (wohl noch Jelly Bean). Wie waren denn die Erfahrungen damit? Konnte er die vordere Kamera implementieren? Es gab da wenig an Erfahrungsberichten.

Grüße
 
G

guihei

Neues Mitglied
Hallo Hapee könntest du auch noch mal ein update der Fimware mit aktualisierem TWRP zur Verfügung stellen? Ich kenne mich mit dem flashen und adb nicht aus und würde gerne mir den 2. Schritt (ADB) sparen.
 
H

h1618

Neues Mitglied
hallo hapee,

erst mal danke dafür, dass du für dieses Tablet dieses ROM gebastelt hast - kein Vergleich zu dem Schrott, der von Werk aus drauf ist.

nun aber doch ein paar Anmerkungen:
Beim Ersetzen von SuperSU durch Koush's Superuser (mir ist wichtig, dass su und die Kontroll-App Open Source ist, das ist schließlich der Zugang zu allem) sind mir ein paar Sachen aufgefallen, die ich nicht so toll fand. Erstmal klappte da nichts, weil Install-recovery.sh nicht aufgerufen wird - die init.rc ist nämlich verändert. Da fehlt nun zum einen der in allen Android-Versionen vorhandene install-recovery-Service, was blöd ist, weil sich viele Root-Tricks da einklinken wollen. Statt dessen ist der SuperSU-Daemon-Aufruf fest drin - finde ich nicht so gut. Und dann ruft die init.rc noch mehrfach alte busybox-versionen in /system/bin auf, und zwar an Stellen, wo es die eingebaute Shell auch tut, also unnötig - bis auf eine Stelle, wo eine init.d-Unterstützung aktiviert wird, was ich wieder gut finde.. Busybox gehört in xbin und gewartet, also z.B. mit dem Busybox-Installer, damit da immer die aktuelle drin ist. Ich hab also erstmal die 1.18 und 1.20 Versionen aus bin rausgeschmissen, und durch einen Symlink auf die neue Version in xbin ersetzt, damit init nicht auf die Nase fällt und init.d funktioniert, und dann den su-daemon-Aufruf in init.d gepackt.

Was ist das Problem mit dem Front-Kamera-Treiber? Läuft er nicht mit dem 3.3-Kernel? Mit dem gefixten TWRP (kannte ich schon und find ich gut) hatte ich übrigens noch keine Display-Probleme, ich bin aber ohnehin meist aus dem ausgeschalteten Zustand dort rein. Auch anschließend Reboot>System klappte immer.

Zur Oberfläche: der Launcher verändert seinen Zoom gelegentlich: die Icons sind dann weiter auseinander und die randständigen nur mehr halb zu sehen - sieht dann doof aus, stört aber nicht wirklich. Und der Akku hält wirklich nicht sehr lange, immerhin mehrere Stunden, aber das Display zieht eine Menge ...

Im Übrigen läuft das Tab absolut rund - super und nochmal danke!
 
E

EltechMJE

Neues Mitglied
Hallo zusammen.
Ich reihe mich sowohl in die viel gekauften Pollin-Tablets, als auch in die Nutzer des hervorragenden Custom-Rom's von Hapee. Hier an dieser Stelle Vielen Vielen Vielen Dank!!!
Eine kleine Anmerkung hab ich allerdings:
Der Homescreen ist etwas zu groß geraten! Neu installierte Apps werden stellenweise auf den Rand des Homescreens gelegt. Leider konnte ich keine Einstellungen finden, wo ich die Größe anpassen kann.

Ein kleiner Tipp oder eine neue Version wäre super!

Vielen Dank.
 
S

schatzinsel

Neues Mitglied
Ich gehöre auch zu denen die bei Pollin das angebliche schnäppchen von ionik gekauft haben.
Gleich 2 Stück ander Zahl für mich und meinen Sohnemann.
Sobald das Tablet komplett heruntergefahren wurde oder der Akku leer war startete das Teil nicht mehr.
Ein Hardreset war nötig und somit alle Einstellungen waren weg.
Mein Kleiner war natürlich stinkig da seinen ganzen Spielstände und Apps weg waren.
Zum Glück bin ich auf dieses Forum gestoßen und habe mir das Android von harpee geflasht.
Für diesen Dienst vielen vielen Dank.:thumbup:
Bis auf die bereits bekannten Kleinigkeiten die nicht funktionieren läuft alles perfekt !!!
Bisher keine nennenswerten Abstürze oder Aufhänger.
Falls harpee mal Zeit und Lust hat noch etwas zu verbessern, würde mich das natürlich freuen.:biggrin:
 
W

Worm

Neues Mitglied
Hallo zusammen, hallo hapee

ich habe Probleme mit der WLAN (WiFi) Verbindung.

Ich habe auf meinem i-onik tp9-7-1200qc-retina die Custom ROM von hapee geflasht.
Läuft auch alles soweit ganz gut, aber bei der WLAN Verbindung ist nicht immer eine Datenübertragung möglich, obwohl die WLAN-Verbindung nicht unterbrochen wird (Symbol hat 3 oder 4 Balken). Habe auch schon mehrere Zugangspunkte probiert. Der Ping auf die IP des Tablet ist auch nicht stabil.

Ich habe auch schon die WiFi Bug Fix App von Ionik installiert.
Quelle Tablet PCs 9.7" Quad Core | ionik:
Nach unserem letzten Over The Air (OTA) Update sind vereinzelt Probleme bei der Nutzung von WLAN aufgetaucht. Zur Behebung dieser Probleme steht folgende App zum Download zur Verfügung:
www.cnstorage.de/downloads/ionik/ionik_TP97-1200QC_WiFiFix.zip

Die App lässt sich auch starten, aber nach dem Touch auf "Install Update" kommt die Meldung
Ihr Gerät verfügt bereits über die aktuellste Software und muss nicht mehr aktualisiert werden.

Hat jemand auch dieses Problem?
Wie kann ich das beheben?
Kann das Update der WiFi Bug Fix App geforced werden?
@hapee Ist hier vielleicht noch ein BUG in der Custom ROM?

Schon jetzt vielen Dank für eure Antworten.
 
P

PascalDerBeste

Neues Mitglied
Hallo hapee und die anderen✌

Sorry das ich das Thema nochmal hoch hole aber mir ist was schlimmes passiert


Ich hab die 2. Beta von hapee geflasht und es hat alles super funktioniert!
Nun kommt da so ein trottel wie ich um die Ecke und wollte das Tablet zurücksetzen auf Werkseinstellungen und hab vergessen vorher eine Sicherung zu machen (was ich jetzt sehr bereue!!!) jetzt hab ich das Tab hier liegen ohne jegliches Betriebssystem und nurnoch mit der TWRP Version 2.7.1.0
Ich Weiß leider nicht wie ich wieder ein Betriebssystem drauf bekomme
Ich bitte um DRINGENDE HILFE!!!
 

Anhänge

R

reibuehl

Neues Mitglied
Sorry, wenn ich dieses alte Thema nochmal hoch hole, aber ich hab ein i.onik TP0.7-1200QC Ultra ausgegraben, auf dem ein sehr instabiles Android 4.2.2 (Stock ROM vermute ich) läuft - oder auch nicht.

Gibt es von dem ROM hier noch irgendwo eine - evtl. sogar neuere - Version?
 
Oben Unten