[INFO] [v0.9 beta1] CPU Governor ZZMoove (03.06.2014)

  • 101 Antworten
  • Neuester Beitrag
Diskutiere [INFO] [v0.9 beta1] CPU Governor ZZMoove (03.06.2014) im Kernel für Samsung Galaxy S3 im Bereich Root / Custom-ROMs / Modding für Samsung Galaxy S3.
B

Borkse

Erfahrenes Mitglied
Hallo,

ich bin auch auf diesen Kernel gestoßen und bin begeistert. Vielen Dank für deine Arbeit :)
Eine Frage hätte ich noch: Ich bin sehr daran interessiert, möglichst viel Akku zu sparen. Ist in diesem Fall eher das Profil "Battery Plus" oder "Yank Battery Extreme" geeignet? Oder schenken sich die beiden nicht viel?
 
S13gfried

S13gfried

Lexikon
Yank Battery war nach meinem empfinden etwas sparsamer, aber nicht ganz so flüssig was man aber sehr selten merkt. Also als Notfalltelefon würde ich Yank Battery extrem nehmen, als mein täglicher Begleiter bin ich sogar von Battery (also ohne Yank) zu optimized und merke ein bisschen mehr Dampf unter der Haube. Aber echt schwer zu sagen, es sind Kleinigkeiten die das entscheiden.
Ich werde, wenn mein S3 als Ersatztelefon endet, "Battery Plus" auswählen.
 
B

Borkse

Erfahrenes Mitglied
Danke für deine Meinung. Also da ich direkt von Samsung + Touchwiz komme, ist vermutlich jede Einstellung subjektiv flüssiger. Aber wenn es sich nur um Kleinigkeiten handelt, dann belass ich es mal bei dem Profil Yank Battery Extreme. Damit komme ich eigentlich ganz gut über den Tag, aber man will ja immer so viel rausholen wie möglich. :)
 
Zuletzt bearbeitet von einem Moderator:
SaschaKH

SaschaKH

Ehrenmitglied
Du weißt aber schon das dies kein Kernel sondern ein Governor ist (bzw. verschiedene Profile eines Governors) der von mindestens vier verschiedenen Custom Kerneln für das S3 verwendet wird? Governors verhalten sich auch in einem anderen Kernel oft leicht unterschiedlich. Das ist zwar nicht viel aber es könnte eventuell sein das Yank Battery im Boeffla-Kernel leichte Vorteile hat, im Yank-Kernel aber Battery Plus besser ist. Dann kommt auch eventuell noch hinzu das der Boeffla-Kernel schon die neueste Version des ZZmoove verwendet, der AGNi aber noch eine ältere Version.
 
B

Borkse

Erfahrenes Mitglied
Das ist mir bewusst, dass wir hier über Governor Profile reden. Trotzdem danke für deine Ausführungen. Bin auf dem Gebiet noch relativ neu und man lernt immer hinzu.
 
Gamer-king

Gamer-king

Stammgast
Kurze Frage: Müssen die Profile an neue Version angepasst werden wen ja passt jeder seine Profile selber an?
 
ZaneZam

ZaneZam

Stammgast
Nein das is ja das schoene fuer euch ich passe die Profile an und ihr habt es dann automatisch ;)
 
Gamer-king

Gamer-king

Stammgast
Danke für die Info. Habe ich das jetzt richtig verstanden, das du alle, also auch die Profile von Andi und JP anpasst?
 
ZaneZam

ZaneZam

Stammgast
Aehm ja genau falls was ansteht aktualisiere ich die von yank auch. andi hat noch kein eigenes abgeliefert. die integration aller vordefinierten einstellungen in den governor machts moglich, und zb. Im boeffla kern bleibt die auswahl des profils die selbe also die kernel devs brauchen hier nix mehr zu aktualisieren. Wenn jedoch zb. yank änderungen seinerseits macht fliessen die auch mit ein falls er es mir miteilt. Wobei sowas eher selten vorkommt, also anderungen an seinen settings, ich weiss nur von einer zusätzlichen ;)
 
D

denyo81

Gast
Also wichtig für mich ist nur der zzmove alles andere nutze ich nicht. Ohne jetzt irgendwas schlecht reden zu wollen. Vor euch Devs. habe ich den allergrößten Respekt. Alleine schon aus der Perspektive, da Ihr es schafft aus einem vermeintlichen Auslaufmodell. (S3)

Es schafft das Teil Rennen zu lassen wie ein Formel 1 Auto!

Habe das Problem mit dem stotternden Apollo Player jetzt auch in den Griff bekommen. Habe die minimale Taktrate auf 500 hochgedreht, war vorher auf 400 das reichte aber nicht um im Ruhemodus die gewünschte Performance für den gute alten Apollo music player zu liefern.

Ich habe da noch eine Frage an dich ZaneZam:

Verbrauche ich jetzt im deep sleep mehr Saft, dadurch das ich die minimale Taktrate von 200 auf 400 hochgeschraubt habe?
 
ZaneZam

ZaneZam

Stammgast
theoretisch schon aber genau kann das nur jemand bestätigen der es ne Zeit lang eingestellt hat, ich musste das nie machen. ;) offensichtlich bin ich hier mit Glück gesegnet oder hab einfach immer die richtige Konstellation gefunden. Ich möchte hier aber auch an ein Feature des zzmoove erinnern das early_demand_sleep welches ich eingebaut habe um solche Probleme zu lösen, bei manchen hat das geholfen. Vlt kannst du an diesen Einstellungen noch etwas drehen und oder mal das sleep Limit ausschalten anstatt die min freq zu erhöhen. mit freq_limit=0 kannst du das aus machen dann verhält sich der gov so wie alle anderen im Suspend also so wie im wachzustand. ;)
 
D

denyo81

Gast
Oha, da stellst mich jetzt aber vor einer Mammut Aufgabe! :D

Ich belassen das meiste immer auf Stock, da ich weiß das Ihr ob jetzt Kernel oder Gouvernor Profile immer so eingestellt habt. Um das bestmögliche aus unseren Geräten herauszuholen. Ich möchte im Alltag ein funktionierendes Gerät haben. Und nicht den ganzen Tag mit Kopfschmerzen herumlaufen. :)

Aber deinem Vorschlag werde ich mal Nachkommen, wenn du mir sagst wo ich early_demand_sleep mit der Boeffla Configuration App einstellen muss. ;)

Edit:

Ok ich muss die Turntables aktivieren. Aber trotzdem wäre ich Dir für jeden weiteren Tipp sehr Dankbar. Ein kleiner Crash Kurs schadet nicht.

Danke im voraus.
 
Zuletzt bearbeitet von einem Moderator:
ZaneZam

ZaneZam

Stammgast
naja die ganzen settings sind nur vorschläge wie du siehst müssen die ja nicht bei jedem gleich gut laufen. können sie auch nicht bei unendlich verschiedenen systemen ;)

ach das bekommst du schon hin *g* einen punkt hast du ja schon gefunden auf tuneable mode schalten, dann die tuneable "early_demand_sleep auf 1 setzen wenn nicht schon aktiviert und dann die "grad_up_threshold_sleep" tuneable so lange reduzieren (5er schritte würde ich machen) bis das problem verschwindet falls es damit überhaupt verschwindet. falls nicht kannst du stattdessen oder auch zusätzlich die tuneable "freq_limit_sleep" auf 0 stellen, damit ist das sleep limit ausser kraft und du hast den vollen freq bereich bei sleep verfügbar, also würde das system wie im wachzustand sich holen was es braucht ;) damit sollte es eigentlich keine probeme mehr geben vorrausgesetzt es sind nicht auch noch die anderen einflüsse die es noch gibt wie zb. scheduler readahead einstellung und und und.. aber wenn dir das anheben der min freq hilft dann sollten dir diese einstellungen eig. auch helfen ;)
 
D

denyo81

Gast
Nur zu meinem Verständnis:
Wenn ich die minimale Taktrate auf Null setze. Verbrauche ich dann auch wesentlich mehr Strom als in direkten Vergleich zu meinen alten Einstellungen? So wie es beim Gouvernor Performance ist? Oder liege ich da verkehrt mit?

Edit: Aber es wäre schon cool wenn ich den zzmove im Deep Sleep so tweaken könnte das ich wieder die minimale Taktrate von 500 auf 200 reduzieren kann. Ohne das Apollo faxen macht! :D
 
Zuletzt bearbeitet von einem Moderator:
ZaneZam

ZaneZam

Stammgast
Genau das ware cool ja :) naja langfristig verbrauchts vlt. Etwas mehr als mit diesem sleep limit, aber wie gesagt muesstest grad selbst testen ob es überhaupt einen gravierenden unterschied fuer dich macht, hängt ja auch von deinem system ab ;)

Der ursprüngliche Beitrag von 20:25 Uhr wurde um 20:26 Uhr ergänzt:

Ahem mit freq_limit_sleep=0 stellst du das limit ab nicht die freq auf 0 ;)
 
D

denyo81

Gast
Ok, danke habe es soweit verstanden. Bist du noch so gut und erklärst mir was ich mit der grad_up_threshold_sleep verändere wenn ich von 35 in 5er Schritten runter gehe?! Wie weit darf ich maximal runtergehen mit der freq. ohne Probleme zu bekommen?
Dem Namen nach zur Folge, müsste diese Einstellung was mit dem Akku sparen im Deep Sleep Modus zutun haben?!

Auch wenn ich einen 7200 mAh starken Akku zur Verfügung habe, steht Saft sparen für mich immer an erster Stelle. Wobei ich ungerne beim rumspielen auf die Performance verzichten möchte! :)
 
ZaneZam

ZaneZam

Stammgast
Damit änderst du das scaling verhalten und die sampling rate bei screen off so dass alles etwas schneller geht. Grad up 35 heisst wenn der load in einem stück 35% rauf geht wird das aktiviert wenn der wert niedriger eingestellt wird dann wirds empfindlicher also öfter geschalten.
 
Gamer-king

Gamer-king

Stammgast
Kannst du mir vielleicht erklären, wieso die Musikwiedergabe stottert wenn ich den zzmoove bei KK Ports verwende? Kann man das irgendwie beheben?
 
D

denyo81

Gast
Wenn du die Möglichkeit hast die minimale Taktrate auf 500 zu erhöhen. Dann hast du diese Probleme möglicherweise nicht mehr. Das hat mir auf jeden Fall geholfen. Ein Paar posts zuvor hatte ich dieses Problem schon mal etwas näher erläutert. Was für ein Telefon nutzt du? Und welche Rom?

Ich habe das GALAXY S3, Rom CM11, Kernel Boeffla.

Governor zzmove läuft bei mir auf dem Modus ''optimal'' Einstellungen sind alle Stock, außer das ich die minimale Taktrate von 200 GHz auf 500 GHz erhöht habe. Und die maximale Taktrate von 1400 GHz auf 1600 GHz

Das Problem liegt daran: Das der zzmove so eingestellt ist, dass er im Deep Sleep soviel wie möglich an Akku sparen soll. Aber da kann Dir der ZaneZam bestimmt noch ein paar präzisere Infos geben.

Ein paar Screenshots wie die Einstellungen bei mir aussehen, siehst du im Anhang.
 

Anhänge

Zuletzt bearbeitet von einem Moderator:
M

Micha_he

Ambitioniertes Mitglied
Man habe ich ein langsames S3 :) Das kann mit deinen 1,6 THz nicht mithalten !