Mitglieder surfen ohne Werbung: Jetzt kostenlos registrieren!

Hilfe bei Red Light Brick mit Sp Flash Tool

  • 31 Antworten
  • Neuester Beitrag
Diskutiere Hilfe bei Red Light Brick mit Sp Flash Tool im LeEco Le 2 Pro (X620/X52x) Forum im Bereich LeEco (LeTV) Forum.
feuerossi

feuerossi

Erfahrenes Mitglied
Moin moin
Da ich vor kurzem das Glück hatte, ein defektes LeEco LE2 pro x620 mir Red Light Brick in die Finger zu bekommen und es tatsächlich wieder herstellen konnte, möchte ich euch den Weg dort hin beschreiben. Das Problem sind die englischen Foren. Musste mich da auch erst und immer wieder durchwühlen.
Weil unter Win 10 immer Fehlermeldungen vom Flash Tool kamen, habe ich das ganze unter Win 7 gemacht. Ich dachte, Win 10 ist bekannt dafür, mit Mediatek Probleme zu haben. Aber die gleichen Fehlermeldungen kommen auch unter Win 7. Ist aber egal, es geht trotz dieser Fehlermeldungen.

So, geht los. Erst einmal die Treiber installieren. Ist bei Win 7 recht einfach, will ich auch nicht extra aufführen. Hier ist eine Top Anleitung
Anleitung MTK65XX USB VCOM Treiber Installation + Test: [CWM Recovery Flash]

Win 10 wird etwas komplizierter
Erst einmal muss Win 10 präpariert werden, damit man unsignierte Treiber einspielen kann
Windows 10 unsignierte Treiber installieren - code-bude.net

Die Treiber gibt es hier
Windows 10_MTK VCOM USB Preloader Drivers.zip | by skeleton1911 for Generic Device/Other

Kommen wir jetzt zu den Programmen, die ihr für das Phone braucht. Zum einen das Flashtool
Fehler (warum hier Fehler steht weiss ich nicht,Link geht)

desweiteren die Recovery
recovery_stock_works _after_brick.img

Damit sind die Vorarbeiten erledigt.
Öffnet jetzt den Ordner des Sp Flashtools. Startet die Flashtool.exe mit Rechtsklick, als Administrator ausführen.
Die Zeile mit dem Download Agent füllt ihr aus dem Ordner des Flashtools. Bitte den DA-PL Agent nehmen.
Die Scatter Datei aus dem LE2_SPFT_ROM Ordner. Die Android Scatter Datei nehmen, die nur Scatter geht nicht.
Jetzt drückt ihr die Tastenkombination "strg+alt+s". Eine weitere Zeile öffnet sich im Flashtool. Dort soll die auth file hinein. Findet ihr auch im Flashtool Orner unter Secureboot. Jetzt in den Kästchen die Haken bei recovery und boot rausnehmen.. Sollte bei euch so aussehen




Jetzt den Gerätemanager parallel öffnen, im Flashtool auf Download klicken, das Phone anschliessen. Im oberen Bereich des Gerätemanagers seht ihr, wie immer der Treiber MTK USB erscheint und wieder verschwindet. Ihr müsst den Zeitpunkt des Erscheines wählen, reinklicken und auf MTK Preloader wechseln. Jetzt sollte der rote Balken im Flashtool durchlaufen und eine Fehlermeldung erscheinen.


Nun kommt, was für das Flashtool nicht normal ist, aber es funktioniert. Die Fehlermeldung mit OK bestätigen, und erneut auf Download klicken. Kann sein, das ihr das öfter machen müsst. Ich habe 4 oder 5 mal bestätigt, und plötzlich lief das Flashtool los. Fragt mich nicht wieso, aber es geht. Haben einige auch so im englischen Forum beschrieben. Sollte anschliessend so aussehen

Jetzt nur das kleine Fenster mit dem Haken schliessen, Flashtool offen lassen, Phone abziehen.
Jetzt Tastenkombination "strg+alt+v" machen. Im Flashtool oben links auf Window klicken. Dort sollte dann die Schaltfläche "Write Memory" erscheinen. Draufklicken. In der Zeile File Path jetzt den Weg zur Recovery Datei
"recovery_stock_works _after_brick" suchen. In der Begin Adress Zeile löscht ihr alles und schreibt ihr 0x08000 rein.
Sollte dann so aussehen

Auf Write Memory klicken, Phone wieder einstecken. Normal soll der Schreibvorgang jetzt ohne Fehlermeldung durchlaufen. Wenn geschehen, Phone wieder abziehen.
Im Reiter auf Download wechseln. Jetzt die Haken bei Recovery und Boot wieder reinsetzen.
Auf Download klicken und beim Phone die Lautstärke Taste + jetzt gedrückt halten und einstecken.
Wenn jetzt das Flashtool durchläuft bis zum gelben Haken, habt ihr es geschafft. Phone abziehen, Powertaste gedrückt halten bis zum Neustart.
Es kann sein, das bei den ersten Schritten die Lautstärke Taste auch gedrückt werden muss beim Einstecken. Habe da verschiedene Versionen in den Foren gefunden. Bei mir hats auf diesem Weg geklappt.
Viel Erfolg :biggrin:
 
Zuletzt bearbeitet:
feuerossi

feuerossi

Erfahrenes Mitglied
feuerossi schrieb:
Bitte den DA-PL Agent nehmen.
Da ist mir ein Fehler unterlaufen. Aus dem Ordner Secureboot den DA-BR Agent nehmen
 
Mikehop

Mikehop

Stammgast
@feuerossi
Bei mir klappt deine Anleitung leider nicht, nach mehrmaligem erfolglosen Versuch mit meinem Windows 8 PC, habe ich unter deiner Anleitung
es mit dem Windows 7 Notebook meiner Frau probiert.
Nach erfolgreicher Treiberinstallation, kam bei mir auch immer der rote Balken beim Flash Tool.
Habe immer wieder mit OK die Fehlermeldung quittiert und erneut auf Download gedrückt mindestens 10 mal ohne Erfolg.
Hast du das Phone jedes Mal abgesteckt und wieder eingesteckt, oder einfach die USB Verbindung lassen.
Ich habe beides probiert, jedoch ohne Erfolg.
-- Dieser Beitrag wurde automatisch mit dem folgenden Beitrag zusammengeführt --
Am Schluss kam bei mir nach dem roten Balken noch ein violetter in dem stand "Download Bootloader 100 %"
 
feuerossi

feuerossi

Erfahrenes Mitglied
Sorry, viel um die Ohren zur Zeit.
Kommst du evtl jetzt in fastboot?
 
Mikehop

Mikehop

Stammgast
@feuerossi
Ja ich komme ins Fastboot
 
feuerossi

feuerossi

Erfahrenes Mitglied
Mikehop

Mikehop

Stammgast
Danke,
aber das habe Ich schon mehrmals gemacht, seit dem Fastboot Rom ist mein Bildschirm auf den Kopf um 180 Grad gestellt, und die Schrift Spiegelverkehrt, und der Touch reagiert nicht mehr.
-- Dieser Beitrag wurde automatisch mit dem folgenden Beitrag zusammengeführt --
Evtl. Ist sie fehlerhaft ??
-- Dieser Beitrag wurde automatisch mit dem folgenden Beitrag zusammengeführt --
Ich habe schon mal ne Fastboot Rom auf meinem X820 geflasht ohne Probleme.
Aber bei dieser hier stimmt was nicht.
Habe Die Batt.1 und die Bat. 2 ausprobiert
 
feuerossi

feuerossi

Erfahrenes Mitglied
Nein die rom ist ok. Musste sie selbst schon benutzen.
Hast du auch das x620?
-- Dieser Beitrag wurde automatisch mit dem folgenden Beitrag zusammengeführt --
Da bin ich mit meinem Latein auch am Ende
 
Mikehop

Mikehop

Stammgast
Ich habe das X622 aber das ist normalerweise egal ob X620 oder X622 oder X622 alles MTK Chips
 
feuerossi

feuerossi

Erfahrenes Mitglied
Denke mal Hardware Fehler
-- Dieser Beitrag wurde automatisch mit dem folgenden Beitrag zusammengeführt --
Lief es vor dem flashen normal?
 
Mikehop

Mikehop

Stammgast
"S3" heißt die Neuauflage des LE 2 auf der LeEco Seite sind die Roms gleich für S3 und Le 2 x620 da 100 Prozent identisch.
-- Dieser Beitrag wurde automatisch mit dem folgenden Beitrag zusammengeführt --
Ja vor dem flashen lief es normal wollte halt nur mal für den Ernstfall testen.
Und habe es somit mit der "Unbrick Rom" gebricked :cursing:
 
feuerossi

feuerossi

Erfahrenes Mitglied
Wie sieht die recovery aus, normal?
 
Mikehop

Mikehop

Stammgast
Bin eigentlich was das flashen angeht sehr erfahrenen (Hauptsächlich mit SD Modelle)
aber in diesem Fall bin ich auch mit dem Latein am Ende
-- Dieser Beitrag wurde automatisch mit dem folgenden Beitrag zusammengeführt --
Es ist dieses Chinesische TWRP drauf.
Ich kann auch das eui (works after brick) flashen über fast boot, aber nicht bedienbar zwecks Nicht reagieren des Touchscreens.
Das eui recovery man man auch über die seitlichen Tasten bedienen, somit wollte ich ne Rom als Update. Zip in den internen Speicher verschieben, klappt aber auch nicht, da das Gerät nicht erkannt wird im Recovery Modus.
-- Dieser Beitrag wurde automatisch mit dem folgenden Beitrag zusammengeführt --
Schade aber vielen Dank trotzdem für die Mühe
:thumbsup:
-- Dieser Beitrag wurde automatisch mit dem folgenden Beitrag zusammengeführt --
Ich muss sagen die Snapdragon Modelle sind wirklich besser.
 
feuerossi

feuerossi

Erfahrenes Mitglied
Da brauchst du das mit dem sp flashtool nicht weiter versuchen. Nutzt die gleiche rom zur Wiederherstellung
-- Dieser Beitrag wurde automatisch mit dem folgenden Beitrag zusammengeführt --
Schade, vielleicht findest ja noch eine Lösung.
 
JamBay

JamBay

Erfahrenes Mitglied
eBay ist auch ne Lösung :cool2:
Die Beschreibung finde ich aber sowas von eBay...
 
Mikehop

Mikehop

Stammgast
@JamBay
was sollte man sonst damit machen ???
Außerdem habe Ich
a: Den Fehler richtig beschrieben, und
b: ganz klar das Gerät als Defekt angeboten.
:flapper:
 
feuerossi

feuerossi

Erfahrenes Mitglied
@Mikehop
Lohnt sich nicht auf den Troll zu reagieren :lol:
 
Zuletzt bearbeitet:
pepe81

pepe81

Fortgeschrittenes Mitglied
Mahlzeit, vielleicht kann mir jemand weiterhelfen? Ich hatte gestern die grandiose Idee das Phone meiner Frau eine Custom ROM zu verpassen.

Was mach ich auf der Kommandozeile "fastboot reboot" - KLASSE, hätte man vorher wissen, dass man Handy damit fast tötet :D ... never again MTK!!!

Nun denn, nachdem ich mich am Sonntag Mittag in deutschen / englischen Foren durchgeschlagen hatte, konnte ich das X620 nach den "red light brick" irgendwie durch Zufall wieder zum laufen bringen! Erst "red state", dann "organge state", aber es lief ohne bootloop endlich wieder.

Soweit so gut, da ich gestern nur in WLAN mit dem Handy unterwegs war, stellte sich heute heraus, dass "Mobile Daten" mit AOSP ROM vom 05.10. nicht funktioniert. Hat jemand einen Tipp / Work around damit ich die "Mobile Daten" wieder zum laufen bringe? Zudem funktioniert die Ebay App nicht, gab es da eine Lösung?

VG
 
feuerossi

feuerossi

Erfahrenes Mitglied
Es gibt nicht eine custom rom, die anständig läuft. Mucken haben alle irgendwie. Und ich habe ALLE ausprobiert. Mit der Aosp hatte ich das gleiche Problem mit diversen Apps, liefen einfach nicht. Mobile Daten funktionierten allerdings bei mir.
Um dieses Phone anstandslos zu betreiben, wirst du bei der Stock bleiben müssen.
Lineage 14 ist im Moment in der Mache, aber auch da hapert es an allen Ecken und Kanten.
-- Dieser Beitrag wurde automatisch mit dem folgenden Beitrag zusammengeführt --
Da fällt mir noch ein, du weißt schon, das man mobile Daten noch mal extra anschalten muss? Auf das Icon und dann den Schalter umlegen.
Willst du SMS versenden und empfangen, musst du vom Playstore noch Aosp SMS installieren.​
 
pepe81

pepe81

Fortgeschrittenes Mitglied
Hi feuerossi,

das icon "Pfeil hoch/runter" für mobile Daten ist bei mir gar nicht vorhanden, unter den Einstellung sind Mobile Daten aktiviert! Wie bekomme ich das Stock ROM wieder auf dem X620 gespielt, über TWRP?
 
Ähnliche Themen - Hilfe bei Red Light Brick mit Sp Flash Tool Antworten Datum
0