LineageOS 17 möglich ?

  • 486 Antworten
  • Neuester Beitrag
Diskutiere LineageOS 17 möglich ? im LineageOS Forum im Bereich Root / Custom-ROMs / Modding für bq Aquaris X / X Pro.
Quallenauge

Quallenauge

Erfahrenes Mitglied
Zippen mit Passwort
Und dann hier hochladen: WeTransfer
Dann Link und PW per PM.
(Machmal muss der Link angepasst werden.)
 
Quallenauge

Quallenauge

Erfahrenes Mitglied
Kurze Frage noch: Welcher Player wird bei AntennaPOD angezeigt? (Einstellungen -> Wiedergegabe -> Medienabspieler).

Was steht bei Euch bei AudioFX: an oder angeschaltet ( und welcher Modus )?
 
mädschie

mädschie

Erfahrenes Mitglied
Audio FX an (kleiner Lautsprecher)
AntennaPOD ExoPlayer
 
lilax

lilax

Fortgeschrittenes Mitglied
Quallenauge schrieb:
Welches Headset benutzt Du? (Ich glaub zwar nicht dass es daran liegt, aber sicher ist sicher).
[...]
Nachtrag an alle mit dem Problem: Sind die Probleme beim Pro oder nur beim Non-Pro oder bei beiden vorhanden?
Ich nutze ein Aquaris X Pro und ein Bluetooth-Headset.
Quallenauge schrieb:
Was steht bei Euch bei AudioFX: an oder angeschaltet ( und welcher Modus )?
Genau wie bei @mädschie.
mädschie schrieb:
Audio FX an (kleiner Lautsprecher)
bzw. "Benutzerdefiniert" wenn ich übers Headset höre. Das ist aber sehr selten. Audio FX ist aber stets an.
 
G

Germelein

Erfahrenes Mitglied
Moin zusammen, ich antworte mal eben formlos:
- Wie lange (ungefähr) lief das Telefon bis es verstummte?
=> Mehrere Stunden, ca. 3-4h.

- Du nutzt AntennaPOD, sind da irgendwelche Einstellungen bzgl. Wiedergabe gesetzt? Welcher Player ist dort ausgewählt?
=> Bei mir ist "Androids eigener Abspieler" eingestellt.

- Hast Du Audio-Effekt Apps im Einsatz (evtl. auch Plugins über Magisk?)
=> ja, AudioFX ist an, Effekt ist "Normal" (wusste garnicht, dass ich sie angestellt hatte...ist das per Default angestellt bei LOS?)
=> kein Magisk in Benutzung

oder Einstellungen gesetzt und wenn ja, welche?
=> folgende:
- Kopfhörer-Trennung
- Kopfhörer wieder eingesteckt
- Nach Anruf fortsetzen
- Downloads einreihen
- Duchgehendes Abspielen
- Behalte übersprungene Episoden


- Welches Headset benutzt Du? (Ich glaub zwar nicht dass es daran liegt, aber sicher ist sicher).
=> House of Marley, Smile Jamaica (Kabel-Headset mit Mikrofon und Kabelbruch, rechter Kopfhörer geht mal und mal nicht)
Beitrag automatisch zusammengefügt:

@Quallenauge : Habe meinen Eintrag nochmal aktualisiert.:
 
Zuletzt bearbeitet:
Bearbeitet von Germelein - Grund: Audioeffekte sind doch eingeschaltet
mädschie

mädschie

Erfahrenes Mitglied
Guten Morgen,
seit Mittwoch hat sich der Eingabezeitpunkt des Passworts bei mir geändert. Bisher war die Eingabe des Passworts immer in der Mitte der Hochfahrprozedur. Jetzt kommt die Eingabe am Ende. Gerade wurde ich beim heutigen Update im TWRP-Recovery auch nicht wie sonst nach dem Passwort gefragt. Laut System ist mein Smartphone aber immer noch verschlüsselt.
Wie kommt das?
 
Quallenauge

Quallenauge

Erfahrenes Mitglied
@mädschie Hallo, geändert wurde an der Stelle nichts.
Verschlüsselung heißt auch, dass der Inhalt der eMMC mit einem Standardpasswort verschlüsselt wird. Das kennt Android und auch TWRP und fragt daher nicht nach dem Schlüssel. (Das muss jetzt nicht vollständig stimmen...soweit ich mich erinnern kann.) Erst wenn man in den Sicherheitseinstellungen -> "Displaysperre wählen" -> Muster/Pin/Passwort das Passwort setzt, wird man nach dem "Sicheren Start" gefragt. Dann wird ein spezielles Passwort gesetzt, was auch beim nächsten Start bzw. in TWRP abgefragt werden sollte. Vielleicht wurde hier irgendwas "zurückgesetzt", probiere doch einfach das Ding nochmal zu setzen.
Beitrag automatisch zusammengefügt:

Übrigens, gestern hatte ich den Soundbug zum ersten Mal bei mir. Also schnell alle Logs gezogen und auch das mit dem TinyMix gemacht und mit einem funktionierenden System verglichen. Ich konnte Unterschiede feststellen 🙃
TLDR; Ich kenne die Ursache nicht wirklich, hätte aber einen Workaround:
Kann jemand diese Datei auf sein Gerät spielen und mal probieren das Verhalten beobachten?
Diese Datei audio_platform_info.xml herunterladen und /system/vendor/etc/audio_platform_info.xml
kopieren (im TWRP).

PS: Ich habe mich nicht mit einem verkabelten Headset verbunden. Es hat scheinbar nichts damit zu tun.
 
Zuletzt bearbeitet:
mädschie

mädschie

Erfahrenes Mitglied
Ich nutze auch ein kabelgebundenes Headset...
Wie lade ich die Datei herunter 🤯?
 
H

Henning_H

Fortgeschrittenes Mitglied
Ich habe das heutige Update installiert, inkl. Aug. Sicherheitspatch. Lief ohne jegliche Probleme👍
 
lilax

lilax

Fortgeschrittenes Mitglied
@mädschie Also am Desktop mit Firefox: Rechtsklick -> Ziel speichern unter. Aufm Handy kriege ich das auch nicht gebacken. Komplizierte Umwege würden mir einfallen...

Ich würde ja echt gerne helfen, aber ich hatte den Soundbug nur 1x. War zwar extrem ärgerlich, weil mein Wecker nicht geklingelt hatte, aber seitdem lief alles wieder. Wüsste auch nicht wie ich das reproduzieren könnte. Von daher wäre ich keine Hilfe.
 
K

Kai B

Ambitioniertes Mitglied
Hm, ich habe eben auch die aktuelle Version installiert. Leider startete das Bq danach nicht mehr. Es hielt direkt am Anfang, beim Bq Schriftzug, an.
Ich habe dann eine ältere Version genommen, jetzt startet es wieder.
Hat noch jemand dieses Problem?
 
G

Germelein

Erfahrenes Mitglied
Quallenauge schrieb:
Übrigens, gestern hatte ich den Soundbug zum ersten Mal bei mir. Also schnell alle Logs gezogen und auch das mit dem TinyMix gemacht und mit einem funktionierenden System verglichen. Ich konnte Unterschiede feststellen 🙃
TLDR; Ich kenne die Ursache nicht wirklich, hätte aber einen Workaround:
Kann jemand diese Datei auf sein Gerät spielen und mal probieren das Verhalten beobachten?
Diese Datei audio_platform_info.xml herunterladen und /system/vendor/etc/audio_platform_info.xml
kopieren (im TWRP).

PS: Ich habe mich nicht mit einem verkabelten Headset verbunden. Es hat scheinbar nichts damit zu tun.
Moin @Quallenauge,
ich habe die Dateien ausgetauscht und werde es beobachten. EIne Neugierfrage habe ich aber noch: Was macht der Workaround denn im Detail? ;)

Mit Dank und Gruß,
G.
Beitrag automatisch zusammengefügt:

Kai B schrieb:
Hm, ich habe eben auch die aktuelle Version installiert. Leider startete das Bq danach nicht mehr. Es hielt direkt am Anfang, beim Bq Schriftzug, an.
Ich habe dann eine ältere Version genommen, jetzt startet es wieder.
Hat noch jemand dieses Problem?
Nein, bei mir funktioniert die aktuelle Nightly "17.1-20200808" reibungslos. Ich habe mir allerdings angewöhnt, vor Einspielen eines Updates meinen Pin (und somit die Laufwerksverschlüsselung) rauszunehmen. Evtl. hakt da etwas bei dir?
 
Zuletzt bearbeitet:
G

Germelein

Erfahrenes Mitglied
@Quallenauge : Was mir noch gerade einfällt: Gerade sind ja von Checkpoint ~400 Lücken im Qualcomm Snapdragon DSP gefunden worden (Quelle: Sicherheitslücken: Millionen Smartphones mit Snapdragon-Chip verwundbar - Golem.de) , die meines Wissens nur per proprietärem Firmware Blob gefixt werden. Da BQ ja keine Firmwareupdates mehr raushaut (und somit die Fixes von Qualcomm nicht an die Endgeräte weiterverteilt) und mein Threat bei mibqyyo.com kurz nach Eröffnung wieder gelöscht wurde, sehe ich hier auch weiterhin keine Abhilfe/Unterstützung seitens BQ.

Meine Frage daher an dich: Werden/wurden die o.g. Exploits über die AOSP gefixt, oder planst du für unsere LineageOS-ROM mittelfristig, die Firmwareblobs eines "verwandten", ggf. noch supporteten Smartphones (mit gleichem SOC, z.B. Meizu 15) einzupflegen?

Mit Dank und Gruß,

G.
 
Zuletzt bearbeitet:
Quallenauge

Quallenauge

Erfahrenes Mitglied
@Germelein Kann ich gerade gar nichts dazu sagen, da ich keine Kenntnis habe, wo genau hier was geändert werden muss.
Die Blobs in der modem-Partition aus einem Dump eines anderen Smartphones zu nutzen wird meistens fehl schlagen, da diese digital signiert sind. Die Loader für diese Dateien prüfen diese Signatur und vergleichen diese mit der Vorgabe im Telefon, siehe:
https://www.qualcomm.com/media/docu...ge-authentication-technical-overview-v2-0.pdf

Wenn es natürlich über den Kernel abgewickelt werden kann, dann sollte die Lücke ja bald gefixt sein.
 
Zuletzt bearbeitet:
lilax

lilax

Fortgeschrittenes Mitglied
@Henning_H Also beim Pro gibt's den aktuellen Sicherheitspatch leider noch nicht :-(
 
H

Henning_H

Fortgeschrittenes Mitglied
@lilax
ich habe die nicht Pro Version. Security Patch Date 5.8.2020.
 
A

AndroidIAm

Neues Mitglied
Zuletzt habe ich mein XPro (dirty upgrade) regelmäßig (also wöchentlich) geupdated, aktuell also der Build vom 08. August.

Zwischenzeitlich hatte ich Probleme mit dem Touch, während mein In-Ear-Headset eingesteckt war. Diese scheinen jetzt nicht mehr zu bestehen.

Neu hinzugekommen und immer noch vorhanden sind leider unvermittelte Abstürze mit Neustart im Betrieb als Hotspot. Für mich leider ein wichtiger Anwendungsfall.

Das "Flackern" habe ich sicherlich nicht ganz glücklich bezeichnet. Was ich damit meinte war, dass sich Bildschirme mti einer wandernden Linie aufbauen, bzw. dass der Screen schon steht aber diese Linie vertikal "darüberläuft". Wenn ich schätzen solle würde ich sagen, dass das ca. 125 ms dauert. Diesen Effekt sehe fast nirgends mehr, außer auf einem F-Droid Screen.

Immer noch sehe ich falsche Doubletten von App-Vorschau Bildern.
 
A

AndroidIAm

Neues Mitglied
Ausserdem habe ich seit kurzer Zeit leider Probleme mit dem WiFi-Handoff zwischen meinen Access Points mit identischen 2.4- und 5-GHz-SSIDs. Wenn ich das richtig sehe, ist der Wechsel auf einen anderen AP mit 2.4 GHz zu zögerlich, wenn das Gerät vorher auf 5 GHz eingependelt war. Jedenfalls habe ich bei Bewegung zwischendurch gar kein WiFi-Empfang mehr. Das lief vor kurzer Zeit mit denselben Settings noch reibungslos.
 
lilax

lilax

Fortgeschrittenes Mitglied
Ich hab jetzt auch mal die audio_platform_info.xml ausgetauscht. Hab die ganze Zeit gezögert, weil ich darauf gehofft hatte, dass dieser Fix schnell in die aktuellen Builds mit einfließt, aber das Changelog sieht ja nicht danach aus. Oder hab ich mich da verguckt?

Wie dem auch sei. Kam ja nix mehr zu diesem Thema. Deshalb geh ich einfach mal davon aus, dass dieser Workaround funktioniert. Und ich wollte endlich wieder meinem Handywecker vertrauen können. Vielen Dank, @Quallenauge =)

@AndroidIAm Ich war auch erst mit einem Dirty Flash unterwegs. Teilweise hab ich meine Probleme durch eine saubere Neuinstallation beheben können. Insbesondere dieses Doubletten-Problem sollte behoben werden. Da geh ich zumindest ganz stark von aus.
Thema WLAN ist super schwierig mit unserem X (pro), ich fahre am besten mit 2,4 GHz only.
 
Ähnliche Themen - LineageOS 17 möglich ? Antworten Datum
18
2
1