Ubuntu / Netbook-Linux auf AC100

  • 712 Antworten
  • Neuester Beitrag
Diskutiere Ubuntu / Netbook-Linux auf AC100 im Linux auf Android Forum im Bereich Sonstige Betriebssysteme für mobile Geräte.
1

12smatty

Neues Mitglied
Hallo AC100 Fans (wenn es noch welche gibt?)

Ich habe mit vor ein paar Tagen dieses tolle Teil gekauft. Obwohl 4 Jahre alt und nur Android 2.2, bin ich doch sehr angetan von diesem Netbook.

Es gibt ja schon seit geraumer Zeit ein Lubuntu Trusty Tahr 14. Die Installationsanleitung ist aber für Version 12 und die deutsche Tastatur muss angepasst werden.

Daher die Frage, wer hat das allerneueste Preinstalled Bootimg drauf und kann was dazu sagen? Eine schöne Installationsanleitung gibts nämlich auch noch nicht:)

Auch wenn ich keinen Playstore brauche und ohne Flash leben kann...reizen würde es mich ja schon.

Die vorangegangenen Versionen konnten wohl auf Dauer niemanden überzeugen, deshalb wäre ich sehr dankbar für ein Feedback zur letzten Version bevor ich mich 2 Stunden plus damit befasse, und vielleicht wieder rückwärts...

Grüßle
 
Zuletzt bearbeitet:
peter334

peter334

Erfahrenes Mitglied
Kann mich nicht an eine bemerkenswerte Verbesserung bei 14.04 erinnern, aber warum eine ältere Version installieren? Von der Vorgehensweise müsste es gleich sein.
Das Teil ist schon praktisch und klein, allerdings stoße ich beim RAM immer an die Grenzen des Gerätes, deswegen wird es auch nur noch sehr selten benutzt.
 
P

pibach

Gesperrt

Ich nutze das auch schon seit Jahren nicht mehr, überlege aber, es mal wieder zu reaktivieren...
 
J

janemann77

Stammgast
Habe meins nun mal reaktiviert und nun Android 4 drauf.
Bin soweit auch zufrieden. Werde es die Tage aber noch ausführlicher testen. Habe aber das Gefühl, das es nun etwas langsamer reagiert und ich kann nicht auf einen angeschlossenen USB-Stick zugreifen. Vielleicht hat ja jemand eine Lösung dafür.

Gruß janemann
 
V

verzweifelt1

Neues Mitglied
Hi zusammen,

also Ich zweifle langsam an meinem Verstand :D
Ich versuche seit mehr als zwei wochen ubuntu auf mein ac100 zu installieren, aber irgendwie will das blöde ding nicht so wie Ich will ...
Ich befolge die Anleitung bei folgendem link: ARM/TEGRA/AC100 - Ubuntu Wiki .
Als erstes mache Ich das was unter folgendem Punkt steht :
nvflash

The bootimage needs to be flashed via a mini-USB cable and using the nvflash tool.
This image when booted will set up the internal storage using a tarball provided on a USB stick or SD card.

danach befolge Ich die Anleitung weiter wie unnter dem ersten link beschrieben (ohne das ac100 abzustöpseln oder ähnliches, und dann steht in meinem terminal nvflash started... aber danach kommt nichts mehr :(
Mache Ich etwas falsch oder bin Ich vielleicht einfach zu ungeduldig ? (Ich warte meist ca 30 min bevor Ich dann alles abstöpsel und herunterfahre...)

Hier mal noch die auszüge aus dem terminal...

sk@sk-ThinkPad-R61e ~ $ cd /tmp
sk@sk-ThinkPad-R61e /tmp $ wget http://share.grandou.net/deb20110628-2_all.deb _
--2015-08-23 04:15:50-- http://share.grandou.net/debian/nvflash/nvflash_20110628-2_all.deb
Auflösen des Hostnamen »share.grandou.net (share.grandou.net)«... 213.186.33.19, 2001:41d0:1:1b00:213:186:33:19
Verbindungsaufbau zu share.grandou.net (share.grandou.net)|213.186.33.19|:80... verbunden.
HTTP-Anforderung gesendet, warte auf Antwort... 200 OK
Länge: 4222 (4,1K) [application/x-debian-package]
In »»nvflash_20110628-2_all.deb.1«« speichern.

100%[======================================>] 4.222 --.-K/s in 0,1s

2015-08-23 04:15:52 (39,2 KB/s) - »»nvflash_20110628-2_all.deb.1«« gespeichert [4222/4222]

sk@sk-ThinkPad-R61e /tmp $ sudo dpkg -i nvflash_20110628-2_all.deb
[sudo] password for sk:
(Lese Datenbank ... 162786 Dateien und Verzeichnisse sind derzeit installiert.)
Vorbereitung zum Entpacken von nvflash_20110628-2_all.deb ...
Entpacken von nvflash (20110628-2) über (20110628-2) ...
nvflash (20110628-2) wird eingerichtet ...
sk@sk-ThinkPad-R61e /tmp $ nvflash --bl /usr/lib/nvflash/fastboot.bin --download 6 /path/to/lubuntu-12.10-preinstalled-desktop-armhf+ac100.bootimg
Nvflash started


...tja und das wars dann wiegesagt für 30 min (länger hab Ichs bisher nicht durchgehallten)
Wäre toll wenn mir jemand helfen könnte :))
LG
 
peter334

peter334

Erfahrenes Mitglied
Ist bei mir schon etwas her ... aber liegt deine "fastboot.bin" wirklich unter /usr/lib... ?

Versuch doch mal die Datei aus dem Archiv dieser Anleitung.
 
V

verzweifelt1

Neues Mitglied
Hi Peter,

Ich habe das rad nochmal gecheckt und ja, die fastboot.bin liegt genau unter /usr/lib/nvflash...
Ich habe mir jetzt auch nochmal die Datei aus dem Archiv neu geladen, und mein system sagt mir dann auch dass diese Version bzw eine aktuellere bereits installiert waere...
Ich kanv dann aber trotzdem auf erneuern druecken.
(hab Ich gemacht...)

Ich hab dann jetzt nochmal das komplette programm von vorne an durchgespielt aber das Ergebniss bleibt dass gleiche :(
nvflash started ercheint noch...und das wars dann...

Hast du vielleicht noch eine idee was Ich versuchen kann ?
...fange hier echt langsam an zu verzweifeln... so wie sich das ueberall liest scheint dass doch recht einfach zu sein Ubuntu aufs ac100 zu spielen. -nur Ich bin iwie zu doof dafuer :-D

danke schonmal fuer deine hilfe :)
gruss
 
peter334

peter334

Erfahrenes Mitglied
@verzweifelt1
Hast du mal probiert nvflash mit sudo zu starten?
 
V

verzweifelt1

Neues Mitglied
Hi Peter,

sorry für die verspaetete Antwort. Ja, hab Ich in der zwischenzeit auch mal versucht...muss sagen dass Ich ein absoluter gruenschnabel bin :-D ...
Also wenn Ich "sudo nvflash" mach,dann bekomm Ich 'ne grosse Auswahl an oeglichen optionen,siehe hier...
Nvflash started
nvflash action [options]
action (one or more) =
--help (or -h)
displays this page
--cmdhelp cmd(or -ch)
displays command help
--resume (or -r)
send the following commands to an already-running bootloader
--quiet (or -q)
surpress excessive console output
--wait (or -w)
waits for a device connection (currently a USB cable)
--create
full initialization of the target device using the config file
--download N filename
download partition filename to N
--setboot N
sets the boot partition to partition N
--format_partition N
formats contents of partition N
--read N filename
reads back partition N into filename
--getpartitiontable filename
reads back the partition table into filename
--getbit filename
reads back BIT into filename
--getbct
reads back the BCT from mass storage
--odm C Data
ODM custom 32bit command 'C' with associated 32bit data
--go
continues normal execution of the downloaded bootloader
options =
--configfile filename
indicates the configuration file used with the following commands:
--create, --format_all
--bct filename
indicates the file containing the BCT
--sbk 0x00000000 00000000 00000000 00000000
indicates the secure boot key for the target device
--bl filename
downloads and runs the bootloader specified by filename
--odmdata N
sets 32bit customer data into a field in the BCT, either hex or
decimal
--diskimgopt N
sets 32bit data required for disk image convertion tool
--format_all
formats all existing partitions on the target device using the config file,
including partitions and the bct
--setbootdevtype S
sets the boot device type fuse value for the device name.
allowed device name string mentioned below:
emmc, nand_x8, nand_x16, nor, spi
--setbootdevconfig N
sets the boot device config fuse value either hex or decimal
--verifypart N
verifies data for partition id = N specified. N=-1
indicates all partitions
Intended to be used with --create command only.
--setbct
updates the chip specific settings of the BCT in mass storage to
the bct supplied,used with --create, should not be with --read,and
--format(delete)_all,format(delete)_partition,--download, and--read
--sync
issues force sync commad
--rawdeviceread S N filename
reads back N sectors starting from sector S into filename
--rawdevicewrite S N filename
writes back N sectors from filename to device starting from sector S
--updatebct <bctsection>
bctsection should refer to the section of the bct we are updating.
Curently we suport updates for following sections
<SDRAM> updates SdramParams and NumSdramSets fields
<DEVPARAM> updates DevParams, DevType and NumParamSets
<BOOTDEVINFO> updates BlockSizeLog2, PageSizeLog2 and PartitionSize

Bloederweise bringt mich dass aber noch nicht weiter... -_-
Ich habe inzwischen auch mal android auf 2.2 upgedatet da Ich gedacht hab es koennte daran liegen, ...leider Fehlanzeige. Hat nichts gebracht... :(

Gibts es denn nicht irgendeine moeglichkeit da ein evtl neueres OS von linux evtl per cd via extern lfwaufzuspielen?

schonmal danke fuer deine Muehe :)
gruss
 
peter334

peter334

Erfahrenes Mitglied
Soweit ich weiß, gibt es keine andere Möglichkeit.

Ich meinte damit sudo davor zu setzen, also:
Code:
sudo nvflash --bl /usr/lib/nvflash/fastboot.bin --download 6 /path/to/lubuntu-12.10-preinstalled-desktop-armhf+ac100.bootimg
Die Pfade natürlich entsprechend anpassen zu fastboot und dem lubuntu image.
 
V

verzweifelt1

Neues Mitglied
ok, dann hatte Ich das falsch verstanden... Ich lass gerade die Variante wie von dir beschrieben durchlaufen.
Aktuell stehen wir wieder bei nvflash started (seit ungefaehr 15min)
Ich finde es super doof dass man nicht sieht ob bzw was im Hintergrund passiert :(
 
peter334

peter334

Erfahrenes Mitglied
verzweifelt1 schrieb:
Aktuell stehen wir wieder bei nvflash started (seit ungefaehr 15min)
Da hätte schon lange etwas passieren müssen.
Wenn du nach der Anleitung hier gehst und die Schritte genau so ausführst um die Verbindung herzustellen, sollte es funktionieren.
Mit den Download Befehl (auf deinen Pfad angepasst):
Code:
nvflash -r --download 6 /path/to/lubuntu-preinstalled-ac100.bootimg
Wenn das nicht klappt, habe ich auch keine Idee mehr ...
 
peter334

peter334

Erfahrenes Mitglied
@verzweifelt1
Wurde an dem Gerät schon mal ein neues System geflashed?

Wenn ich mich recht erinnere, musste man für einen neueres android (4.x?) bzw. einen neueren kernel auf eine normale Partitionstabelle (GPT) wechseln und den bootloader von fastboot zum universal bootloader.
Das würde vielleicht erklären warum nvflash nicht funktioniert, habe mich damit aber nie befasst.
 
Zuletzt bearbeitet:
Ähnliche Themen - Ubuntu / Netbook-Linux auf AC100 Antworten Datum
3
37