Root für das Lifetab

  • 128 Antworten
  • Neuester Beitrag
Diskutiere Root für das Lifetab im Medion Lifetab S10333 / S10334 Forum im Bereich Medion Forum.
G

Geradeaus

Neues Mitglied
Danke für die Antwort, daddle.

Vielleicht gibt es jemanden hier im Forum, der in meiner Nähe wohnt und das Rooten für mich mal macht? Für ein Bier oder so.........
Wohne in Münster /Westfalen
Gruß
Geradeaus
 
longolong

longolong

Fortgeschrittenes Mitglied
So, habe es gestern Abend auch erfolgreich gerootet, dank daddles hervorragender Anleitung. Danke dafür! War nicht wirklich schwer, obwohl man sich als Linux-Neuling erst mal orientieren muss, wo denn bei Kubuntu die Konsole und der Explorer ist ... und irgendwie hatte ich eine amerikanische Tastaturbelegung, na egal, -zbackup konnte ich dann trotzdem eingeben. Also Hürde eher bei Linux als bei kkorc, da lief alles bestens. Und gerootet habe ich doch ein besseres Gefühl, z.B. wenn ich den Apps die ganzen Schnüffel-Berechtigungen entziehen kann.
 
Schnuppe

Schnuppe

Experte
Auch ich habe es gepackt. Hat etwas gedauert, bis ich im Flash-Modus war. Bei mir lag es schlussendlich daran, dass ich am Ende beide Tasten gleichzeitig losgelassen habe. Erfolg stellte sich erst ein, als ich erst die Powertaste und dann die +Taste losgelassen habe.
Linux und die amerikanische Tastatur war ein kleines Problem, ging aber ( das "-" könnt ihr mit "ß" eingeben).

Nun ist mit Adaware die Werbung weg und meine Spielstände habe ich mit Titanium-Backup auf neue Tab übertragen. Mit Xposed Framework noch die Akkuanzeige in Prozent gestellt. Dann war der Abend auch schon rum.

Danke für die Anleitung daddle!
 
D

daddle

Lexikon
Schnuppe schrieb:
Hat etwas gedauert, bis ich im Flash-Modus war. Bei mir lag es schlussendlich daran, dass ich am Ende beide Tasten gleichzeitig losgelassen habe. Erfolg stellte sich erst ein, als ich erst die Powertaste und dann die +Taste losgelassen habe.
Linux und die amerikanische Tastatur war ein kleines Problem, ging aber ( das "-" könnt ihr mit "ß" eingeben).

Danke für die Anleitung daddle!
Hallo, Glückwunsch! Es ist in der Tat etwas schwierig den exakten Zeitpunkt zu treffen, zu dem man am besten beide Tasten loslässt.
Es ist ein grosser Unterschied ob ich 1 bis 4 oder langsam 21 bis einschliesslich 24 zähle, das schwankt zwischen 2 und bis zu 6 echten Sekunden! Aber es ist egal ob du erst Power loslässt, oder beide gleichzeitig. Entscheidend ist das Zeitfenster.Zeitbestimmend ist zwar die Powertaste, da mit Drücken derselben das Zeitintervall (Neu: 4-5 Sekunden!) beginnt und mit dem Loslassen endet, aber in über 50 mal den Flashmodus aufrufen funktionierte es bei mir immer mit dem gleichzeitigem Loslassen beider Tasten!

Aktualisiert:

Mein Tip: Zum Zeitpunkt des Drückens der Powertaste für 4-5 Sek. in Gedanken zügig 21-22-23-24 ... zählen, dann beide Tasten loslassen!

Alternativ kann man die von @untergrundbiber gepostete Tastenfolge mit gleichzeitigem Einsatz des USB-Kabels benutzen; damit ist man vom Zeitfenster unabhängiger.
Dafür ist es aber fummeliger, jetzt muss man die Vol.(-) Taste nehmen: es sind gleichzeitig die Vol.(-) Taste gedrückt zu halten, dann die Powertaste zu drücken u. zeitgleich das bereits am Micro-USB-Port eingesteckte USB-Kabel mit dem USB-Stecker am PC in den USB-A-Port einstecken.

Die Gefahr dabei wäre in der "Hektik" den USB-Port nicht gleich zu treffen, also alles schön gelassen angehen, auch wenn einem dann in aller Regel die dritte Hand fehlt. :sad:

Habe selbst alle Varianten nach Erwerb des E10334 ausgetestet und finde meine gepostete Methode letztlich als einfacher und sicherer.. Man kann dabei nichts verkehrt machen, ausser vielleicht zu langsam oder zu schnell (s.o.) gezählt zu haben. Die einzige Folge ist, dass man es manchmal zwei oder drei mal versuchen muss das Zeitfenster zu treffen. Und was solls? Keine unnötige Eile dabei nötig.

daddle
 
Zuletzt bearbeitet:
Mechanoid1

Mechanoid1

Erfahrenes Mitglied
Recht hast du.

Ich habe die Variante mit USB genommen welche auch beim gleich beim ersten Anlauf funktioniert hat.

Alles im allen muss ich sagen, dass das flashen dennoch recht zügig von statten ging. Habe zwar keine Zeit gestoppt, aber länger als 15min hat es nicht gedauert. Auch von mir deswegen nachträglich ein fettes Dankeschön.
 
D

daddle

Lexikon
Da ich ja mit den Vorbesitzern, die das Tab letzte Woche bei Aldi-Nord gekauft hatten, die Root-Frage bereits geklärt habe, poste ich zum schnelleren Auffinden hier nochmal den Link. Das Rooten funktioniert einwandfrei!

Hilfreich ist es trotzdem sich die einzelnen Beiträge des Thread durch zu lesen, damit nicht erneut die gleichen Fragen gestellt werden und ein paar Tipps und Antworten zu euren kommenden Fragen sind auch schon drin! :winki:

daddle
 
Zuletzt bearbeitet:
longolong

longolong

Fortgeschrittenes Mitglied
Hallo,

jetzt habe ich nochmal eine Frage zum Unrooten, denn ich will das Tab zurückgeben. Habe es dank der Anleitung von daddle mit dem Android Terminal Emulator wie hier beschrieben auch hinbekommen, aber jetzt habe ich immer noch SuperSU drauf! Und diese App kann ich auch nicht löschen, nur deaktivieren .... Oder verschwindet das dann wenn ich den Reset auf Werkseinstellungen mache?

Ich will das Ding natürlich ohne jeden Hinweis auf das Rooten zurückgeben ....
 
D

daddle

Lexikon
Hattest du ein Update der SuperSu gemacht? Das könnte das Erklären.

Lösungen:

1. Factory-Reset sollte die App löschen, es könnten aber die su-binaries unter /system/xbin verbleiben, obwohl die durch unroot entfernt werden sollten. Aber nach einem Binaries-Update vielleicht nicht. Kann man aber nicht kontrollieren, da es ohne Root keinen Lesezugriff mehr auf das Verzeichnis gibt.

2. Erneut rooten. Terminal aufrufen, "Unroot" tippen, noch nicht bestätigen! Dann In der SuperSU.App in Einstellungen -> Runter scrollen auf - Bereinigung -> Vollständiges Un-Root wählen, dann erst den Befehl im Terminal mit Return bestätigen. Danach erst ein factory-reset machen!

3. Dein Backup, dass du vor dem Rooten gemacht und gesichert haben solltest, wieder mit ./kkorc -zrestore zurückflashen. Falls du das komprimierte backup mit -zbackup gemacht hast wie angegeben war. (Falls du dein Backup nur mit -backup gemacht hattest, musst du natürlich den anderen Parameter -restore nehmen). Das löscht auf jeden Fall alle Spuren vom Rooten in der System.
Danach noch einen Factory-reset, um deine root-pflichtigen Anwendungen und die bis zum Backup vorgenommenen Einstellungen (Google-Konto!), Installationen und bis zum Backup angesammelten Daten zu löschen.

Lies bitte auch hier
 
Zuletzt bearbeitet:
longolong

longolong

Fortgeschrittenes Mitglied
@daddle: o. k., ich probiere das erst mal mit 1) aus, das ist der leichteste Weg. Dauert noch ein paar Tage, weil ich das Tab noch so lange behalte bis mein neues von Samsung da ist. Ich werde hier dann mal Bericht erstatten. Danke!
 
D

daddle

Lexikon
longolong schrieb:
Hallo,

jetzt habe ich nochmal eine Frage zum Unrooten, denn ich will das Tab zurückgeben. Habe es dank der Anleitung von daddle mit dem Android Terminal Emulator wie hier beschrieben auch hinbekommen, aber jetzt habe ich immer noch SuperSU drauf! Und diese App kann ich auch nicht löschen, nur deaktivieren .... Oder verschwindet das dann wenn ich den Reset auf Werkseinstellungen mache?
longolong schrieb:
@daddle: o. k., ich probiere das erst mal mit 1) aus, das ist der leichteste Weg. Dauert noch ein paar Tage, weil ich das Tab noch so lange behalte bis mein neues von Samsung da ist. Ich werde hier dann mal Bericht erstatten. Danke!
War das doch eher eine hypothetische Frage? Das wundert mich jetzt doch, denn in der Unroot-Routine ist die App-Deinstallation mit drin und bei meinen Tabs wurde die App mit deinstalliert, auch nach dem Binaries-Update!.

Auf jeden Fall gibt es in der App selber unter Einstellungen, runterscrollen bis zum Eintrag "Bereinigung" drei Möglichkeiten, hier vollständiges 'Unroot' wählen, falls die App nach dem "unroot" tatsächlich verbleiben sollte!
 
Zuletzt bearbeitet:
T

topsurfer

Fortgeschrittenes Mitglied
Hallo,
ich komme nicht in den Flashmodus (Tab startet immer normal durch..
Verwende allerdings gerade nicht das original Kabel, sondern ein anderes Kabel (am PC angeschlossen zeigt es aber auch "USB Gerät erkannt" und "Ladesymbol" an).

Halte mich eigentlich an die tolle Anleitung; Tab ist aus, USB Kabel rein (in mit kubuntu gebooteten PC, an USB2 Port), warten bis grosses BattSymbol ausgeht, Vol+ drücken (und gedrückt halten), nach 0.5s die Powertaste drücken (und gedrückt halten), nach 3s lasse ich Vol+ und Power los.
Aber nach 5s erscheint der Bootvorgang :-(

Habe jetzt 10 Versuche mit leicht unterschiedlichen "Zeiten", alles erfolglos.

Liegts an dem nicht original Kabel??? Übersehe ich was?
 
D

daddle

Lexikon
Vermute du hast ein nur Ladekabel genommen, ohne Datenleitung, oder mit falschem Ohm'schen Widerstand zwischen den Leitungen > original Kabel nehmen. Warum hast du das nicht genommen wie es in der Anleitung steht?

Wenn das Tab durchstartet, kann auch die Haltezeit der Tastenkombi etwas zu lang (oder zu kurz?) sein. Ausprobieren, mal bis 4 zählen, falls du nur 1 2 3 zählst; wenn du in Gedanken einundzwanzig, zweiundzwanzig ... zählst, dann kann die Phase auch zu lang sein. Und du musst warten bis das Akkusymbol erloschen ist, das zeigt dass das Tab wirklich aus war vor dem neuen Versuch. Sonst auch mal Kabel ab- und wieder anstecken, Akkusymbol weggehen lassen und neu versuchen.

Alternativ kann man die von @untergrundbiber gepostete Tastenfolge mit gleichzeitigem Einsatz des USB-Kabels benutzen; damit ist man vom Zeitfenster unabhängiger:
Dafür ist es aber fummeliger: Jetzt hierfür die Vol.(-) Taste nehmen!), die Vol.(-) Taste gedrückt halten, dann die Powertaste drücken und zeitgleich mit der Powertaste das bereits am Tab eingesteckte USB-Kabel mit dem USB-Stecker in den PC-USB-Port einstecken! daddle
 
Zuletzt bearbeitet:
T

topsurfer

Fortgeschrittenes Mitglied
Hi, mit der untergrundbiber-Variante hat es auf Anhibe funktioniert, zumindest zeigt mir lsusb "2207:310b" an !
Die andere Variante habe ich wie geschrieben 10x mit leichten zeitlichen Änderungen erfolglos versucht.

Tipp: Das Micro-USB war im Tablet eingesteckt, habe das normale USB, das beim drücken der Tasten eingesteckt werden muss, für das zeitkritische einstecken verwendet.
Geht leichter zu treffen als der kleine USB-Stecker in das Tablet!
 
Mechanoid1

Mechanoid1

Erfahrenes Mitglied
daddle schrieb:
Alternativ kann man die von @untergrundbiber gepostete Tastenfolge mit gleichzeitigem Einsatz des USB-Kabels benutzen; damit ist man vom Zeitfenster unabhängiger:
Dafür ist es aber fummeliger: Jetzt hierfür die Vol.(-) Taste nehmen!), die Vol.(-) Taste gedrückt halten, dann die Powertaste drücken und zeitgleich mit der Powertaste das bereits am PC eingesteckte USB-Kabel mit dem Micro-USB-Stecker in den Micro-USB-Port einstecken! daddle
Das ist erstaunlich. Bei mir hat es bei dieser Variante nur mit Vol+ funktioniert. Sind die Tabs insich unterschiedlich?
 
D

daddle

Lexikon
@Mechanoid1
Dann hast du dich schlicht in der Eile bei den Tasten vergriffen, oder einen zu breiten Daumen benutzt. Vol.(-) ist die von der Powertaste abgewandte Seite der Volumen - Wippe!

topsurfer schrieb:
Tipp: Das Micro-USB war im Tablet eingesteckt, habe das normale USB, das beim drücken der Tasten eingesteckt werden muss, für das zeitkritische einstecken verwendet.
Geht leichter zu treffen als der kleine USB-Stecker in das Tablet!
Das hatte ich ja auch so als Alternative beschrieben! Der Tipp mit der dritten Hand! :winki: daddle
 
Mechanoid1

Mechanoid1

Erfahrenes Mitglied
daddle schrieb:
@Mechanoid1
Dann hast du dich schlicht in der Eile bei den Tasten vergriffen, oder einen zu breiten Daumen benutzt. Vol.(-) ist die von der Powertaste abgewandte Seite der Volumen - Wippe!


Mitnichten :rolleyes:

Trotz meines Alters funktionieren meine Augen noch ganz gut.

Und ich hatte es mehrmals mit vol- versucht. Erst vol+ brachte mich zum Erfolg.
 
Z

zaphod7

Neues Mitglied
Vielen Dank für die Anleitung daddle, hat super funktioniert! :thumbup:
 
D

daddle

Lexikon
Mechanoid1 schrieb:
Mitnichten :rolleyes:

Trotz meines Alters funktionieren meine Augen noch ganz gut.

Und ich hatte es mehrmals mit vol- versucht. Erst vol+ brachte mich zum Erfolg.
Tut mir leid. ich wollte dir nicht zu nahe treten; aber ich bin nur mit Vol(-) gehalten, Power gedrückt und gleichzeitig USB-Kabel einstecken rein gekommen, wie es auch Untergrundbiber beschrieben hatte. Dann musst du dich mit ihm "streiten". :biggrin:

Es gibt bei den rockchip mehrere reset-states, wenn es vielleicht nicht ganz ausgeschaltet war, bzw. ob du mit einem Soft- oder Hardware-Reset, mit oder ohne USB-Kabel zwischendurch ab- und wieder anstecken ind den "Aus"-Zustand gekommen bist!
Das kannst du auch im Geräte-Manager in Windows sehen, Tab aus, USB angeschlossen ein "AndroidPhone" > "Android Single Interface" wird verzögert angezeigt, es wird da ein Vor-Bootloader geladen für die Akku-Überwachung. Vielleicht warst du da gerade im vulnerabelem Moment bevor dieser ansprang?

K.A, Das kann ich auch nicht loggen, daher Rätselraten. Andere User, die nach der USB-Kabel-Methode in den Flashmodus gegangen sind, haben auch berichtet, dass es so mit Vol.(-) geklappt hatte. daddle

Und es geht mit
nur darum einen sichere Methode den anderen User zu beschreiben, damit keine Verwirrung entsteht!
Du kannst es ja nochmal ausprobieren in den Flashmodus zu gelangen und dann berichten, würde mich interessieren ob du das reproduzieren kannst!

Nachtrag: @Mechanoid1, du bist rehabilitiert!

Habe es jetzt selber mehrfach ausprobiert und es geschafft auch mit Vol.+ gedrückt, Powertaste und USB-Stecker gleichzeitig in den Flashmodus zu kommen, wie du es beschrieben hast.

Allerdings von je 10 Versuchen klappte es öfter mit der Vol. (-)Taste. Mein Eindruck ist, dass wenn man die Vol.(+)Taste wie du genommen hast, diese etwas länger festhalten muss, während mit der Vol.(-) Taste die Taste nur kurz direkt nach dem Einstecken des USB-Steckers losgelassen werden muss.

Ein weiterer wichtiger Punkt ist auch die Reihenfolge in der die Trigger-Signale ausgelöst werden, denn es ist fast unmöglich diese exakt gleichzeitig auszulösen. Also Power-Signal und USB-Power (od. Datensignal der über Widerstand im USB-Stecker verbundenen Datenleitungen?). Kommt das Powertasten-Signal zuerst, oder zuerst die Signale vom USB-Kabel? Welcher Kontakt schliesst zuerst und triggert den weiteren Ablauf? Auch wenn es nur Millisekunden Unterschied sind, die Reihenfolge und die Dauer des Tasten-Drucks scheint entscheidend zu sein. Davon hängt es dann ab ob es klappt den Flashmodus auszulösen, entweder mit der Lautstärken-minus od. plus-Tasten-Version.

Eindeutig definierter ist die in der Anleitung gegebene Version, vorausgesetzt man beachtet die Haltezeit der Powertaste mit ca. 4-5 Sekunden!
 
Zuletzt bearbeitet:
C

clumsy

Neues Mitglied
Vielen Dank für die Anleitung. Hat gut geklappt. In den Flash-Modus zu kommen hat mich zwar sicher 20 Versuche gekostet, aber was soll's :)
 
M

mexico67

Ambitioniertes Mitglied
Hallo daddle,
da ich von Linux bisher keine Ahnung habe, und ich mein Tab nach Deiner super Anleitung rooten möchte, welches Linux soll ich am besten installieren ? Lubuntu standard oder ein anderes ?
Für Deine Hilfe besten Dank
Viele Grüße
Mexico67