S7852 Root Unroot Backup Tools

  • 217 Antworten
  • Neuester Beitrag
Diskutiere S7852 Root Unroot Backup Tools im Medion Lifetab S7851 / S7852 Forum im Bereich Medion Forum.
D

daddle

Lexikon
@MartinMamrd

I show you how to flash the _all.bin.gz in Windows onto the Tab, but the Tablet has to be in Bootloader-Mode:

1. Download the Rkdeveloptool. decompress it to D: -> d:\RKDevelopTool\
2. Decompress the stockorg.rar you downloaded already to _all.bin.gz, and decompress again to _all.bin (1.887.436.800 bytes)
3.
Rename the file _all.bin to complete.img and copy it into subfolder -> d:\RKDevelopTool\rockdev\image\
4. Win 10-PC "New Start" with pressed down Shift-Tab -> PC reboots into -> Problembehandlung -> Advanced Options > Start options -> New Start -> choose cypher 7 and reboot
5. Install DriverAssistant.exe from decompressed RK_DriverAssistant.7z, confirm warnings positiv
6. Connect switched off Tablet by USB and start into download-mode; read in Rooten HowTo (Vol. minus and Power press 4-5 Sec.), Windows should beep and show new entry in device-manager -> Class for rockusb devices _-> Rockusb device

7. Start as admin RKAndroidTool.exe in d:\.\.\RKDevelopTool_v1.37\ RKAndroidTool.exe
8. In the opening mask now the bottom line should show: "Found RK Android Loader Rock Usb"
9. Untick in first green marked line "loader" (do not flash any Loader here at this point and moment, might brick)
10. Open with Right Click -> Add Item -> Fill in the name field "Complete"
11. Right click the field next to the path field (...) -> tick in the search box the complete.img-file path name
-> d:\RKDevelopTool\rockdev\image\ complete.img
12. Start with "Run", and the Image will be flashed to the Nand.
13. After you have to reconfigure the tab and you can update. Maybe you first have to start in Recovery and do a factory reset. All your data will be lost.
May be RKAndroid-Tool does not find your Tab in bootloader mode on a Win 10-PC, then use Win 7 or Vista

daddle
 
Zuletzt bearbeitet:
M

MartinMamrd

Neues Mitglied
Ha! I will try this one as soon as i will have some time. I aprecciate your effort, @daddle and will let you and others know how successfull i was.

...Still no luck. My win (win7-32bit) can see Rockusb device, but RKAndroidTool not. Will try it on W10.
 
Zuletzt bearbeitet:
D

daddle

Lexikon
@MartinMamrd

With me on Win7 64-bit Laptop RKAndroidTool for which I gave the link found the tablet in download-mode.
If you see the Tab in bootloader-mode in device-manager, RKAndroid-Tool should see it as well. Which rockusb-driver-version shows up in device-manager for Class for Rockusb devices?

Win 10 should work as well, only you have to deactivate driver signature in Startoptions.
(There is a new version of Android-Tool 2.3 for Win 10. Check next post.)

Easiest would be you make use of "kkorc" following Post 1! :thumbup:
 
Zuletzt bearbeitet:
D

daddle

Lexikon
@MartinMamrd

RKAndroid-Tool (Develop-Tool 1.37) with Rockchip-USBDriver-Version 3.7 works in Win 7 Sp1 without problems. Why it doesn't with your Win 7-PC I do not know.

Since Win 10-Anniversary-Update something differs. MTP-Connection must be reinstalled, in some cases doesn't happen automatically anymore.

Also RKAndroid-Tool 1.37 does not connect anymore in Win 10 to rockusb-devices as it did before; (but still does on my Win7-PC, in Win 7 with rockusb-drivers Version > 3.5).

Make use instead of Android-Tool V 2.33, plus RKDriversVer 4.3

Start after decompressing (with driver-signature check in Win 8 /10 deactivated) the DriverInstall.exe and choose first Uninstall.
Reboot with again deactivated driver-signature check, then DriverInstall.exe for installing Version 4.3.

Rebooten with "New Start" and connecting the switched off Tab, then boot into bootloader-mode -> Vol.(-) pressed plus Power for ~4 sec. Device-Manager should show a new catagory "Class for rockusb devices"

Then start AndroidTool_v2.33\AndroidTool.exe. Untick the loader-line. Then with rightcklick in the free white space choose "Add item" (address 0x00000000 is preset automatically), fill in the name -> "complete";
and "open" in the search box (right column) the path of your twice decompressed file in Stock44org.rar -> "_all.bin", renamed to "complete.img", as mentioned in an earlier post.

Then start AndroidTool-Flashfunction with -> "Run". Do not low level format.

After this you have KiKat 4.4 on the tab; you should update to KK 4.4.2. Or with OTA-update, or with the accompanying saved ota-update-file in stock44org.rar -> s785x-mp2-to-update1.zip.

daddle

Edit: Correction of Download-Link for AndroidTool_v2.33.
 
Zuletzt bearbeitet:
M

MartinMamrd

Neues Mitglied
Almost there... AndroidTool_v2.33 sees the device, shows loader, but when i add my image and click run, it shows succesfull device check, but after that it shows: "no found offset of complete partition" (where the word complete is user provided in the field name)
and : "download image failed"
I have tried to download the image again if its not corrupted with the same results..

..using win 7 32bit, driver 4.3 and AndroidTool v2.33
 
D

daddle

Lexikon
@MartinMamrd
It looks as if you post as Maximus 23 in arctablet.com as well? The same questions concerning a S10334-Tablet?
What so ever, make use of "kkorc" and you will succeed. I can't give in this thread lessons on RKAndroid-Tools.
 
Zuletzt bearbeitet:
M

MartinMamrd

Neues Mitglied
@daddle
No i'm not Maximus 23 and don't even know the site you mentioned. Anyway.. thank you for your patience. I think others may find this continuing thread helpfull as well.
 
Wattsolls

Wattsolls

Super-Moderator & Mediator
Teammitglied
@MartinMamrd You know, we´re a german speaking forum. And our rules say german is the forum language. So please , use a translator like google. You can do it like User Kevin Jansen in post 195.
 
Zuletzt bearbeitet von einem Moderator:
S

steve2000

Neues Mitglied
@daddle
Hat perfekt bei meinem Hofer/Aldi Medion Tab funktioniert! Danke
 
I

icehouse

Neues Mitglied
Hallo zusammen,
habe mich hier gerade angemeldet. War bislang nur stiller Teilhaber. Habe keine Ahnung, ob hier überhaupt noch mitgelesen wird. Zu meinem Problem:
Habe den vom Threadsteller erstklassig beschriebenen root-Prozeß vom Anfang bis zum allerletzten "Done" kopiert. Das Superuser-Logo ist auch da.
Allerdings: Nach einigen klicks (ca. einer Minute) schmiert das Tablet ab, Bildschirm wird (nicht ganz) dunkel und nichts geht mehr. Nach erneutem reboot gleiches Ergebnis!?
Hatte hier jemand anfänglich ähnliche Probleme?

Beste Grüße
Klaus
 
D

daddle

Lexikon
@icehouse

Dann spiele mal dein Backup ein (du hattest geschrieben du hättest alles wie in der Anleitung beschrieben "kopiert", (denke Du meinst alles so durchgeführt) und berichte ob das Tablet dann ohne Probleme läuft. Es spricht ja evtl. für einen Fehler in der /system, Bisher ist das noch nicht vorgekommen. Ich denke eher an einen Akku-Fehler oder einen Nand-Fehler.

Gruss, daddle
 
Zuletzt bearbeitet:
I

icehouse

Neues Mitglied
@daddle
Wow!
Hallo daddle, Danke für die schnelle Antwort! Werde es so machen und probieren, das backup zu installeren. Werde dann berichten.
Ich habe den root-Vorgang dreimal gemäß Anleitung durchgeführt. Ergebnis war ebenfalls dreimal wie beschrieben... schauen wir mal!
Danke nochmal und Grüsse
Klaus
 
I

icehouse

Neues Mitglied
@daddle
Nachdem ich das backup via -zrestore zurückgespielt habe, läuft das Tablet wieder wie zuvor einwandfrei.
Keine Ahnung, ob mein Problem damit zu tun hatte:
Das verwendete Kubuntu (mein erster Linux-Kontakt) verwendet als Standardeinstellung die automatische Bildschirmverdunkelung nach 5 Minuten auch
im Netzbetrieb also mit angeschlossenem Netzteil. Während des root-Vorgangs also mehrfach geschehen. Ich habe jeweils auf's mouse-pad getippt, damit ich den
Bildschirm wg. möglicher Fehlermeldungen verfolgen konnte...
Habe diese Option zwischenzeitlich in den Systemeinstellungen geändert bzw. abgeschaltet.
Gruß
Klaus
 
D

daddle

Lexikon
@icehouse
Vielleicht war es ja nicht nur Bildschirmverdunkelung sondern auch Standby? Und die Tastatur sollte ja während die /system "on the fly" modifiziert wurde nicht betätigt werden. Was letztendlich zum Fehler führte kann ich nicht sicher sagen; schliesslich haben über zig tausende User den Thread besucht und vermutlich sehr viele davon auch gerootet. Ich würde es noch mal probieren.
 
Zuletzt bearbeitet:
I

icehouse

Neues Mitglied
@daddle

werde ich machen...und berichten
 
D

daddle

Lexikon
@icehouse

...und, hat das erneute Rooten jetzt geklappt?
 
I

icehouse

Neues Mitglied
@daddle
Hi,
nach einigen Maßnahmen, deren (partielle) Wirksamkeit ich nicht mehr im nachhinein nachvollziehen kann, hat letztlich ein
factory reset den root möglich gemacht (mit root checker gecheckt). Wahrscheinlich war ich einfach nur zu spät am Ball.
Gerät ist von 2014 und der thread samt Anleitung ist ja auch schon älter.
Naja, sei's drum. Ohne Deine Hilfe und die geniale Beschreibung hätte ich es nicht hinbekommen!!
Also vielen Dank nochmal
Klaus
 
D

daddle

Lexikon
@icehouse

Schön dass es geklappt hat. Dass das Gerät von 2014 ist, bedeutet nichts, denn auch die Anleitung und die verwandte Software ist ja von 2014/2015; Updates zu dem S7852 Tablet gab es ja nach dem Erst-Update nicht mehr; und kkorc ist erst nach dem Erst-Update gleich nach dem Verkaufsstart entstanden. Das verwendete Linux ist wahrscheinlich nicht mehr 14.04; aber es funktioniert genauso mit einer neueren Linux-Version, was ich vor Kurzem selber noch mal beim Neuaufsetzen des S7852 mit Linux Version 18.04 gemacht hatte.
Ich nehme eher an Du hattest vorher bereits Rootversuche mit anderen Methoden versucht, die naturgemäss alle nicht funktionieren konnten. Oder sonstwie das System durcheinander gebracht. Daher half der Werkreset.

Gruss, daddle
 
Zuletzt bearbeitet: