WLAN Verbindungsprobleme

  • 155 Antworten
  • Neuester Beitrag
Diskutiere WLAN Verbindungsprobleme im Motorola Defy+ Forum im Bereich Weitere Motorola Geräte.
F

Fl0

Neues Mitglied
Ich habe an meiner FritzBox 3270 sämtliche Wlan Einstellungen durchprobiert nichts hat geholfen. Seit ich die tiwlan.ini geädert habe funktioniert alles super.
 
N

neographic

Neues Mitglied
Dito! Hat bei mir genauso geklappt.

Hier eine kurze Anleitung zum Editieren der tilan.ini:

1.) Gerät rooten. Dauert ca. 5 Minuten und alle Einstellungen/Apps/etc. bleiben erhalten!

Anleitung zum rooten:
https://www.android-hilfe.de/forum/...y.576/how-to-motorola-defy-rooten.149497.html

2.) Root Explorer kaufen & installieren (kann auch nur kurz gekauft werden und innerhalb der 15 Minuten trial wieder deinstalliert werden)
Link zum Market: https://market.android.com/details?id=com.speedsoftware.rootexplorer&feature=search_result

3.) Im Root Explorer in folgendes Verzeichnis "/system/etc/wifi" wechseln und oben rechts bei "mount" auf "r/w" tippen um die Schreibberechtigung zu setzen.

4.) die Datein "tiwlan.ini" lokalisieren und mittels langem Halten die Optionen aufrufen. Dort etwas nach unten scrollen und "Im Editor öffnen" wählen.

5.) Im Dokument ca. bis zur Mitte scrollen und den Eintrag "HT_Enable=1" lokalisieren. Dort ansatt der "1" eine "0" eintragen und das Dokument speichern. (ein Backup der Originaldatei wird automatisch erstellt!)


Durch das Setzen der "0" wird der Wifi-N-Draft-Modus deaktiviert, was v.a. bei Fritzbox-Routern zu Problemen führt.

Das Ganze lässt sich natürlich auch wieder aktivieren, indem man einfach wieder die ursprüngliche "1" setzt hinter "HT_Enable="

Hoffe damit ist einigen geholfen!

Beste Grüße
Dominik
 
Zuletzt bearbeitet:
W

wadelbeisser

Neues Mitglied
Hallo zusammen,

ich hab's heut mit dem WLAN eines Freundes versucht. Mit dessem b/g Accesspoint hatte ich keine Probleme.
Außerdem habe ich eine Antwort vom Moto-Support erhalten:
Erste Empfehlung: Mit anderem AP ausprobieren.
Sollte das nicht funktionieren: Gerät auf Werkseinstellungen zurücksetzen.

Wieso hab ich nur das Gefühl, dass auch das nicht wirklich mein Problem lösen wird???
 
E

eTaurus

Neues Mitglied
Mit einem Asus RT-N16 funktioniert draft-n. Keine berauschende Geschwindigkeit, aber immerhin muss ich mein n-only-Netzwerk nicht aufgeben.
Auf dem Gerät läuft die alternative Firmware DD-WRT (Kong Mod).
 
Zuletzt bearbeitet:
W

wadelbeisser

Neues Mitglied
Das Rücksetzen auf Werkseinstellungen hat, erwartungsgemäß, nichts gebracht.

Dann hab ich, wie von neographic beschrieben, den n-Standard ausgeschalten.

Ergebnis:
- Webseiten bauen sich jetzt zwar schnell auf, aber
- im Market bekomme ich jetzt eine Fehlermeldung in einem Popup, dass ein Netzwerkfehler vorliegt.
- gleiches gilt für den YouTube Client.

--> Sobald die Datenmengen größer werden scheint es einen Fehler zu geben.

Was nun?
 
N

neographic

Neues Mitglied
Hast du schon den neuen Market auf deinem Defy, sprich den mit der neuen Startseite wo man seitlich durch die Applisten wechseln kann?

Ansonsten würde ich mal vorschlagen unter "Anwendungen" die ensprechende App "Market" und "Youtube" zu lokalisieren und dann draufklicken und "Dateien löschen" sowie "Cache löschen" auswählen. Dann erscheint im Market nochmal die AGB Meldung wie beim ersten Start. Die Einstellungen musst du halt dann wieder neu setzen, aber beim Market und bei Youtube gibt es eh nur wenig einzustellen...


Bitte testen und Feedback geben!

Viel Erfolg!
 
W

wadelbeisser

Neues Mitglied
Hat leider nichts gebracht. Es wird der erste Teil der Listen geladen, dann ist aber wieder Schluss.

Erinnert mich etwas an ein "altes DSL" Problem.
--> Kann man die MTU bei Android einstellen (festzustellen)?
Oder gibt es eine Option, die die Übernahme der MTU per DHCP "aktiviert"?

Hab grad mal mit dem PC die Verbindung durchgeklingelt. (ping -f -l 1472 www.google.de)
Bis 1472 Bytes gehen die Pakete noch unfragmentiert raus, danach würde fragmentiert werden.
Standard bei "eth" devs war mal 1500(als ich damit noch zu tun hatte :o ) .
 
Zuletzt bearbeitet:
F

fboyde

Ambitioniertes Mitglied
Hallo, sämtliche hier im Forum oder anderswo beschriebenen workarounds haben bei mir nicht geholfen,also ini Datei im Defy bearbeiten,n-draft deaktivieren, Gastzugang der Fritzbox 7270 benutzen. Was letztendlich funktioniert hat, war das umstellen der Verschlüsselung von WPA+WPA2 auf WPA(TKIP),kann dann stundenlang mit n-draft über das Defy surfen. Habe das bei mir zu Hause jetzt so gelöst, das ich den normalen wlan Zugang über WPA+WPA2 laufen lasse und den Gastzugang mit WPA(TKIP) . Kann so wunderbar n-draft benutzen, keine Verbindungsabrüche mehr. Gruß Frank
 
W

wadelbeisser

Neues Mitglied
Gutem Morgen!

Ich hab gestern noch meime rudimentären Linux-Kentnisse ausgegraben und mal etwas mit der MTU experimentiert.

- genutztes Tool: GScript Lite

- Script: ifconfig tiwlan0 mtu 1472
- Script2: ping -c 3 -s 1450 -M do www.SuSE.de

Ergebnis:
- Der Seitenaufbau im Market, Browser, YouTube funktioniert super!
- ABER: App Downloads starten nicht (Hört bei “Download wird vorbereitet“ auf). Videos laufen an, bleiben aber nach knapp einer Minute stehen.

Wichtig bei den Tests: Die Einstellung muss nach jedem WLAN Aktivieren neu vorgenommen werden.


Gesendet mit der Android-Hilfe.de-App
 
M

mabti

Neues Mitglied
Hat mich geholfen: SSID broadcast einschalten

"Wifi Analyzer" aus dem Market zeigte mir einen pulsierenden Empfang, der alle paar Sekunden zwischen -40dB und -90dB (kein wlan) schwankte. Verschlüsselung ändern oder "n" ausschalten brachte nichts. Jetzt funktioniert es einwandfrei. Der Sicherheitsverlust ist wohl akzeptabel.
 
DarkTaur

DarkTaur

Erfahrenes Mitglied
Ich habe das gleiche Problem mit meiner FB 7270, über den Gastzugang (WPA statt WPA+WPA2 aber inkl. N-Draft) funktioniert es aber ohne Probleme. Aus diesem Grund würde ich es nicht alleinig auf N-Draft schieben und auch nicht auf die FritzBox.
Da ich irgendwie keine Account bei Motorola erstellen kann (es wird einer angelegt aber Anmeldung oder Reset funktioniert nicht) habe ich es bei AVM versucht. Bei denen war das Problem nicht bekannt (bin ich wirklich der Erste der sich mal an AVM wendet?)!?! AVM wollte von mir nun einen Support-Report direkt nach dem Auftreten des Problems. Diesen habe ich mal an AVM geschickt und mal sehen was dabei herauskommt.

PS: Habe es heute mit einer FB 7112 testen können und dort gibt es auch kein Problem. Ok, die kann auch kein N-Draft.
 
N

netrowdy

Erfahrenes Mitglied
same here. (auch Fritzbox)

- keinen n-Modus ... hat nicht geholfen (nur kurzzeitig).
- SSID sichtbar ... hat nicht geholfen (war es sowieso)
- Kanalwechsel ... hat nicht geholfen
- Ändern der Verschlüsselung (TKIP statt ...) ... hat nicht geholfen

Mit dem Gastzugangs klappts bisher.
ABER: Ich kann ja nicht jeden Tag den Gastzugang neu aktivieren.
Wie macht ihr das?

Überhaupt finde ich es eine Schande, dass man sich als User mit solchen Problemen, die es wohl schon beim Defy gab, rumschlagen muss.
Bin da echt enttäuscht von Moto. :(
 
M

mabti

Neues Mitglied
Habt ihr denn schon mal den "Wifi Analyzer" aus dem Market ausprobiert? Zeigt dieser Einbrüche im Empfang an?
 
DarkTaur

DarkTaur

Erfahrenes Mitglied
netrowdy schrieb:
ABER: Ich kann ja nicht jeden Tag den Gastzugang neu aktivieren.
Wie macht ihr das?
Dazu muss doch einfach nur die Option "automatisch deaktivieren nach" komplett abgewählt werden. Damit bleibt der Gastzugang immer aktiv.

netrowdy schrieb:
Überhaupt finde ich es eine Schande, dass man sich als User mit solchen Problemen, die es wohl schon beim Defy gab, rumschlagen muss.
Bin da echt enttäuscht von Moto.
Ich frage mich halt ob überhaupt jemand das Problem bei Moto gemeldet hat. AVM kannte das Problem auch noch nicht obwohl schon in vielen Foren darüber "geredet" wurde. Die Schuld würde ich aber auch alleinig auf Motorola schieben oder warum tritt das Problem bisher nur bei der Fritzboxen auf?
Ich persönlich warte nun auf die Auswertung der Supportdaten von AVM... Bericht folgt.
 
W

wadelbeisser

Neues Mitglied
Also ich bin mit dem Moto-Support noch in Kontakt.

Ich hab mal darauf hingewiesen, dass auch andere Nutzer von dem Problem betroffen sind.

--> Warten auf Antwort.
 
N

netrowdy

Erfahrenes Mitglied
Danke euch beiden.
Wenn ich auch noch was beitragen kann/soll, bitte Info.
 
A

appletosh

Neues Mitglied
Moin, moin! Seit gestern bin auch ich vom „wlan-problem“ betroffen, und zwar halb. Halb deswegen, weil meine Frau ihr „normales“ Defy in unserem Haus seit Monaten ohne Probleme im Netz benutzt, ich hingegen mit meinem „+“ unter den beschriebenen Abbrüchen leide. In meinem Fall führt der Betrieb über eine feste IP-Adresse zur dauerhaften „Lösung“ des Problems.

Bevor ich überlege, mein Handy über den Händler zu tauschen oder zu Datrepair zu schicken, würde mich mal interessieren, ob überhaupt mal einer, der betroffen war, durch den Austausch des Geräts zufriedengestellt werden konnte. appletosh
 
Quereinsteiger

Quereinsteiger

Neues Mitglied
Servus!

Bei mir ist es so, dass bei mir die beschriebenen Probleme (fast keine Datenübertragung) auftreten, sobald ich mit dem Fritz!Repeater N/G mein WLAN-Netzwerk erweitere.

Klemme ich dann den Fritz!Repeater und gehe nur über meinen billigen China-Router TPLink WR1043ND ins Internet, funktioniert alles normal wie es sollte.

Es scheint sich hierbei also wohl um ein herstellerspezifisches Problem (AVM) zu handeln.
 
M

mobile_user

Gast
Hallo,

Ich habe zwei Fritzboxen 7270 und 7390. Bin der Sache mal genauer auf die Spur gegangen und konnte eine Lösung finden.
In Amerika sind keine 5Ghz Frequenzen für Wlan vergeben. Darauf hin habe ich das 5GHz Band ausgeschaltet, dann nur b+g und zum Schluß die Erweiterten Kanäle 12+13 auch ausgemacht, denn auch diese gibt es dort nicht. Die 300MBit Option auch ausschalten.
Nach einem Anschließenden Neustart der Fritzbox geht es stabil und zuverlässig.

Bin jetzt mit dem Defy+ sehr zufrieden, reboot Problme konnte ich auch lösen.
 
N

netrowdy

Erfahrenes Mitglied
@ mobile_user: Auch schon mal über einen längeren Zeitraum und mit datenintensive Sachen getestet? (Youtube, Download, etc.). Mich würde interessieren ob es weiterhin klappt.

Die Optionen nicht 12+13, nur b+g (das meinst du ja mit 5GHz-Band, oder?) und keine 300MBit Option habe ich auch schon alle durchprobiert.
Hatte auch mal kurzzeitige Erfolge, hielt allerdings max. einen halben Tag bzw. bis spät. zum nächsten größeren Download.

@appletosh: hm, feste IP half bei mir leider nicht.

@Quereinsteiger: habe auch einen Fritz!Repeater im Einsatz, allerdings auch einen normale FB. Danke für den Tipp, ohne Repeater habe ich es noch gar nicht versucht, fällt mir gerade ein. Wäre aber eine Erklärung bei mir warum der Gastzugang (meines Wissens ohne Repeater) klappt.

Was mich am meisten nervt ist genau der Punkt, dass es sich nicht auf eine eindeutige, logische Ursache einschränken lässt. Einige finden (für sich) scheinbar immer mal wieder eine Lösung, die widerum bei anderen nicht funktioniert. :sad: