1. v4der81, 04.03.2016 #1
    v4der81

    v4der81 Threadstarter Neues Mitglied

    Hallo zusammen,

    ich hatte mein Moto G in Reparatur, wegen einer defekten Hintergrundbeleuchtung.
    Die haben dann Android 6 installiert. Ergebnis ist, dass ich kaum noch Telefonempfang hatte.
    Dachte ich, ok geh ich zurück auf 4.4.x.

    USB Debugging aktiviert, Moto G im Fastboot gestartet (Leisertaste + Einschaltknopf) und am PC fröhlich:
    fastboot oem get_unlock_data eingetippt. Nach dem Neustart hat er dann im Fastboot den Status: Bootloader unlocked.
    Handy ist dann aber resettet. Kein Problem dachte ich, wieder im Android wieder USB Debugging eingeschaltet und das gleiche Spiel nochmal. Wieder im Fastboot angekommen habe ich am PC eingetippt:
    mfastboot.exe flash partition gpt.bin
    mfastboot.exe flash motoboot motoboot.img
    mfastboot.exe flash logo logo.bin
    mfastboot.exe flash boot boot.img
    mfastboot.exe flash recovery recovery.img
    mfastboot.exe flash system system.img_sparsechunk.0
    mfastboot.exe flash system system.img_sparsechunk.1
    mfastboot.exe flash system system.img_sparsechunk.2
    mfastboot.exe flash system system.img_sparsechunk.3
    mfastboot.exe flash modem NON-HLOS.bin
    mfastboot.exe erase modemst1
    mfastboot.exe erase modemst2
    mfastboot.exe flash fsg fsg.mbn
    mfastboot.exe erase cache
    mfastboot.exe erase userdata
    (Anleitung von [Restore to Stock][XT1068][All Dual Sim Model][4.4.4][Lock Bootloader])

    Das Ergebnis ist jetzt, dass das Telefon nicht mehr startet. Wenn ich wieder im Fastboot bin, sehe ich zwar:
    USB connected, aber wenn ich auf einen Punkt wie Recovery, oder Normal Boot gehe, dann kommt für 0,1
    Sekunde der Warnscreen vom offenen Bootloader und dann bin ich wieder im Fastboot Menü.

    Lange Rede kurzer Sinn: Gibt es eine Möglichkeit, OHNE USB Debugging aktiv zu haben, irgendwie auf das Gerät zu flashen? Der PC erkennt das Handy nur noch als "Unbekanntes Gerät".

    Ich hoffe, es gibt eine Möglichkeit.

    Gruß Stefan
     
  2. ooo, 04.03.2016 #2
    ooo

    ooo Lexikon

    Versuch, deine letzte davor installierte Firmware (Marshmallow) zu finden und flashe die komplett. - Versprechen kann ich dir nichts ...

    (Downgrade auf Lollipop und KitKat bleiben lassen. - XDA ist nicht "Gott".)
     
  3. v4der81, 04.03.2016 #3
    v4der81

    v4der81 Threadstarter Neues Mitglied

    Das Problem ist, dass ich auch nicht in den Punkt "Recovery" rein komme. Ich lande nach 0,1 Sekunden wieder im Fastboot-Menü.
     
  4. ooo, 04.03.2016 #4
    ooo

    ooo Lexikon

    Ich spreche von in den Bootloader starten (Fastboot Modus), nicht weiter in das Recovery gehen.
    Mit der fastboot.exe dann die komplette (vorher gesuchte und heruntergeladene) originale Motorola Marshmallow-Firmware flashen (das, was du oben selbst beschrieben hast "fastboot flash ...", aber mit einer passenden Marshmallow-ROM, nämlich der, die vorher drauf war).
    Das ist etwas Anderes, als über das (Stock-)Recovery einen Update.zip zu installieren oder über TWRP Custom Recovery ein Backup wieder einzuspielen.
     
  5. v4der81, 04.03.2016 #5
    v4der81

    v4der81 Threadstarter Neues Mitglied

    Ok, um über diesen Weg eine Firmware zu flashen brauche ich doch zwingend USB Debugging, oder?

    Folgende Schritte habe ich gemacht:
    - Handy in Fastboot gestartet, erst dann
    - USB Kabel angeschlossen. Jetzt wird "Fastboot titan S" erkannt, ohne Treiber.
    1.PNG
    Wenn ich die Motorola Treiber installiere, erkennt er es anschliessend nur noch als "unknown device"
    und er erkennt es auch nicht, wenn ich zB: "fastboot devices" eingebe.
    Ich kann die Treiber also nicht aktualisieren, bzw es bringt nix.

    Welcher Treiber ist dann der Richtige, wenn nicht der von Motorola selber?

    Ich hab schon die von den "Android SDK Tools" probiert, die akzeptiert er nicht.

    Gruß Stefan
     
  6. ooo, 04.03.2016 #6
    ooo

    ooo Lexikon

    Nein, du brauchst kein Android-/USB-Debugging, nur die richtigen Treiber.
    (Der Bootloader muss ebenfalls nicht UNLOCKED sein, Root ist auch nicht nötig bzw. alles egal.)
    Außerdem nur einen direkten USB-Anschluß (v2.0) benutzen, keinen USB-Hub.

    Probier andere USB-Buchsen am Rechner oder einen anderen Rechner, der noch nicht "befummelt" wurde ...
    Die Treiber (für fastboot, Phone im Bootloader/Fastboot Mode) sollten sich nach der Verbindung mit dem USB-Daten-Kabel (nach kurzer Wartezeit) unter Windows (Win 7) völlig automatisch installieren (das Ende der Installation abwarten, klar).

    Motorola-Treiber braucht man überhaupt nicht (zumindest nicht für diese Aktion).
    Deinstallier alles, was von Motorola ist, boote den Rechner neu, dann teste nochmal.
    Am Phone muss im Bootloader/Fastboot Screen irgendetwas mit "USB cable connected" kommen.
    Kabel abziehen, lesen, wieder einstecken, lesen.
    Dann muss auch "fastboot devices" funzen und die Serial Number ausgeben.
    (Evtl. cmd.exe als Windows-Administrator öffnen)

    ___
    Edit: Das ist auch noch eine Möglichkeit: Koush
     
    Zuletzt bearbeitet: 04.03.2016
  7. v4der81, 04.03.2016 #7
    v4der81

    v4der81 Threadstarter Neues Mitglied

    Habe alles deinstalliert, dann den PC neu gestartet, einen USB 2.0 Port direkt am Mainboard gewählt.
    2.PNG
    Den Treiber mag er irgendwie nicht, oder er hat ihn nicht. :(

    Ich hab leider keinen zweiten PC.

    Kann es sein, dass das Handy in diesem Brick Status auch nicht mehr richtig läd?

    Was kann ich jetzt noch machen?

    Was ist der Unterschied zwischen "fastboot.exe" und "mfastboot.exe" ?
     
  8. ooo, 04.03.2016 #8
    ooo

    ooo Lexikon

    Das weiß ich nicht, wenn die Ladeanzeige da ist, dann lädt es.
    ___
    follow-up - Post #130
    Mark_Venture's Verizon Phone Info Page
     
    Zuletzt bearbeitet: 04.03.2016
  9. v4der81, 04.03.2016 #9
    v4der81

    v4der81 Threadstarter Neues Mitglied

    Habe nun die "UniversalAdbDriverSetup.msi" installiert.

    Ergebnis: "Unknown Device" :(

    Der Treiber scheint auch nicht der Richtige zu sein.
    -- Dieser Beitrag wurde automatisch mit dem folgenden Beitrag zusammengeführt --
    Update: plötzlich das hier nach deinstallation der ADB Driver
    3.PNG

    Das Teil spinnt doch, oder????
    Jetzt wird es erkannt.
     
  10. ooo

    ooo Lexikon

    Wie alt sind deine Motorola-Treiber (aktuell ist 2.5.4 / 6.x / für 32- und 64-bit)
    Where can I download the USB drivers for my device?

    Wenn es geht, dann hol dir folgende aktuelle Werte via fastboot:
    Damit kannst du evtl. ein passendes ROM finden.
    Ansonsten frag beim Support nach, was sie dir aufgespielt hatten.​
     
    Zuletzt bearbeitet: 04.03.2016
  11. v4der81, 04.03.2016 #11
    v4der81

    v4der81 Threadstarter Neues Mitglied

    Es sieht bisher "gut" aus. Also das Device wird zumindest erkannt und der Status ist: Charging.
    4.PNG

    Das Display sieht so aus:
    5.jpg
    Ganz unten im Display steht in gelb:
    getvar:max-download-size
    download:0008000
    flash;partition


    Kein Fehler, kein Error, keine rote Schrift.

    Macht er es jetzt nur nicht, weil die Batterie noch nicht voll genug ist, oder wo liegt der Fehler?
     
    Zuletzt bearbeitet: 04.03.2016
  12. ooo

    ooo Lexikon

    Soweit sieht das okay aus, aber, was für eine Firmware versuchst du denn genau zu flashen?
    1. Kompletter Dateiname und Link von deinem KitKat-ROM
    2. Und ebenfalls exakter Dateiame und Link vom Marshmallow-ROM, wenn du bereits soweit bist/warst
    Was geben die fastboot-Befehle aus, die ich dir oben genannt habe?
     
  13. v4der81, 04.03.2016 #13
    v4der81

    v4der81 Threadstarter Neues Mitglied

    fastboot getvar version-bootloader:
    4886

    fastboot getvar ro.build.fingerprint:
    (bootloader) ro.build.fingerprint[0]: motorola/titan_retde/titan_umtsds:
    (bootloader) ro.build.fingerprint[1]: 6.0/MPB24.65-34/31:user/release-ke
    (bootloader) ro.build.fingerprint[2]: ys
    ro.build.fingerprint: Done

    fastboot getvar cid:
    cid: 0x0007

    fastboot getvar sku:
    sku: XT1068

    fastboot getvar ro.carrier:
    ro.carrier: retde

    fastboot getvar iswarrantyvoid:
    iswarrantyvoid: yes

    Am liebsten wäre mir, wenn ich wieder Kitkat hätte, aber ich wäre froh, wenns am Ende überhaupt wieder läuft.
    Bist du Entwickler?

    Es gibt viele Versionen zum runter laden, ich weiss aber nicht, welche "funktioniert".
    Ich hatte diese probiert: TITAN_RETBR_DS_6.0_MPB24.65-34_cid12_CFC

    Das Ergebnis waren die Screens.

    EDIT: CMD als Admin gestartet. Jetzt sieht die Sache besser aus:
    Z:\Downloads\XT1068_6>mfastboot.exe flash partition gpt.bin
    target max-sparse-size: 256MB
    sending 'partition' (32 KB)...
    OKAY [ 0.100s]
    writing 'partition'...
    OKAY [ 0.340s]
    finished. total time: 0.440s

    Kann aber auch daran liegen, dass Battery OK (Charging) jetzt grün ist.
     
    Zuletzt bearbeitet: 04.03.2016
  14. ooo

    ooo Lexikon

    Du benötigst eine deutsche (DE, EU - cid 7) nicht eine brasilianische ROM (RETBR = Retail Brasilia, cid12 = Latein-Amerika)

    Falsch:
    TITAN_RETBR_DS_6.0_MPB24.65-34_cid12_CFC

    Richtig wäre z. B. so etwas (ähnliches)
    TITAN_RETDE_DS_6.0_MPB24.65-34_cid7_CFC
    TITAN_RETEU_DS_6.0_MPB24.65-34_cid7_CFC
    TITAN_RETAILDSDS_6.0_MPB24.65-34_cid7_CFC

    Nimm diese hier versuchsweise (das ist die globale GSM-Version):

    Dev-Host - XT1068_TITAN_RETAILDSDS_6.0_MPB24.65-34_cid7_CFC.xml.zip - The Ultimate Free File Hosting / File Sharing Service
    XT1068_TITAN_RETAILDSDS_6.0_MPB24.65-34_cid7_CFC.xml.zip

    Dein Bootloader ist momentan re-locked (code 2). - Deine Bootloader-Version ist Marshmallow (oder evtl. Lollipop?).
    Das Gerät wird in diesem Zustand nur die absolut korrekte ROM akzeptieren (wenn überhaupt).

    Alles vor Marshmallow (z. B. KitKat) kannst du erstmal vergessen, sorry.

    ___

    Nein, ich bin Kosmetiker ... (joke)
     
  15. v4der81, 04.03.2016 #15
    v4der81

    v4der81 Threadstarter Neues Mitglied

    Mit dem einmal geöffneten Bootloader bekommt man keine Updates mehr, oder?

    Soll ich dann gleich den Bootloader wieder auf machen, oder spielt das gar keine Rolle?

    Ich kenn mich mit Android unterhalb der Oberfläche wirklich 0 aus.

    Hab zum Test jetzt immer nur diese gpt.bin drauf gemacht, sonst nichts. Hoffe das war nicht schon der Fehler.
    Rom ist runter geladen. Ich flash jetzt wie in Post 1 beschrieben wieder alles durch, richtig?

    Ich starte nicht ohne dein GO.
     
  16. ooo

    ooo Lexikon

    Nein, erstmal die ROM komplett flashen und schauen, ob sie überhaupt startet. - Wenn das in Ordnung ist, dann kann man an das Bootloader entsperren denken, vorher nicht.​
    Das ist genau die "falscheste" und gefährlichste Datei, die man testweise flashen kann. Und auch mit einer falschen motoboot.img kann man viel Spaß bekommen (bis zum Total-Verlust des Phones). - Finger weg von den beiden Images ...​
    Schau vorher in das Zip-File und zeige mir bitte ALLE darin enthaltenen Dateien (als Screenshot), damit wir die Befehls-Liste evtl. korrigieren können.​
     
  17. v4der81, 04.03.2016 #17
    v4der81

    v4der81 Threadstarter Neues Mitglied

    Das heisst die falsche gpt.bin flashen = ganz totes Handy? Das heisst man kann auch dieses Fastboot Flash Tool "vernichten" ???
    Dachte das wäre eher so, wie ein "Notfall-Tool", das immer geht - klar, die Recovery davon hab ich ja auch schon geschrottet :/

    6.PNG

    Das ist der komplette Inhalt des Ordners. adb.exe und die dlls braucht man ja, oder?
    Auch die fastboot.exe ist von den ADB Tool, aber unbenutzt.

    Dateinamen sollten passen.
     
  18. ooo

    ooo Lexikon

    Okay jetzt flashst du einzeln nacheinander folgende Dateien:
    Code:
    fastboot flash logo logo.bin
    fastboot flash boot boot.img
    fastboot flash recovery recovery.img
    
    fastboot flash system system.img_sparsechunk.0
    fastboot flash system system.img_sparsechunk.1
    fastboot flash system system.img_sparsechunk.2
    fastboot flash system system.img_sparsechunk.3
    
    fastboot flash modem NON-HLOS.bin
    fastboot erase modemst1
    fastboot erase modemst2
    fastboot flash fsg fsg.mbn
    
    fastboot erase cache
    fastboot erase userdata

    Wenn bei einem der Befehle ein Fehler auftritt, meldest du dich bitte wieder mit der kompletten Fehler-Meldung.
    (Die gpt.bin und motoboot.img lassen wir absichtlich erstmal weg, um zu sehen, ob die originalen Marshmallow noch drauf sind und ob sich die restliche Firmware flashen lässt.)
     
  19. v4der81, 04.03.2016 #19
    v4der81

    v4der81 Threadstarter Neues Mitglied

    Naja, die gpt.bin hab ich ja leider schon drüber gebügelt.


    Z:\Downloads\XT1068_6>mfastboot.exe flash logo logo.bin
    target max-sparse-size: 256MB
    sending 'logo' (697 KB)...
    OKAY [ 0.117s]
    writing 'logo'...
    FAILED (status read failed (Unknown error))
    finished. total time: 0.147s

    Fängt schon gut an :(
     
  20. ooo

    ooo Lexikon

    Okay, dann fängst du mit gpt.bin und motoboot.img an:
    Code:
    fastboot flash partition gpt.bin
    fastboot flash motoboot motoboot.img
    Plus den Rest von oben, klar.
     
Die Seite wird geladen...
Ähnliche Themen Forum Datum
Motorola Moto G 2. Generation - Display Schaden - Kann ich irgendwie aufs Telefon zugreifen? Motorola Moto G (2014) Forum 01.07.2019
Moto Action für das Moto G2 ? Motorola Moto G (2014) Forum 18.12.2018

Besucher kamen mit folgenden Begriffen auf unsere Seite:

  1. motorola/titan_retde/titan_umtsds

    ,
  2. motorola/titan_retaildsds/titan_umtsds6.0/MPB24.65-34/31

    ,
  3. titan_retaildsds/titan_umtsds6.0/mpb24.65-34/31

    ,
  4. motorola/titan_retaildsds/titan_umtsds6.0/MPB24.65-34/31 package download
Du betrachtest das Thema "Moto G 2. Gen (XT1068 Dual-Sim) Brick" im Forum "Motorola Moto G (2014) Forum",
  1. Android-Hilfe.de verwendet Cookies um Inhalte zu personalisieren und dir den bestmöglichen Service zu gewährleisten. Wenn du auf der Seite weitersurfst stimmst du der Cookie-Nutzung zu.  Ich stimme zu.