Moto G4 plus BootLoop

  • 42 Antworten
  • Neuester Beitrag
Diskutiere Moto G4 plus BootLoop im Motorola Moto G4 Plus Forum im Bereich Motorola Forum.
C

coraMoto

Neues Mitglied
Hallo Forum

Ich habe ein G4 bei dem der Akku defekt war. Ein neuer wurde eingebaut, und nach ca. 60 % iger Ladung konnte ich das Gerät einschalten.
Leider bin mit dem Thema nicht so vertraut, jedoch sah mir das gleich nach einem Problem aus, denn das Gerät kam nur bis zum blauen Schirm mit dem "M".
Nach einem VibrationsTon und ca. 10s dasselbe.

Ich habe dann nach einiger "Googelei" die Tastenkombinationen für Recovery Mode etc, und Versuche zu "wipen" herausgekriegt. ( Leider ohne Erfolg )
Zu Anfang hatte ich "Nougat" drauf, habe es dann aber irgendwie geschafft Oero zu installieren ( nach Anleitung von XDA ).

Booten geht aber nach wie vor nicht. Jetzt 2 Tage später dreht sich alles in meinem Kopf, krege keine strukturierte Vorgehensweise mehr hin.

Wer kann hier helfen ?

Gruß und schöne Tage...
 
cptechnik

cptechnik

Moderator
Teammitglied
ACHTUNG - FALSCH ANGEWENDET LÄSST DAS VORGEHEN DEIN GERÄT ZU EINEM BRIEFBESCHWERER, TÜRSTOPPER, SCHNEIDEBRETTCHEN WERDEN !

  • Zwangs-Reset (einschalten) : 10 s Power on
  • Bootlader Menü : Power on + vol down
  • Im Bootmenü kann man "Recovery" Modus auslösen,
    • mit : vol up/down auswählen, und mit Power bestätigen
    • Jetzt befindest du dich im recovery System ,
    • wahrscheinlich im Recovery-System von Motorola, wenn man seinen so Gerät gerootet hat, kann man auch ein custom Recovery hier installieren und hat mehr Möglichkeiten (andere Geschichte) ...
    • Wenn du im Recovery von Motorola steckst, sieht man erst nur ein Männchen... Wenn du jetzt Power und volume up drückst zeigt es dir endlich das Recovery-Menü indem du auch "wipe" auswählen kannst, das löscht alle flüchtigen Speicher.
    • Hier kann es Probleme mit dem Google Account geben und dem geräte-schutz... Wenn hier also jetzt ein anderer Account benutzt wird, du nicht das Passwort von dem ursprünglichen Account hast und du hier alles löschst, bekommst du einen netten teuren Briefbeschwerer. Hast du aber so wie ich, den gleichen Account, oder gar nicht verknüpft mit dem Google-Konto oder mit der gerätesicherung... Bekommst du ein blankes sauberes System so insofern die Firmware im Flash-Speicher intakt ist. (Bei root Manipulationen oder fehlerhaftem flash kann auch die original Firmware beschädigt sein.)
    • Auch hier wird wieder mit der schaltwippe factory wipe, oder factory Reset ausgewählt und mit der Lautstärken-Tasten-Wippe oder mit der Power-Taste bestätigt... Ich weiß es auswendig nicht mehr, ich möchte es jetzt nicht nachvollziehen ...
Viel Glück, und berichte!
 
Zuletzt bearbeitet:
C

coraMoto

Neues Mitglied
Hallo Peter

Vielen Dank für die rasche Antwort und die Erläuterungen. Was nun die Button und MenueThematik angeht, habe ich mir das Handling hierzu einigermaßen erarbeitet. Hier liegt ja auch mein Problem. Bspw. die zwei Optionen mit dem "Wipe" bringen ja leider nichts.

Da ich über die Tage ( bis der bestellte Akku da war ) die SIM Karte in ein altes Telefon gesteckt habe, ist also bildlich gesprochen auch der GoogleAccount umgezogen. Worüber ich aktuell gar nichts weiß, ist das Thema "Geräteschutz". Darüber muss ich erst mal was lesen.

Bei den vielen Versuchen die ich gemacht habe, kann es schon sein, dass das Gerät längst hinüber ist. Aber da ich > 30 Jahre IT hinter mir habe, sind so kleine Dinge wie ein 4 Jahre altes Telefon bereits mental abgeschrieben bevor man sich an die Arbeit macht.

Wichtig wäre mir zu verstehen wie denn der aktuelle Status ist, denn ich denke das sich die Möglichkeiten nach dem Zustand ergeben.

Gibt es vielleicht ein PDF mit Erklärungen der wichtigsten Prozeduren, also so was wie eine HowTo Sammlung ?

Anbei kurz der Screenshot. Hier hatte ich vorher Nougat , ganz sicher !!

Ich werde wohl nochmal die FlashUmgebung ( platformtools , treiber, adb etc ) frisch aufsetzen, da ich mit den Treibern nicht so klar bin. Auch erscheint das G4 im DeviceManager nicht als QualComm....., sondern immer nur als ADB Device. Die oder den ComPort kriege ich auch nie zu sehen.

Fragen über Fragen....

Jetzt aber erst mal frohe Weihnachten.. ( das Abendessen ruft )
 

Anhänge

  • scan.pdf
    147,2 KB Aufrufe: 2
C

coraMoto

Neues Mitglied
Hallo Peter ( all others )

Hier ein Zwischenbericht wo ich aktuell stehe:

Neu installiert ; Alles Defaults ; Alle ohne Fehler !!
##################################
Motorola_Mobile_Drivers_64bit
C:\Users\-----\Downloads\Qualcomm-QDLoader-HS-USB-Driver-64bit-Setup
C:\Users\-----\Downloads\15_Second_ADB_Installer_v1.4.3\15 Second ADB Installer v1.4.3
##################################
Diese drei Pakete wären irgendwie dran, oder
##################################

ATHENE_OPJ28.111-22-1_cid50_subsidy-DEFAULT_regulatory-DEFAULT_CFC.xml.zip
blankflash_athene_8.1.0_OPJ28.72.zip
flash-script.zip

Und in der Datei die hier angefügt ist, kann man sehen was gerade geht, aber eben nicht mehr !!
 

Anhänge

  • Trial_1.pdf
    29,2 KB Aufrufe: 3
chrs267

chrs267

Erfahrenes Mitglied
@coraMoto Du brauchst kein Blankflash. Ein Blankflash wird nur benötigt, wenn dein Handy gar nicht mehr startet und der Bootloader beschädigt ist. Dann könntest du mithilfe des Blankflashs einen neuen BL aufspielen. Aber da der Befehl 'fastboot devices' ein ordentliches Ergebnis liefert, ist zumindest soweit alles in Ordnung.

Versuch doch mal, ob das Lenovo Rescue Tool dir weiterhilft. Lade dir einfach die aktuelle Version herunter, die auf der Seite geforderte Seriennr. musst du nicht eingeben.
 
C

coraMoto

Neues Mitglied
Hallo chrs267
Das war ja ein superTip. Leider aber nach 3 Vesuchen ( Tool Success ) bootet das G4 noch nicht.
Vielleicht doch ein Fall für blankflash ??
Wäre für jeden weiteren Hinweis dankbar.
Capture.PNG
LG
 
C

coraMoto

Neues Mitglied
Hi all

Nachdem ich so langsam zu einem blankflash tendiere, habe ich gelesen, daß das Telefon von diesem QUalComm Treiber erkannt werden muss, und dann auch so im DeviceManager unter Ports/ComX erscheinen muss. Da aber das Gerät ständig bootet, kommt es wohl nicht dazu.
Vielmehr habe ich immer nur das "Motorola ADB Interface, nachdem ich die BootLoop per Tastenkombi in den FastBoot Mode verlasse.
Also kriege ich den Blankflash nicht hin. Es bleibt also bei dem Bootloader der sich immer im Kreis dreht.

Any ideas welcome ........

Vielen Dank im Voraus
 
cptechnik

cptechnik

Moderator
Teammitglied
Du benutzt eine US Version Firmware... Ich tät das nicht...
Beitrag automatisch zusammengefügt:

Hast du definitiv eine US Version xt1642?
Beitrag automatisch zusammengefügt:

... verwirrend für mich...
 

Anhänge

Zuletzt bearbeitet:
chrs267

chrs267

Erfahrenes Mitglied
@cptechnik Das ist keine US-Version. Unten steht doch reteu.
 
C

coraMoto

Neues Mitglied
Hallo zusammen

Das mit der US Version hätte ich auch nicht erklären können.
Aber eine weitere Frage habe ich. Es scheint ja beim restore des Bootloaders auf den Treiber Qualcomm HDG oder so anzukommen.
Manche Einträge im Netz sprechen dabei auch von der Windowsversion. Kann es sein, dass es für blankflash eine Win8 oder Win7 Umgebung braucht ? Wegen der Nicht-anerkennung dieser Treiber unter Win10.

LG
Beitrag automatisch zusammengefügt:

Kurzes Update

Seit eben kriege ich beim Wechsel in den FastBoot Mode folgendes im DevMgr:

1640538083593.png
 
Zuletzt bearbeitet:
rene3006

rene3006

Inventar
@coraMoto
Aktualisiere die mal
Oder füge die Legacyhardware manuell hinzu
 
chrs267

chrs267

Erfahrenes Mitglied
@coraMoto Du kommst weder in den EDL Modus (der dazu nötig ist) noch macht es Sinn, weil dein Bootloader ganz offensichtlich einwandfrei funktioniert.
 
cptechnik

cptechnik

Moderator
Teammitglied
Sorry, ich benutze Linux/Ubuntu, da braucht man keine "Treiber"...
Nur die Tools aus dem Standard-Repository und... ganz schmutzig... "sudo"...
Für sowas könnte man sich auch ein Boot-Stick fertig machen...
 
C

coraMoto

Neues Mitglied
OK. Verstanden. Wenn ich diese Seite
( What is EDL Mode and How to Boot your Qualcomm Android Device into it )
richtig verstehe, dann kommt erst im EDL Mode der QDL Treiber zum tragen, und das Telefon erscheint im DevMgr als QualCommDevice. Richtig ? Das würde bedeuten, dass ich es mit den Treibern nicht "weiter treiben" muss!!?
Beitrag automatisch zusammengefügt:

@cptechnik

Ich bin auch mehr im Linux unterwegs. Aber sag mal mit welchen Tools machst du was ?
 
Zuletzt bearbeitet:
chrs267

chrs267

Erfahrenes Mitglied
coraMoto schrieb:
Das würde bedeuten, dass ich es mit den Treibern nicht "weiter treiben" muss!!?
Nein, musst du nicht. Dein Handy ist vollkommen bereit, um eine neue Firmware zu flashen.
 
C

coraMoto

Neues Mitglied
Also, dann suche ich für morgen nach einer passenden Anleitung, und werde versuchen diese auszuführen.
Mit Firmware meinst du jetzt den Bootloader, oder ein neues Android release ( Oreo ?! ).
 
cptechnik

cptechnik

Moderator
Teammitglied
[Factory Images] [OTA-Updates] [6.0.1] XT1642
Da mal umsehen...

apt install adb
apt install fastboot
Siehe auch Ubuntu Wiki

[Factory Images] [OTA-Updates] [6.0.1] XT1642

Das wichtigste dabei ist eigentlich...
fastboot flash system xxx
... wobei xxx mit dem Dateinamen der Partitionsteile (Mehrzahl) auszutauschen ist...
Das Drumherum sollte man aber auch mitmachen...
Ist halt wie bei Linux üblich... per Hand... es gibt bei den Images oft auch ein script.sh, ich habe es immer per Hand gemacht...

Diese Windows-Tools und auch das Lenovo Rescue Tool nimmt einem die Arbeit ab...

Ich glaube dass du nicht das richtige Image zum Gerät hast...

Vielleicht hilft auch händisch das Löschen der Partitionsinhalte mit fastboot erase... Oder mal verschiedene Images ausprobieren die nah an der Versionsnummer sind die vorher drauf war.
Beitrag automatisch zusammengefügt:

... und die User Partition löschen...

Ich gehe aber bald meiner Beschreibung immer davon aus das auf der User Partition nichts mehr drauf ist was zu retten gilt...
Getreu nach dem Motto... Kein Backup, kein Mitleid...
Dann kann man mich wunderschön brutal mit dem Gerät umgehen, alles löschen... neu flashen...

Bei irgendeinem Gerät hatte ich das auch schon mal... da musste ich eine gute handvoll Images durcharbeiten...
Und auf der externen SD-Karte darf auch kein Android Verzeichnis mehr sein in dem System Dateien abgelegt werden...
Beitrag automatisch zusammengefügt:

Noch eine Zugabe:
Ich kenne dieses Windows-Tool nicht, ich weiß nicht was die Anzeigen bedeuten, ich weiß nur eins... Wenn das Gerät ein US Gerät ist und man versucht eine EU-Version zu flashen, klappt das nicht - und umgekehrt... Es sind unterschiedliche Geräte.
 
Zuletzt bearbeitet:
C

coraMoto

Neues Mitglied
Danke erstmal. Wird ne Weile dauern bis ich das abgearbeitet habe.
FYI. Daten sind gesichert bzw. deren Wichtigkeit geht gegen 0000.

CU Hartmut
 
chrs267

chrs267

Erfahrenes Mitglied
cptechnik schrieb:
Ich kenne dieses Windows-Tool nicht, ich weiß nicht was die Anzeigen bedeuten, ich weiß nur eins... Wenn das Gerät ein US Gerät ist und man versucht eine EU-Version zu flashen, klappt das nicht - und umgekehrt... Es sind unterschiedliche Geräte.
Was das Tool anzeigt und von dir rot eingekreist wurde, ist der aktuelle Stand des Handys. Die Firmware, die geflasht wird, ist ganz unten in gelber Schrift dargestellt. Er hat Android 7 drauf und das Tool will Android 8 flashen. Diese Firmware braucht er nun.
 
cptechnik

cptechnik

Moderator
Teammitglied
Dann... Ist jetzt US drauf und er will reteu flashen ...
Meiner Kenntnis nach ist ein mischen nicht so einfach möglich.
Ich habe damals ebenfalls mit
fastboot get var (all)
verglichen, ob Hardware mit Firmware übereinstimmt... CID (50?) ... RETEU ...
Beitrag automatisch zusammengefügt:

Wenn jetzt offiziell Android 7 drauf war, würde ich auch wieder versuchen 7.0 zu flashen. Wenn die dann erfolgreich läuft, kann man immer sich noch überlegen 8.0 zu flashen.
 
Zuletzt bearbeitet:
Ähnliche Themen - Moto G4 plus BootLoop Antworten Datum
16