Huawei X2 GEM 701L Kein App Autostart [ GELÖST ]

  • 91 Antworten
  • Neuester Beitrag
Diskutiere Huawei X2 GEM 701L Kein App Autostart [ GELÖST ] im Original-Firmwares für Huawei MediaPad X2 im Bereich Huawei MediaPad X2 Forum.
Sarahlein

Sarahlein

Erfahrenes Mitglied
Nunja um das Thema damit mal abzuschließen um wider zum eigentlichen Thema zu kommen sei folgendes gesagt.

Ich hatte damals das Mate 7 und hate auch die Beta FW getestet. Ich hatte z.b das Problem das Whtasapp nicht gepusht hat weil es nicht selber gestartet ist. Andere Nutzer hatten das nicht. Ich hatte das Problem sogar wenn ich nur Whtasapp drauf hatte und sonst keine Änderungen.

Ich denke nicht das ein anderer Luancher große Auswirkungen haben kann. Es ist ja nur eine andere UI aber das System bleibt das selbe.

Beste Beispiel ist Windows. Wenn du das Design änderst läuft dein PC im normalerweise genauso wie davor.

Ich denke daher nicht das eine andere UI das gerät derart beinflusen kann.
 
K

kajos01

Gast
Naja, ein Launcher ist doch weit mehr, als das Design.
Dein Windows Vergleich würde sich wohl beschränken auf unterschiedliche Hintergrundbilder, bzw. vielleicht zusätzlich noch, ob animiert oder nicht, bzw. ob dafür Wetterdaten o.ä. abgefragt werden oder nicht.
Dazu kämpfen die Pc's wohl ehr ein wenig weniger mit der Umsetzung von Rechten der Einzelnen Anwendungen...

Dein geschildertes WhatsApp Problem habe ich zudem schon sehr oft gehört, bzw. bin diesbzgl von unterschiedlichen Bekannten zu Rate gezogen worden.
Das ließ sich eigentlich nicht auf eine bestimmte Smartphone Marke festlegen, nichtmal den Gerätetyp.
Dann aber schon ehr im Bereich Wlan-Umschaltung/HandyNetz
Das führt jetzt aber sicherlich erst einmal zu weit...

Ich bin erstmal gespannt, was Paypal bietet
Benötige noch einen Perlator(Strahlregler) für meinen Wasserhahn.
Sollte ich kostengünstig fündig werden, gibt's eine Ebay-Bestellung mit PayPal
App ist im System und Phone ist rebooted ;)
-- Dieser Beitrag wurde automatisch mit dem folgenden Beitrag zusammengeführt --
!!PayPal im System hat funktioniert!!

werde das weiter beobachten, und ggf. hier kommentieren
 

Anhänge

H

helios

Fortgeschrittenes Mitglied
Nicht vergessen mit AutoRunManager nachzugucken ob ne APP (die eben nicht startet) den "boot_completed" receiver gesetzt hat !!!!

Mir ist aufgefallen das zb. "Missed call reminder" der auch nach der SystemUmwandlung nicht startete, den"boot_completed" receiver NICHT gesetzt hatte (kann man via AutoRunManager ändern).
Nach dem setzen,und reboot,tuts !!

Hab ne große Freude mit dem Großen Teil :)
Für mich is das also erledigt,und ma sehn wenn das 6erUpdate kommt,hoffentlich von Huawei gelöst !

Danke allen für die Tipps und Hilfe !!
 
Sarahlein

Sarahlein

Erfahrenes Mitglied
So Auquamail geht auch.

Am besten klappt das ganze mit Link2SD.

Übrigens. Wer mehr platz auf auf der System Partiton braucht ohne das das Handy spinnt.

Mit Link2SD einfach eine System App in einer User App machen. Dann klappt es auch. Nicht Einfach deinstallieren!!!

Mit Link2SD gehen beim Umwandeln von User in System Apps auch keine Daten der App verloren und es geht sehr einfach.

Nur so als Tipp.
 
H

helios

Fortgeschrittenes Mitglied
Danke für den Tipp,wußte nicht das es in die andere Richtung auch geht !!!
 
K

kajos01

Gast
helios schrieb:
Nicht vergessen mit AutoRunManager nachzugucken ob ne APP (die eben nicht startet) den "boot_completed" receiver gesetzt hat !!!!

Mir ist aufgefallen das zb. "Missed call reminder" der auch nach der SystemUmwandlung nicht startete, den"boot_completed" receiver NICHT gesetzt hatte (kann man via AutoRunManager ändern).
Nach dem setzen,und reboot,tuts !!
Irgendwie drehen wir uns hier bisw. wohl im Kreis :confused:

kajos01 schrieb:
Ich habe nach wie vor den Verdacht, dass bei Dir diesbzgl etwas schief liegt, weil ich das Problem generell nicht so ausgeprägt habe, auch ohne das Umwandeln in System-Apps
ev:
Huawei-Info - Tipps & Tricks für EMUI 3.1 (Huawei P8, Mate S etc)
Hier habe ich gestern Abend erst wieder auf diese Problematik hingewiesen, halt nur nicht auf English ;)
-- Dieser Beitrag wurde automatisch mit dem folgenden Beitrag zusammengeführt --
Ich habe seinerzeit ausführlichst mit LinkToSD gearbeitet - hat auch grundsätzlich einwandfrei funktioniert und habe mir deshalb auch noch die Plus-Version gegönnt!

Allerdings hat es das Note erheblich träger gemacht, sodass ich es nach 1/2Jahr Nutzung wieder runtergeschmissen habe!

Mit dem X2 dürfte das wg. potenterer Harware weniger relevant sein, vermeide es deshalb aber trotzdem.
-- Dieser Beitrag wurde automatisch mit dem folgenden Beitrag zusammengeführt --
Ferner nutze ich aktuell keine SD, sondern DualSIM :cool:
-- Dieser Beitrag wurde automatisch mit dem folgenden Beitrag zusammengeführt --
Wenn es mit dem internen Speicher irgendwann knapp werden sollte..

kajos01 schrieb:
Funktioniert, habe ich mit einer "alten" SIM nachvollzogen!
-- Dieser Beitrag wurde automatisch mit dem folgenden Beitrag zusammengeführt --
wenn ich einen Ersatz-Einschub erwerben kann, werde ich mir eine praktikablere, altagstaugliche Lösung schaffen!
Aktuell ist der Speicherplatz ohnehin noch ausreichend, sodass ich ein Angebot in Ruhe abwarten kann.
Von div. Huawei sind SIM Tray's unlängst verfügbar, halt nur (noch) nicht vom X2

Dual SIM and SD memory DIY - Post #47
Vielleicht versuch' ich dann auch mal wieder LinkToSD Plus ;)
 
Zuletzt bearbeitet von einem Moderator:
K

kajos01

Gast
Im Zuge des AutoStart Tests im erweiterten Sinne hatte ich nun auch den Ansatz, TitaniumBackup in eine Systemanwendung umzuwandeln.
Ziel:
Ev. hierdurch die Bordfunktion "In eine Systemanwendung umwandeln" funktionstüchtiger, also ohne "Dauerschleife" zu gestalten.

Offensichtlich 'akzeptiert' das/mein X2 Titanium nicht als Systemanwendung!
Ich habe es mehrfach, auf unterschiedlichen Wegen versucht:
Titanium startet, wird aber umgehend kommentarlos wieder beendet..

Bedingt wohl durch die vielen Versuche ging es nach einem Neustart sogar so weit, dass angezeigt wurde, mein System sei inconsistent -> wipe data..
Ich war mutig und habe angekreuzt: "I feel lucky.."

Die Ursache habe ich dann natürlich mit Rückwandlung/konventionellem Löschen und erneuter Install. erfolgreich behoben, trotzdem sei hier gewarnt, dass es diesbzgl offensichtlich nicht so problemlos läuft, wie zumind. bei älteren Samsung Phones.
Ich nehme an, dass Titanium wohl zwangsläufig noch nicht so auf Huawei optimiert ist.

BoxToGo und web.deMAIL laufen aktuell im AutoStart Test als Systemanwendungen:cool:
 
Zuletzt bearbeitet von einem Moderator:
Sarahlein

Sarahlein

Erfahrenes Mitglied
So ich habe das ganze jetzt mal getestet.

Ich habe folgende Apps ins System gemacht.

- Facebook
- Ebay
- Ebaykleinanzeigen
- TVMovi
- Mein Vodafone
- Paypal
. Android Wear
- Shpock
- Twitter
- Auquamail

Facebook: Diese App läuft ohne Probleme und startet schön brav mit.

Ebay: Diese App lief bei mir auch als User Anwedung. Auch als Systemapp läuft diese top.


Ebaykleinanzeigen: Bisher war kein Test möglich.

TVMovi: Diese App startet mit und pucht zu gewohnten Zeit um 19:00 Uhr

Mein Vodafone: Tja meine Rechnung kam erst vor einigen Tagen daher muss ich hier warten.

Paypal: Selber nicht getestet aber es wurde bestätigt das es geht.

Android Wear: Es gab immer mal Probleme mit der Uhr, seit die App im System ist klappt alles ohne Fehler.

Shpock: Leider bisher nicht getestet

Twitter: Alles top ohne es selber zu starten.

Aquamail: Nachdem ich es mit Link2SD ins System geschrieben habe läuft sie top.

Um mehr Platz im System zu haben ich Google Maps und einige andere Apps als User App umgeschrieben.

Mit TB hatte ich nur ärger was das Umwandeln betroffen hat. Mit Link2SD klappt das erheblich besser. Link2SD erfordert übrigens keine SD Karte ;)

Ich hoffe das mein Beitrag hilfreich war.

LG

Sarah
 
K

kajos01

Gast
Sarahlein schrieb:
Link2SD erfordert übrigens keine SD Karte ;)
Ist mir klar bzgl. Funktionen, wie Systemumwandlung.
Ich dachte da ausschließlich an die Speicherplatz-Erweiterungen, welche der App auch ihren Namen geben;)

Nach Deiner euphorischen Beschreibung der App und meinen Titanium-Problemen mit dem X2 habe ich ich die App bereits wieder install. und werde sie demnächst bzgl. der Sytem-Umwandlung testen:cool:
Das betrifft dann natürlich auch nicht meine geschilderten Vorbehalte wg. der festgestellten Performance-Probleme auf dem Gnote1
 
Sarahlein

Sarahlein

Erfahrenes Mitglied
Du kannst nach dem umwandeln einfach Link"sd wider löschen und fertig.
 
K

kajos01

Gast
will ich erst einmal gar nicht, wie gesagt, bezog sich das im Wesentlichen auf die Partitions-Geschichte.
Und wenn das wirklich so problemlos läuft, wie einst bei T., hat die App ihre volle Daseinsberechtigung zurückerworben:cool:

Wo ich allerdings noch vorsichtig bin, sind diese Dalvik-Cache Bereinigungen bei Link2SD
Im Gegensatz zu der von T, hat die mir mal richtig Ärger gemacht...
Das führt jetzt hier aber zu weit und muß man ja auch nicht zwingend nutzen
 
Zuletzt bearbeitet von einem Moderator:
Sarahlein

Sarahlein

Erfahrenes Mitglied
Ich nutze Link2SD eben nur fürs umwandeln oder Entfernen von System Apps. Wobei zweiteres bei mir probleme machte.

Um Apps auf die SD Karte zu linkem kann ich Folder Mount empfehlen. Ist wesentlich Einfacher.
 
K

kajos01

Gast
Habe mir das gerade einmal angeschaut:

Die ohnehin von mir inst. Allround-App
3C Toolbox Pro – Android-Apps auf Google Play
hat selbstversändlich u.A. die Systemumwandlung!

Da das, wie gesagt bislang bei T. funktionierte, hatte ich keinerlei Ansatz, querzuschauen

Der Cedric Counotte ist zudem ein sehr hilfsbereiter und lösungsorientierter Mensch, mit dem ich schon wg. des BatteryMonitorWidgets mehrfach im Kontakt stand.
Am Ende stand immer eine Lösung des Problems!

Naja, wieder viel auszuprobieren;)
 
Sarahlein

Sarahlein

Erfahrenes Mitglied
Ebaykleinanzeien App geht auch.

Gerade getestet.
 
H

helios

Fortgeschrittenes Mitglied
@Titanium Backup "Bitte Warten" loop bei UserAPP=>SystemApp-Umwandlung :
Einfach TiB nach zb. 20 sec mit dem Taskmanager killen,neu aufrufen/nexte App umwandeln.
TiB bleibt nach beendigung der Umwandlung stecken,nicht mittendrin.
Alle Apps die ich so umgewandelt hatte,funktionieren einwandfrei !

Wäre nicht dieser Aufwand nötig das gewollte Apps selberstarten,ist Huaweis Art den Autostart zu managen,ja extrem sinnvoll.

Während zb. bei allen SamsungTeilen die ich je hatte,Chrome/Youtube/und anderes IMMER von selber startete (nicht nur boot,auch nach beenden,zb. bei Wlan Statusänderung/Autosync an/... Chrome is da besonders nervig,selbst mit allen receivers deaktiviert,ist es immer am Laufen) ,ist beim X2 Stille :)
Du startest/beendest Chrome und da gibts kein ZombieWiederauftauchen später.


Das einzige was mich derzeit noch beim X2 wurmt,is die hohe "SYSTEM" CPU Zeit (im Taskmanger / verwende SystemPanel)
Selbst wenn das Teil DisplayOFF hat,läuft die CPU Zeit für SYSTEM weiter,und am ende vom Tag hab ich dann schon mal 50 minuten CPU Zeit zusammen,bei meinem alten SamsungHändi waren das vielleicht 10 min max,bei normaler Nutzung. Das is schon extremer Unterschied find ich.

Hat sich das jemand schon ma angeguckt ?
 
K

kajos01

Gast
wo ist denn der tatsächliche Nachteil? Ich empfinde den Energie-Verbrauch als grundsätzlich extrem niedrig, und sehe daher kein Handlungsbedarf
 
H

helios

Fortgeschrittenes Mitglied
dazu kann ich noch nichts sagen,ich hab nur was die CPU zeit angeht,nen Vergleich.
Wieviel % nimmt AndroidSystem bei dir in der AkkuStatistic ein ?
 
K

kajos01

Gast
0,42%
 
H

helios

Fortgeschrittenes Mitglied
wouh ok... du siehst den "kleinen" unterschied zu mir :)
was für ne laufzeit hast dein os,weil ich denk die % werden relativ berechnet zum Messzeitraum,sprich wenn ich jetzt rumbastle & reboote und das System viel zu tun hat,und wenig zb. Firefox/Tel/anderes nutze,is klar das das System höheren % hat.
 
K

kajos01

Gast
war bei nächtlicher Ladung noch nie unter 70%. Daher ist das für mich eigentlich irrelevant
 

Anhänge