Huawei X2 GEM 701L Kein App Autostart [ GELÖST ]

  • 91 Antworten
  • Neuester Beitrag
Diskutiere Huawei X2 GEM 701L Kein App Autostart [ GELÖST ] im Original-Firmwares für Huawei MediaPad X2 im Bereich Huawei MediaPad X2 Forum.
H

helios

Fortgeschrittenes Mitglied
danke für den screenshot !!!!!!!

der Prozess um den es mir geht ist der zweite bei dir in der Liste : "Android-System".
Ich weiß nicht ob das jetzt ein BatteryDrain bei mir ist (wegen meiner Konfig) oder das es bei Huawei normal so ist.
Jedenfalls nimmt der SystemProcess weiter CPUzeit in Anspruch wenn ich den Bildschirm abschalte.
Hab das mit nem SammyTab überprüft und da bleibt die CPUzeit Aufnahme vom SystemProcess stehn bzw. in 5h. läuft der vielleicht 5 sec weiter.
Aber beim X2 sind das 20-30 min....

Will einfach nur wissen ob das an meiner Konfig liegt (weil zb. ein Tool da was auslöst) oder das normal ist,da die HuaweiAndroid"Edition" doch ganz anders als die von Samsung ist!
 
K

kajos01

Gast
werde es mal beobachten, befüchte das bald in Deinem Falle...
 
K

kajos01

Gast
@Sarahlein
Ich habe jetzt testweise mal MonsterBackupPro mit L2SD in's System überführt - Funktion ist erstmal gegeben, aber:

die App wurde in system/priv-app untergebracht:confused:
nicht in system/app

interessanterweise wurde auch diese, mir erstmals auf diesem Gerät verwendete Struktur mit der .apk Unterbringung in einen Extra-Ordner, nur für die jeweilige App, angewandt

Wenn ich händisch in das System integriere, verwende ich stets die klassische Struktur, d.h. die .apk kommt direkt in system/app
 
H

helios

Fortgeschrittenes Mitglied
glaub ab Android 5.0 gilt diese neue Folderstructure !
Wie ich mein SammyTab aufgeräumt hab,sprich von BloatWare gesäubert hab (wurde mit 5.0.2 ausgeliefert) ist mir das auch aufgefallen.
Wichtige Sachen sind nachwievor system/app jedoch eben mit OrdnerStruktur und naja halbsowichtige Sachen sind in system/priv-apps (sammyBloatWare war fast nur dort)

Die Apps die TiB am X2 in eine SystemApp umgewandelt hat.... die sind alle im system/apps verzeichnis einfach als .apk gelegt worden ohne unterordner!!
 
Sarahlein

Sarahlein

Erfahrenes Mitglied
kajos01 schrieb:
@Sarahlein
Ich habe jetzt testweise mal MonsterBackupPro mit L2SD in's System überführt - Funktion ist erstmal gegeben, aber:

die App wurde in system/priv-app untergebracht:confused:
nicht in system/app
Ist das nicht absolut egal? Es Funktioniert so hervoragen da macht es keinen Unterschied wo es liegt. Jedenfalls keinen für mich erkennbaren.
 
K

kajos01

Gast
ich wollte es eigentlich gar nicht kommunizieren, aber ich habe mir mit dem Verschieben ->Link2SD mein X2 derart abgeschossen, sodass ich es mit dem Komplett_Restore vollkommen neu aufsetzen mußte!
Soetwas ist mir niemals zuvor passiert und meine Eingriffe sind bislang vergleichsweise lächerlich!

Das ist also gewiss nicht egal, schon gar nicht absolut, hat @helios doch in Post #64 bereits äußerlich deutlich erkennbare Unterschiede in der Art der Systemverschiebungen ausgemacht/bestätigt.
Mit der 3C Toolbox Pro(ehem. AndroidTuner) habe ich es allerdings noch nicht versucht

Zum Glück hat das wiederum verblüffend gut funktioniert.
Die Wiedereinspielung habe ich kompl. über SD gemacht

Ich bin jetzt allerdings keineswegs so drauf, den Ursachen nicht doch, zumindest zum T. auf die Spur kommen zu wollen!

Was ich nach ersten Erkenntnissen vermeiden werde:
eine mit anderweitiger Methode nach system/app verschobene Anwendung mit Link2SD wieder zu einer User Anwendung umwandeln zu wollen...
 
Sarahlein

Sarahlein

Erfahrenes Mitglied
Das das X2 abschmiert passierte bei mir nur wenn ich versuche Apps aus dem Systen zu löschen. Aber beim einfügen ist mir das nicht passiert. Ich habe ALLE meine Apps die ich genannt habe mit Link2SD ins System gepackt und ALLE laufen wie sie sollen. Der Akku hält bei mir genausogut wie vorher und das X2 läuft genauso flüssig wie davor.

Entweder hast du was falsch gemacht oder ich hatte einfach viel Glück.

Man kann Apps aus dem System löschen mit Link2SD aber man muss sie zuvor in eine User App umwandeln dann führt es auch nicht zum Crach.

Aber beim einfügen einer User App ins System hatte ich mit Link2SD 100% Erfolg und nicht ein einziges Problem.

Ich habe sogar Google Maps als User App umgeschrieben und später wider als System App gemacht und auch da gab es keiner Fehler. Ich habe sie wider ins System geschrieben weil meine Wear sie als User App nicht mehr aufrufen konnte.

Wie gesagt ich kann nur das berichten was bei mir geht und was eben nicht geht.
 
K

kajos01

Gast
Genau beim Umwandeln in eine User-App ist es passiert!
(meine ich auch indirekt beschrieben zu haben)

kajos01 schrieb:
Was ich nach ersten Erkenntnissen vermeiden werde:
eine mit anderweitiger Methode nach system/app verschobene Anwendung mit Link2SD wieder zu einer User Anwendung umwandeln zu wollen...
 
Sarahlein

Sarahlein

Erfahrenes Mitglied
Welche App war denn das???
 
Sarahlein

Sarahlein

Erfahrenes Mitglied
Die App habe ich nichtmal auf dem X2 drauf...
 
S

Sofaoppa

Neues Mitglied
Lange ist es her...
So, ich habe nur eine App als Systemapp eingerichtet: Nur Autostart And StaY. Nach einem Neustart startet die App und startet alle Apps, die ich in Autostart And StaY dafür vorgesehen habe.
 
K

kajos01

Gast
..z.B.
mit den anderen Apps hat's den selben Hintergrund -

Tendenziell alles
- was sicher automatisch synchronisieren/aktualisieren.. soll, auch nach einem Neustart
- was nach dem Booten starten soll
(Apps, welch dieses von sich aus - also auch auf anderen Phones nicht tun, benötigen dafür ggf. einen Schubser durch "Autostart And StaY")
 
Zuletzt bearbeitet von einem Moderator:
Sarahlein

Sarahlein

Erfahrenes Mitglied
Ich habe es anders gemacht.

Ich habe erstmal alles aus dem System gelöscht was ich nicht brauche. In Android ist ja so viel Müll drin den keiner nutzt oder braucht.

Dadurch konnte ich sehr viel Platz auf der Systempartiton gewinnen.

Dann habe ich alle Apps die nicht Automatisch starten wollten ins System geschrieben. Seit dem läuft alles rund und das X2 begeistert mich von Tag zu Tag mehr.

Ich muss nicht starten oder anschubsen oder so. Alles geht ganz alleine. Ich muss nur das Handy einschalten.
 
K

kajos01

Gast
Hier sind wir aktuell auch gerade nahe an diesem Thema:
Apps Empfehlung oder ihre eventuellen Probleme
-- Dieser Beitrag wurde automatisch mit dem folgenden Beitrag zusammengeführt --
Dann hast Du es nicht anders gemacht, @Sarahlein , sondern exakt genau so, nur dass Du zuvor etwas Platz geschaffen hast..
(das dürfte aber für viele ohnehin ein Grund sein überhaupt zu rooten;)
-- Dieser Beitrag wurde automatisch mit dem folgenden Beitrag zusammengeführt --
Die "Daseinsberechtigung" für den "Schubser" habe ich zur Vermeidung von Mißverständnissen nun zusätzlich fett-geschrieben!
Das ist aber defintiv ein ehr seltener Sonderfall,
bei mir z.B. Nify
Nify – Android-Apps auf Google Play
 
H

Horka

Ambitioniertes Mitglied
Beim Titel steht "Gelöst".

Sorry, ich finde die Lösung hier nicht...

Ich bekomme z. B. kein Sidebar ans Autostarten, auch mit Autostart And Stay nicht.
 
K

kajos01

Gast
Das war darauf bezogen, dass in vielen Fällen es hilft, die betreffende App in eine Systemapp umzuwandeln, z.B. mit Link2SD
Das betrifft im Wesentlichen auch Apps, welche einer (regelmäßigen) Synchronisation bedürfen
-- Dieser Beitrag wurde automatisch mit dem folgenden Beitrag zusammengeführt --
Welche Manipulationen bzgl. SystemApps habe ich beim MediaPadX2 vorgenommen und warum..?
-- Dieser Beitrag wurde automatisch mit dem folgenden Beitrag zusammengeführt --
Hast Du mal einen Link zu der Sidebar-App, es gibt da so viele verschiedene
 
K

kajos01

Gast
App2SD öffnen
Benutzer- oder Alle Apps
App auswählen
lange auf die App tippen
in System-App umwandeln
Neustart
-- Dieser Beitrag wurde automatisch mit dem folgenden Beitrag zusammengeführt --
Ist Dein Phone rooted?
Das ist allerdings Voraussetzung!
 
H

Horka

Ambitioniertes Mitglied
Beim Umwandelversuch kommt: Link2SD hat keine Root-Rechte bekommen.

Funktioniert das Verfahren nur bei gerooteten Geräten?