Aquaris X Pro Komme nur in den Fastboot oder den anderen Modus, bzw. nur ganz selten

  • 18 Antworten
  • Neuester Beitrag
Diskutiere Komme nur in den Fastboot oder den anderen Modus, bzw. nur ganz selten im Root / Custom-ROMs / Modding für bq Aquaris X / X Pro im Bereich bq Aquaris X / X Pro Forum.
vonharold

vonharold

Experte
Hallo zusammen,
ich habe aktuell hier einen neuen Patienten auf dem Tisch liegen und das mit offenem Herzen (ohne Rückdeckel, gesplittert).
Ich würde das Teil gerne flashen, da vermutlich noch die Original Software installiert ist.
Leider fährt das Teil immer runter, sobald es den Screen erreicht hat.
Ich kann leider nicht sagen, ob eine Pin eingegeben werden muss.
Aktuell komme ich nur mit viel Glück in den Fastboot Modus, oder in den anderen Modus, siehe Bilder.

Leider kann ich die Build nicht in den Systemeinstellungen auf den Entwicklermodus umstellen.
Wer hat eine Idee, wie ich das Teil wieder zum starten bewegen kann, damit ich das BQ rooten kann.

Daten welche installiert sind, sind nicht wichtig zu diesem Zeitpunkt.

Nachtrag: Ich werde mal diesen Thread hier komplett abarbeiten Aquaris X Pro - bleibt im Boot Loop und wird nicht erkannt
Akku wurde schon getauscht.
Leider wird die LED Anzeige nicht grün.
Probiere mal die Sachen vom Beitrag #9 aus. Melde mich dann und gib den Stand durch.
 

Anhänge

Zuletzt bearbeitet:
der_tiroler

der_tiroler

Erfahrenes Mitglied
Du kommst ja noch in die Recovery wie auf dem ersten Bild ersichtlich.
Da schon mal Factory Reset gemacht ?
Installiert ist laut den Bildern das aktuelleste Update (2.11) das von BQ noch kam.
Beitrag automatisch zusammengefügt:

Firmwares, USB Treiber und Flashtool bekommst du auch hier falls die Links aus dem andern Thread nicht mehr gehen sollten.
BQ Aquaris X Pro Notebooks & Tablet PCs > Downloads Drivers, Manual and Firmware
 
Zuletzt bearbeitet:
vonharold

vonharold

Experte
Hallo @der_tiroler,
aktuell habe ich das Problem, dass ich das Teil wieder nicht gestartet bekomme.
Aber sobald ich das wieder in den Griff bekomme, werde ich das auch noch tun.

Die ganzen Links aus dem anderen Thread sind tot. Danke für den neuen Link.
Mache ich da mit der Firmware nicht ein Downgrade?
 
Zuletzt bearbeitet:
der_tiroler

der_tiroler

Erfahrenes Mitglied
Downgrade musst ja nicht machen. Kannst die selbe 2.11 ja drüberflashen.
Ist halt nur die Frage ob das Flashtool das Telefon erkennt wenn USB Debugging nicht aktivieren kannst, und ob du nicht die json-Datei zum Bootloader entsperren brauchst im Flashtool.
Kannst auch mal probieren ob mit Einschaltknopf und die beiden Lautstärketasten gleichzeitig für etwa 20 Sekunden drücken nicht den Hardreset auch so auslösen kannst.
 
Zuletzt bearbeitet:
Bearbeitet von der_tiroler - Grund: Typo
vonharold

vonharold

Experte
Hallo zusammen,
ich bin aktuell soweit, dass ich das Pinmuster eingeben soll. Nur das steht mir leider nicht zur Verfügung.
Gibt es eine Möglichkeit das zu umgehen?
 
Skyhigh

Skyhigh

Guru
Nein. Leider nicht.
Das Problem ist, das du dieses nach einem Factory reset auch wieder benötigst wegen der FRP.
(So weit bin ich nämlich auch)
Einen Weg die FRP zu umgehen hab ich bisher nicht gefunden, da die gängigen Videos dazu bei mir nicht funktionieren.

Hier wäre die Json der richtige Weg, leider habe ich hier auch einen Briefbeschwerer liegen, da BQ nie veröffentlicht hat, wie die Json generiert wird.
Versuchs Mal bei VinSmart. Die haben BQ gekauft und die Modelle unter dem Namen Active 1 baugleich weiter vertrieben.

Mit Glück können die dir eine Json generieren.
Meine Mail wurde damals jedoch wiederholt einfach ignoriert
 
vonharold

vonharold

Experte
Hallo zusammen,
das mit der Pin hat sich erledigt. Habe das Muster erhalten mit ganz viel Zureden und Eidesstattlicher Versicherung, dass ich kein Unfug mit den Daten mache ;-)
So morgen oder im Laufe der Woche wird das Teil gerootet und mit LineageOS 19.1 bestückt als Versuchsobjekt.
 
chrs267

chrs267

Stammgast
@vonharold Nur als Info: USB-Debugging, Entwickleroptionen und sonstiges, was im lfd. System in den Einstellungen geändert werden kann, spielen beim Flashen überhaupt keine Rolle.
 
Skyhigh

Skyhigh

Guru
@chrs267 Die OEM Entsperrung schon.
Ohne diesen Schalter umgelegt zu haben, kannst du ohne json den Bootlader nicht entsperren

Und ohne offenen BootLoader, kein Flash
 
Zuletzt bearbeitet:
chrs267

chrs267

Stammgast
@Skyhigh
Ja, die OEM-Entsperrung ist natürlich richtig. Aber ich wollte mich darauf beziehen:
der_tiroler schrieb:
Ist halt nur die Frage ob das Flashtool das Telefon erkennt wenn USB Debugging nicht aktivieren kannst,
 
der_tiroler

der_tiroler

Erfahrenes Mitglied
Skyhigh schrieb:
Versuchs Mal bei VinSmart.
Kannst du vergessen. ViSmart hat doch die Handysparte auch eingestampft.
vonharold schrieb:
So morgen oder im Laufe der Woche wird das Teil gerootet
Für Lineage brauchst nicht rooten.
Entwickleroptionen USB Debugging aktivieren und OEM-Entsperrung.
Anschliessend in Fastboot reinstarten und LOS Recovery oder TWRP Recovery flashen am Rechner über ADB.
Recovery IMG-Datei am einfachsten in den ADB Ordner kopieren am Rechner.
Code:
fastboot flash recovery xxxxxx.img
fastboot reboot
Dann wieder in die Recovery rein und ROM flashen.
Zusätzlich zu vorherigem durchzuführenden Wipe System/Data (TWRP: löschen -> erweitertes löschen) empfiehlt es sich auch die Datenpartition zu formatieren.
Wenn GAPPS benötigt werden, dann die gleich anschliessend flashen bevor man das System das erste mal startet !
Magisk kann man bei Bedarf auch später machen.
 
Zuletzt bearbeitet:
der_tiroler

der_tiroler

Erfahrenes Mitglied
@chrs267 ohne dass Debugging aktivierst, wird der PC das Handy halt nicht erkennen in der ADB bzw im Fastboot.
 
Zuletzt bearbeitet:
chrs267

chrs267

Stammgast
@der_tiroler USB-Debugging ist absolut irrelevant für die USB-Verbindung bei Fastboot. USB-Debugging ist einzig und alleine nur für ADB im lfd. System relevant, damit du Zugriff auf das Gerät bekommst. Selbst in der Recovery brauchst du das nicht, da dort ADB immer standardmäßig aktiv ist.
 
der_tiroler

der_tiroler

Erfahrenes Mitglied
chrs267 schrieb:
USB-Debugging ist einzig und alleine nur für ADB im lfd. System relevant, damit du Zugriff auf das Gerät bekommst.
Damit du im Fastboot Mode am Gerät über ADB eine Custom Recovery (mit der originalen bekommt du ja kein CustomROM drauf) flashen kannst, brauchst es wohl auch.
Sonst würde es wohl auch nicht in den Wikis so stehen. 🤔

los.jpg
Install-Guide TWRP:
los2.jpg


chrs267 schrieb:
Selbst in der Recovery brauchst du das nicht,
Niemand redet von Zugriff in der Recovery........
 
Zuletzt bearbeitet:
Skyhigh

Skyhigh

Guru
Wenn ich mir die Guides so anschaue, wird ADB wirklich nur benötigt um komfortabel in den Fastboot/Bootloader Modus zu kommen.

(adb reboot bootloader)

Wahrscheinlich zur Vereinheitlichung, da verschiedene Geräte manchmal verschiedene Tastenkombinationen haben.

Wenn man die Tastenkombination kennt, wird es also tatsächlich nicht benötigt.
 
Zuletzt bearbeitet:
chrs267

chrs267

Stammgast
@der_tiroler In deinem Screenshot steht es doch auch so drin: Du sollst USB-Debugging aktivieren, um den Befehl adb reboot bootloader auszuführen. Und das im lfd. System.
 
der_tiroler

der_tiroler

Erfahrenes Mitglied
Skyhigh schrieb:
um komfortabel in den Fastboot/Bootloader Modus zu kommen.
chrs267 schrieb:
Du sollst USB-Debugging aktivieren, um den Befehl adb reboot bootloader auszuführen. Und das im lfd. System.
Hm, von der Richtung hab ich es noch gar nie betrachtet.
Hab aber auch immer manuell per Tastenkombi in Fastboot gestartet.
Und dabei flash ich schon seit CyanogenMod 10 an meinen Geräten rum. 🤦‍♂️
Man lernt nicht aus...
 
vonharold

vonharold

Experte
Hallo zusammen,

vielen Dank für Eure ganzen Tipps und Hilfe. Aktuell läuft nur das nackte LineageOS 19.1 auf dem Bastelhandy.
Es werden keine Gapps installiert.
Mit der Originalen Rom ist mir das Handy laufend abgestürzt und war kaum noch zu starten.

Ich hoffe, dass durch das flashen der LineageOS das Problem sich gibt.
Werde das mal im Auge behalten und vorerst nicht viel Energie da rein stecken.
 
Zuletzt bearbeitet: