fastboot flash recovery b119,waiting for device ........

  • 37 Antworten
  • Neuester Beitrag
Diskutiere fastboot flash recovery b119,waiting for device ........ im Root / Custom-ROMs / Modding für Huawei Ascend Mate 7 im Bereich Huawei Ascend Mate 7 Forum.
S

Satmaster2014

Neues Mitglied
Hi Leute

Kann kein flash recovery mit fastboot mehr flashen.

Software auf dem Handy B145,gerootet,und CWM 6.0.5.0
Bootloader ist geöffnet(PHONE Unlocked)

Treiber, HiSuiteSetup_V2.3.14 und minimal_adb_fastboot_v1.1.3_setup installiert.

Habe auf unterschiedlichen Systemen 32-Bit- und 64-Bit und PCs ausprobiert,USB Kabel ausgetauscht.

Handy wird am PC erkannt, sowohl als MTP und USB Massenspeicher.

Reset und auf Werkseinstellungen zurück gesetzt bringt auch nichts.

Wipe data/factory reset und wipe cache bringt auch nichts.

Waiting for device.... und weiter komme ich nicht.

Habt Ihr noch eine Idee?
 
fooox1

fooox1

Lexikon
Fastboot funktioniert nur bei ausgeschalteten Gerät. Also, Mate 7 ausschalten und mit gedrückter Vol leise an den PC. Solltest den weißen Bildschirm mit Unloget sehen. Dann kannst du am PC deine FastbootBefehle eingeben.
Ach ja, am Gerät muss USB Debugging aktiv sein.
 
S

Satmaster2014

Neues Mitglied
Hallo

am Gerät ist natürlich USB Debugging aktiv.
Habe schon zig mal Software aktualisiert und kenne mich aus mit Fastboot Befehlen und wie mann dahin kommt.
Habe ja auch den Bootloader entsperrt und root hinzu gefügt.

Es ligt also nicht daran wie ich ins Fastboot Modus komme sondern
das Tel steht schon im fastboot Modus und der PC wartet auf Waiting for device....
d.h.
das tel wird im FASTBOOT MODUS vom PC nicht erkannt obwohl ich die Treiber zig mal installiert habe.
es erscheint auch nicht im FASTBOOT MODUS das USB Zeichen am PC .

Im normalen Betrieb wird das Tel erkannt.
 
fooox1

fooox1

Lexikon
Ok, hatte es so verstanden das du es angeschaltet an den PC gehängt hast. Du kannst es ja mal mit meinen Tool versuchen. Wichtig, deine img muß um benannt werden. Braucht den Namen von der enthaltenen.
[Tool] Stock- und Custom-Recovery aufspielen
 
S

Satmaster2014

Neues Mitglied
universal adb driver instaliert,aber ohne Erfolg.
Gerät wird erkannt aber nicht im FASTBOOT MODE !

fooox1 schrieb:
Ok, hatte es so verstanden das du es angeschaltet an den PC gehängt hast. Du kannst es ja mal mit meinen Tool versuchen. Wichtig, deine img muß um benannt werden. Braucht den Namen von der enthaltenen.
[Tool] Stock- und Custom-Recovery aufspielen

Der Link ist tot,Hast du bitte ein Link der geht ?

habe das Tool von Kang gefunden ,geth auch nicht.

Hier ein Bild vom Fehler. waiting for device
https://dl.dropboxusercontent.com/u/79152911/Screenshot 2015-09-13 21.58.42.png
 
Zuletzt bearbeitet:
Momochoid

Momochoid

Ambitioniertes Mitglied
Hast du die HiSuite von Huawei installiert wenn Ja, deinstallier die mal (ggfs danach PC mit CCleaner zzgl registry reinigen und PC neu starten) und probier es dann nochmal evtl. auch mal einen anderen USB-Port am PC probieren...

& der Link geht...
 
Simon G.

Simon G.

Guru
Hat dein Handy noch schnell Start in den Einstellungen oder Bedienungshilfen wenn ja auch ausmachen denn daran kann es auch haken solltest du das haben
 
S

Satmaster2014

Neues Mitglied
Momochoid schrieb:
Hast du die HiSuite von Huawei installiert wenn Ja, deinstallier die mal (ggfs danach PC mit CCleaner zzgl registry reinigen und PC neu starten) und probier es dann nochmal evtl. auch mal einen anderen USB-Port am PC probieren...

& der Link geht...
Habe hisuite deinstalliert und mit ccleaner die Registry geputzt, aber immer noch ohne Erfolg. [emoji26]
 
Simon G.

Simon G.

Guru
Viellicht ein Treiber konflikt.
Du kannst mit Usb Deview alle instalierten Treiber anzeigen lassen.

Dann alle Adb und Handy treiber deinstalieren.

Dann das Handy im Normal Betrieb anschliessen das es sich.neu instaliert.

Dann universal adb treiber instalieren und nochmal probieren.

Treiber konflikte konnte ich mit Usb Diewiew gut lösen.

Sowas gibt es oft.

Ich persöhnlich mache adb und fastboot manuell ohme toolkits bewehrt sich am besten.

Probier das mal.


Ohne Toolkit macht man einen adb Ordner auf c:

Dort die adb und fastboot exe zzgl der usb treiber dll dateien rein und die Recovery.

Dann CMD

cd c:/adb enter
fastboot flash recovery "recovery name" enter

Das geht immer.

So ein Ordner habe ich auf gdrive fals bedarf ist schicke ich dir den musst nur deine Recovery img reinkopieren dann im Fastboot mode Handy am Pc cmd starten.den Befehl wie gezeigt und fertig.

Die Recovery als vollen Namen ohne anführungs zeichen das ist bomben sicher.



Usb Dewiev

USBDeview (32 Bit) - Download - CHIP

Mit adminrechten starten alle Treiber mit Rechtsklick deinstalierren.

Dann Handy neu und universal adb Treiber neu.

Dann flashen. Entweder auf deine Art oder bei bedarf melden auf meine erklärte


Ordner adb ( Recovery nachträglich einfügen)

adb

Ins Hauptverzeichniss c:

Dann Befehl wie gezeigt


Sollte in dem Ordner noch eine Recovery enthalten sein löschen und dann deine einfügen
 
Zuletzt bearbeitet:
S

Satmaster2014

Neues Mitglied
Habe alle Treiber deinstalliert mit Usb Dewiev und nochmal so versucht wie du beschrieben hast.

Diese Variante hatte ich bisher immer so benutzt und hatte nie Probleme

erst seit dem ich ein Update von der B141 auf die B312 und dann wieder zurück weil ich mit Lollipop 5.1.1 unzufrieden war.

Habe trotzdem das Problem "waiting for device"
 
Simon G.

Simon G.

Guru
Also ich bin ja so das ich alles probiere was geht sei es noch so unwahrscheinlich.

Versuch doch einfach mal deine Firmware neu zu dloaden oder ein anderes Build evtl liegt ein Fehler vor. Und evtl geht es dann.

Man muss halt alles probieren was geht und das Gerät selbst nicht gefährdet.
Also Firmware nochmal per dload instalieren.
Usb Debugging an

Und dann nochmal probieren.

Die Alten Geräte haben Usb Debugging und Schnellstart die neuen soweit kein Schnellstart mehr bin mir da aber nicht sicher.

Mehr weiss ich da auch nicht.So viele Barrieren gibt es für ein waiting for Device auch nicht.

Das Gerät hat aufjedenfall kein Schnellstart ja.Oder eine andere Einstellung in den Dev Option die adb und fastboot behindern ich kenne mich mit den neuen Geräten nicht aus
 
fooox1

fooox1

Lexikon
Fehler liegt in der Verbindung Gerät/PC.
Möglichkeiten:
- Falscher USB Eingang am PC
Dafür in die Systemsteuerung/Datei Manager schauen als was es erkannt wird.
- Falsche oder fehlende Treiber
Siehe Punkt 1
- USB Debugging anschalten
- USB Buchse defekt
Dann dürfte es nicht in den Fastboot gehen.
Schnellstart spielt hier keine Rolle, da man anders in den Fastboot wechselt. Entweder ADB Befehl oder man schaltet es aus und schließt es mit gedrückter Vol leise an den PC.
Was mich wundert, er schreibt ja das er den Bootloader entsperrt hat, somit sollten die Treiber vorhanden sein. Ich tippe auf defektes Kabel oder falschen Anschluss(Hub).
 
S

Satmaster2014

Neues Mitglied
Habe original Huawei Kabel aus der Verpackung mittlerweile ausprobiert und somit 3 Kabel getestet trotzdem das Problem "waiting for device"


Ich habe alle Möglichkeiten die es im Internet gibt getestet und weiss nicht mehr weiter .
Dieses Problem habe ich erst als ich von Lollipop B312 zurück auf die B145 bin.
Nur was kann man da falsch gemacht haben ?

Irgend etwas von der Software auf dem Handy zerschossen ?
 
Zuletzt bearbeitet von einem Moderator:
Simon G.

Simon G.

Guru
Wenn das alles was hier erklärt wurde getan wurde bin ich auch überfragt.
Das die Buchsen defekt sind glaube ich nicht. Die Treiber sind auch richtig.
Er hat ja sogar schon alle deinstalierst und nur das Handy zzgl. Uni Adb instaliert und das reicht. Geht aber nicht.

Befehle hat wohl auch richtig.
Verschiedene adb und Fastboot Methoden.

Usb Debugging ist auch an.


Am Besten du machst wirklich ein dload einer Kitkat Firmware.

Und dann nimmst du ein anderen Rechner instalierst dort die Treiber und probierst es da mal wenn das da auch nicht geht stimmt was mit dem Gerät nicht
 
fooox1

fooox1

Lexikon
Hier bin ich dann auch überfragt. Ich würde auch erst mal den Downgrade auf eine ältere Version empfehlen und dann noch mal versuchen. Obwohl das auch unlogisch ist, da er ja, nach seiner Aussage, in den Fastboot kommt. Schaden kann es aber nicht.
 
Simon G.

Simon G.

Guru
Eben alles machen was geht. Aus meiner Erfahrung haben die blödsten Versuche oft Wunder bewirkt ist so. Es ist ja hier schon wirklich sehr komisch finde ich. Soll er mal downgraden dloaden wie auch immer und dann sich melden ob es geht. Und zusätzlich ein anderen Rechner nutzen wenn das alles nicht hilft hat das Gerät ein weg.


Aber!!!!

Ist es vielleicht möglich nur vielleicht gesponnen das beim Upgrade auf Lollipop der BL geschlossen wurde??
 
fooox1

fooox1

Lexikon
Eher nicht. Ob geschlossen oder offen, auf Fastboot kann man zugreifen. Kommt halt nur ne Fehlermeldung das er nicht schreiben kann.
 
Simon G.

Simon G.

Guru
Nein nein wenn geschlossen kann man mit Fastboot nicht arbeiten ganz einfach da wird dann immer waiting for device kommen.


Darum spinn ich mal rum mit dem gedanken das er mit Upgrade auf LP gesvhlossen wurde.
Liess dann BL status doch einfach mal aus.

Ich sage immer wieder alles ausprobieren sei es noch so unsinnig alles ausschliessen.

Es sind schon selbst bei mir die dollsten sachen vorgekommen.
 
fooox1

fooox1

Lexikon
Ok, lasse mich gerne eines besseren belehren.