[OS, 4.4.2] KitKat für Cynus T1 (IMO S88, my|phone A898) portiert

  • 231 Antworten
  • Neuster Beitrag
genki

genki

Neues Mitglied
Hallo Obernetter und JoWi,

danke erstmal, dass ihr mein Prob bestätigen könnt, war schon etwas nervös geworden. Hab jetzt nen Walkaround mit dem ich erstmal leben kann. Ich hab nachdem ich zum x. Mal formatiert, repartitioniert und KK neu installiert habe, direkt nach der erfolgreichen Installation die SD-Karte aus dem Telefon entfernt. Dadurch können die Apps nur intern gespeichert/ installiert werden (wohin auch immer), wo es ja jetzt immerhin >2gb Platz dafür gibt. Dort überstehen sie auch einen Neustart des Telefons.
Danke Obernetter für den Tipp mit dem Tausch der SD-Karte.
 
O

Obernetter

Ambitioniertes Mitglied
Hallo Jowi,

hat geklappt!
Hatte nach dem Verschieben und Reboot dann zwar zwei Sokobahn Icons auf dem Desktop, aber löschen ist ja einfach.
:)
Jetzt brauche ich noch einen Tipp, wie ich das Sicherungsimage am besten auf mein 2. Handy bekomme.
Nach Wipe und Formatierung dirket die Sicherung installieren?

Gruß
Obernetter
 
JoWi81

JoWi81

Fortgeschrittenes Mitglied
Threadstarter
Hallo zusammen :winki:,

für alle, die hin und wieder mit Speicherproblemen konfrontiert wurden, möchte ich unbedingt die Aktualisierung Update_2016-02-12 empfehlen. Diese Aktualisierung beinhaltet wie folgt hauptsächlich die Fehlebehebungen und Optimierungen der bereits vorhandenen Funktionen.
  • Weitere Möglichkeit zur Schließung aller Apps durch langes Gedrückthalten der Zurück-Taste unter der Ansicht für kürzlich geöffnete Apps (langes Gedrückthalten der Home-Taste) hinzugefügt.
  • Probleme bei Erstellung eines Screenshots während des Betriebes der emulierten SD-Karte als primären externen Speicher ("ro.jowi81.extsdasprim=0" und "ro.jowi81.embsdasint=0") behoben.
  • Das Verschwinden bestimmter Apps nach der Installation und Neustart während des Betriebes der emulierten SD-Karte als sekundären externen Speicher ("ro.jowi81.extsdasprim=1" und "ro.jowi81.embsdasint=0") behoben.
  • Die Fälschlicherweise angebotene Option zum Verschieben der Apps während des Betriebes der emulierten SD-Karte als sekundären externen Speicher ("ro.jowi81.extsdasprim=1" und "ro.jowi81.embsdasint=0") entfernt.
  • Zugriffsproblem z.B. der Kamera-App auf Telefonspeicher bei Nutzung dieser als Standartschreibdatenträger während des Betriebes der emulierten SD-Karte als primären externen Speicher ("ro.jowi81.extsdasprim=0" und "ro.jowi81.embsdasint=0") behoben.
  • Einige Probleme unter USB-Verbindungen (UMS, MTP) behoben.
  • 3G-Switch-Modus 2 ("ro.jowi81.3gswitchmode=2") komplett überarbeitet und optimiert.
  • Und einige anderen weniger wichtigen Sachen.

An dieser Stelle nochmals Dankeschön an Obernetter, genki und Nick Knatterton für die Tests und Rückmeldungen!

MfG, JoWi81
 
O

Obernetter

Ambitioniertes Mitglied
Hallo Jowi,

vielen Dank für das Update!
Kannich das einfach so einspielen, oder sind dann wieder alle Einstellungen weg?

Gruß
Obernetter
 
JoWi81

JoWi81

Fortgeschrittenes Mitglied
Threadstarter
Kannst einfach so einspielen. Die Einstellungen sind von dieser Aktualisierung nicht betroffen :winki:
 
genki

genki

Neues Mitglied
Erstmal fettes merci JoWi81,
bislang läufts ganz zuverlässig, ich konnte nun auch die fehlenden Apps installieren, die bislang rumgezickt haben.
Verschieben auf SD funktioniert bei mir nun auch.
Hab da noch nen paar Fragen übrig: Den Inhalt der original Android Notizen App finde ich nicht zufällig in einem der Backups die da auf der SD Karte angelegt wurden (und die zu löschen ich bislang abgelehnt habe)? Am grundsätzlichen GPS Empfangs Prob des T1, scheint sich auch durch das Android Update nichts getan zu haben (Ich war gestern 5h unter freien Himmel und es wurde über die ganze Zeit kein Satellit gefunden)?! Im alten Hersteller Android gabs so vorgefertigte Soundschemata (Im freien, Allgemein, Vibration, Lautlos), wurden die in dieser Version wegrationalisiert oder einfach nur gut versteckt?
 
JoWi81

JoWi81

Fortgeschrittenes Mitglied
Threadstarter
@Nick Knatterton
Nick Knatterton schrieb:
Wird es eine angepasste Vollinstallation geben?
Ich will noch ein, zwei Sachen noch mit einbringen (z.B. Build-Properties-Editor unter Entwickleroptionen) und dann erst die Vollinstallation mit herausgeben.

@genki
genki schrieb:
Den Inhalt der original Android Notizen App finde ich nicht zufällig in einem der Backups die da auf der SD Karte angelegt wurden (und die zu löschen ich bislang abgelehnt habe)?
Klar, die Datenbank befindet sich unter "/data/data/com.mediatek.notebook/". einfach den darin befindlichen Ordner "databases" ersetzen.

genki schrieb:
Am grundsätzlichen GPS Empfangs Prob des T1, scheint sich auch durch das Android Update nichts getan zu haben (Ich war gestern 5h unter freien Himmel und es wurde über die ganze Zeit kein Satellit gefunden)?!
Werden es überhaupt keine Satelliten gefunden? Suchen und anzeigen kann man diese unter [Einstellungen]->[Entwickleroptionen]->[Engineering Mode]->[Location]->[YGPS]->[SATELLITES] (siehe Screenshot).
Ggf. musst du zuerst die Entwickleroptionen über [Einstellungen]->[Über das Telefon]->[ Build-Nummer (5x-Klick)] aktivieren.

genki schrieb:
Im alten Hersteller Android gabs so vorgefertigte Soundschemata (Im freien, Allgemein, Vibration, Lautlos), wurden die in dieser Version wegrationalisiert oder einfach nur gut versteckt?
Ich denke mal man hatte sich bei dieser OS-Version, bedingt durch die getrennte Einstellungsmöglichkeit des Nachrichtentones für SIM1 und 2, für die simple Variante entschieden. Eine Änderung zur umfangreicheren Variante mit Soundprofilen ist nach meiner kurzen Analyse sehr aufwendig. Wenn sich etwas Freizeit ergibt, schaue ich mal nach was sich da machen lässt.
 
Nick Knatterton

Nick Knatterton

Ambitioniertes Mitglied
genki schrieb:
Am grundsätzlichen GPS Empfangs Prob des T1, scheint sich auch durch das Android Update nichts getan zu haben (Ich war gestern 5h unter freien Himmel und es wurde über die ganze Zeit kein Satellit gefunden)?!
Ich habe bei meinem Gerät anderes beobachtet, weiss allerdings nicht, ob das schnelle und präzise Orten etwas mit den vielen Sendemasten und WLANs zu tun hat, die ebenfalls zur Ortung herangezogen werden können. Auf jeden Fall hatte ich nichts anderes angestellt als "Standort" in den Einstellungen zu aktivieren, wo allerdings "Hohe Genauigkeit" eingestellt ist (also inkl. Nutzung von WLAN- und Mobilfunknetzen zur Ortung). BTW: "Standort" lasse ich bei diesem Gerät aus alter Erfahrung 24 Stunden an, was die Akkulaufzeit kaum zu beeinträchtigen scheint.
-- Dieser Beitrag wurde automatisch mit dem folgenden Beitrag zusammengeführt --
JoWi81 schrieb:
@Nick Knatterton

Ich will noch ein, zwei Sachen noch mit einbringen (z.B. Build-Properties-Editor unter Entwickleroptionen) und dann erst die Vollinstallation mit herausgeben.
Darauf freue ich mich schon.
 
genki

genki

Neues Mitglied
Hallo JoWi, hallo Nick,
zum GPS: mit eingeschalteten WLAN hab ich`s noch nicht probiert, aber mit inaktivem WLAN sucht sich das Telefon nen Wolf ohne auch nur einen Satelliten zu finden, hab`s gerade vorhin nochmal ausprobiert.
zu den Notes: Bin fündig geworden, leider nicht mit dem erhofften Ergebnis
Zu App Thematik hab ich neue Erkenntnisse, die mich irgendwie verwirren: Es gibt einige größere Apps die ich beim Installieren ohne SD-Karte ausgelassen hab, jetzt mit dem Update wollt ich das nachholen, auch weil zB der Flugpilot-Simulator 3D von Fungames bei der Installation meinte er brauche ganz dringend eine zusätzliche Speicherkarte (für Auslagerungsdaten). Mit dem Update wurde das jetzt ohne zu murren installiert.
Ich hatte die Apps ja schon vor dem AndroidUpdate/ Repartitionieren installiert und auf die SD Karte ausgelagert.
Nach der Neuinstallation wurden die Saves nicht gefunden und ich habe überall neu angefangen.
Testweise habe ich gestern _nur eine_ der größeren Apps ( JetpackJoyride, Halfbrick vorgestern installiert, zuletzt gestern benutzt) auf die SD Karte verschoben. [Wir müssen nicht über die Sinnhaftigkeit der Apps diskutieren oder - ich nutze den öff. Nahverkehr. ]
Lange Rede kurz: heute morgen waren wieder einige Apps nicht mehr installiert (betreffende Apps s. Screenshot).
Die sind da in der Liste Heruntergeladen in einem Block aufgeführt, finden sich auch mit der korrekten Größe in der Liste SD-Karte, sind aber defacto verschwunden (sämtliche Icons weg, im PlayStore gibt`s wieder die Möglichkeit der Installation)
Weiß der Geier warum da immer Aldiko dabei sein muss.
Ich hab jetzt zum weißnichtwieoften Male die betreffenden Apps neu installiert und siehe da bei JetpackJoyride hat er ganz plötzlich meinen alten Speicherstand gefunden. FlightPilot wird direkt nach dem Starten mit einem Fehler wieder beendet.
Mal gucken was morgen früh im Bus noch verfügbar ist.
Btw. Bin ich eigentlich der einzige der die Funktion "Ein-/Abschalten nach Zeit" nutzt?
 

Anhänge

genki

genki

Neues Mitglied
Update von heute morgen, alle wieder weg, nur diesmal anders sortiert (siehe Screenshots im Anhang).
So jetzt erzählt mir mal was mache ich falsch, wie bekomme ich es hin, dass das bei mir genau so rund lüft wie bei euch?
Mich verlässt langsam die Lust täglich neu zu installieren.
 

Anhänge

Nick Knatterton

Nick Knatterton

Ambitioniertes Mitglied
Hallo genki, ich kann dir leider nicht sagen, was bei dir schiefläuft. Allerdings verstehe ich bei dem üppigen internen Speicherangebot durch JoWi81s Update nicht die Notwendigkeit, Apps auf die SD-Karte auszulagern.

Ergänzung: Bei KitKat 4.2.2 hatte sich einiges geändert, z.B.: "Änderungen am Sicherheitskonzept, kein Schreibzugriff auf externe Speichermedien (SD-Karte) für installierte Apps mehr möglich, sondern nur für vorinstallierte Systemapps." (aus Wikipedia) Aus der Erinnerung war auch das Verschieben von Apps auf SD-Karte betroffen (oder irrt sich da meine Erinnerung?).
 
Zuletzt bearbeitet:
genki

genki

Neues Mitglied
Hallo Nick,
vielleicht habe ich mich missverständlich ausgedrückt. Ich habe nur die eine App ausgelagert/ verschoben. Und das auch nur weil JoWi meinte das sei nun gefixt. Alle anderen hab ich dort hin installieren lassen, wo das Telefon meinte es sei sinnvoll. Ich habe an den vorgegebenen Standardeinstellungen nix geändert.
 
Nick Knatterton

Nick Knatterton

Ambitioniertes Mitglied
Hallo @JoWi81, eine Kleinigkeit ist mir gestern aufgefallen. Beim Downloaden von Maps für mein Karten- und Navigationssystem bekam ich in kurzen Abständen Meldungen (siehe Screenshot), wobei die vorangestellte Nummer der Meldung (in Klammern) jeweils einen hochzählte. Nach einem Neustart nach dem Downloaden habe ich diese Meldungen nicht wieder gesehen.
 
JoWi81

JoWi81

Fortgeschrittenes Mitglied
Threadstarter
@genki:
genki schrieb:
zum GPS: mit eingeschalteten WLAN hab ich`s noch nicht probiert, aber mit inaktivem WLAN sucht sich das Telefon nen Wolf ohne auch nur einen Satelliten zu finden, hab`s gerade vorhin nochmal ausprobiert.
Für die schnellere Sattelitenortung sollte man einen Internetzugang ermöglichen um die EPO-Datei für die Sattelitenvorhersage vom Mediatek-Server (nicht immer erreichbar) in regelmäßigen Abständen (alle 30 Tage) automatisch herunterladen zu lassen (siehe "/data/misc/EPO.DAT"). Wenn dies aus unbekannten Gründen nicht automatisch geschehen ist, kann man dies wie folgt manuell versuchen:
  1. Installiere GPS_Fix_2016-02-16_-_MT6620_Combo-Chip im Recovery-Modus und starte anschließend Android OS.
  2. Aktiviere Datenverbindung bzw. Internetzugang.
  3. Wähle GPS zur Standortbestimmung unter [Einstellungen]->[Standort]->[Modus]->[Nur Gerät] aus.
  4. Lade die EPO-Datei über [Einstellungen]->[Entwickleroptionen*]->[Engineering Mode]->[Location]->[Location Based Service]->[EPO]->[EPO (DOWNLOAD)] herunter (siehe Screenshot1).
  5. Starte das YGPS-Tool unter [Einstellungen]->[Entwickleroptionen]->[Engineering Mode]->[Location]->[YGPS]->[SATELLITES] und warte bis GPS-Fix erfolgt ist (siehe Screenshot2).
Wenn die EPO-Datei (siehe "/data/misc/EPO.DAT") immer noch nicht heruntergeladen wurde, dann kann man 4. Schritt zum späteren Zeitpunkt nochmal versuchen oder diese von der alternativen Quelle unter http://epodownload.mediatek.com/EPO.DAT herunterladen und anschließend nach "/data/misc" kopieren. Bei dieser Datei ist anschließend die Berechtigung auf "rw- rw- r--" einzustellen.

genki schrieb:
zu den Notes: Bin fündig geworden, leider nicht mit dem erhofften Ergebnis
Ich hatte vergessen zu erwähnen, dass die ersetzte Datenbank erst nach einem Neustart der Notiz-App geladen wird. Das heißt, dass du diese App unter der Ansicht für kürzlich geschlossene Apps (siehe Screenshot3) aus dem RAM-Speicher rausschmeißen musst.

genki schrieb:
...heute morgen waren wieder einige Apps nicht mehr installiert (betreffende Apps s. Screenshot).
Die sind da in der Liste Heruntergeladen in einem Block aufgeführt, finden sich auch mit der korrekten Größe in der Liste SD-Karte, sind aber defacto verschwunden (sämtliche Icons weg, im PlayStore gibt`s wieder die Möglichkeit der Installation)...
Darf ich fragen welche SD-Karten-Kombination du nutzt (hierzu Tabelle)? Ich habe mit der Kombination 4 mit Aldiko getestet und diese App bleibt auch nach Neustart installiert. Lediglich die Speicheranzeige unten und der Reitername unter [Einstellungen]->[Apps]->[SD-Karte] beziehen sich fälschlicherweise auf die externe SD-Karte (siehe Screenshot4) und nicht wie es sein soll auf die eingebettete SD-Karte bzw. Telefonspeicher (siehe Screenshot5), welche ich noch später beheben werde.
Übrigens, die verschobene App z.B. Aldiko befindet sich auf der eingebetteten SD-Karte unter "\.android_secure\com.aldiko.android-1.asec". Diesen Ordner kann man nicht unter Android sehen, sondern z.B. über UMS im MS Windows.

@Nick Knatterton:
Nick Knatterton schrieb:
Beim Downloaden von Maps für mein Karten- und Navigationssystem bekam ich in kurzen Abständen Meldungen (siehe Screenshot)...
Diese Meldung sollte normalerweise unter [Einstellungen]->[Entwickleroptionen*]->[Engineering Mode]->[Location]->[Location Based Service]->[AGPS]->[Feature Enabler: Allow EM Notification] abschaltbar sein, aber irgendwie behält er die Einstellungen nicht. Ich schaue es mir bei Gelegenheit nochmal einmal genauer an.

Möchte noch kurz erwähnen, dass ich für die nächsten paar Tage nicht am Rechner bin und erst zum späteren Zeitpunkt die offenen Fragen nachgehen kann.

MfG, JoWi81
 

Anhänge

Zuletzt bearbeitet:
Nick Knatterton

Nick Knatterton

Ambitioniertes Mitglied
Diesmal stehe ich vor größeren Rätseln:

JoWi81 schrieb:
: siehe "/data/misc/EPO.DAT"
data/misc (gibt es bei mir nicht) oder Android/data/misc ?

JoWi81 schrieb:
: Lade die EPO-Datei über [Einstellungen]->[Entwickleroptionen*]->[Engineering Mode]->[Location]->[Location Based Service]->[EPO]->[EPO (DOWNLOAD)] herunter
Woran kann ich erkennen, dass der Download erfolgreich war?

JoWi81 schrieb:
Starte das YGPS-Tool unter [Einstellungen]->[Entwickleroptionen]->[Engineering Mode]->[Location]->[YGPS]->[SATELLITES] und warte bis GPS-Fix erfolgt ist (siehe Screenshot2).
Innerhalb welchen Zeitrahmens sollte sich der erste Satellit grün färben (grobe Schätzung)?

JoWi81 schrieb:
: Bei dieser Datei ist anschließend die Berechtigung auf "rw- rw- r--" einzustellen.
Wie geht das?

JoWi81 schrieb:
:Möchte noch kurz erwähnen, dass ich für die nächsten paar Tage nicht am Rechner bin und erst zum späteren Zeitpunkt die offenen Fragen nachgehen kann.
Dann bis in Kürze.
 
genki

genki

Neues Mitglied
Hallo nochmal,
ich hab das jetzt erstmal sacken lassen und einige Tage vor mich hin probiert mit euren Hinweisen klar zu kommen. Ich glaub jetzt bin ich um einiges schlauer.
An den vorgeschlagenen Einstellungen die da im Update ausgewählt waren, hab ich nichts verändert, auch sonstige Einstellungen hab ich belassen wie sie mir gegeben wurden, da ich das außerhalb des Updates nicht einzusehen vermag und es jetzt endlich läuft, will ich da lieber nix dran rumfummeln, ich glaub aber es handelt sich um Kombination 2 (dasint=0; dasprim=1). Wie dem auch sei auf meinem Screenshots oben sieht man ja, das die Apps auf die SDKarte installiert wurden und dann beim Neustart verschwanden.
Ich hab dann Nicks Tipp beherzigt und alle Apps wo der Haken in der Tabelle SD-Karte gesetzt war mittels "nach Interner Speicher verschieben" bewegt. Seitdem ist alles prima und ich musste nix mehr neu installieren. Das ändert zwar nix am beobachteten Problem ... but worked for me

Die Geschichte mit dem Notizblock hab ich auch durch exorziert, hab leider in den vorhanden Backups nur leere Datenbanken gefunden. Da hab ich während eines Upgrades irgendwo doch was falsch gemacht und das entscheidende Backup weggelöscht.

Zum GPS kann ich auch nur Positives berichten (also bislang): Bei mir gab`s tatsächlich Initialisierungsprobleme. Ich hab mal das volle Programm angeschaltet. WLAN, Datenverbindung aktiviert und GPS an. Wie lang das nun gedauert hat bis die EPO geladen war, kann ich leider nicht sagen, aber am Ende meines Spazierganges hatte ich alle Satelliten auf Empfang. Jetzt geht`s innert Sekunden, dass welche gefunden werden auch ohne WLAN und Datenverbindung. Den GPS Fix von dir JoWi hat`s gar nicht gebraucht.

Btw. ich wusste gar nicht wie mannigfaltig die Möglichkeiten der Entwicklungsoptionen sind. Gibt`s da nen Handbuch für das ihr empfehlen könnt?
 
O

Obernetter

Ambitioniertes Mitglied
Ich mal wieder...

Ich kann keine Kalendereinträge ändern..
:-(
Wenn ich einen vorhandenen Eintrag öffne und das Datum ändere - was nun wesentlich schöner ist - wird der Kalender beim Speichern beendet.
Habe ich mit mehreren Terminen probiert, immer "beendet"..

Die Einträge hatte ich mit Myphone Explorer aus Outlook hochgeladen - wie in der alten Version auch, da immer ohne Probleme.

Ein im Handy neu ersteller Termin kann allerdings problemlos geändert werden. Fehlen für die hochgeladenen Termine eventuell noch Berechtigungen?
Komisch...

Gruß
Obernetter
 
O

Obernetter

Ambitioniertes Mitglied
Noch ein Bug?

Ich benutzte daheim gern Whatsappweb am PC. Wenn das T1 nun nach zwei Minuten den Bildschirm dunkel schaltet, meldet WA gleich "Telefon nicht verbunden".
Drücke ich die Einschalttaste am T1, ist die Verbindung gleich wieder da.
Die einzige passende Einstellung ist unter erweiterten WLAN Einstellungen, aber da habe ich "Wlan im Ruhezustand abschalten" nicht aktiviert.
Sollte also aktiv bleiben...
Wird dieser Schalter vielleicht falsch ausgewertet?
Kann jemand dieses Verhalten bestätigen?

Gruß
Obernetter
 
Nick Knatterton

Nick Knatterton

Ambitioniertes Mitglied
Hallo Obernetter, ein ähnliches Verhalten, wenn auch weniger häufig, kann ich von einem Samsung Galaxy Note3 berichten. Kurz das Display entsperrt, geht es wieder. Scheint also nichts T1-spezifisches zu sein.

Gruß Nick
 
Oben Unten