Gelöst! Recovery für MOTO 4G 1.Gen.

  • 8 Antworten
  • Neuester Beitrag
Diskutiere Gelöst! Recovery für MOTO 4G 1.Gen. im Root / Custom-ROMs / Modding für Motorola Moto G (LTE) (1. Generation) im Bereich Motorola Moto G (LTE) (1. Generation) Forum.
M

mike03kd

Gast
Hallo, ich habe ein Problem mit einem gerooteten Moto 4g: Aufruf der Recovery wird mit dem grünen Männchen mit rotem Dreieck beantwortet: "kein Befehl".Rom-Manager sagt: " Aktuelles Recovery-System TWRP ", starte ich aber ins Recoverysystem, dann Fehler wie oben.
Was mache ich falsch?
Gruß Mike

P.S.:liegendes Männchen mit rotem Dreieck durch Drücken von Power und Vol/lauter beseitigt. Soweit ok, aber obwohl ROM-Manager behauptet, TWRP zu starten, kommt m.M. das Standard-Recovery.
Warum ist das beim Moto G so umständlich, bei meinem Nexus 7 ging das alles ohne Probleme.
 
Zuletzt bearbeitet von einem Moderator:
M

mike03kd

Gast
So, habe nun twrp über adb geflasht. ROM-Manager kann das wohl nicht.
TWRP 2-8-3 funktioniert aber nicht richtig, wenn ich reboot anklicke, passiert nichts. Das Flackern des Bildes ist nur ein Schönheitsfehler.
Gruß Mike
 
O

ooo

Lexikon
Wir kennen den aktuellen Zustand deines Phones nicht.
Hast du evtl nur noch das TWRP Recovery auf dem Gerät?
Wenn ja, dann musst du dir jetzt noch eine Custom ROM flashen.
Mit Reboot versucht das Phone in die ROM zu starten, nicht wieder in das TWRP Recovery.
Oder du gehst komplett zurück zu deiner Original-ROM und fängst noch mal in Ruhe ganz von vorne an.
Hier im Forum gibt es genug Threads mit detaillierten Infos zu dem Thema.
 
M

mike03kd

Gast
Danke für die Antwort, aber habe inzwischen ein größeres Problem: Bootloop: habe inzwischen twrp 2-8-7 geflasht, das ist stabil, es flackert nichts mehr.Leider erkennt mein PC das Moto nicht mehr, der Treiber war schon immer zickig. Positiv: Ich komme ins TWRP, nun muß ich einen Weg finden, über adb zu flashen.
Der vorhergehende wipe war nicht gut, mein Backup ist verschwunden, so kann twrp nix machen, bis ich vom PC was aufs Moto gebracht habe.
Gruß Mike
 
O

ooo

Lexikon
Mit adb sideload könnte das in etwa so aussehen:

Kann nach Wipe Internal Storage keine Custom ROM mehr flashen

Edit:
(Vorausgesetzt, du bekommst eine stabile USB-Verbindung, wie du sagst ...)
Danach kann man auch mit ADB über Netzwerk weitermachen, um TWRP-Backups über das W-LAN zu pushen.
Tipp: Falls du einen "zickigen" USB 3.0 Port hast, nimm einen USB 2.0 Port bzw. gleich einen anderen Rechner.
 
Zuletzt bearbeitet:
M

mike03kd

Gast
Ja, ich habe inzwischen eine Stock Rom geflasht, lief durch, aber o weh, keine Tastatur, schlecht, wenn man ein Paßwort eingeben will...
Habe inzwischen 2 verschiedene Stock Roms geflasht, vorher immer wipe, aber es ist zum verweifeln, AOSP-Tastatur wurde beendet. Damit ist das Moto unbrauchbar.
Jemand noch einen Tip?
 
Zuletzt bearbeitet von einem Moderator:
M

mike03kd

Gast
Übeltäter war das TWRP 2-8-3, nach Flashen auf 2-8-7 hatte ich wenigstens eine stabile Recovery. Anscheinend wurde Wipe nicht umfassend durchgeführt, sowohl 4.4.4 und 5.1 Stock-ROM´s hatten keine Tastatur. Nochmaliges Wipe ( alles ) und Flashen mit CM Nightly vom 6.7. lösten das Problem.
Hauptgrund für den halbtägigen Dauereinsatz: 25 Jahre PC-Erfahrung stehen knapp 2 Jahren Android gegenüber, vieles beim A.system ist noch unklar.
Gruß Mike
 
O

ooo

Lexikon
AnySoft-Keyboard von F-Droid downloaden und die .apk-Datei installieren . Vorher in den Einstellungen > Sicherheit > Unbekannte Quellen > zulassen
F-Droid ist ein alternativer App Store und hat eine eigene App, mit der man ohne Google freie, nicht kommerzielle Apps installieren kann.

Edit: Ah, ich sehe gerade dein neues Posting, dann bist du ja bereits weiter ...
 
Zuletzt bearbeitet:
M

mike03kd

Gast
Danke trotzdem, ohne die Hilfe im Forum würde man ganz schön alt aussehen, vor allem, wenn das englisch für komplizierte Sachverhalte zu dürftig ist.