OnePlus X: twrp-3.0.3-0-onyx.img installiert

  • 44 Antworten
  • Neuester Beitrag
Diskutiere OnePlus X: twrp-3.0.3-0-onyx.img installiert im Root / Custom-ROMs / Modding für OnePlus X im Bereich OnePlus X Forum.
vonharold

vonharold

Dauergast
Hallo zusammen,

habe das twrp-3.0.3-0-onyx.img über die twrp-3.0.2-0-onyx.img installiert installiert. Jetzt komme ich überhaupt nicht mehr in das TWRP-Menü und bleibe beim OnePlus Logo hängen.

Was kann ich jetzt tun, damit ich wieder ganz normal in das TWRP Menü komme?

In den Fastboot Modus komme ich noch.
Wieder zurück auf die alte twrp-3.0.2-0-onyx.img gehen? Und mit welchen Befehlen komme ich dahin?

Habe vorher aber eine komplett TWRP Sicherung auf der externen SD-Karte von dem kompletten Handy gemacht.

Das Handy startet aber noch ganz normal hoch in das Menü, somit noch funktionsfähig.

Hallo zusammen,

habe wieder die alte Version von twrp-3.0.2-0-onyx.img

Folgende Befehle eingegeben:

"fastboot devices"

folgende Meldung:

c:\adb>fastboot devices
xxxxxx_fastboot

Erscheint diese Meldung können wir weitermachen. Wir wechseln nun die Recovery. Mit dem Kommando

Mit dem Befehl
"fastboot flash recovery twrp-3.0.2-0-onyx.img" wird die Custom Recovery installiert.

Somit alles wieder gut.

Nur warum funktionierte die neue nicht?
Hätte ich noch diese vorher einspielen müssen "twrp-3.0.2-1-onyx.img"?

Diese Version einspielen geht auch nicht und hängt somit auch im OnePlus Logo fest.
 
Zuletzt bearbeitet von einem Moderator:
TomTim

TomTim

Ehrenmitglied
Installier das Recovery nochmals. Nach dem erfolgreichen Installationsprozedere schaltest du das Telefon AUS, dazu einfach lange die Powertaste drücken.
Wenn das Telefon aus ist hältst du die Leiser- und die Power-Taste gedrückt - bis das Recovery bootet.
 
vonharold

vonharold

Dauergast
Hallo TomTim,

funktioniert leider nicht. Hängt immer beim OnePlus Logo.
Hängt das mit meiner CM13 zusammen, letzter Stand 20161009.
Die Nightly danach kann ich nicht mehr installieren, da ich dann auf einen neuen Bootloader umstellen muss.
Somit wären die ganzen Daten weg und müsste alles wieder neu einrichten.

Oder habe ich da einen Denkfehler?
 
TomTim

TomTim

Ehrenmitglied
vonharold

vonharold

Dauergast
Hallo TomTim,

ich kann bei dem Tool keine TWRP Version auswählen, packt einfach die 3.0.0.1 drauf. Da bin ich mit dem ADB bis an die Version twrp-3.0.2-0-onyx.img gekommen.
Damit läuft das Teil auch. Ich wollte halt einfach das neuste drauf packen. Scheint aber nicht zu gehen.
 
TomTim

TomTim

Ehrenmitglied
Habe mich bislang nicht wirklich mit dem OPX beschäftigt um dir eine noch bessere Hilfe Stellung bieten zu können.
Eventuell meldet sich ja noch wer der die neuste Version nutzt.
 
der_berliner

der_berliner

Stammgast
Guten Tag,

@vonharold das du die 3.0.3.0 nicht installieren kannst hängt damit zusammen das diese twrp-Version für Nougat ist. Somit bekommst du einen neuen Bootloader. Der funtioniert nur mit ROM´s die den neuen Bootloader brauchen.

Um aus deinem Dilemma herauszukommen installier dir die twrp von blu_spark. Läuft auch mit Marchmallow also MM. Ich selbst habe jetzt gerade die neuste 3.0.3.0 installiert und es gab keine Probleme. Leider weiss ich nicht welches OS du installiert hast. Solltest du OOS X.X.X haben installier dir dieses noch mal.

Recovery wird überschrieben. Dann 3.0.2.0 installieren, darüber dann 3.0.2.1 und dann die neuste 3.0.3.0. Viel Erfolg

grüsse
 
vonharold

vonharold

Dauergast
Hallo Berliner,

ich habe kein OOS mehr drauf. Ich habe zurzeit das twrp-3.0.2-0-onyx.img und die CM13 von hier CM13 Nightlies Changelog - Onyx
Die letzte lauffähige Version war vom
Stand 20161009.

Die nächste Version lief schon nicht mehr mit dieser Zusammenstellung, da diese ja scheinbar den Bootloader geändert hatten.
Somit finden keine Update mehr von CM13 bei mir statt.

Voraussichtlich warte ich dann auf die CM14-onyx und flashe dieses dann wieder ganz jungfräulich mit den ganzen Apps.

Weiß schon jemand, wie weit diese beim Oneplus X Nougat sind?

Beim Galaxy S2 läuft die 14.1 inoffizielle schon recht gut.

Nachtrag: Habe jetzt versucht die twrp-3.0.2-2_blu_spark.v41-onyx_by-engstk.img über ADB zu installieren.
Leider komme ich da auch nicht weiter. Bleibe weiterhin am OnePlus Logo hängen.
Oder habe ich die falsche Version erwischt?
Dann den Downloadlink zur richtigen Version mitteilen. Danke!

Jetzt läuft aktuell diese Version drauf: blu_spark_r164-CM_onyx_7ceaf31.zip
Die neusten CM13 kann ich immer noch nicht installieren.

Weitere Ideen?
 
Zuletzt bearbeitet:
Ron15

Ron15

Ambitioniertes Mitglied
Ich denke du kommst nicht herum den Bootloader upzudaten (Geht einfach). Die neusten CM13 benötigen doch den neuen Bootloader (schrieb Ashwin am 10 Oktober 16). Ich bin aktuell auf den Nightlies von CM14.1 (läuft gut). Da benötigst du aber auch den neuen Bootloader.

Den Bootloader hab ich mit dieser Anleitung geupdatet.
 
vonharold

vonharold

Dauergast
Hallo Ron,

vielen Dank für die Info.
Ich warte aber noch ein paar Tage mit der CM14.1, bis ein paar Kinderkrankheiten draußen sind.
Es ist doch erst die erste zum Download angeboten.
Oder läuft das Teil schon so stabil?
 
Ron15

Ron15

Ambitioniertes Mitglied
Seit dem 15 September bin ich schon dabei. Die war vorher noch nicht offiziell. Ja, es läuft stabil. Ich hab keine Reboots + das Ding ist flüssig. Es hat natürlich ein paar kleine Bugs hab ich gelesen aber Kamera, GPS, MobileData und so weiter geht alles.
 
der_berliner

der_berliner

Stammgast
Guten Abend,

weiss der Geier warum es funktionierete aber mit twrp-3.0.3-0 ließ sich problemlos CM13 installieren doch ein dirty mit CM14 führte nicht zum Erfolg. Steckte im Bootlogo fest.

Nochmal installiert und anschließend das mir angebotene Update auf 14.1. vom 21.12. heruntergeladen, ließ es automatisch installieren und nach dem reboot steckte ich im Bootlogo fest. Klasse.

Probiere noch einiges aus denke aber mal das der "Fehler" bei CM liegt. Habe keine Probleme AOSP-ROM´s zu installierem aber alles was auf CM, z.B. MoKee, basiert gibt es Probleme. Bei mir jedenfalls.

grüsse
 
vonharold

vonharold

Dauergast
Hallo zusammen,

habe hier ein Video gefunden wie es einfach gehen soll.
 
der_berliner

der_berliner

Stammgast
Moinsen,

auch mit dieser Anleitung gelang es mir nicht CM14.1 zu installieren. Mit diesem Problem bin ich aber nicht der einzige denn auf XDA haben mehere User dieses Problem. Nichtsdestotrotz, Frohe Weihnachten.

mahalo
 
vonharold

vonharold

Dauergast
Hallo zusammen,

ich drehe mich irgendwie im Kreis.
Ich bekomme das neue TWRP nicht installiert, da ich ja noch die alte Version von CM13 habe. Die neue Version lässt sich aber nur mit dem neuen TWRP installieren. Habe das OnePlus X schon komplett platt gemacht und alles versucht neu zu installieren. Nur irgendwie passt was nicht. Bleibe immer im Bootlogo hängen.

twrp-3.0.2-2_blu_spark.v41-onyx_by-engstk.img
cm-14.1-20161223-NIGHTLY-onyx.zip
open_gapps-arm-7.1-pico-20161101.zip

Wo liegt mein Fehler?
 
der_berliner

der_berliner

Stammgast
Mahlzeit,

@vonharold Also irgendwie werde ich aus deinem Text nicht ganz schlau. Mit der Recovery von blu_spark hast du doch die ideale Recovery. Probier doch mal aus der Recovery von blu_spark heraus direkt die .img von twrp zu flashen.

Ich hatte ein ganz anderes Problem. Es ließen sich keine Stock-Recoverys installieren. Erst mit der recovery3.img konnte ich dann OOS-3.1.4, anschließend CM13 installieren. Doch ein flashen mit CM14.1 endete wieder im Bootlogo obwohl die Stock-Recovery drauf war. Verdammte K§&%?.

Werde das OPX gänzlich platt machen also so als wenn ich einen Hardbrick hätte. Mal sehen was dann passiert.

Tschau Bello und Frohes Fest
 

Anhänge

  • recovery3.zip
    13 MB Aufrufe: 154
vonharold

vonharold

Dauergast
Hallo Berliner,

das Problem liegt scheinbar schon bei der Recovery von blu_spark. Sobald ich diese drauf habe, bleibe ich im Bootlogo hängen. Also kann ich gar nicht mehr weitermachen und die img von twrp flashen.

Irgendwie komme ich aus dem Schlamassel nicht raus. Ich habe das OPX komplett platt gemacht, wie Mister X es im Video zeigt.
Sobald dann die CM14.1 drauf kommt, habe ich die Fehlermeldung ERROR 7.

Bingo Endstation.

Was bringt mir die Datei die Du mit angehängt hast für mich?
Habe ja die CM13 durch ein Vollbackup wieder am laufen.

Für Dich natürlich und den Rest der Welt wünsche ich trotzdem ein erholsame Weihnachtsfest.
 
der_berliner

der_berliner

Stammgast
Hallo again,

wenn du in der Rec von blu_spark bist kannst du doch die .img von twrp flashen. Einfach bei Installieren anstatt "zip" auf "img" drücken (unten rechts). Dann die twrp-3.0.3-0.img flashen anschließend reboot in die Rec von twrp und versuchen die CM14.1 zu flashen. Ich hatte mit dieser Methode auch keinen Erfolg. Evtl. gelingt es dir ja. Viel Erfolg.

Die recovery3.img ist für alle die nicht mehr die Stock-Recovery installieren können. Das war z.B. mein Problem.

grüsse
 
vonharold

vonharold

Dauergast
Hallo Berliner,

die einzig funktionierende TWRP ist bei mir die 3.0.2-0, bzw. die blu_spark_r164-CM_onyx_7ceaf31.zip

Mit diesen bleibe ich im Bootlogo hängen und komme nicht mehr in das TWRP zurück um irgendwas zu machen.
twrp-3.0.3-0-onyx.img
twrp-3.0.2-1-onyx.img
twrp-3.0.2-2_blu_spark.v41-onyx_by-engstk.img
Sultan-TWRP-onyx-3.0.2-3_2016-10-23.zip
TWRP_multirom_onyx_20161024-01.img

Ich glaube für die Weihnachtsfeiertage gebe ich das Projekt auf.

Dabei wünschte ich mir vom Christkind/Weihnachtsmann oder wie die Geschenke Bringer noch heißen ein OPX mit 14.1 (Nougat) drauf!

Der Witz ist, beim Galaxy S2 war die 2 oder 3te Version der inoffiziellen CM14.1 Ruckzuck drauf, ohne größere Probleme.
 
Zuletzt bearbeitet:
der_berliner

der_berliner

Stammgast
Guten Abend,

Dieses Problem mit der Recovery habe ich nicht. Kann immer wieder in die Recovery booten. Egal ob blu_spark oder twrp.

Habe nun mein OPX platt gemacht, d.h. habe OOS-2.1.2 nach der Hardbrickanleitung neu installiert. Nicht gerootet, jedes Update bis 3.1.4 durchgezogen anschließend versucht CM14.1 zu installieren ".......und ewig grüßt das Murmeltier". "Installation Failed" mit der Stock-Recovery war mein Weihnachtsgeschenk. Nun denn. Neuer Versuch mit twrp-3.0.3-0. Gleiches Ergebniss. Jetzt CM13.1 installiert. Update auf CM14.1, keine Fehlermeldung uuuuuuuunnnnd jawohl, da ist er wieder. Der kleine Stalker, mein Bootlogo. Wie habe ich dich vermisst :-(

Werde mal morgen wieder XenonHD installieren jetzt aber ist American Football angesagt.

Fröhliches Geschenkeauspacken

Update Moinsen Habe mal probeweise die unoffizielle CM14.1 installiert und es gab keine Probleme. Läuft, nur das Problem mit den Entwickleroptionen ist vorhanden. Jetzt mal "Dirty" die Offizielle einfach drübergeflasht und wie nicht anders zu erwarten erschien mein kleiner Freund. Das Bootlogo. MMn hat CM etwas im Updaterscript geändert. Werde die beiden vergleichen.

servus
 
Zuletzt bearbeitet: