OnePlus X: Wiederherstellung nach Hard-Brick

der_berliner

der_berliner

Stammgast
Threadstarter
Guten Morgen,

mit der nachfolgenden Anleitung gelang es mir unter Windows 8.1 ein "totes" OnePlus X wieder gangbar zu machen, d.h. das einzige was funktionierte war "Fastboot". Keine Recovery, kein Bootloop. Nichts. Die Suche im Netz ergab nichts brauchbares für das OPX. Letztendlich versuchte ich einfach eine Installationsanleitung für das OnePlus One was für mich selbst überraschend zum Erfolg führte.

Folgende Dateien müssen installiert werden oder sind schon auf euren PC.

- ADB und Fastboot und USB-Treiber, s. Anhang

ACHTUNG Die nachfolgenden Datein nur herunterladen und nicht entpacken. Zuvor muß die Treibersignierung deaktiviert werden. Anleitung für 8.1 und 10

- OnePlus Qualcomm Driver
- OnePlus_14_A.04_151103


ADB und Fastboot.exe Setup ausführen. Alles mit "y" beantworten. Fertig. USB-Treiber entpacken und Setup.exe ausführen. Fertig. Qualcomm-Driver auf dem Desktop entpacken. OnePlus_14_A.14_151103 ebenfalls auf dem Desktop entpacken.

Schaltet das OPX aus. Haltet nun die Power und Vol+ gedrückt (Fastboot Mode) und verbindet das Phone mit dem PC. Im Gerätemanager müßte dann unter "Anschlüsse (COM & LPT)" folgendes stehen: RELINK HS-USB QDLoader 9008

USB-Kabel abziehen und bringt das OPX mit Power sowie Vol+ in den Fastboot-Modus. Wieder mit den PC verbinden.
Mit dem Kommando "fastboot devices" müßte euer OPX erkannt werden.

Kopiert folgende Datein aus dem entpacken Order OnePlus_14_A.04_151103 in den Ordner c:\adb:

- boot.img
- userdata.img
- recovery.img
- cache.img
- system.img
- logo.bin
- NON-HLOS.bin
- sbl1.mbn
- tz.mbn
- rpm.mbn
- emmc_appsboot.mbn

Mit folgenden Kommandos werden die Datein installiert:

fastboot flash modem NON-HLOS.bin
fastboot flash sbl1 sbl1.mbn
fastboot flash aboot emmc_appsboot.mbn
fastboot flash rpm rpm.mbn
fastboot flash tz tz.mbn
fastboot flash LOGO logo.bin
fastboot flash recovery recovery.img
fastboot flash system system.img
fastboot flash boot boot.img
fastboot flash cache cache.img
fastboot flash userdata userdata.img

Abschließend ein "fastboot reboot" und das System wird gestartet. Nun ist die Stock-Recovery sowie OOS-2.1.2 installiert. Ein Update auf 2.2.1-X verlief problemlos. Ich konnte es natürlich nicht lassen und mußte gleich twrp-3.0.2-0 sowie SuperSU flashen was ebensfalls problemlos funktionierte.

Laßt mich abschließend folgendes sagen dass diese Installationsmethode bei mir zum Erfolg führte was nicht bedeutet das diese Methode auch bei allen anderen zum Erfolg führt. Es gibt mehere Möglichkeiten einen Hardbrick wieder rückgängig zu machen. Im Netz gibt es dazu mehere Anleitungen.

Wünsche allen viel Erfolg
 

Anhänge

  • OnePlus_USB_Drivers_Setup.zip
    17.9 MB Aufrufe: 382
Zuletzt bearbeitet:
M

Medmedoc

Fortgeschrittenes Mitglied
@der_berliner ich habe ein ähnliches problem: nach root mit kingroot und unroot mit super-sume pro und anschließender versuchter installation von paranoid firmware mit flasfire (das angeblich kein alternatives recovery benötigt) stehe ich vor der situation, daß nur fastboot noch funktioniert. in adb wird zwar das gerät erkannt, der bootloader läßt sich jedoch mit dem fastboot oem unlock befehl nicht entsperren. um das zu umgehen, habe ich mir die qualcomm treiber, so wie in der hardbrick anleitung beschrieben, heruntergeladen. diese lassen sich jedoch in windows 10 leider nicht installieren bzw. wird der treiber als fehlerhaft nach dem entpacken mit win-rar angezeigt. was kann ich nun tun???
 
der_berliner

der_berliner

Stammgast
Threadstarter
Guten Morgen,

entweder ist dein D-Load korrupt oder aber du mußt nach dieser Anleitung die Treiber Signatur umgehen, d.h Anleitung befolgen und dann Treiber entpacken bzw. installieren. Dann müßte meine Anleitung dir weiterhelfen.

grüsse
 
M

Medmedoc

Fortgeschrittenes Mitglied
der_berliner schrieb:
Guten Morgen,

entweder ist dein D-Load korrupt oder aber du mußt nach dieser Anleitung die Treiber Signatur umgehen, d.h Anleitung befolgen und dann Treiber entpacken bzw. installieren. Dann müßte meine Anleitung dir weiterhelfen.

grüsse
Danke für Deinen Tipps, aber es war wohl das Windows 10, das zu dieser Fehlfunktion führte ("falsche Prüfsumme"). Mit XP hats schließlich dann doch gefunkt...
 
T

Timo84

Neues Mitglied
Vielen Dank für die Anleitung. Mit Ihr konnte ich meine Oneplus X wieder zum leben erwecken. Ich Kam nurnoch in den Fastboot-Modus.

- Mein Problem ist durch King(o)root oder durch flashen ohne md5 entstanden

Grüße
 
der_berliner

der_berliner

Stammgast
Threadstarter
Guten Abend,

@Timo84 Freut mich das du deinen "Briefbeschwerer" wieder zum Leben erweckt hast. Denke mal das es die App war. Hielt und halte nichts von Apps für das Rooten.

servus
 
YesMan2

YesMan2

Erfahrenes Mitglied
Ich habe unter CM13 mit blu_spark_r164 Kernel und twrp-3(???)blu_spark das aktuellste twrp.3.0.2.2_blu_spark_by-engst.img geflasht. Seitdem funktioniert beim Oneplus x nur noch der Fastfood mode. Flashen der von "der_berliner" genannten Dateien endet mit der Meldung "Device not unlocked cannot Flash or erase". Alle Treiber (Qualcom und USB) etc. sind installiert und das Gerät wird bei Eingabe von "fastboot devices" erkannt.
Bei Eingabe von "fastboot oem unlock" wird das Gerät anscheinend entsperrt, es bootet jedoch nicht neu. Bei Überprüfung mit "fastboot oem device-info" steht bei "Device Tempered" und "Device unlocked" false.
Hat dazu noch jemand eine Idee?
-- Dieser Beitrag wurde automatisch mit dem folgenden Beitrag zusammengeführt --
Hab noch eine andere Anleitung gefunden, mit der hat es problemlos geklappt.
[GUIDE] Mega Unbrick Guide for A Hard Bricked OnePlus X
Das in der Anleitung genannte und verlinkte "MSMDownloadToolV2.0" befindet sich in der von "der_berliner" bereits aufgeführten "OnePlus_14_A.14_151103".
 
Zuletzt bearbeitet:
der_berliner

der_berliner

Stammgast
Threadstarter
Guten Tag,

@YesMan2 Interessant und du bist ja nicht der erste dem dieses Problem trifft das mit CM13 und der Recovery sowie der Kernel von blu_spark dir es nicht gelang in das System zu kommen. Dürfte eigentlich nicht sein. Vllt. ist beim installieren von CM13 der Bootloader wieder Locked. Irgendjemand sollte doch in den CM13-Forum eine Info schreiben das es sein kann dass der Bootloader wieder Locked ist und man dieses in den Einstellungen kontrollieren sollte um evtl. Bootloops sowie das Nichtstarten des Systems ausschliessen sollte.

Hauptsache ist aber das du wieder ein funktionierendes OPX hast auch wenn es mit meiner Anleitung nicht geklappt hat.

mahalo
 
YesMan2

YesMan2

Erfahrenes Mitglied
@der_berliner
Deine Anleitung ist schon super und auch top verständlich. Die benötigten Dateien und Treiber fürs flashen mit dem "MSMDownloadToolV2. 0" hatte ich damit ja schon an Bord. Lediglich der Flashvorgang läuft ein bisschen anders. Bei dir halt händisch, Stück für Stück per adb und mit dem Tool per Doppelklick auf eine .exe. Vielleicht sogar der einfachere Weg. [emoji5]️
 
Zuletzt bearbeitet:
der_berliner

der_berliner

Stammgast
Threadstarter
Guten Morgen,

@YesMan2 Ich vermute mal du hast die Anleitung von XDA. Auch ich wollte nach dieser Installationsanleitung mein "totes" OPX wieder zum Leben erwecken was aber daran scheiterte das dass "MSMDownloadToolV2.0" bei mir nicht funktionierte. Dann habe ich einfach "auf gut Glück" den händischen Weg gewählt und ich war sehr erstaunt als ich das Bootlogo von OOS sah und wieder ein System hatte.

Nur zum besseren Verständnis. Das "tote" OPX war nicht mein Phone sondern gehörte meinem Kumpel. Er wollte "nur" mal, so wie ich es handhabe, eine andere ROM flashen und schaffte es innerhalb von 5 Minuten einen Briefbeschwerer herzustellen. Er gab es mir dann mit den Worten "Mach damit was du willst". Somit konnte ich ohne Sorgen herumprobieren und hatte sogar Erfolg.

grüsse
 
F

Frettchenhamm

Neues Mitglied
Problembeschreibung:
Mein Freund hat mich um Rat gefragt, jedoch komme ich nicht weiter.
Das Opo x macht nix mehr.
Mein Freund sagte, das er das Handy jeden Abend aus und Morgens anschaltet.
Diesmal ging es nicht mehr an.
Wenn ich das Ladekabel anschließe leuchtet für 5 sek oben Rechts die rote Leuchte und geht aus. Wenn ich das Handy am PC anschließe höre ich auch ein Ton, aber nichts wird angezeigt.
Der Akku müsste eigentlich voll sein.

Ich komme auch nicht in den Recovery oder Fastbootmodus

Habe schon mehrere Sachen ausprobiert
Als Qualmcom bekomme ich es erkannt.
Das sagt er mir wenn ich opoToolkit v2.0 starte


Das kommt wenn ich auf Verify klicke



Heute bekomme ich diese Meldung






Da ich ja nicht in den Fastboot Modus komme, wartet adb auf meine device

Bitte um Hilfe
Vieln Dank Frettchenhamm
 
F

Frettchenhamm

Neues Mitglied
@YesMan2
danke für deinen Hinweis.
Ich habe gestern Abend mit dem opo Support gechattet und der Support kam zum Entschluss das ich es einschicken muss.
 
der_berliner

der_berliner

Stammgast
Threadstarter
Guten Abend,

@Frettchenhamm Das das LED-Licht kurz aufleuchtet bedeutet das der Akku leer ist. Du mußt das OPX ca. 48 Std. laden. Dann kannst du es ja noch mal mit "Fastboot" probieren. Auch ich mußte mein OPX so lange laden aber dann funktionierte anschließend die händische Installation.

grüsse
 
W

Wagn

Neues Mitglied
Ohoo! das könnte bei mir funktionieren - ich hoffe der gelockte Bootloader macht mir keine Probleme.. - Einkaufen gehen und dann los!

Fu..
c:\adb>fastboot flash modem NON-HLOS.bin
target reported max download size of 1073741824 bytes
sending 'modem' (58561 KB)...
OKAY [ 1.936s]
writing 'modem'...
FAILED (remote: Device not unlocked cannot flash or erase)
finished. total time: 1.944s​
 
Zuletzt bearbeitet:
der_berliner

der_berliner

Stammgast
Threadstarter
Guten Abend,

@Wagn Probier doch einfach mal eine andere Reihenfolge beim flashen, so z.B. boot und Recovery zuerst. Vllt. hilft dir das weiter.

servus
 
S

SG-Master

Neues Mitglied
Ich kann mich nur für diese Thread bedanken, da ich aufgrund eines Romumstiegs (von Paranoid auf Lineage OS) mein TWRP updaten musste und dadurch (warscheinlich unachtsamkeit von mir...) mein One X hart gebrickt hab.

Durch diesen Thread konnte ich allerdings es wiederbeleben auf Stock.

Viele dank dafür und ein Vote für das anpinnen des Threads!
 
S

Schrammi97

Neues Mitglied
Ich habe es gemacht wie in der Anleitung...es hat auch alles geklappt (habe es über das MsmDownloadTool gemacht). Nun bleibt das Handy aber im bootvorgang stehen und man sieht nur noch das OnePlus Logo...kann mir da jemand helfen?
 
der_berliner

der_berliner

Stammgast
Threadstarter
Guten Abend,

schalte dein OPX mal aus und versuche in die Recovery, Power und Vol-, zu kommen. Dann Dalvik Cache, reboot.

grüsse
 
S

Schrammi97

Neues Mitglied
Hey, Thread kann Gott sei Dank geschlossen werden. Läuft wieder alles! Danke
 
Ähnliche Themen - OnePlus X: Wiederherstellung nach Hard-Brick Antworten Datum
23
21
Oben Unten