OnePlus X: Wiederherstellung nach Hard-Brick

vonharold

vonharold

Stammgast
Hallo Schrammi97,

wäre toll, wenn Du uns Allen sagen könntest. was Dich schlussendlich an das Ziel gebracht hat.
Somit haben alle anderen User mit dem gleichen Problem eine Chance, das Teil auch wieder zum laufen zu bringen.
 
D

demoman

Neues Mitglied
Hallo,

seit dem versuch das Handy irgend wie zu retten. Geht jetzt garnichts mehr. Komme zwar in Recovery Stock rein. Aber das wars auch. Kann nichts mehr machen.

Das komische ist auch, dass es jetzt nicht mehr unlocked ist. Und ich es auch irgend wie nicht unlockes machen kann. So mit kann ich im fastboot Modus nichts mehr installieren. Bekomme immer die Meldung "device not unlocked cannot flash or erase".

Bei MSM und Verfiy bekomme ich diese Meldung

8974_msimage.mbn: OK
dynamic_nvbk.bin: OK
emmc_appsboot.mbn: OK
gpt_backup0.bin: OK
gpt_main0.bin: OK
rawprogram0.xml: FAILED
NON-HLOS.bin: OK
MPRG8974.mbn: OK
rpm.mbn: OK
sbl1.mbn: OK
sdi.mbn: OK
static_nvbk.bin: OK
tz.mbn: OK
persist.img: OK
recovery.img: OK


Dazu sei gesagt, dass "OnePlus_14_A.04_151103" link tot ist und man es nicht downloaden kann. Ein Re-Upp wäre gut.

Danke



edit://

Bei versuch von



    • fastboot oem unlock
erscheint "remote: oem unlock is disabled"


edit://

habe jetzt über MSM die Recovery TWRP 2.8.7 aufgespielt und auch zum laufen bekommen. Alle anderen twrp Versionen gingen nicht. Aber auch hier leider ohne Erfolg bis jetzt. Komm ins Recovery rein. Aber kann weder eine Stock noch eine Custom Rom installieren. Fehler ist immer der selbe "Updater process ended with ERROR: 7"
 
Zuletzt bearbeitet:
der_berliner

der_berliner

Stammgast
Threadstarter
Guten Morgen,

die "OnePlus_14_A.04_151103" wurde leider gelöscht. Der Ersteller des Threads auf XDA wurde daraufhin bereits angeschrieben. Vllt. lädt er die Datei wieder hoch.

Jetzt habe ich doch eine Frage. Wieso benutzt ihr immer dieses MSM-Tool?? Habe ohne dieses Tool bereits zwei OPX wieder zum Leben erweckt ohne Probleme. Klar, mit dem Tool spare ich mir die Arbeit alle Befehle händisch einzugeben aber der Erfolg spricht für sich.

Ich habe eine Recovery zu downloaden unten angehangen. Probier diese Recovery zu flashen und anschließend ist OOS 2.x.x zu installieren. Viel Erfolg.

namaste
 

Anhänge

  • OPX_recovery.img
    14.6 MB Aufrufe: 170
D

demoman

Neues Mitglied
Hi, ja das MSM-Tool habe ich nur benutzt, da es mit der manuell Eingabe immer zu Fehlern kam. Mir ist auch die manuelle Eingabe lieber.

So nun zum Probelm :) Habe deine Recovery genommen. Kann auch in Recovery rein booten. Doch bei "Install from local" tut sich nichts. Ob wohl auf dem Handy, einige Images drauf sind. Auch die OOS 2.x.x.

Mach ich da was falsch ?
 
Zuletzt bearbeitet von einem Moderator:
Bearbeitet von TomTim - Grund: Direktzitat entfernt - bitte Forenregeln beachten. Grüße TomTim
der_berliner

der_berliner

Stammgast
Threadstarter
Guten Morgen,

wenn du jeden Schritt in der richtigen Reihenfolge ausgeführt hast wie ich es in #1 beschrieben habe dürfte es bei bei der händischen Eingabe zu keiner Fehlermeldungen kommen. Wenn ich dich richtig verstanden habe kommen dann mit dem MSM-Tool keine Fehlermeldungen??

Leider weis ich nicht welches Win8/10 du auf deinen PC/Notebook installiert hast. Denke bitte an die Deaktivierung der Treibersignierung. Wichtig.

Versuche in der Recovery dein OOS mit "adb sideload deinOOS 2.x.x" zu flashen. Leider kann ich dir den Weg zum adb nicht beschreiben. Ist zu lange her und habe es vergessen. Du mußt ein bisschen suchen und wenn du diesen Weg nimmst muß dein OPX natürlich unlocked sein. Ist es doch,oder??

Bin jetzt leider an einem anderen PC. Werde dir noch andere Recoverys zu D-Load anbieten. Mußt halt ein bisschen warten.

servus

Update Probier die Recovery von blu_spark zu flashen. Mache anschließend ein reboot in die Recovery, flash dein OOS, boote dein System, reboot in die Recovery, flashe anschließend die Recovery von lucian77, auch wieder reboot in die Recovery und System. Wenn das läuft dann die 3.1.1-0 von twrp und SuperSU um zu rooten. Good Luck.

namaste
 

Anhänge

  • twrp-3.0.2-2_blu_spark.v41-onyx_by-engstk.img
    12.8 MB Aufrufe: 145
Zuletzt bearbeitet:
D

demoman

Neues Mitglied
@der_berliner

Hey, das mit dem adb sideload" hat geklappt. Thanks :) Falls jeman die gleich probleme haben sollte, habe diese Anleitung dafür genutzt [How-To] Offizielles Update mit der ADB-Sideload-Methode installieren natürlich "umgewandelt" auf das one+.

Werde gleich mal schauen ob ich es, auf lineage flashen kann.


edit://

Also sowohl lineage (error 7) als auch eine höere version von 2.8.7.0 twrp, kann ich nicht installieren :/

Stock läuft 2.2.3 . Alles andere nicht.

edit://

twrp 3.0.2.0 läuft. alles andere was da drüber ist nicht. habe auch kernel geflasht (
arsenic.kernel-onyx.R32-20161221.zip).

habe jegliche Versionen ausprobiert. erst 2.8.7.0, dann blu_spark, dann 3.1.0.0, ging auch nicht.

lineage 14 und oxygen 3.x.x kommt immer wieder fehler 7.
 
Zuletzt bearbeitet:
Lucian77

Lucian77

Stammgast
Hast Du TWRP 3.1.1-1 auch schon versucht ?
Bei meinem OPX klappts mit dem und LineageOS ohne Probleme.

Gruß
 
D

demoman

Neues Mitglied
Habe ich auch versucht gehabt. Aber leider geht es mit dem 3.1.1-1 auch nicht :/
 
der_berliner

der_berliner

Stammgast
Threadstarter
Guten Morgen,

du hättest nach dem erfolgreichen flashen von OOS 2.x.x die updates bis OOS 3.1.4 ohne zu rooten durchführen sollen. Aber egal. Mach einen D-Load dieser Zip. Flashe in der Recovery diese Zip. Reboot in die Recovery. Sollte das nicht klappen dann die von blu_spark flashen. Klappt es dann auch die von blu_spark flashen. Reboot in die Recovery. Anschließend die Recovery von hier flashen. Wieder reboot in die Recovery und in das System. Nun die neuste von Twpr nehmen und flashen.

Dieser Weg führte zumindest bei mir zum Erfolg.

servus
 
D

demoman

Neues Mitglied
Habe nochmal komplett alles zurück gesetzt und von Anfang gemacht. Wie du sagtest ohne zu rooten bis auf OOS 3.1.4. Das passt jetzt auch. Auch habe ich twrp 3.1.1-1 zum laufen bekommen. Nur lineage kann ich mal wieder nicht installieren :/ Immer noch Fehler 7 :(

Irgend wie ist da der wurm drin.

edit://

ich glaube nach superus bleibt er jetzt beim booten wieder hängen :/
 
Zuletzt bearbeitet:
der_berliner

der_berliner

Stammgast
Threadstarter
Mahlzeit,

versuchte doch mal LOS mit einem Custom-Kernel zu flashen. Vorzugsweise den Arsenic-Kernel. Vllt. liegt es am Kernel von LOS. Sollte das nicht klappen dann flash noch mal die Recovery von Lucian77 und anschliessend noch mal die 3.1.1-1.

grüsse
 
vonharold

vonharold

Stammgast
Hallo,

den Fehler7 hatte ich glaube ich auch mal beim umstellen auf LineageOS.
Ich musste damals glaube ich in TWRP eine Partion manuell einhängen. Danach konnte ich das installieren. Aussage aber unter Vorbehalt, da das schon lange her ist und ich auch Probleme hatte, die kein anderer hatte.
 
der_berliner

der_berliner

Stammgast
Threadstarter
Moin, Moin,

"Fehler 7" bedeutet das du deinen Bootloader updaten mußt. Hier eine Anleitung. Sie eigentlich so beschrieben wie ich es auch schon gemacht habe. Eine andere Lösung gibt es hier.

MFG mit freundlichen Grüssen, die Welt liegt dir zu Füßen und wir stehen drauf. :)
 
Ähnliche Themen - OnePlus X: Wiederherstellung nach Hard-Brick Antworten Datum
23
21
Oben Unten