Lineage OS 17.1 und 18.0 für das Galaxy S3 Neo

  • 47 Antworten
  • Neuester Beitrag
Diskutiere Lineage OS 17.1 und 18.0 für das Galaxy S3 Neo im Root / Custom-ROMs / Modding für Samsung Galaxy S3 Neo im Bereich Samsung Galaxy S3 Neo (I9301) Forum.
H

Humax

Erfahrenes Mitglied
Hallo zusammen, wenn alles nach Plan verläuft wird demnächst LOS17.1 offiziell, das bedeutet auch, das es von LOS16 auf der offiziellen LOS-Webseite keine Updates mehr geben wird.


Ich habe auf Android-File-Host auch andere Roms für das S3Neo hochgeladen. Hier finden sich auch aktuelle LOS17.1 und 18.0 - Builds.
17.1 ist stabil. Für 18.0 sollte heute Abend bessere Builds online sein, die ich dann auch auf Android-File-Host uploaden.
- Standortbestimmung mittels GPS & Glonass-Satelliten
- WiFi & mobile Daten
- Root durch Magisk (BasicIntegry & CTS profile (Magisk hide enabled))
- Front- & Rückkamera
- SMS: senden und empfangen
- Ausgehender Telefonanruf
- Eingehender Telefonanruf
- Bluetooth-Tethering
- 2,4 GHz Hotspot, 5 GHz Hotspot
- USB-Tethering
- Bluetooth ( Headset / Micro ) in Anrufen und Musikplayer
- FM Radio
- Offline Charging (Handy aufladen, während es ausgeschaltet ist)
- Video playback
- Gerät ist im Playstore zertifiziert (ohne magisk - mit Magisk ging es später auch?!)
-Videoanruf in Apps wie Telegram
-Videoaufnahmen: selbes Problem wie unter LOS14.1 und LOS16 für das S3Neo. Mit der Standardkamera-App nur sehr wenige weiße Linien (wenn man die Kamera (schnell) schwenkt) in den Videos, mit anderen Apps deutlich mehr.
-Verbindung zu einem versteckten Netzwerk - Verbindung kann immer nur manuell eingerichtet werden.
- Screencast —> REBOOT!
 
Zuletzt bearbeitet:
H

Humax

Erfahrenes Mitglied
So jetzt dann wohl doch noch eine Planänderung. Wie es aussieht werden die offiziellen LOS17.1 - Builds übersprungen und direkt mit 18.0 weiter gemacht. Voraussichtlich nicht vor Weihnachten. Auf Android File-Host sind die LOS17.1 und die neuesten 18.0 Builds vorhanden. 17.1 ist wie gesagt sehr stabil. 18.0 werde ich die Tage testen. Sollte aber soweit gut aussehen.

Wichtig für 18.0. Bei Installation wird gefragt ob, das LOS - Recovery benutzt werden soll - dies auf jeden Fall verneinen!!!
 
H

Humax

Erfahrenes Mitglied
LOS16 hat an diesem Wochenende sein voraussichtlich letztes Update erhalten. Damit sollte das DeepSleep Problem gefixt sein. Werde ich heute testen. Wenn das alles passt, wird sich zuerst LOS17.1 offiziell.
 
H

Humax

Erfahrenes Mitglied
So , es ist fast geschafft. LOS 16 hat für alle 3 Modelle den Deep Sleep - Fix erhalten und es wurde nun auf 17.1 umgestellt. Für die ds -Variante ist 17.1 bereits offiziell, jv und xx sollten am Sonntag und Montag folgen.
 
H

Holzmichel1

Neues Mitglied
Nun verabschiede ich mich aus dem Tread OS16 und Starte hier,
denn seit heute ist für das S3 Neo mit Sony-Camera auch die 17.1 zu haben.
Somit hatte ich heute das Vergnügen 2 x S3 Neo, einmal mit Samsung und einmal mit Sony-Kamera zu flashen.
Hat beides super funktioniert, und macht einen guten Eindruck.
 
H

Holzmichel1

Neues Mitglied
Hallo, hier wieder doch nur ein Zwischenstand.
Erstes Neo Samsung-Flash und Samsungkamera mit Build 17.1 funktioniert nach wie vor korrekt.
Zweites Neo Sony-Flash und Sonykamera hatte Anfangs hausgemachte Probleme mit dem Playstore siehe anderem Beitrag. Dies ist erledigt.

Trotzdem zickt das zweite Sonyflash nun mit Speicherproblemen rum, was es mit Build 16 nicht getan hat.
Dieses äußert sich wie folgt:
Ich komme auf den Playstore, aber beim Installieren von Apps wird mir mitgeteilt dass nicht genügend Spericherplatz vorhanden ist.
Ich starte die Kamera. Diese startet sauber, aber informiert mich: Legen Sie vor Verwendung der Kamera eine SD Karte ein.
In der Speicherverwaltung habe ich 27% also 4,26 von 16GB belegt, SD Karte 715K von 30,9GB belegt.
Über Dateimanager komme ich auf die SD-Karte und es ist genügend frei. Zwischenzeitlich eine neue SD eingelegt mit identischem Erfolg.
Nun setze ich nochmals auf und werde zum Test das Androidbuild 17.1 versuchen. Auch wenn die Kamera dann ja nicht fuktioniert...
Installation läuft gerade.
 
H

Humax

Erfahrenes Mitglied
Holzmichel1 schrieb:
Installation läuft gerade.
Ich vermute dass wird dir nicht helfen. Kenne das Problem nur von LOS16 und dachte dass tritt nur dort sporadisch auf.
Laienhaft erklärt ist dein interner Speicher nicht "richtig" "gemountet", ist also nicht vorhanden. Deshalb die Meldung von zu wenig Speicher. Ich hatte das Problem unter LOS16 auch ein-zweimal. Neuflash oder auch das Wiederherstellen eines zuvor fehlerfreien LOS16-Backup haben nicht geholfen. Ich konnte es damals reparieren, indem ich ein CM12.1 wiederhergestellt habe. Bei einigen anderen hat die folgende Methode funktioniert, also probier erst Mal das Terminal aus.

Öffne ein Terminal tippe(Root nötig):
su (ENTER)
restorecon -fR /data/media (ENTER)
 
Zuletzt bearbeitet:
H

Holzmichel1

Neues Mitglied
Nachdem ich gestern im Sitzen eingeschlafen bin (beim Flash) hier die Rückmeldung:
Du hast recht. Es brachte nichts. Zwischenzeitlich habe ich auf den Sonycam-Gerät
wieder die lineage-17.1-20210111-nightly-s3ve3gxx-signed drauf.
Kamera startet, aber das Speicherproblem ist statisch.
Wenn ich richtig verstehe ein Problem beim Einbinden des Hauptspeichers.
Dir ist das schon bei Build 16 passiert? Wieviele Flashs hast du schon hinter dir?

Nun kenne ich mich mit Root nicht aus. Nur soviel das ich da wohl ein Terminalprogamm benötige.
Beim Suchen hier in "Grundsätzlichem" und "Anleitungen zum Rooten" dreht sich bei mir alles.
Muss fürs Root die Magisk-v21.2.zip über das TWRP nachinstaliert
werden (Ist mit Fehler: Dateiformat falsch abgebrochen)?
Oder muss das über Odin eingeschoben werden?
Und wo kommt dieses Terminal her? Appstore?

Ich glaube ich gehe lieber über CM12.1. Dazu hattest du ja im Tread OS16 Beitrag 6 ein paar Tipps
zurück gelassen. Damit funktionierte das Teil gut als Webcam für meinen 3D-Drucker.

_________________________________________________________________

Aber es wird nicht Langweilig: Ich habe gerade ( vor 4 Stunden) von meinem Sohn sein altes,
also mein nun drittes Neo bekommen.
Vorher mit Device Info HW App geprüft. Mit 2x SamsungKamera, Top. Kleiner Freudentanz.

Pustekuchen, 20210110 und nano Gapps drauf und... keine Kamera da.
Device Info HW App drauf siehe da die Auskunft über die Kamera ist dürftiger:
Unterstützt s5k6a3yx
Keine Herstellerangabe mehr und auch kein Kamera 1 und 2.
Für heute bin ich am Ende.
 
H

Humax

Erfahrenes Mitglied
Ja mach lieber Schluss für heute bevor einschläfst und das Handy noch runterfällt...
Ich hab gefühlt auf dem Neo hundert flashs... Bei LOS16 ist mir es zweimal passiert, das dann der interne Speicher Weg war. Einfacher ist es über das Terminal. Hier die Anleitung:
Magisk v21 oder neuer downloaden, ins TWRP booten und die Datei flashen. Danach reboot ins System. Dann sollte bei deinen Apps die App Magisk Manager vorhanden sein - manchmal aber auch nicht, dann musst die Apk - glaube aktuell ist 8.0.4 - downloaden und installieren. Damit hast du nun Root Zugriff.

Ein Terminal kannst du im playstore runterladen oder die Entwickler Optionen aktivieren und dort das lokale Terminal aktivieren, welches dann in der App Liste ist. Ich benutze immer das eingebaute.
Dann die Befehle wie beschrieben eingeben. Nach su kurz warten - dann wirst du gefragt ob du Root Zugriff erlauben willst - da machst du ja, kannst auswählen ob nur dieses Mal oder immer. Ist dir überlassen. Dann den anderen Befehl und dann reboot und gucken ob der interne Speicher jetzt da ist. Danach kannst Root auch wieder deinstallieren, wenn es nicht brauchst.
Mit der Kamera hab ich schon öfter gehört, dass unter Stock-Rom manchmal falsch angezeigt wird.

Ich habe Mal magisk angehängt. Nicht ganz das aktuellste passt aber...
 

Anhänge

  • MagiskManager-v8.0.2.apk
    3,1 MB Aufrufe: 2
  • Magisk-v21.0.zip
    5,9 MB Aufrufe: 1
Zuletzt bearbeitet:
H

Holzmichel1

Neues Mitglied
Hallo Humax,
Dein Bericht hat mich wieder wach gemacht.
Hui, dann war ich ja schon auf dem richtigen Weg, nur das der Flash aus dem TWRP dauernd
mittendrin meinte das Zip-File wäre falsch. Die Installation der Magisk 21.2 also nicht funktionierte. Mit der 21.1 funktionierte das dan gleich richtig. Das Update habe ich dann nicht mehr gemacht. Und siehe da mit 21.1. lief es dann sauber.

Deinen Befehl habe ich um das kleine "f" erleichtert und schon war auch mit

su (ENTER)
restorecon -R /data/media (ENTER)
alles geritzt.

Das Speicherproblem ist tatsächlich behoben. Dabei hatte ich mir schon alles für das CM12.1 hingelegt.
Das SonyKameraNeo funktioniert wieder.
Danke Danke Danke.
 
H

Humax

Erfahrenes Mitglied
Moin. Vielleicht ist das v21.2 ZIP-File defekt gewesen. Egal Hauptsache es passt jetzt. Ging der Befehl mit -fR nicht oder warum hast du es weggelassen?
 
H

Holzmichel1

Neues Mitglied
Guten Morgen Humax,
Ich hatte das interne Terminal benutzt
und der Befehl restorecon -R /data/media war nicht gültig.
Dann die Syntax von restorecon angeschaut und dort gibt es die Variante -F oder -R
also das fR in R gewechselt und alles funktionierte.

Damit ist das SonyKameraNeo abgeschlossen. Sonykamera Sony Build alles OK

-----------------------------------------------------------------------

Nun zu Nummer 3

> Pustekuchen, 20210110 und nano Gapps drauf und... keine Kamera da.
> Device Info HW App drauf siehe da die Auskunft über die Kamera ist dürftiger:
> Unterstützt s5k6a3yx
> Keine Herstellerangabe mehr und auch kein Kamera 1 und 2.

3. Neo mit definitiv der Anzeige unter 4.4 Kitkat und der App Device Info HW: Kamera 0 Samsung; Kamera 1 Samsung.
Vorgehen war
Dieses Mal hatte ich den deutschen Bootloader aus dm Los16-Tread verwendet verwendet (obwohl laut deinen Angaben Q oder R als drittletzter Buchstabe bei der Bootloaderversion auf dem alten Ding bereits vorhanden war).
Nach dem Flash 20210110 und nano Gapps war keine Kamera vorhanden. Aber auch kein internes Speicherproblem,
denn ich konnte den Appstore öffnen und die Device Info HW App installieren.

OK was dann?
1. Alles nochmal, leider ohne Erfolg.
2. Einfach mal ins TWRP booten, Speicher (bis auf SD-Karte und USB) löschen,
zurück zur Installation, 20210111 (Sony) und Gaps Nano drauf. Neustart:
3. Kamera ist da. mit der Ansage: SD-Karte einlegen.... Appstore gecheckt: Bei installation von Device Info HW App
die Meldung räumen Sie Ihren Speicher auf, also wie wir gelernt haben, kein korrekter Zugriff auf den Internen Speicher.
Nachgefügt:
4. Also auch hier Magisk 21.1 drauf, Terminal gesucht und gefunden und auch hier mit
su (ENTER)
restorecon -R /data/media (ENTER)
Das Dateisystem wieder korrigiert.
Nun funktioniertz auch das 3. Neo wieder.
 
Zuletzt bearbeitet:
H

Humax

Erfahrenes Mitglied
Ich hab leider nit so viel Kenntnisse in den Linuxbefehlen, aber gut dass es hinbekommen hast.

Den Rest deiner Nachricht verstehe ich dann nicht mehr so ganz. Geht jetzt alles oder hast du noch (oder wieder) das Problem mit dem Speicher oder ein anderes Problem?

Wie gesagt die Anzeige unter Stock Rom bezüglich der Kamera stimmt wohl nicht immer, ich könnte mir vorstellen, dass immer Samsung Kamera angezeigt wird!
 
Zuletzt bearbeitet:
H

Holzmichel1

Neues Mitglied
Hallo Humax, ich war seit 55 Minuten am fertigschreiben inklusive Danksagung ans Forum und besonders an dich,
als mir der Bericht "abhanden kam"

Nun kurz ergänzt:
Kamera Sony oder Samsung ist ein Loteriespiel. Mit der Device Info Ap wurde unter Andro 4.4 der Hersteller der Kamera angegeben.
Ich gehe davon aus das die auch immer korrekt war.
Beim Build 16 und 17 geht es eher um die Bezeichnungstype der Kamera, jedenfalls wird da mit identischer App kein Hersteller mehr angezeigt.
Erschwehrend kommt hinzu dass eine Kontrolle nicht möglich ist, wenn zeitgleich das Dateizuordnungssystem spinnt.
Das äußert sich bei funktionierender Kamera durch den Fehler : Legen Sie eine SD Karte ein
und bei dem Versuch aus dem Playstore zu installieren, der Fehler zuwenig interner Speicher.

Fazit auf die SD-Karte gehören die Zips von: Los17.1 Sony und Samsung, die Open Gapps nach Wunsch in ARM 9
und die Magisk v21.1
Ist das Kamerasymbol nicht da, einfach das andere Build benutzen.

Also nochmals herzlichen Dank für deine klar strukturierten und auch für Gelegenheitsandrojaner wie mich,
letzendlich nachvollziehbaren und zum Ziele führenden Beiträge.

Danke für deine Geduld
 
H

Humax

Erfahrenes Mitglied
Ok, verstanden.
Alles klar. Wenn mal wieder was klemmt einfach melden.
 
D

DerApfelbaum

Fortgeschrittenes Mitglied
Hallo Humax,

dank Deiner Hilfe habe ich jetzt ein sehr gut funktonierendes LOS-16-System.
Leider gibt es ja jetzt keine Updates mehr. Ist es ratsam, auf LOS17.1 zu wechseln, oder noch zu warten, bis das 18 raus ist? Wann kommt das raus? Kannst Du mir dazu was sagen?

Danke im Voraus
 
H

Humax

Erfahrenes Mitglied
Nabend! Ist wohl auch Geschmackssache. Das 17.1 läuft genauso stabil. Ich bin noch auf 16, hatte noch keine Zeit/Bedarf zu wechseln. Aber klar, Sicherheitsupdates gibt's für 16.0 nicht mehr...
Vom 18.0 hab ich ein ganzes Weilchen nix mehr gehört, bis auf heute - was ein Zufall - es werden wohl gerade neue builds gemacht. Aber ob das schon alles läuft wie ich nicht.
 
B

Benno84

Neues Mitglied
Hallo zusammen,
vielen Dank für eure Forumsbeiträge. Dank dieser läuft ein weiteres S3neo mit 17.1. Ich hatte es schon abgeschrieben.

Ich habe eine Frage. Ich habe gestern, dass neuste OTA Update von 17.1 vom 07.02. installiert. Beim Neustart blieb das Gerät in dem Bootvorgang (LineageLogo) hängen und es bewegte sich 30 min nur ein Kreis.

Wie kann das sein? Muss etwas vor dem Update ausgeschaltet, deaktiviert werden?

Vielen Dank für die Hilfe und Antwort!
 
H

Humax

Erfahrenes Mitglied
Hallo, anscheinend gibt es Probleme mit diesem Build, habe nun schon mehrfach von diesen Verhalten mit dem neuesten Update gehört. Ich würde einfach das Build von vor einer Woche drüber flashen.
 
B

Benno84

Neues Mitglied
Hallo Humax,
wow, das ging aber schnell. Vielen Dank für die schnelle Antwort!

Ich versuche mal ein älteres OTA und werde berichten.

Leider musste ich komplett das Recovery, Gapps und Magisk neu einspielen, da die Sicherungen von TWRP keine Besserung beim Booten brachten. Gibt es hierzu Erfahrungen, warum sich nach einem fehlgeschlagenem Update nicht eine Wiederherstellung nutzen lässt?

Vielen Dank für die Antwort!
 
Ähnliche Themen - Lineage OS 17.1 und 18.0 für das Galaxy S3 Neo Antworten Datum
1