Restore von Android System Sicherung auf S7 klappt nicht

  • 32 Antworten
  • Neuester Beitrag
Diskutiere Restore von Android System Sicherung auf S7 klappt nicht im Root / Custom-ROMs / Modding für Samsung Galaxy S7 im Bereich Samsung Galaxy S7 (G930F) Forum.
chrs267

chrs267

Experte
krockie schrieb:
Ich hatte zuerst versucht die Sicherung vom laufendem System aus mit TWRP und Titanium wiederherzustellen, das klappte natürlich nicht.
TWRP = Recovery
Da ist nix mit laufendem System. TWRP wird als Image über die originale Recovery geflasht und als Recovery gestartet. Also wie die originale, nur mit vielen speziellen Features.
Beitrag automatisch zusammengefügt:

Aber schön zu hören, dass es geklappt hat. 👍😉
 
Zuletzt bearbeitet:
DBan

DBan

Ambitioniertes Mitglied
Lieber eine gesunde Paranoika als einen ungesunden Datenverlust.
Wichtig ist ja erst mal: was will der User. Und wenn das System jetzt so ist wie du es brauchst...

Backup: TWRP (Team Win Recovery Project) ist zuerst mal ein Custom-Recovery. Das braucht man um ein Custom-ROM
zu installieren. Dazu kann es noch "Backup und Restore". Um das zu benutzen muss das Phone ins Recovery gebootet werden.
Ist zwar minimal umständlich - aber nötig.

So wie ich es lese ist dein Problem deshalb gelöst. Als TE kannst du dann den Thread als "gelöst" markieren.
Und was Google will und was es warum macht = a never ending Story. Da langen die Server vom Forum nicht aus 🤣

LG
Dietmar
 
Zuletzt bearbeitet:
DBan

DBan

Ambitioniertes Mitglied
Einspruch euer Ehren
Bis auf Win korrekt geschriebentwrp.png
Das Windows war dem Schreibfluss geschuldet. (wobei ich mit Windows nix am Hut habe)

Edit: hab's korrigiert

Edit2: einen hab ich noch "ave Cloud - moreturi te salutant"
 
Zuletzt bearbeitet:
K

krockie

Ambitioniertes Mitglied
Hallo,
ich nochmal.
Habe nachdem Anpassen der wiederaufgespielten Nandroid Sicherung von 2018 alles soweit wieder angepasst und aktualisiert.
Google Play Dienste deaktiviert.
Dann sicherheitshalber einen aktuellen Backup mit TWRP gemacht und Google Play Dienste wieder aktiviert da sonst weder Spracheingabe noch Google Maps funktionieren. Auch diese ständigen nicht abschaltbaren Meldungen auf dem Display das es nicht aktiviert ist haben genervt.
Dann update von Google Play Diensten durchgeführt und tataa schon ging es wieder los das Google Play Dienste angehalten wurde, so schön mitten im Bildschirm ohne es wegklicken zu können oder auch etwas anderes auswählen zu können.
Nun gut, hab ich die neulich gemachte Sicherung wieder unter Recovermodus mit TWRP eingespielt.
Nachdem Neustarten bleibt es allerdings immer beim Samsung Logo hängen und es vibriert 1x lang und 3x kurz, das Gerät wird heisser und heisser.
Habe jetzt wieder erstmal das Nandroidbackup von 2018 aufgespielt.
Kann wer sagen was da schiefläuft warum TWRP seine eigenes Backup nicht richtig aufspielt.?

Das Backup hatte ich mit der älteren 3.0.1Version vonTWRP gemacht, diese konnte beim Restore aber weder die externe SD Card noch den USB Stick auslesen, das erklärt auch warum das erste mal es Probleme beim Restore gab. Habe dann die TWRP 3.6.0 geflasht und diese konnte dann alle Medien am Handy auslesen.

Hier die beiden Backupsinhalte als Foto eingefügt.
Es sind verschieden Datein, ich erstehe nicht warum TWRP sein eigenes Backup nicht richtig aufspielen kann.
und diese 1x lang und 3x kurz Vibration sagt mir auch nichts.

Vielleicht Jemand hier der es versteht?
Vielen Dank.
Gruß
 

Anhänge

chrs267

chrs267

Experte
krockie schrieb:
Kann wer sagen was da schiefläuft warum TWRP seine eigenes Backup nicht richtig aufspielt.?
Genau das schreibt TWRP ins eigene recovery.log hinein und zwar sehr detailliert. Aus der Ferne kann dir keiner helfen, ohne eine Fehlermeldung zu kennen.
 
K

krockie

Ambitioniertes Mitglied
meinst du die Liste die während des Restorevorganges auf dem Bildschirm erstellt wird?
Wenn ja kam da etwas rotes (hab leider kein Foto von gemacht)
in etwa war der Wortlaut, Error...cant mount efsx ...
 
Zuletzt bearbeitet:
chrs267

chrs267

Experte
@krockie Das ist nur der Output, kein Log. Hauptmenü > erweiterte Einstellungen > Log erstellen
 
K

krockie

Ambitioniertes Mitglied
ok dies bedeutet, ich müsste den Restore Vorgang wiederholen und danach ein Log erstellen auswählen oder schon vor dem Restorevorgang?
Ich werde es später versuchen, jetzt nicht mehr.
Danke für den Tip
 
Zuletzt bearbeitet:
chrs267

chrs267

Experte
@krockie Du könntest auch unter /data/recovery nachsehen. Es gibt immer ein Log der aktuellen Sitzung und ein Log, welches forlaufend geführt wird.

krockie schrieb:
Es sind verschieden Datein
Sie sind nur anders aufgeteilt, aber sie sind gleich. Eigentlich wird bei TWRP die Sicherung einer Partition auf Dateiebene (*.ext4.winXXX) in mehrere Splits (auch Tapes genannt) zu max. 1,5GiB aufgeteilt, sobald diese Größe erreicht wird. Kommt darauf an, was zum Ende dem Archiv hinzugefügt wird. Das macht die neuere Version bei dir offensichtlich nicht. Irgendwie schon merkwürdig, kann aber nicht die Wiederherstellung beeinflussen.
 
K

krockie

Ambitioniertes Mitglied
Ich komme immer noch nicht zu, muss erst mal Autobatterie erneuern usw.. Melde mich Später wieder wenn ich es mit dem Protokoll hinbekommen sollte.
Gruß
 
chrs267

chrs267

Experte
@krockie Mach dir doch keinen Stress. :)

Vergiß den Pfad aus dem vorherigen Post. Die Logs sind hier:
/data/recovery/log.gz
/data/recovery/last_log.gz
 
K

krockie

Ambitioniertes Mitglied
Hallo,
also eine Log Datei weder in /data noch in data/Data/ konnte ich nicht finden auch sonst nirgends .
Ich habe dann nochmals einen Backup mit TWR3.6.0 gemacht und dabei alles was möglich war ausgewählt.
Diesen kann es wiederherstellen. Siehe auch Fotos
Ich belasse es jetzt dabei, das ist verrückt für einem Telefon soviel Zeit zu invetsieren ohne zu wissen was da genau passiert.
Ich komme zu nichts mehr und kann das Telefon nicht mer sehen. Mit dem blöden Google Meldung habe ich versucht abzuschalten, soll er doch sein Update für sich behalten. Die Meldung kommt immer wieder, dann werde ich es immer wieder löschen müssen.
Map und Playstore funktioniert noch.
Das reicht völlig aus wenn es mal wieder abschmieren sollte dann spiele das Backup in 2 Minuten auf und mache einige APP-Updates und gut sollte es sein. Soviel Nerv und Ausdauer für ein Telefon habe ich nicht mehr, sonst drehe ich noch ab hier😃
Ich muss auch mal wichtigere Sachen erledigen.
Vielen Dank nochmals an alle für die Hilfestellungen

Gruß
 

Anhänge