[HowTo] Änderung des Splash Screens

  • 36 Antworten
  • Neuester Beitrag
Diskutiere [HowTo] Änderung des Splash Screens im Root / Custom-ROMs / Modding für Telekom Move im Bereich Telekom Move Forum.
keinea-hnung

keinea-hnung

Erfahrenes Mitglied
Splash-Screen wird vor dem Boot-Screen angezeigt und ist in de Regel das Firmenlogo vom Hersteller.

Weiß jetzt nicht was bei euch angezeigt wird, aber bei mir ist es weiß und sehr hell (mir gefällt es nicht und auch sehr unangenehm!).:angry:

Hier habt ihr ein paar andere Splas-Screens!

Einfach die Zip entpacken und einer der *.mbn Dateien in sytem/logo Verzeichnis als oemlogo.mbn kopieren (die vorhandene oemlogo.mbn überschreiben). Vielleicht muss man noch einen "wipe data....." durchführen.

PS: Ich hab das Grüne ausgewählt. GEIL!

oemlogo-pack.rar
 
woingenau

woingenau

Fortgeschrittenes Mitglied
Klappt nach 2-maligen Booten, nachdem ich einen Wipe durchgeführt habe.
Danke!
 
Zuletzt bearbeitet:
keinea-hnung

keinea-hnung

Erfahrenes Mitglied
Habe die and_oemlogo.mbn und green_oemlogo.mbn ausprobiert, und beide funktionieren bei mir (die anderen habe ich noch nicht ausprobiert).

Klappt, na prima!

Noch ein Tipp:

Ihr könnt im Ordner system/media die beiden Dateien bootanimation.zip und shutdownanimation.zip (das Telekom Boot/Shutdownscreen) löschen. Beim herunterfahren ist es schneller, und beim booten wird ein Standard Bootscreen angezeigt. Ob es schneller bootet weiß ich nicht?!
 
C

cannabis

Stammgast
gute sache, danke
 
Icfu

Icfu

Neues Mitglied
keinea-hnung schrieb:
Einfach die Zip entpacken und einer der *.mbn Dateien in sytem/logo Verzeichnis als oemlogo.mbn kopieren (die vorhandene oemlogo.mbn überschreiben). Vielleicht muss man noch einen "wipe data....." durchführen.
Muß man nicht, einfach das Logo einmalig laden:
Code:
> adb shell
$ su
# load_oemlogo /system/logo/oemlogo.mbn
 
keinea-hnung

keinea-hnung

Erfahrenes Mitglied
Icfu schrieb:
Muß man nicht, einfach das Logo einmalig laden:
Code:
> adb shell
$ su
# load_oemlogo /system/logo/oemlogo.mbn

Jede kann es machen wie er will. Gibt bestimmt noch 1 Million andere Möglichkeiten.

Nur wenn man das so macht wie du, dann muss man es jedes mal neu übertragen, wenn man einen "Wipe Data Factory reset" durchführt.
Wenn das oemlogo.mbn auf system gelöscht würde, dann reicht deine Vorgehensweise glaube ich?!?!?!

Macht doch was ihr wollt :lol:!
 
Icfu

Icfu

Neues Mitglied
keinea-hnung schrieb:
Jede kann es machen wie er will. Gibt bestimmt noch 1 Million andere Möglichkeiten.
Sollte eigentlich nur 'ne Hilfestellung sein für Leute, die keine Lust haben, wegen eines Logo-Austauschs ihre Datenpartition ins Nirvana zu schicken. Ich jedenfalls hatte dazu keine Lust, als ich Dein Posting entdeckte und habe meine neu gewonnenen Erfahrungen geteilt.

War wohl nicht erwünscht. Egal.
 
keinea-hnung

keinea-hnung

Erfahrenes Mitglied
Nein, war wirklich nicht so gemeint.
Entschuldige mich auch, wenn es so herübergekommen ist!

SORRY!:rolleyes2:
 
Icfu

Icfu

Neues Mitglied
Is' angenommen... ;)
 
E

Erich123456

Neues Mitglied
Icfu schrieb:
Muß man nicht, einfach das Logo einmalig laden:
Code:
> adb shell
$ su
# load_oemlogo /system/logo/oemlogo.mbn
Vielleicht ne dumme Frage, aber wo oder wie gebe ich das ein?
 
Andy

Andy

Ehrenmitglied
Am pc wenn du in der Eingabeaufforderung per Adb Shell die Shell zu deinem Gerät hergestellt hast, alternativ auch am Gerät selber zb mit der App 'Android Terminal Emulator'

Gesendet von meinem U8600 mit der Android-Hilfe.de App
 
Icfu

Icfu

Neues Mitglied
Erich123456 schrieb:
Vielleicht ne dumme Frage, aber wo oder wie gebe ich das ein?
Du startest im Ordner, der die adb.exe enthält, 'ne Konsole. Beispielsweise im entpackten root_U8600.zip von hier:
https://www.android-hilfe.de/forum/...dding-debloating-fuer-das-u8600-1.343227.html

Wenn Du Windows 7 nutzt, einfach bei gedrückter Shift-Taste 'nen Rechtsklick auf den Ordner oder im Ordner machen, dann enthält das Kontextmenü 'nen zusätzlichen Eintrag "Open command window here".

Die /system-Partition muß gemountet sein. Ist sie bei mir eh automatisch, weil ich TC+ADB-Plugin nutze. Explorer-Nutzer müssen leider noch 'ne mount-Zeile einfügen.

Das ganze schaut dann so aus:
Code:
D:\Downloads\root_U8600>prompt $g$s

> adb shell
$ su
su
# mount -o rw,remount -t yaffs2 /dev/block/mtdblock4 /system
mount -o rw,remount -t yaffs2 /dev/block/mtdblock4 /system
# load_oemlogo /system/logo/oemlogo.mbn
load_oemlogo /system/logo/oemlogo.mbn
#
 
Zuletzt bearbeitet:
D

D3V!Lc0r3

Gast
Hi @ll,

leider hat sich mein Oemlogo durch flashen einer anderen Firmware verändert :(

Ich habe mich jetzt schon totgegoogelt und noch keine Lösung für dieses Problem gefunden. MorphX hat schon in anderen Unterforen Anleitungen bzw. Lösungen gepostet, die auf dem Move leider nicht funktionieren.

Jemand eine Idee, wie man das beheben könnte ?!?

Vielen Dank im Voraus ;)

Gruss, D3V!Lc0r3
 
Zuletzt bearbeitet von einem Moderator:
A

Andromi

Ambitioniertes Mitglied
Zuletzt bearbeitet:
D

D3V!Lc0r3

Gast
@Andromi: Vielen Dank für Deine Bemühungen ;) Leider habe ich das schon alles ausgetestet :(

Habe alle Wipes durchgeführt und meine Firmware neu geflasht. Vorher habe ich im Ordner "clogo" die Datei oemlogo.mbn eingefügt ...

No chance ... funzt einfach nicht :thumbdn:
 
Zuletzt bearbeitet von einem Moderator:
keinea-hnung

keinea-hnung

Erfahrenes Mitglied
Es gibt tausend wege wie man Logo flashen kann.

-was auf jedem Fall funktioniert, wenn du das Original-ROM flasht und im system/media die oemlogo vorher änderst.

- das von @Ifcu mit ADB müsste auch funktionieren, musst nur das richtige Verzeichnis angeben (selber noch nie ausgeführt).
https://www.android-hilfe.de/forum/...g-des-splash-screens.349594.html#post-4964422


- Mit deiner ADB-Tools kann man das oemlogo auch flaschen.
AOI-Flasher vielleicht ?

Glaube das es auf einer der Partitionen geflasht wird (ist glaube ich die splash-Partition?!).
 
S

segler11

Gast
fastboot flash logo logo

Alternativ als Bildchen auf´s Display kleben......
 
Zuletzt bearbeitet von einem Moderator:
keinea-hnung

keinea-hnung

Erfahrenes Mitglied
Segler altes Haus..... :lol:.

@D3V!Lc0r3

jetzt ich verstehen, was du haben vor :D.
Du wollen das in deiner Firmware automatisch funktionieren, wenn flashi flashi machen deine ROM.

Ich haben eine Idee:lol:.
Du kopieren aus StockROM in /system/bin/load_oemlogo in deiner Firmware, dann kann funktionieren deine Firmware laden automatisch oemlogo.

VIELLEICHT FUNKTIONIERT ES SO:lol:?????
 
Zuletzt bearbeitet:
S

segler11

Gast
Keine Ahnung ob das geht, habe ich mal wo gelesen.