CM10 Alpha

  • 162 Antworten
  • Neuester Beitrag
Diskutiere CM10 Alpha im Root / Hacking / Modding für das Odys Xelio im Bereich Odys Xelio Forum.
B

benno01

Ambitioniertes Mitglied
Bei mir genau das gleiche: bis zum Einrichtungsassi und nichts geht mehr, außer die Hardwaretasten. War bei der vorigen Version mein selbes Problem.
Hab jetzt CyanBook V4 drauf, bin allerdings noch nicht ganz zufrieden: startet zwar schneller und WLan ist nach dem Ausschalten auch schneller wieder da, aber V3 lief runder. Bei beiden habe ich aber das Problem, dass es nicht mehr komplett ausschaltet! Irgendwann startet es einfach neu und bleibt dann halt an (im Ruhemodus). Habe das nur durch Zufall gesehen. Jetzt brauche ich mich auch nicht zu wundern, warum der Akku immer so schnell leer war, obwohl ja eigentlich ausgeschaltet. Hat da jemand eine Idee?

Gruß
Thomas
 
Android-freak 12

Android-freak 12

Fortgeschrittenes Mitglied
Hi, ich habe eine Frage. Ich möchte Cm10 auf meinem Tablet installieren. Kann mir jemand eine GENAUE ANLEITUNG geben !!! Bitte!!! Danke im voraus:sad::cool2:
 
B

benno01

Ambitioniertes Mitglied
Hallo raphael,

das ist gar nicht so schwierig. Bis vor kurzem hatte ich auch noch keinen Schimmer. Du solltest nur nicht das aktuelle originale Rom drauf haben, da soll das nicht funktionieren, rede ich aber nur nach, nicht getestet.
Ein paar Beiträge vorher habe ich das mal kurz erklärt #83.

Grüße
 
AsusFreak

AsusFreak

Fortgeschrittenes Mitglied
Hmm - soweit ich das verstehe möchtest Du CM10 und nicht CyanBook installieren. Hier die an den CM9 Thread angelehnte Beschreibung.

Installation:
1. CWM am Xelio installieren, falls noch nicht vorhanden: Verschiedene Mods/Verbesserungen fürs Xelio (Punkt4) - oder über die Novo Tools (weiter oben beschrieben).

2. Folgende Dateien downloaden und auf die externe SD-Karte kopieren
- ROM:Download
- Gapps:Download
- xelio_compatibility_1.2.0:Download

3. Dateien per CWM in folgender Reihenfolge flashen:
- ROM
- Gapps
- xelio_compatibility_1.2.0

Fertig.
 
W

wishmasterf

Erfahrenes Mitglied
joe_sixpack schrieb:
So, mal schell ein Flash zwischdurch ohne Wipe, also von der letzten CM10 auf die aktuelle Version geht nicht!:thumbdn:
Du wirst nach dem Update das

- xelio_compatibility_1.2.0:Download

flashen müssen!
 
Android-freak 12

Android-freak 12

Fortgeschrittenes Mitglied
Habe das Odys mit z4root zuerst un-root gemacht und dann einen Permanent Root weil ich dachte dass sich dann Superuser von selbst installiert ! Falsch gedacht! Nach jedem ein/aus schalten ist alles auf Werkstand und ich habe keinen zugriff mehr auf den internen Speicher !
 
Zuletzt bearbeitet von einem Moderator:
jna

jna

Ehrenmitglied
Das Gerät ist bereits von Haus aus gerootet, kein Bedarf für seltsame Experimente, wie du sie gemacht hast.
Spiel einfach die Firmware nochmals drauf.

Gesendet von meinem GT-I9000 mit Tapatalk 2
 
Android-freak 12

Android-freak 12

Fortgeschrittenes Mitglied
Wie denn?
 
hävksitol

hävksitol

Ehrenmitglied
joe_sixpack

joe_sixpack

Stammgast
Hi!
wishmasterf schrieb:
...
Testing Download

Download Build 2012-11-30
...
* Fix for exessive battery usage

Testen und berichten! Danke!

Testergebnisse:
Ich habe kein Fullwipe gemacht, sondern einfach einmal "drübergeflascht, nachfolgend G-Apps & dann das Kompatibility-PacK. Tastenzuordnung stimmt, Scrolling (bei meinem Xelio) butterweich. Häufiges WLAN Ein- und Ausschalten ohne Reboot möglich (das hat beim Stock-Rom nie funktioniert, irgendwann bootete das Teil beim Einschalten:thumbdn:).
Allerdings bekomme ich wieder mal die nervigen Melldungen mit "App reagiert nicht", das war in der alten Version irgendwie besser.
Größtes Manko ist der Stromverbrauch: 24 Stunden Standby ohne WLAN und der Akku ist von 87 auf 25% runter?! Das geht ja gar nicht!!:blink:
Da muss ich jetzt erst mal schauen, wer hier so "frisst"...
 
joe_sixpack

joe_sixpack

Stammgast
joe_sixpack schrieb:
Größtes Manko ist der Stromverbrauch: 24 Stunden Standby ohne WLAN und der Akku ist von 87 auf 25% runter?! Das geht ja gar nicht!!:blink:
Da muss ich jetzt erst mal schauen, wer hier so "frisst"...
Leider bin ich hier noch nicht wirklich weiter gekommen - laut System ist Platz 1 im Stromverbrauch der "Ruhezustand", weit abgeschlagen kommt dann der Bildschirm und dann mit einem weiteren großen Abstand der Rest an Anwendungen/System.:confused2:
Allerdings ist mir aufgefallen, dass in der build.prop die "üblichen" Modifikationen in Richtung Energiesparen & Schlafmodus fehlen. Die werde ich jetzt erst mal nachtragen, neu starten und weiter beobachten.
Es gab doch irgendwie mal so'n Programm, was genau aufschlüsselt, welche App wie lange aktiv war bzw. ob das Tablet überhaupt in den Tiefschlafmodus kommt - aber mir fällt der Name nicht mehr ein. Kann mir da mal jemand auf die Sprünge helfen...
 
Zuletzt bearbeitet von einem Moderator:
djolivier

djolivier

Experte
Könnte vielleicht ein Zeichen dafür sein, dass das Tablet nicht in den Tiefschlaf versetzt wird bzw werden kann :confused:

Gesendet von meinem HTC Wildfire S A510e mit Tapatalk
 
AsusFreak

AsusFreak

Fortgeschrittenes Mitglied
joe_sixpack schrieb:
.... ob das Tablet überhaupt in den Tiefschlafmodus kommt - aber mir fällt der Name nicht mehr ein. Kann mir da mal jemand auf die Sprünge helfen...
CPU Spy ?
 
joe_sixpack

joe_sixpack

Stammgast
Hi!
djolivier schrieb:
... das Tablet nicht in den Tiefschlaf versetzt wird bzw werden kann...
Das habe ich ja vermutet - allerdings weiß ich nicht mehr, wie ich mir genau aufschlüsseln lassen kann, welche App oder welche Systemkomponente wie lange in Betrieb war bzw. wieviel Strom verbraucht hat. Irgendeine zusätzliche Anwendung gab's da mal - aber ich komme nicht mehr auf den Namen.
Dafür habe ich jetzt mal ein paar Änderungen in der build.prop hinterlassen und neu gestartet - das Ergebnis ist ansprechend:thumbsup:

Folgende Werte/Einträge wurden eingefügt:

debug.sf.hw=1
video.accelerate.hw=1
debug.egl.profiler=1
debug.egl.hw=1
debug.composition.type=gpu
ro.ril.power_collapse=1
pm.sleep_mode=1

Nach guten 6 Stunden Standby immer noch 91% Akku-Kapazität verfügbar, darüber lässt sich schon mal reden. Die Geschindigkeitssteigerung durchs GPU-Rendeing ist applikationsabhängig, bei Aldiko geht z.B. die Darstellung der Bücherregal-Ansicht um Größenordnungen schneller:D
Ich bin jedenfalls sehr zufrieden!
Wenn die CPU noch etwas potenter wäre, könnte ich mit dem Xelio durchaus auch noch länger glücklich sein. So "träume" ich jedoch von einem Google Nexus Tablet...

Viele Grüße

Der ursprüngliche Beitrag von 11:56 Uhr wurde um 13:38 Uhr ergänzt:

@AsusFreak:
AsusFreak schrieb:
Danke - genau das hatte ich gesucht! Ich habe im Play-Account so langsam nicht mehr durchgesehen, so viele Programme, die ich irgendwo schon mal installiert und wieder runtergeschmissen habe. Dazu dann die Masse der Endgeräte (fast jedes Mal, wenn ich 'ne neue Firmware auf'm Xelio probiere, gibt's einen neuen Eintrag)...:thumbdn:
Da hat Google aber mal Handlungsbedarf!


Viele Grüße
 
Zuletzt bearbeitet:
joe_sixpack

joe_sixpack

Stammgast
Hi!
djolivier schrieb:
...das Tablet nicht in den Tiefschlaf versetzt wird bzw werden kann ...
Problem geklärt - nach der Änderung der build.prop sowie einem Neustart ist das Ärgernis anscheinend erst mal weg. Laut CPU-Spy ist der Prozessor die meiste Zeit im Tiefschlaf oder bummelt mit 60 MHz vor sich hin. Nun ja, beim Lesen kommt nur kurz die GPU (zum Umblättern), danach ist wieder "Ruhe"...

Viele Grüße
 
H

Hansi Hinterseer

Erfahrenes Mitglied
Ich hab mir jetzt die gesammte letze Nacht um die Ohren geschlagen, 1000x mit LiveSuit geflasht, 1000x CWM geflasht.

Problem 1) Ich komme nicht per Tastenkombination ins Recovery. Ich habe schon zig Sachen probiert wie hier beschrieben, aber nicht ein einziges Mal ist er ins Recovery gegangen.
- Gerät aus
- Menütaste (beim Stromanschluss) gedrückt halten
- Powertaste drücken und gedrückt halten.

Problem 2) Wenn ich nach dem Flashen des CWM im Recovery lande per ADB Befehl,
mache ich einen Factory Reset und flashe danach das CM10. Doch jedes mal bleibt es in einer Bootschleife bei der Cyanogen Animation hängen.

Bei CyanBook Rom ist es das gleiche.

Wenn ich dazu das Compatibility.zip flashe, komm ich im CyanBook immerhin bis zur Anmeldung, die dann aber verreckt.


Kann mir bitte jmd helfen?


EDIT: Problem gelöst, siehe hier: https://www.android-hilfe.de/forum/...unter-neuer-firmware-installieren.316314.html
 
Zuletzt bearbeitet:
W

wishmasterf

Erfahrenes Mitglied
Testing Download by Shaun2029
Download Build 2012-12-08
MD5: 38f0fb0a33734d71af3e8d25990ee6ea

* Set wifi.supplicant_scan_interval = 90
* Updated CM10 sources
* Merge "Avoid memory leaks when handling metadata strings" into jellybean
* framework: fix reference leak in activiy manager
* Added Synchronization block to avoid Race condition

Bitte Testergebnisse posten!

Was sagt ihr zu den build.prop-Tweaks von joe_sixpack?:

joe_sixpack schrieb:
debug.sf.hw=1
video.accelerate.hw=1
debug.egl.profiler=1
debug.egl.hw=1
debug.composition.type=gpu
ro.ril.power_collapse=1
pm.sleep_mode=1
 
Zuletzt bearbeitet:
H

Hansi Hinterseer

Erfahrenes Mitglied
Meine Erfahrungen:

Weder die Version vom November noch mit der aktuellen Version läuft es bei mir.

Ich bekomme nach dem Flashen direkt eine Meldung, dass sich die Android Tastatur aufgehangen hat. Irgendwas mit AOSP Fehler. Die versucht sich dann immer wieder neu zu starten und funktioniert halt auch nicht.

Ich hab jetzt ein paar build.prop Befehle ausprobiert und egal was ich mache, die Kiste bootet danach nicht mehr. Als Editor habe ich Notepad++ genutzt.
EDIT: Es geht, wenn man Tools aus dem Market benutzt wie BuildProp Editor.


PS: Ist es normal das unter CM10 die Rotation nicht klappt? Genauso wenig Youtube Videos? Oder bei der Tagesschau App alle Videos schwarz bleiben und nur Ton kommt?
 
Zuletzt bearbeitet:
W

wishmasterf

Erfahrenes Mitglied
Hansi Hinterseer schrieb:
Meine Erfahrungen:

Weder die Version vom November noch mit der aktuellen Version läuft es bei mir.
compatibility-zip auch geflashed? Wird im gegensatz zu cyanbook benötigt!

Hansi Hinterseer schrieb:
Ich hab jetzt ein paar build.prop Befehle ausprobiert und egal was ich mache, die Kiste bootet danach nicht mehr. Als Editor habe ich Notepad++ genutzt.
EDIT: Es geht, wenn man Tools aus dem Market benutzt wie BuildProp Editor.
Klingt danach als hättest du "CR LF (Windows)" oder "CR (Macintosh)" und nicht LF (Unix). Als Editor für solche Files empfiehlt sich immer einen reinen Unix-editor zu verwenden (z.b. vi). Dann passiert sowas nicht.

Hansi Hinterseer schrieb:
PS: Ist es normal das unter CM10 die Rotation nicht klappt? Genauso wenig Youtube Videos? Oder bei der Tagesschau App alle Videos schwarz bleiben und nur Ton kommt?
[/QUOTE]
Kann ich dir leider jetzt nicht beantworten. Ich werde das aktuelle build Testen und die dann bescheit geben. Vielleicht kommt mir auch jemand anderes zuvor...
 
H

Hansi Hinterseer

Erfahrenes Mitglied
1) Ja klar, Compatibility war drauf.

2) Hab mir auch gedacht, dass es an den Rechten liegt. Die Anleitung hier im Forum sagt dazu nichts und empfiehlt auch noch Notepad++. Die sollte mal überarbeitet werden.

3) Konntest du schon testen?



Mein Erfahrungen mit CyanBook v4:

Ich hab die build.prop Einstellungen wie beschrieben benutzt und zusätzlich die App "Pimp my Rom", mit der man noch einige andere Tweaks machen kann. KSM ist aktiviert, Zram deaktiviert. Governer: Interactive, I/O Scheduler habe ich auf Noob gestellt, das soll lt. Foren die beste Leistung bringen. Der Prozessor lässt sich unter den Einstellungen nicht richtig übertakten. Man kann da zwar höhere Werte einstellen, aber nach ein paar Neustarts stellt sich der Max-Wert immer wieder auf 1008 MHz zurück. Ich hatte keine Lust da jetzt noch mehr Zeit zu investieren, das Gerät ist für meine Mutter, es soll eher stabil als nur schnell sein. Performance ist jetzt ziemlich gut, alles flutsch, spürbar besser als ohne die Tweaks, ich habe aber auch nur 10 Apps installiert. Ich kann keinem empfehlen bei 512 MB RAM die Kiste bis oben zu zu ballern, eher ein paar Apps weniger, dann bleibt der Frust beim Bedienen auch aus.

Wer doch sehr viele Apps installiert, dem "empfehle" ich unter den Entwickleroptionen die Zahl der Hintergrundanwendungen auf 4 einzuschränken, danach rennt die Kiste wieder. Empfehlen in Anführungszeichen, weil dann z. B. der Skype Hintergrunddienst auch sehr schnell vom System beendet wird und man dann nicht mehr erreichbar ist. Kommt also auch darauf an, welche Anwendungen ihr benutzt. Ausserdem geht die Einstellung nach jedem Neustart verloren, aber in irgendeiner Config kann man das bestimmt auch fest einstellen.

Im Standby (Wlan schaltet nach 15 Minuten ab) hab ich über Nacht (22 Uhr bis 11:30) gerade mal 3 % Akku verbraucht.
EDIT: Das Gerät hing, nach einem Neustart ist der Akku auf 15 %, letzte Nacht war er auf 52 %. Ich halte das mal im Auge.

Er findet das WLAN nach dem Aufwecken aus dem Standby innerhalb von 10 Sekunden, ich halte das jetzt erstmal für einen guten Wert.

Probleme sind nach wie vor das Problem mit der Autorotation und das Videos schwarz bleiben bzw. Youtube App abschmiert.
 
Zuletzt bearbeitet: