adb ohne bootendes System?

  • 70 Antworten
  • Neuester Beitrag
Diskutiere adb ohne bootendes System? im Root / Hacking / Modding für Motorola Milestone im Bereich Motorola Milestone Forum.
Compufreak

Compufreak

Erfahrenes Mitglied
Archer schrieb:
Hattest du USB-Debugging vor der Tragödie an? Wenn ja, sagt "adb logcat" genau, was das Problem ist (damit du nicht so ganz im Blindflug bist)?
Das Problem ist ja, dass ich adb nicht zum laufen kriege... "error:device not found"..
Und USB Debugging war vorher an.
 
Archer

Archer

Erfahrenes Mitglied
Hmm, die Gestures.APK ist ~ 220kB groß

Wenn du das APK auf die SD-Karte bekommst, kann dir das root-team vielleicht ein update.zip geben, dass das APK nach system/app kopiert...

Auf die SD-bekommst du das APK z. B. über dein Galaxy. Und das update.zip muss das "cp" binary (z. B. das standard toolbox umbenannt in "cp") drin haben,

dann "run_program PACKAGE:bin/cp /sdcard/Gestures.apk /system/bin/" rein und dann sollte es wieder gehen, wenn es daran lag...
 
Archer

Archer

Erfahrenes Mitglied
Dein Problem ist ja noch größer :rolleyes:

Durch ein "Install Theme" werden die APKs ersetzt, die Frameworks angepasst - du müsstest dir quasi das gesamte ROM auf die SD packen :eek:
 
P

pha3ton

Fortgeschrittenes Mitglied
macht ja nichts! wäre kein Problem, die karte ist ja groß genug :)
Aber ich verstehe nicht warum das nicht geklappt hat! Wahrscheinlich auch nur wieder ein Tool fürs Droid.....
 
Archer

Archer

Erfahrenes Mitglied
Beim Installieren von Themes werden APKs, jars etc. pp. ausgewechselt. Wenn die Versionen nich zu deinem Telefon/ ROM passen, dann... kaput.
 
P

pha3ton

Fortgeschrittenes Mitglied
na hoffentlich kann ich dass dann mit einen kompletten Rom wieder herstellen.
Müsste doch eigentlich möglich sein ein komplettes Rom zu erhalten, oder
 
W

winni2001

Ambitioniertes Mitglied
... mmm ich schließe mich dann mal hier an.... ;-)

Wollte VPN zum laufen bringen und habe anhand von div. Anleitungen für das Droid 2 Dateien im ordner /system/lib durch andere ersetzt.
Jetzt habe ich die gleichen Syntome.

Da die originalen libs aber noch im System sind (habe diese vorher umbenannt), sollte eine solche neue update.zip recht einfach zu erstellen sein - oder?

Bei mir müßten in etwa die folgenden Befehle ausgeführt werden, um die zusätzlichen libs zu löschen und um die beiden originalen wieder umzubenennen:

run_program PACKAGE:bin/rm /system/lib/libcrypto.so;
run_program PACKAGE:bin/rm /system/lib/liblzo.so;
run_program PACKAGE:bin/rm /system/lib/libssl.so;
run_program PACKAGE:bin/rm /system/bin/openvpn;
run_program PACKAGE:bin/cp /system/lib/libcrypto-orig.so system/lib/libcrypto.so;
run_program PACKAGE:bin/cp /system/lib/libssl-orig.so system/lib/libssl.so;

Kann ich das so einfach mal versuchen oder gibt es beim zusammenpacken der update.zip noch was anderes zu beachen?

Müßte mir zuerst eh noch nen Cardreader für die sdcard besorgen.

Bin für Feedback gerne dankbar!
 
Archer

Archer

Erfahrenes Mitglied
Eher
run_program PACKAGE:bin/cp /sdcard/lib/libcrypto.so system/lib/libcrypto.so

Außerdem müssen dann noch die Berechtigungen und so gesetzt werden - das ist ein echt echt anstrengendes Unterfangen...
 
W

winni2001

Ambitioniertes Mitglied
mmm - die berechtigungen sollten noch stimmen, da die dateien zuvor ja auch nur umbenannt wurden. und qulle ist nicht die sdcard, sondern wirklich der origianl-ordner /system/lib
 
Archer

Archer

Erfahrenes Mitglied
Ah, okay, ich hatte nicht verstanden, dass du sie an Ort und stelle gelassen hattest. In diesem Falle hast du Recht. Ich drücke einfach die Daumen, dass das angedeutete Tool bald kommt, um eigene "Exploit Files" zu erstellen!
 
geminga

geminga

Dauergast
Compufreak schrieb:
Das Problem ist ja, dass ich adb nicht zum laufen kriege... "error:device not found"..
Und USB Debugging war vorher an.
Kabel raus und wieder rein, 10 sec. warten, dann adb remount...
 
Archer

Archer

Erfahrenes Mitglied
Poor man's recovery (Idee):

Ein shellscript, das diese Dateien von der SD-Karte nimmt und kopiert... Müsste machbar sein.
 
W

winni2001

Ambitioniertes Mitglied
Das ist echt super lieb von Dir!
Das könnte eine gute Möglichkeit sein, das system wieder herzustellen, wenn der übereifrige Spieltrieb zu weit ging (so wie bei mir).
Wenn dann noch jemand beim Erstellen der update.zip hilft oder sich damit auskennt, wäre super.
Werde mir morgen sofort mal nen sd-cardreader holen und die mal mit der von mir vorhin geposteten version versuchen meine Fehler zu reparieren. Wenn das geht, dann sollte es auch möglich sein das komplette System mit Hilfe Deiner Liste zu retten.
 
Zuletzt bearbeitet:
Archer

Archer

Erfahrenes Mitglied
Hmm… habe ich auch schon festgestellt ;)

Ich kann schon ein wenig Erfahrung vom Galaxy mitbringen (was update scripts und das System angeht). Vielleicht bekommen die root truppe und ich ja was hin… Ich werde mich heute Morgen mal mit den Jungs in Verbindung setzen.
 
Compufreak

Compufreak

Erfahrenes Mitglied
So langsam werden's ja einige ^^
Ich glaube bei mir ist wahrscheinlich auch das Problem, dass ich den Wipe gemacht und damit meinen Debugmodus deaktiviert habe .-.

Na hoffen wir mal, dass bald ein Tool für die Update.zip kommt...

Und ich drück die Daumen, dass ihr Erfolg habt @Archer.
 
Zuletzt bearbeitet:
Archer

Archer

Erfahrenes Mitglied
Wenn das Tool kommt, bin ich der Erste, der an poor man's recovery sitzt ;) man will ja versichert sein :p
 
Spacefish

Spacefish

Ambitioniertes Mitglied
habt ihr mal dran gedacht Euch nen dump von der ganzen mtd6 von SDKarte über Exploit einfach mit dd einzuspielen b.z.w. mit flash_image? Müsst beachten das die mtd benamsung im reovery mode anders ist!

Hab damit mein recoverysystem schonmal mit sp recovery beschrieben und danach wieder auf das ursprüngliche recovery zurückgeschrieben aus einem eigenen backup das ich mit cat /dev/mtd/mtd4 > /sdcard/mtd4.img erstellt hatte.

Das Updatezip scheint ja nicht sooo schwer zusammen zu bauen sein und man müsste ja eigentlich auch nen script von der sdkarte ausführen können durch den update.zip exploit. Mit dem Script könnte man dann über flash_image den dump einspielen b.z.w. einfach reincaten mit ner pipe geht ja evtl au.
 
Zuletzt bearbeitet: