[FIX] GPS Fix

  • 101 Antworten
  • Neuester Beitrag
Diskutiere [FIX] GPS Fix im Root / Hacking / Modding für Samsung Galaxy S im Bereich Samsung Galaxy S (I9000) Forum.
K

kingjezdi

Erfahrenes Mitglied
ok^^
und wie ersetz ich das bzw. wo find ich den gps ordner?
 
Ralf W.

Ralf W.

Ambitioniertes Mitglied
Hallo,

habe gerade den GPS-Fix aus CM 10.2 unter SuperNexus #4 ausprobiert. Es werden zwar mehr Satelliten gefunden, aber der Fix dauert ewig. Habe es deshalb wieder deinstalliert.

Der ursprüngliche Beitrag von 14:11 Uhr wurde um 14:15 Uhr ergänzt:

kingjezdi schrieb:
ok^^
und wie ersetz ich das bzw. wo find ich den gps ordner?
Hi,

wo die Dateien hin gehören ist doch beschrieben. Für die Installation benutze ich "adb". Es sollte auch ein Dateiexplorer unter Android gehen, der die Partition "/system" von "ro" auf "rw" umstellen kann.
 
pLAUBi

pLAUBi

Stammgast
Wer diese Basics nicht beherrscht sollte es besser lassen.
 
K

kingjezdi

Erfahrenes Mitglied
ja aber nicht genau wie, von daher..
tja dann erklärs halt, sind nicht nur nerds wie du hier unterwegs ;)
 
pLAUBi

pLAUBi

Stammgast
Kennst du den Begriff Eigeninitiative? Alles was du brauchst findest du bei Google.
Hast du explizite fragen kannst du gerne fragen, aber die Anleitung aus meinem ersten post sollte eigentlich ausreichen.

Kleiner tip: du musst 'nur' die Dateien ersetzen und brauchst dafür root.

Gesendet von meinem GT-I9000 mit Tapatalk 2
 
orangerot.

orangerot.

Experte
Kleine Anmerkung :D
Reboot ist nötig, damit alles neu initialisiert wird. Ohne reboot hat es keinen Effekt.
 
S

Sigi43

Stammgast
ich werde das auch teste, wenn ich wieder zu Hause bin.

Ich hatte aber schon eine wesentliche verbesserung durch Umstellung auf CM9.
Besonders war, dass nach finder der Satelliten auch gleich die Daten drauf waren.
Oder da sind schon diese dateien drin.
 
E

eiscremeburger

Fortgeschrittenes Mitglied
Der beste Fix, ändert aber leider nichts an der Tatsache, dass die Antenne des sgs Hundsmiserabel ist. Ein zuverlässiges GPS Signal ist jedenfalls nicht möglich... Die Verbesserung kann ich aber bestätigen.
 
D

durd3n

Neues Mitglied
pLAUBi schrieb:
Am besten wäre es, wenn hier jemand über Verbesserungen/Verschlechterungen berichten würde!
Hey

Ich hab die inoffizielle 4.3 seit einer Woche am Laufen (CM 10.2 http://http://forum.xda-developers.com/showthread.php?t=2385178).
Ich würde sagen es ist mit 2.3.6 ebenbürtig gut und deutlich besser als cm10.1. Da der ganze GPS-Kram aus dem Release zu stammen scheint kann ich es jedem CM Nutzer nur empfehlen :thumbup:

Oder gleich ein ganzes Update. Das SGS läuft seither durchweg stabil und 4.x macht echt Spaß ;)

d3n
 
Ralf W.

Ralf W.

Ambitioniertes Mitglied
Der GPS-Fix aus CM ist ja doch geil. Mein erster Versuch war nicht von Erfolg gekrönt (sh. oben / Fix mit SuperNexus #4).

Der Fehler war, dass ich einen GPS-Fix installiert hatte. Habe mir die /etc/gps.conf aus CM10.2 angesehen und meine wie folgt geändert:
NTP_SERVER=de.pool.ntp.org
XTRA_SERVER_1=http://xtra1.gpsonextra.net/xtra.bin
XTRA_SERVER_2=http://xtra2.gpsonextra.net/xtra.bin
XTRA_SERVER_3=http://xtra3.gpsonextra.net/xtra.bin
SUPL_HOST=supl.google.com
SUPL_PORT=7276

Nach dem reboot hat mir jemand auf wundersame Weise einen neuen GPS-Chip eingebaut. In der Wohnung Fix in 4 Sekunden und 8 Satelliten. Da war vorher nichts. Am Fenster mit GPS-Test zum ersten mal einen Satelliten mit 40 gehabt. Ich bin begeistert ...
 
S

Schoof0815

Fortgeschrittenes Mitglied
hab mal den Fix aus Post #78 installiert. Hab Helly Bean 4.2.2 drauf.
Sieht besser aus als vorher (mit GPS Test getestet).
Genaues kann ich aber erst nach WE sagen, den ich habe immer 2 GPS-Verbindungsabbrüche auf meiner Laufstrecke gehabt. Laufen geh ich erst wieder am Fr oder Sa.

Was ich noch gemacht habe:
die 2 Kontakte an der GPS Antenne mit dem Lötkolben eine dünne Zinnschicht aufgetragen und bei dem Federkontakt auf der Platine ein Stück Draht rein geschoben.
Vorher hab ich auch mal die Antenne durch eine Litze ausgetauscht. Wenn ich die Litze aus dem Handy baumeln liess, hatte ich die 2 Verbindungsabbrüchenicht nicht. War sie aber im Gehäuse, hatte ich wieder schlechte Werte.

Ich melde mich wieder
 
S

Schoof0815

Fortgeschrittenes Mitglied
so nun bin ich laufen gegangen.
an den 2 Punkte wo ich sonst kurze GPS aussetzer hatte, hatte ich keine. Dafür an einem anderen Punkt :cursing:
Ich hab dann gleich GPSTest angeschmiessen. Ich hatte 4 Sat mit über 30 aber keinen Fix und das ca 1min lang. Insgesammt waren es 12 Sat.
Auch wenn ich bei mir im Garten hock, GPSTest aktiveren bekomme ich nach ca 30sec 8-10 Sat + Fix. Ich selber bewege mich nicht und auch das Handy halte ich in der Hand, aber der Fix zu den Sat wechseln oft und manchmal hab ich dann komplett den Fix wieder verloren.
Also ka was da geht mit dem GPS
 
tobiasth

tobiasth

Guru
Ironie an
Zum Glück stehen die Satelliten ja auch immer an der selben Position und bewegen sich nie! :D
Ironie aus

Das SGS ist nun mal schlecht was den GPS Empfang betrifft, da hilft einfach nix. Ich kann gut den Vergleich mit dem S4 ziehen, welches sofort mind. 10 Satelliten findet, sogar in der Wohnung ... da kann das S1 einfach nicht mithalten.
Abbrüche während des Tracken's hatte ich bisher auch keine (bei derzeit etwa 500km mit dem Radl).
 
S

Schoof0815

Fortgeschrittenes Mitglied
hab gestern noch mein Samsung Ace mit CM7.2 geflasht und mal das GPS probiert.
Parallel mit S1 hab ich GPSTest gestartet. Ace hatte innerhalb 5-6 sek nen fix, S1 nicht mal 1 sat. Dauerte ca 10sec bis S1 nen sat hatte und weitere 15-20sec für den fix. Kurze Zeit später verlor das S1 wieder den fix für ca5 sec. Das Ace "stand" wie ne 1.
Von den Signalstärken her, war das S1 bisl schlechter als das Ace, aber ich glaub nicht mehr an einen HW Fehler sondern eher in Richtung SW.
Denn es verliert einfach das Signal, ohne das die Werte sich groß verschlechtern.
Wie beim laufen wo ich 4 Sat über Wert 30 hatte und keinen fix.

Doof Doof, sonst ist es ein tolles Handy und voll ausreichend für mich.
 
tobiasth

tobiasth

Guru
Es ist einfach ein schlechter GPS Empfänger verbaut, da kann die Software nichts für.
 
D

durd3n

Neues Mitglied
tobiasth schrieb:
Es ist einfach ein schlechter GPS Empfänger verbaut, da kann die Software nichts für.
Das ist richtig aber man kann das Maximum rausholen.

@Schoof0815
Versuche mal von 3G auf 2G zu wechseln. Ansonsten hilft dir evtl. ein Durchprobieren anderer Modems.
 
S

Schoof0815

Fortgeschrittenes Mitglied
hab gestern die Helly 4.3 drauf geflasht. Mir kommt es so vor als ob jemand den GPS empfänger getauscht hat. Innerhalb 5 sec hatte ich nen Fix auf 5 Sats und kurze Zeit später 10/10. Auch waren 3-4 Sat an/über 40. Keine Verbindungsprobleme. Auch als ich ins Haus ging hatte ich immer noch zu 2 Sat nen Fix und keine Aussetzer.

Da ich zur Zeit nicht laufen gehe, kann ich es leider nicht mit meiner Laufstrecke testen. Vielleicht raf ich mich mal am WE auf.
 
S

Schoof0815

Fortgeschrittenes Mitglied
bin am Samstag nun meine Strecke gelaufen.
Ich hatte 2 kurze Aussetzer des GPS Signals (ca für 5sec).
Besser ist es nun mit 4.3 auf jedenfall.

Ich habe aber noch einen TomTom GPS Empfänger gefunden. Diesen habe ich über BT mit meinem Handy gekoppelt, aber Endomondo oder GPS Status finden kein GPS. Muss ich was umstellen damit die Programme über BT GPS empfangen oder wie geht das?
 
S

Schoof0815

Fortgeschrittenes Mitglied
die hab ich inst. und gestartet, connected und die Sat so gesehen wie auf den Bildern. Dann Endomondo gestartet, kein GPS Signal......
Komisch. Ich probiers heute Abend nochmal.