Tasten defekt, Software update

  • 17 Antworten
  • Neuester Beitrag
Diskutiere Tasten defekt, Software update im Root / Hacking / Modding für Samsung Galaxy S2 im Bereich Samsung Galaxy S2 (I9100) Forum.
RJJ

RJJ

Fortgeschrittenes Mitglied
Guten Tag,

Ich habe ein S2 I9100. Ich möchte nicht unnötige Sachen schreiben, deswegen komme ich direkt zu den Fakten:

Ich habe die Stock-Rom 4.1.2 (XXLS8) drauf.
Mit dieser Rom funktioniert das Gerät völlig normal ohne Probleme.

Wenn ich aber eine Custom Rom Flashen möchte, egal welche, tritt immer dasselbe Problem auf.

Zuerst roote ich das Gerät mit Philz-CWM-Datei (weiß nicht genau wie die heißt).
Danach mache einen Fullwipe und installiere die Custom-Rom.
Anschließend mache ich nochmal wipe data/factory reset und wipe cache sowie wipe dalvik cache.

Die Rom startet und bootet auch zunächst, bis es in der Starteinrichtung oder 1-2 Sekunden danach hängen bleibt und rebootet. Das Gerät wird auch deutlich wärmer in der Kameraregion, weshalb ich es Sicherheitshalber ausschalte nach 3-4 reboots.

Ich habe sowohl die Nightmare Rom als auch die Jelly-Bam Rom ausprobiert.
Kein Erfolg. Bei der Nightmare Rom habe ich auch einen anderen Kernel genommen, selbes Phänomen.

Ich weiß nicht, woran das liegt und weiß mir auch nicht mehr weiter zu helfen.
Ich hoffe, dass mir hier jemand helfen kann.

MFG
 
beicuxhaven

beicuxhaven

Ehrenmitglied
Welchen Kernel bei der Stock LS8 hattest du drauf und wie hast du geflasht?
Ach sorry steht ja schon da...

Der ursprüngliche Beitrag von 11:39 Uhr wurde um 11:43 Uhr ergänzt:

Nimm mal dieses Script: Script zum WIPEN
Da nimmst du die NUKE Variante. Vorher die neue CR aufs Handy packen!
Also Nuke ausführen, nicht neu booten oder so, sondern danach gleich die ROM flashen...

Wenn du dich an die Anleitungen in den ROM Threads gehalten hast, dürften diese Probleme nicht auftreten. Es sei denn deine Downloaddateien sind defekt. Also vielleicht auch mal neu runter laden.
 
RJJ

RJJ

Fortgeschrittenes Mitglied
Musste leider aufgrund eines Notfalls verreisen und bin erst jetzt wieder da.
Leider hat das Nuke-Script auch nicht geholfen.

Mit der Stock-Firmware habe ich keine Probleme. Aber egal was ich versuche, mit der Custom Rom habe ich dauerhaft Reboots. Kann das Gerät maximal 30 Sekunden ohne Reboot bedienen. Ich vermute, dass eine App den Crash verursacht, weiß es aber nicht genau und weiß auch nicht was ich machen kann/soll.

Es klappt bisher nichts.
 
beicuxhaven

beicuxhaven

Ehrenmitglied
Wenn du das Nuke-Script genutzt hättest, hast du kein ROM mehr drauf. Also hast du es wohl nicht genutzt. Weil danach musst du zwingend erst mal ein ROM installieren, worin nur die normalen Apps enthalten sind.:thumbdn:
 
RJJ

RJJ

Fortgeschrittenes Mitglied
Wie jetzt?

Ich habe das Nuke-Script genutzt und dann die Nightmare-Rom geflashed.
Was meinst du denn mit einer Rom wo nur normale Apps enthalten sind?
Kannst du mir mal eine Rom geben welche ich nach dem Nuke-Script flashen soll?
Wenn es CM 10.1 ist, habe ich schon versucht, selbes Ergebnis.
 
beicuxhaven

beicuxhaven

Ehrenmitglied
Das bedeutet, du hast das Nuke-Script genutzt, flasht eine ROM und hast dann sofort nach dem Neustart Probleme?
Wenn du nur Probleme mit CM hast, dann solltest du dort nachfragen. Hast du dich an die Anleitung der ROM in Post 1 gehalten?
 
RJJ

RJJ

Fortgeschrittenes Mitglied
Ich kann die Starteinrichtung manchmal komplett beenden und habe dann in ein paar Sekunden einen Reboot oder schon während der Einrichtung.

Mit einer Stock-Rom passiert mir das nicht. Ich komme aus dem S1-Bereich und bin eigentlich ein erfahrener Flasher, da ich mit dem S1 kaum Probleme hatte.
Die Vorgänge sind ja nahezu identisch, doch trotzdem habe ich mir mehrere Anleitungen aus verschiedenen Quellen angesehen. Ich weiß ehrlich nicht, wieso das passiert.

Nachdem Nuke-Script installiere ich zB sofort ohne Neustart CM 10.1 ohne und mit GAPPS, selbes Ergebnis. Kriege immer Reboots nachdem das Gerät kurz gestartet hat.
 
beicuxhaven

beicuxhaven

Ehrenmitglied
Das ist neu, also ich meine davon habe ich noch nie gehört. Du hast ein S2 oder 2G?

Der ursprüngliche Beitrag von 13:45 Uhr wurde um 13:46 Uhr ergänzt:

Sorry wegen der Frage, aber sonst kann ich mir keinen Grund vorstellen..
 
RJJ

RJJ

Fortgeschrittenes Mitglied
Unter dem Akku-Deckel:

Model: GT-I9100
SSN: I9100GSMH
FCC ID: A3LGTI9100
 
beicuxhaven

beicuxhaven

Ehrenmitglied
Das ist def. ein S2
 
RJJ

RJJ

Fortgeschrittenes Mitglied
Wie schon erwähnt komischerweise habe ich mit der Stock-Rom keine Probleme.
Ich brauche aber eine Custom-Rom, weil bei mir die zurück und Menü-Tasten nicht funktionieren. Deshalb muss ich eine Firmware mit Navbar flashen.

Es klappt aber leider nichts.
 
Zuletzt bearbeitet von einem Moderator:
RJJ

RJJ

Fortgeschrittenes Mitglied
Das kann man natürlich nicht ausschließen, dürfte aber eigentlich nicht daran liegen, denke ich. Bevor ich mir das Ersatzteil bestelle, könnte mir vielleicht jemand ein Nandroid-Backup zukommen lassen mit einer 4.2.2 Custom Rom am besten Clean? Oder weiß jemand wo ich so etwas finden kann?

Vielleicht würde es per Nandroid-Backup ja klappen. Und wenn nicht, muss ich mir das Ersatzteil bestellen und selbst einbauen oder einbauen lassen.

Und/oder weiß jemand wie ich eine Navigationsleiste bekommen kann wie bei Paranoid Android ohne eine Custom-Rom flashen zu müssen? Mein Gerät ist gerootet, dass stellt keine Probleme dar.
 
Zuletzt bearbeitet:
RJJ

RJJ

Fortgeschrittenes Mitglied
Habe gerade die Tasten wieder hinbekommen.
Wo lag der Fehler?
Ich habe die Touch-Key Firmware geupdatet.
Aber egal wo ich geschaut habe wurde folgender Code dafür
erwãhnt: *#*#2663*#*# dieser Code ist falsch und geht nicht.
Der richtige Code den ich aus Zufall selbst entdeckt habe lautet:
*#2663#* hier habe ich mit Wlan Verbindung und eingelegter Sim-Karte
Ein Update und anschliessend ein Reboot durchgeführt.
Die Tasten funktionieren nun tadellos.

Nun werde ich mal wieder eine Custom Rom aufspielen und danach berichten
ob es klappt.

MFG
 
beicuxhaven

beicuxhaven

Ehrenmitglied
Ich habe nun den Titel angepasst, da das vielleicht für viele andere auch interessant ist.
 
RJJ

RJJ

Fortgeschrittenes Mitglied
So Custom-Roms funktionieren nun problemlos.
Es lag also anscheinend an den Touch-Keys, die aufgrund des originalen JellyBean Updates plötzlich nicht mehr funktionierten und geupdatet werden mussten.
 
K

kevin919191

Neues Mitglied
Hallo erstmal

Habe so ziemlich den selben Fehler.

Habe einen neuen Display gekauft (koplett muste nur noch die bauteile wieder einfügen).
Hab ihn auch schon eingebaut funktioniert alles tadellos auser die tuchknöpfe. Selbst die home taste funkioniert und die hängt ja mit an den construkt.
Den code von oben habe ich auch schon probiert.Der Eine geht nicht, und beim anderren habe ich jedes update 1 mal probiert.Funtionier denoch nicht.
Hat noch jemand eine idee?