Abstandssensor reagiert nicht mehr

  • 81 Antworten
  • Neuester Beitrag
Diskutiere Abstandssensor reagiert nicht mehr im Samsung Galaxy (I7500) Forum im Bereich Weitere Samsung Geräte.
gonz81

gonz81

Erfahrenes Mitglied
Hallo!

Ich kann mich doch grau entsinnen, dass das Galaxy einen Abstandssensor neben der Hörmuschel hat, der dafür sorgt, dass das Display beim Dranhalten ans ohr aus ist und beim Weghalten wieder an geht. Das funktioniert auch, aber jetzt komischerweise nicht mehr. Es bleibt bis zum Timeout an und ich muss es durch drücken einer Taste wieder aufwecken, wenn ich bspw. etwas eintippen möchte.

Woher kommt das? ist der fehler bekannt? Vielleicht ist dafür ja ein Prozess verantwortlich, der nicht mehr funktioniert. Oder gibt es da eine Einstellung, die ich nicht finde?

ich weiß nicht, ob ich lust habe, einen Reset des gerätes durchzuführen.
 
Z

zeebee

Stammgast
Bei den aktuellen Firmwares ist noch einiges im Argen. Anfangs hatte ich lauter Abstürze, nach dem Update lauter Reboots und Probleme mit dem Locken/Entlocken. Und seit gestern benimmt sich das Handy, als habe es die "Stable"-Version erreicht: keine Abstürze, Reboots oder Fehler. Was ich sagen will: sehr schwer zu sagen woran es liegt. Wenn ein (oder gleich mehrere) Neustarts nichts bringen, hilft wohl nur systemeingreifende Apps zu deinstallieren und schauen ob es sich bessert - oder eben ein komplettes Reset.

Ich wusste gar nicht, dass da ein Abstandssensor ist. Ich dachte das wird mit dem Lagesensor abgefragt in welcher Position sich das Galaxy befindet (und evtl. der Lichtsensor?).
 
V

Vincenco

Fortgeschrittenes Mitglied
Was der gonz81 meint ist sicherlich der Lichtsensor. Aber er reagiert ja wie ein Abstandssensor. Abstand gering -> Lichtsensor dunkel :o
 
gonz81

gonz81

Erfahrenes Mitglied
Mitnichten, check mal die technische Dokumentation, dann wirst Du feststellen, dass das Galaxy einen Abstandssensor hat, wie auch das iPhone. Wie soll das denn sonst nachts funktionieren? Neben der Hörmuschel sind zwei öffnungen, einmal Licht- und einmal Abstandssensor.

Erschwerend hab ich grade festgestellt, dass durch diesen Fehler das Handy nicht mehr weiß, ob das Handy grade am Ohr ist oder nicht und ich deswegen während dem Telefonat den Touchscreen nicht mehr bedienen kann. Macht solche Aufforderungen wie "Drücken Sie die Sterntaste" echt schwierig.

Gerade bei O2 angerufen wegen Gewährleistung: Die hätten mir allen ernstes die Garantie verweigert, wenn ich auf die Frage nach der benutzung herstellerfremden Zubehörs mit "ja" geantwortet hätte. Zum Glück war die Agentin gut drauf und hat mich darüber informiert. :) Da wurde mein hama-KFZ-Ladekabel mal eben totgeschwiegen :) Ansonten hätte ich ihr das BGB um die Ohren hauen müssen, den Unterschied zwischen Mängelgewährleistung und Garantie und bla bla... nein danke, das hab ich grad mit dem Auto alles durch, und letztendlich gewonnen :-D
 
Thyrion

Thyrion

Ehrenmitglied
Ist ein PC ein herstellerfremdes Zubehör (hängt ja immerhin an dem samsungeigenen USB-Kabel)... :rolleyes: :D

Ontopic: Hat jemand irgendwelche Erfahrungswerte, ob die Samsung-Folie (die ja nicht wirklich 100% passgenau geklebt ist (bei mir linke Seite und oben - man soll sie ja auch abbekommen) den Licht/Abstandssensor beeinflußt?
 
gonz81

gonz81

Erfahrenes Mitglied
bei mir funktionierte der sensor auch mit der folie gut
 
dj_ecr

dj_ecr

Fortgeschrittenes Mitglied
Thyrion schrieb:
Ist ein PC ein herstellerfremdes Zubehör (hängt ja immerhin an dem samsungeigenen USB-Kabel)... :rolleyes: :D

Ontopic: Hat jemand irgendwelche Erfahrungswerte, ob die Samsung-Folie (die ja nicht wirklich 100% passgenau geklebt ist (bei mir linke Seite und oben - man soll sie ja auch abbekommen) den Licht/Abstandssensor beeinflußt?
Die SIM ist doch auch nicht von Samsung hergestellt :p

Joa die Folie stört keinen der Sensoren, allerdings hab ich meine oben auch seit einigen Tagen absolut fest drauf... viel langes drücken hat geholfen :)
 
J

juiced

Neues Mitglied
Hallo Zusammen,

würde das Thema gerne nochmal aufgreifen, vielleicht hat jemand ähnliche Probleme und bestenfalls auch eine Lösung parat.

Auch bei meinem Galaxy scheint der Abstandssensor nicht mehr zu funktionieren. Jedenfalls geht das Display nicht aus, wenn ich den Sensor beim Telefonieren mit der Hand oder meinem Ohr verdecke.

Hat einer Ähnliches beobachtet?

BTW: Was für eine Lichtquelle verwendet der Sensor? Kann man mit einer Kamera testen, ob er funktioniert? Vielleicht kann das mal einer probieren. Geht ja schließlich wunderbar mit Infrarot-Sendern (Fernbedienung...)

Viele Grüße,

juiced
 
N

njagulo

Fortgeschrittenes Mitglied
Bei mir funktioniert der Abstandsensor seit dem letzten Update (neuste Firmware) auch nicht mehr.
So ist das halt mit dem Galaxy: mit jeder neuen Firmware wird etwas korrigiert und wiederum etwas auch kaputt gemacht. ;)
 
S

sagdoch

Ambitioniertes Mitglied
Meiner geht auch nicht...
neustes update drauf. Früher ging der auf jeden fall

Ne ne

Gruß andreas
 
gonz81

gonz81

Erfahrenes Mitglied
Kurzes update:
Mein Abstandssensor war nicht kaputt, sondern "verstopft". Das Update war nur zufällig zum gleichen zeitpunkt - bzw fällt einem das ja nicht sofort auf! Scheinbar ist der Spalt zwischen der Glaskante und dem Plastikrahmen das perfekte Schlupfloch für Fussel Staubpartikel. ich hab Galaxy geöffnet, den Sensor und das Displayglas an dieser Stelle mit einem Qtip gereinigt und zack, ging er wieder! Allerdings nur 3 Wochen lang, dann war er wieder zugefusselt. Hab ihn wieder gereinigt und er geht grade wieder.

Ich will das nicht einmal im monat machen müssen. beim nächsten mal überlege ich mir eine lösung mit einer flüssigdichtung.
 
dupi

dupi

Stammgast
gonz81 schrieb:
Kurzes update:
Mein Abstandssensor war nicht kaputt, sondern "verstopft". Das Update war nur zufällig zum gleichen zeitpunkt - bzw fällt einem das ja nicht sofort auf! Scheinbar ist der Spalt zwischen der Glaskante und dem Plastikrahmen das perfekte Schlupfloch für Fussel Staubpartikel. ich hab Galaxy geöffnet, den Sensor und das Displayglas an dieser Stelle mit einem Qtip gereinigt und zack, ging er wieder! Allerdings nur 3 Wochen lang, dann war er wieder zugefusselt. Hab ihn wieder gereinigt und er geht grade wieder.

Ich will das nicht einmal im monat machen müssen. beim nächsten mal überlege ich mir eine lösung mit einer flüssigdichtung.
Wie soll man das Verstehen, hast du dein Galaxy komplett zerlegt, auseinander geschraubt?
 
gonz81

gonz81

Erfahrenes Mitglied
Naja schon, aber nicht komplett.
Du schraubst die 6 kleinen Kreuzschlitzschrauben auf der Rückseite raus und fängst dann von oben am USB-Anschluss an, mit einem kleinen Plastikkeil oder ähnlichem die Clipse zwischen Ober- und Unterschale zu öffnen. Es reicht wenn sie bis zu den Tasten geöffnet sind, Wenn Du es dann oben etwas auseinanderbiegst kommt man an den holraum ran, in dem der sensor steckt.

Es sind übrigens keine Siegel oder Sicherungsschrauben. Wenn man im Inneren nicht gerade Fingerabdrücke hinterlässt kann man diesen Vorgang wohl nicht nachvollziehen.

Es gibt auch nur weniger lockere Teile, die man verlieren könnte: die Tasten an der Seite, was aber auch kein Problem wäre, die wieder zu platzieren und der Chromring um den Kopfhöreranschluss, der wäre etwas fummelig wieder zu platzieren, aber nicht schwierig. Man muss nur drauf achten.
 
S

sagdoch

Ambitioniertes Mitglied
ach man,
das ist ja unglaublich!
einfach nur neeeee!
naja, da muss man wohl durch! probiere das erstamla rauszupüstern...

andreas.
 
bedor

bedor

Stammgast
oh man.. bei mir funzt der sensor auch nicht mehr... übel.. hilft "in den spalt pusten"? will mein galaxy nicht zerlegen...

grüße, bedor
 
S

sagdoch

Ambitioniertes Mitglied
also mit den softwarebugs kann ich noch etwas leben mit, da dort aussichten auf besserung, durch ein update erfolgen, aber das......regt mich wirklich auf!
 
gonz81

gonz81

Erfahrenes Mitglied
bedor schrieb:
oh man.. bei mir funzt der sensor auch nicht mehr... übel.. hilft "in den spalt pusten"? will mein galaxy nicht zerlegen...

grüße, bedor
Das bringt nichts, ich habs vor dem Zerlegen auch mit ner besonders feinen Haarbürste für Babys versucht. Aber außer dass Du die Fussel hin uns her bewegst passiert da nix. Raus bekommt man die auf keine andere Art und Weise als das Öffnen.
 
N

njagulo

Fortgeschrittenes Mitglied
Dass die Fussel der Grund für die Probleme mit dem Abstandssensor sind, das glaube ich überhaupt nicht. Denn dann sollte kein Licht auf den Sensor gelangen (sprich, der Sensor registriert immer kein Licht) und dann sollte das Display beim Gespräch immer abgedunkelt werden. Das ist jedoch bei mir definitiv nicht der Fall. Display bleibt die ganze Zeit an. Bei den meisten von euch sollte es genauso sein, oder?
 
gonz81

gonz81

Erfahrenes Mitglied
njagulo schrieb:
Dass die Fussel der Grund für die Probleme mit dem Abstandssensor sind, das glaube ich überhaupt nicht. Denn dann sollte kein Licht auf den Sensor gelangen (sprich, der Sensor registriert immer kein Licht) und dann sollte das Display beim Gespräch immer abgedunkelt werden. Das ist jedoch bei mir definitiv nicht der Fall. Display bleibt die ganze Zeit an. Bei den meisten von euch sollte es genauso sein, oder?
Du hast vollkommen recht, ich bilde mir das Verhalten meines Telefons scheinbar nur ein. Dass es gleich nachdem ich einen Klumpen Fussel aus dem Telefon operiert habe wieder ging ist nur Zufall, sollte jedem klar sein.

BTW: Während der "Defekt" bei mir akut war, reagiert das Display beim Telefonieren scheinbar willkürlich auf drei Arten:

- Display immer aus, geht bei Tastendruck an und reagiert dann auch auf Touch
- Display immer aus, geht bei Tastendruck an und reagiert nicht auf Touch
- Display immer an, reagiert nicht auf Touch
 
P

Psycholein

Stammgast
bei mir hat der Sensor auch nicht beim Telefonieren funktioniert
hab mir grad die App Tricorder heruntergeladen, um zu prüfen, ob der Sensor noch funktioniert und siehe da er funktioniert, trotz Staub
dann hab ich die Mailbox wieder angerufen und auf einmal geht der Sensor dort auch wieder o.O

keine Ahnung, ob da grad n Staubkörnchen den Weg freigemacht hat oder obs doch n Software-Bug ist ;)